Search the site
  Support :: Frequently Asked Questions :: Hydraulic Programs 5.x
Are Windows Vista supported for Hydraulic Programs v5.x?

Hydraulic Programs v5.x are incompatible with Windows Vista. Windows Vista are supported only by the newer version, TechnoLogismiki Works 2007.

Hydraulic Programs v5.x may be used on Windows 9x/Me/2000/XP.

  Featured Product  
Hydraulics Package


The Hydraulics Package consists of: Sewer Networks with the Toolpack, Water Networks with the Toolpack and the Network Optimization modules, River Flow, Hydraulic Solver, Culverts, Hydraulic Hammer and Reservoir Simulation. Purchase your own copy today!


  e-Shop  

Shopping Cart
Store

  Newsletter  


e-mail:
Language: Greek
English


Copyright © 2019 Technologismiki. All rights reserved.  Privacy Policy |  EULA