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1 About the program

1.1 What does the program do?

This program calculates sewer and storm networks in which flow is under pressure
and/or with free surface. Apart from hydraulic calculations, the program can be used
for water quality checks (for example, for combined networks). The program is based
on and fully compatible with EPA SWMM 5. It offers unique design tools and extensive
import/export capabilities through DXF/GTM/GIS files.

Some of the unique features of Sewer Networks are:

Handles Sewer / Storm / Combined networks

Easy data input in plan view and/or profile view with embedded spreadsheets.

Generation of runoff by raingages, IDF curves, constant rain intensity or by direct
input

Fully compatible with American regulations (ASCE & WPCF) as well as Greek
Regulations

Easy data input from drawings and / or spreadsheets

Automatic data input based on logical rules

Active profile drawings with CAD capabilities

Conduit / Manhole / Trench specifications

One-click generation of professional reports
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One-click generation of plan view and profile drawings

One-click generation of quantities report, including pipe lengths, excavations,
backfill etc.

1.2 Minimum requirements

The minimum requirements for the usage of the programs are the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium III 800 MHz
800x600 with 256 color palette
700 MB free disk space
CD-Rom

If your system does not meet one or more of the above requirements, it is highly
recommended that you upgrade it before installing the programs. The recommended
system configuration is the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium IV 2.0 GHz
1280x768 with 16-bit color palette
1.2 GB free disk space
CD-Rom
Internet connection

1.3 Technical support

Support through the Internet

TechnoLogismiki offers technical support 24 hours per day, 365 days per year, through
the web site where you can get information on the latest programs and services.

Support by e-mail

Please use the dedicated e-mail addresses for better customer service:

for questions regarding sales: sales@technologismiki.com
for questions regarding the usage of programs: support@technologismiki.com
for any other question or comment: info@technologismiki.com

The normal response time is within two business days. If your inquiry cannot be
answered by e-mail, a customer service representative will contact you by telephone.

Interactive Support

Business days, 09:00 - 17:00 Eastern European Time:

Telephone [3 lines]: ++30-210-656-4147
Fax: ++30-210-654-8461
Address: 5, Imittou street, Cholargos, 15561, Athens, Greece.
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2 User Interface

2.1 Methodology

2.1.1 Computational Methods

The program and this manual are based on EPA SWMM 5, which is a dynamic rainfall-
runoff simulation model used for single event or long-term (continuous) simulation of
runoff quantity and quality from primarily urban areas. The routing algorithm
transports the runoff through a system of pipes, channels, storage/treatment devices,
pumps, and regulators. The program tracks the quantity and quality of runoff
generated within each subcatchment, and the flow rate, flow depth, and quality of
water in each pipe and channel during a simulation period comprised of multiple time
steps. 

This section briefly describes the methodology employed by the program regarding the
following topics:

Surface Runoff
Infiltration
Groundwater
Snowmelt
Routing
Surface Ponding
Water Quality Ponding

2.1.2 Surface Runoff

The conceptual view of surface runoff used by Sewer Networks is illustrated in the
following figure. Each subcatchment surface is treated as a nonlinear reservoir. Inflow
comes from precipitation and any designated upstream subcatchments. There are
several outflows, including infiltration, evaporation, and surface runoff. The capacity of
this "reservoir" is the maximum depression storage, which is the maximum surface
storage provided by ponding, surface wetting, and interception. Surface runoff per unit
area, Q, occurs only when the depth of water in the "reservoir" exceeds the maximum
depression storage, dp, in which case the outflow is given by Manning's equation.
Depth of water over the subcatchment is continuously updated with time by solving
numerically a water balance equation over the subcatchment. 
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2.1.3 Infiltration

Infiltration is the process of rainfall penetrating the ground surface into the
unsaturated soil zone of pervious subcatchments areas. The program offers three
choices for modeling infiltration: 

Horton's equation

This method is based on empirical observations showing that infiltration decreases
exponentially from an initial maximum rate to some minimum rate over the course of
a long rainfall event. Input parameters required by this method include the maximum
and minimum infiltration rates, a decay coefficient that describes how fast the rate
decreases over time, and a time it takes a fully saturated soil to completely dry. 

Green-Ampt Method

This method for modeling infiltration assumes that a sharp wetting front exists in the
soil column, separating soil with some initial moisture content below from saturated
soil above. The input parameters required are the initial moisture deficit of the soil,
the soil's hydraulic conductivity, and the suction head at the wetting front. 

Curve Number Method

This approach is adopted from the NRCS (SCS) Curve Number method for estimating
runoff. It assumes that the total infiltration capacity of a soil can be found from the
soil's tabulated Curve Number. During a rain event this capacity is depleted as a
function of cumulative rainfall and remaining capacity. The input parameters for this
method are the curve number, the soil's hydraulic conductivity (used to estimate a
minimum separation time for distinct rain events), and a time it takes a fully
saturated soil to completely dry.

2.1.4 Groundwater

The following figure is a definitional sketch of the two-zone groundwater model that is
used by the program. The upper zone is unsaturated with a variable moisture content.
The lower zone is fully saturated and therefore its moisture content is fixed at the soil
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porosity. 

The fluxes shown in the figure, expressed as volume per unit area per unit time,
consist of the following :

fI infiltration from the surface 

fEU evapotranspiration from the upper zone which is a fixed fraction of the unused
surface evaporation

fU percolation from the upper to lower zone which depends on the upper zone
moisture content θ and depth dU

fEL evapotranspiration from the lower zone, which is a function of the depth of the
upper zone dU

fL percolation from the lower zone to deep groundwater which depends on the lower
zone depth d

L

fG lateral groundwater interflow to the drainage system, which depends on the lower
zone depth d

L
 as well as the depth in the receiving channel or node.

After computing the water fluxes that exist during a given time step, a mass balance
is written for the change in water volume stored in each zone so that a new water
table depth and unsaturated zone moisture content can be computed for the next time
step. 

2.1.5 Snowmelt

The snowmelt routine is a part of the runoff modeling process. It updates the state of
the snow packs associated with each subcatchment by accounting for snow
accumulation, snow 
redistribution by areal depletion and removal operations, and snow melt via heat
budget accounting. Any snowmelt coming off the pack is treated as an additional
rainfall input onto the subcatchment. 
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At each runoff time step the following computations are made: 

1.Air temperature and melt coefficients are updated according to the calendar date. 
2.Any precipitation that falls as snow is added to the snow pack. 
3.Any excess snow depth on the plowable area of the pack is redistributed according

to the removal parameters established for the pack. 
4.Areal coverages of snow on the impervious and pervious areas of the pack are

reduced according to the Areal Depletion Curves defined for the study area 
5.The amount of snow in the pack that melts to liquid water is found using

a heat budget equation for periods with rainfall, where melt rate increases with
increasing air temperature, wind speed, and rainfall intensity
a degree-day equation for periods with no rainfall, where melt rate equals the
product of a melt coefficient and the difference between the air temperature and
the pack's base melt temperature.

6.If no melting occurs, the pack temperature is adjusted up or down based on the
product of the difference between current and past air temperatures and an
adjusted melt coefficient. If melting occurs, the temperature of the pack is increased
by the equivalent heat content of the melted snow, up to the base melt
temperature. Any remaining melt liquid beyond this is available to runoff from the
pack.

7.The available snowmelt is then reduced by the amount of free water holding
capacity remaining in the pack. The remaining melt is treated the same as an
additional rainfall input onto the subcatchment.

2.1.6 Routing

Flow routing within a conduit link is governed by the conservation of mass and
momentum equations for gradually varied, unsteady flow (i.e., the Saint Venant flow
equations). The program offers three levels of sophistication used to solve these
equations: 

Steady Flow Routing
Kinematic Wave Routing
Dynamic Wave Routing

2.1.6.1 Steady Flow Routing

Steady Flow routing represents the simplest type of routing possible (actually no
routing) by assuming that within each computational time step flow is uniform and
steady. Thus it simply translates inflow hydrographs at the upstream end of the
conduit to the downstream end, with no delay or change in shape. The normal flow
equation is used to relate flow rate to flow area (or depth). 

This type of routing cannot account for channel storage, backwater effects, entrance/
exit losses, flow reversal or pressurized flow. It can only be used with dendritic
conveyance networks, where each node has only a single outflow link (unless the node
is a divider in which case two outflow links are required). This form of routing is
insensitive to the time step employed and is really only appropriate for preliminary
analysis using long-term continuous simulations. 

NOTE: Older versions of the program use steady flow routing.
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2.1.6.2 Kinematic Wave Routing

This routing method solves the continuity equation along with a simplified form of the
momentum equation in each conduit. The latter requires that the slope of the water
surface equal the slope of the conduit.

The maximum flow that can be conveyed through a conduit is the full normal flow
value. Any flow in excess of this entering the inlet node is either lost from the system
or can pond atop the inlet node and be re-introduced into the conduit as capacity
becomes available.

Kinematic wave routing allows flow and area to vary both spatially and temporally
within a conduit. This can result in attenuated and delayed outflow hydrographs as
inflow is routed through the channel. However this form of routing cannot account for
backwater effects, entrance/exit losses, flow reversal, or pressurized flow, and is also
restricted to dendritic network layouts. It can usually maintain numerical stability with
moderately large time steps, on the order of 5 to 15 minutes. If the aforementioned
effects are not expected to be significant then this alternative can be an accurate and
efficient routing method, especially for long-term simulations.

2.1.6.3 Dynamic Wave Routing

Dynamic Wave routing solves the complete one-dimensional Saint - Venant flow
equations and therefore produces the most theoretically accurate results. These
equations consist of the continuity and momentum equations for conduits and a
volume continuity equation at nodes.

With this form of routing it is possible to represent pressurized flow when a closed
conduit becomes full, such that flows can exceed the full normal flow value. Flooding
occurs when the water depth at a node exceeds the maximum available depth, and
the excess flow is either lost from the system or can pond atop the node and re-enter
the drainage system.

Dynamic wave routing can account for channel storage, backwater, entrance/exit
losses, flow reversal, and pressurized flow. Because it couples together the solution for
both water levels at nodes and flow in conduits it can be applied to any general
network layout, even those containing multiple downstream diversions and loops. It is
the method of choice for systems subjected to significant backwater effects due to
downstream flow restrictions and with flow regulation via weirs and orifices. This
generality comes at a price of having to use much smaller time steps, on the order of
a minute or less (the program will automatically reduce the user-defined maximum
time step as needed to maintain numerical stability).

Each of these routing methods employs the Manning equation to relate flow rate to
flow depth and bed (or friction) slope. The one exception is for circular Force Main
shapes, where the Hazen-Williams equation is used instead.

2.1.7 Surface Ponding

Normally in flow routing, when the flow into a junction exceeds the capacity of the
system to transport it further downstream, the excess volume overflows the system
and is lost. An option exists to have instead the excess volume be stored atop the
junction, in a ponded fashion, and be reintroduced into the system as capacity
permits. 
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Under Steady and Kinematic Wave flow routing, the ponded water is stored simply as
an excess volume. For Dynamic Wave routing, which is influenced by the water depths
maintained at nodes, the excess volume is assumed to pond over the node with a
constant surface area. This amount of surface area is an input parameter supplied for
the junction. 

Alternatively, the user may wish to represent the surface overflow system explicitly. In
open channel systems this can include road overflows at bridges or culvert crossings
as well as additional floodplain storage areas.

In closed conduit systems, surface overflows may be conveyed down streets, alleys, or
other surface routes to the next available stormwater inlet or open channel. Overflows
may also be impounded in surface depressions such as parking lots, back yards or
other areas.

2.1.8 Water Quality Ponding

Water quality routing within conduit links assumes that the conduit behaves as a
continuously stirred tank reactor (CSTR). Although a plug flow reactor assumption
might be more realistic, the differences will be small if the travel time through the
conduit is on the same order as the routing time step. The concentration of a
constituent exiting the conduit at the end of a time step is found by integrating the
conservation of mass equation, using average values for quantities that might change
over the time step such as flow rate and conduit volume. 

Water quality modeling within storage unit nodes follows the same approach used for
conduits. For other types of nodes that have no volume, the quality of water exiting
the node is simply the mixture concentration of all water entering the node. 

2.2 Main Window (Plan View tab)

To select the Plan View mode, click on the corresponding tab on the top left corner of
the main form. The main window consists of the following:

1. Menu: provides access to all program commands.
2. Toolbar: provides shortcut buttons to most common commands.
3. Categories: when plan view is selected, the categories tree view provides access to
all project properties in a concise and comprehensive way.
4. Object List: enumerates all objects contained in the specified category. This list is
equipped with a dedicated toolbar, containing the following:

Add: adds an object in the specified category.
Delete: deletes the selected object(s).
Edit: edits the selected object(s).
Move Up: moves the selected object one slot upwards.
Move Down: moves the selected object one slot downwards.
Sort: sorts all objects in the list alphabetically.

Not all options may be available at some instances.
5. Time Frame: when the calculations have been completed successfully, the time
frame controls the time instant for which the results are displayed.
6. Plan View: the main plan view drawing. To select an object, click on it. Selected
objects are drawn with a red line. Double-click on an object to display its properties.
7. Plan View Toolbar: a dedicated toolbar, containing shortcut buttons to most
common commands regarding the plan view.
8. Status Bar: displays important messages regarding the state of the program.
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9. Coordinates: displays the current coordinates of the plan view or the profile.

2.3 Main Window (Profiles tab)

To select the Profiles mode, click on the corresponding tab on the top left corner of the
main form. Apart from the controls already explained in the previous topic, the main
window consists of the following:

1. Profile List: a list containing all profiles.
2. Profile: the profile drawing.
3. Spreadsheet: when in profile mode, the spreadsheet provides access to the
properties of all objects consisting the specified profile.
4. Node/List tab: when in profile mode, select the appropriate tab to load the
spreadsheet with the corresponding data.
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3 File

3.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New project
Open project
Save project
Save project as
Import
o Plan view

From DXF file
From ArcView Shapefile
From GTM

o Data from SWMM

o Data from LandXML

o Background from DXF

o Satellite image

Export
o Export selection

o Plan view to DXF

o Plan view to ArcView Shapefile

o Plan view GTM

o Plan view to BMP picture

o Plan view to LandXML

o Plan view to SWMM

Print Setup
Print
Print to
o Print to File

o Print to Word

o Print to Word (Formatted)

o Print to Excel

Exit

3.2 New project

With this option, a new project is started. All data, results, graphs, titles etc. of the
previous project are erased.

To create a new project:

1. Select New project from the File menu.
2. If a project is already loaded and changes have been made, a warning message will
appear that asks the user whether to save the changes or not.
3. The current project is erased and a new project is started.
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3.3 Open project

With this option, an existing project is loaded. The project may be located locally, in a
network or in an external media device such as a CD-Rom. If a project is already
loaded and changes have been made, a warning message will appear that asks
whether to save the changes or not. When a project is loaded, all data of the previous
project are lost.

To open an existing project:

1. Select Open project from the File menu.
2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Sewer Networks project" with the extension .m504.
4. Select the file by clicking on it.
5. Select Open to open the selected file. Select Cancel to cancel the operation.

NOTE: You can find sample projects in the installation folder of the program:
C:\Program Files\TechnoLogismiki\TLW2013\Samples\SewerNetworks

Supported file types

Μ04 (Sewer networks project): Files created by versions 2012 and 2013 of Sewer
Networks.
Μ504 (Sewer networks project): Files created by versions 2011, 2010, and 2008 of
Sewer Networks.
Μ504 (Storm networks project v5.x - 2007): Files created by versions 2007 and 5.0
of Storm Networks.
Μ513 (Sewer networks project v5.x - 2007): Files created by versions 2007 and 5.0
of Sewer Networks.
MB4 (Storm networks project): Files created by versions 1.0 to 4.0 of Storm
Networks.
MB13 (Sewer networks project): Files created by versions 1.0 to 4.0 of Sewer
Networks.
BCK (Backup files): If you have selected from program options the creation of
backup copy when a file is loaded, then the file can be loaded by selecting Backup
files (*.bck) from the Files of type drop-down list.
*.* (All files): Displays all files in the current folder.
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Backwards compatibility

This version implements full backwards compatibility; however, note that when a
project is saved with the latest format, it cannot be used by previous versions.

NOTE: If a message "Could not load project. File may be corrupt or saved by an
unknown or incompatible version of the program" then either you are  trying to load a
project that does not belong to this program or the file is used (and locked) by
another process in your computer.

3.4 Save project

With this option, you can save all data of a project into a file. The file may be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you are saving a project. When
the filename and path are set, all subsequent saves will be made to the same file.

When you want to rename a file or save it in a new location, use Save project as...
from the File menu.

To save the current project:

1. Select Save project from the File menu.
2. If the location of the file is already set, the project is saved to this file without any
messages. If the filename is not set, a dialog box will appear that allows the selection
of the filename and path.

3.5 Save project as

With this option, the current project is saved just as in the case of Save project, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.

To save a project with another name and/or to another location:

1. Select Save project as from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.
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NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current project are saved.

3.6 Import

3.6.1 Plan view

With this option, you can import plan view data from an external file. All previous data
will be erased.

To import plan view data from an external file:

1. Select Import from the File menu.
2. Select Import plan view from the Import menu. The following form appears:
3. From the File menu, select one of the following:

Import from DXF to import plan view data from a DXF file.
Import from ArcView Shapefile to import plan view data from an Arcview
Shapefile.
Import from GTM to import plan view data from a GTM GPS Trackmaker file.

4. Import the data following the specific instructions.
5. Click Ok to save the changes and close the form. Click Cancel to close the form
without saving any changes.
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To split an existing branch:

1. Right-click on the node you wish to split the branch. 
2. Select Split from the drop-down menu. The branch is split into two branches.

To merge two branches:

1. Click the Merge button from the main form.
2. Click on the start node.
3. Click on the last node.

To reverse the flow of the selected branch:

1. Select the branch by clicking on it. The selected branch is drawn in red.
2. Right-click on the selected branch. Select Reverse Flow from the drop-down
menu. The flow is reversed.

In order to manipulate the view of the drawing:

1. Click Zoom In from the main form and click anywhere on the drawing to zoom in.
2. Click Zoom Out from the main form and click anywhere on the drawing to zoom
out.
3. Click Extends from the main form to view the whole drawing.
4. Click Window from the main form to zoom to a specified window.
5. Click Options from the main form to customize the appearance of the drawing.

NOTE: The number of collectors is equal to the number of flow exits.
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3.6.1.1 From DXF file

To import plan view data from a DXF file:

1. Select Import From DXF file from the File menu. The following form appears:

2. Click File > to select the DXF file. The file selection dialog box appears:

3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"DXF file" with the extension .dxf.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The list in the Layers frame of step 1 is
loaded with the layers contained in the DXF file:

7. Select one or more layers containing the data. The data should be defined in



File 31

© 2012 TechnoLogismik i

polylines or a series of lines connected to each other. The connection must be exact,
therefore you may need to use Snap or OSnap when using CAD software. The program
will create stations at the nodes of the polylines and at the end points of the lines.
Optionally, the coordinates of the stations can be used to calculate the distances
between stations. The quick keys (Select all, Select None, Select Invert) can be
used to quickly select all objects, deselect all objects and invert the current selection.
8. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: The following tips may be useful:

Use lines and/or polylines in any combination. The nodes and start/end points of
these objects define stations. You can use a different layer for each branch,
although this is not necessary. You can use a single layer for the whole network.
The names of the stations are filled automatically in descending order (upstream
to downstream). The coordinates and distances between stations are also filled
automatically.
The DXF driver recognizes the following entities:

Lines
LWPolylines
Polylines
3D Polylines

3.6.1.2 From ArcView Shapefile

With this option, you can import plan view data from an ArcView Shapefile. All
previous data are erased.

NOTE: The ArcView Shapefile driver recognizes the following entities:
Nullshapes
Point/PointM/PointZ
Multipoint/MultipointM/MultipointZ
Polyline/PolylineM/PolylineZ

To import plan view data from an ArcView Shapefile:

1. Select Import from Arcview Shapefile from the File menu. The file selection
dialog box appears:

2. Select the path of the file.
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3. Select the file type from the Files of type drop-down list. The default option is
"ArcView shapefile" with the extension .shp.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file. The current project data are erased.
Select Cancel to cancel the operation.

3.6.1.3 From GTM

To import plan view data from a GTM file:

1. Select Import from GTM file from the File menu. The following form appears:

2. Click File > to select the GTM file. The file selection dialog box appears:

3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"GTM file" with the extension .gtm.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The list in the Selection frame of step 1
is loaded with the layers contained in the GTM file:
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7. Select one or more routes or tracklog containing the data. Optionally, the
coordinates of the stations can be used to calculate the distances between stations.
The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection.
8. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.6.2 Data from SWMM

With this option, you can import data from files created by EPA's SWMM or Bentley's
SewerGems. In most cases, import is complete there is no need for intervention. There
are, however, some rare occasions in which you must correct some of the data.

To import data from EPA's SWMM or Bentley's SewerGems:

1. Select Import from the File menu.
2. Select Data from SWMM from the Import menu. The following form appears:

3. Click Browse to select the SWMM file. The file selection dialog box appears.
4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"SWMM Input file" with the extension .inp.
6. Select the file by clicking on it.
7. Select Open to select the file for import. 
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8. Select Grant change access to global settings to allow the file to change
settings that are saved in per-project basis. Enabling this option is not recommended.
9. Optionally, click Data... to select which sections of the file will be imported.
9.1. Select the sections.
9.2. Click Ok to save changes. Click Cancel to ignore changes and close the form.

10. Click Ok to import the selected file. Click Cancel to cancel the import and close
the form.
11. The results and potential error messages during import are loaded in the list. 
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12. Click Ok to close the form.

3.6.3 Data from LandXML

LandXML is an open source format specifically developed and tuned for exchanging
design data used in the design / build process for land development and
transportation projects. LandXML has evolved from previous efforts and is the
cooperative work of representatives from all aspects of the engineering industry. For
more information regarding programs supporting LandXML or for the LandXML scheme,
please refer to LandXML forum.

To import LandXML data:

1. Select Import from the File menu.
2. Select Data from LandXML from the Import menu. The following form appears:

3. Click Browse to select the LandXML file. The file selection dialog box appears.

4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"LandXML file" with the extension .xml.
6. Select the file by clicking on it.
7. Select Open to open and analyze the file. If the file contains error, they are
displayed on screen otherwise another form appears containing a treeview list of all
entities that can be imported.
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8. Select one or more entities that will be used as background or contain network
information.
10. Press Ok to import the background (if available) or the pipe networks (if available)
or Cancel to cancel the import process.

NOTE: In this version the following LandXML entities are supported:
LandXML
Units*
CoordinateSystem*
Project*
Application*
Alignments
CgPoints
Amendment*
GradeModel
Monuments
Parcels
PlanFeatures
PipeNetworks
Roadways
Surfaces
Survey
FeatureDictionary*

* No visual representation.

NOTE: In this version the following LandXML schemes are supported:
v1.2 beta Build32 03.12.2007
v1.1
v1.0
v0.88

The program has been certified regarding its LandXML import and export functionality
from LandXML forum. The certified versions are 1.0 and 1.1 and version 1.2 is pending
until the scheme is finalized.

3.6.4 Background from DXF

With this option, you can import background data from DXF files. The background is
not active, but it is most helpful when designing a network. For performance reasons,
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only the most common entities of DXF files are imported, such as lines, points,
polylines, arcs, circles, text etc.

To import background data from DXF:

1. Select Import from the File menu.
2. Select Background from DXF from the Import menu. The following form appears:

3. Click Browse to select the DXF file. The file selection dialog box appears.

4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"DXF file" with the extension .dxf.
6. Select the file by clicking on it.
7. Select Open to open and analyze the file. The list is loaded with the layers
contained in the DXF file.
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8. Select one or more layers containing the data. The quick keys (Select all, Select
None, Select Invert) can be used to quickly select all objects, deselect all objects
and invert the current selection.
9. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: To modify the background drawing, from the menu select View > Plan View
> Background

3.6.5 Satellite image

With this option you can insert a satellite image as a background image in plan view.
The image is modified accordingly (translation, rotation, skewness) so that it is 
projected in the specified coordinate system.

To insert a satellite image as a background image in plan view:

1. Select Insert > Satellite image from the File menu. The following form appears:

2. Navigate to the area of the project. You can pan the image by holding down the left
mouse button. Using the roller you can change the resolution. Alternatively, enter the
longitude and latitude in decimal degrees and press Jump to:
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3. When you locate the area, select the appropriate resolution (the resolution varies,
depending on the quality of the satellite image), and press Import. The current
viewport is imported as a background image:

4. Without closing the window, pan the viewport and press Import again. A new image
is imported, which may overlap with the previous one. When you cover the whole area
of interest, press Close:
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In the satellite image form, the following options are available:

Style. Some options may not be available, or they may not have an effect,
depending on the quality of the satellite image.
o Roads

o Shaded

o Aerial

o Hybrid

Options
o Show navigation tool.

o Show locator tool.

o Units

Metric
English

Jump. These are quick selections for jumping to:
o To Athens

o To Greece

o To Europe

o To USA

o To World

NOTE: The images are saved as TIFF files in the same path as the project. You can
delete them selectively using the View > Background images > Delete menu.
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3.7 Export

3.7.1 Export selection

With this option, you can export the selected data in simple ASCII text files. The
delimiter is customized by the user.

To export data to a file:

1. Select the cells containing the data.
2. Select the proper delimiter.
3. Select Export from the File menu.
4. Select Export selection from the Export menu. The following form appears:

5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

3.7.2 Plan view to DXF

With this option, a DXF file containing the plan view is created. The following data are
included in the file:

Station, station names 
Node data, pipe data
Hydraulic calculations
Contours (if visible)

To export the plan view to DXF file:

1. Select Export from the File menu.
2. Select Plan view to DXF file from the Export menu. The following dialog box
appears:
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3. Select the appropriate settings:

Intended drawing scale: Select the intended drawing scale. The rest of the
settings are measured in mm (millimeters) in the printed drawings. Based on the
intended drawing scale, the sizes of all drawing elements are automatically
derived.
Select the object you wish to configure from the list on the left. Depending on
the object, the following options may become available:

Basic symbol size (mm): Enter the basic symbol size in mm (millimeters) in
the printed drawing. For example, the basic symbol size for a junction refers 
to the diameter of the circle that represents it.
Top label font: select the font for the top label. All drawing elements are
grouped into layers and font styles, so that they can be easily modified using
CAD software.
Top label font height (mm): Enter the top label font height in mm
(millimeters) in the printed drawings. If the font height is selected to be 2mm
and the scale is 1:1000, then the text height that will be used is equal to
2mm * 1000 = 2m. When printed, the desired font height will be obtained. 
Top label offset (mm) : Enter the top label offset from the center of the
object, in mm in the printed drawing.
Top label : Enter the text that will appear in the top label of the selected
object. The text may contain codes. The codes have the prefix "&" and contain
 a special keyword within brackets. For example, if the top label is selected to
be "&[NAME]", then the name of the object will be displayed. Any
combination of text and/or codes is allowed. For example, if the model
contains junctions named "J1", J2", etc and the manhole type is "T1", then the
label "&[NAME] - &[MANHOLE_TYPE]" will create labels "J1 - T1", "J2 - T1" etc
in the DXF drawing.
Insert code in top label: Depending on the selected object, select the code
from the list and click on the " + " button to enter it in the top label. The
insertion point is the current cursor point in the previous field entitled "Top
label".
Similar options may refer to the bottom label.
Layer color: Select the layer color of the selected object.
Layer color filled: Select the layer color for the filled elements of the selected
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object.

The available codes, depending on the type of the object, are (the names are self-
explanatory):

"&[NAME]"
"&[STATION]"
"&[DESCRIPTION]"
"&[TAG]"
"&[MANHOLE_TYPE]"
"&[GROUND_ELEVATION]"
"&[INVERT_ELEVATION]"
"&[AREA]"
"&[LENGTH]
"&[SLOPE]"
"&[SHAPE]"
"&[DEPTH]"
"&[DEPTH_RATIO]"
"&[FLOW]"
"&[VELOCITY]"

4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
5. The file selection dialog box appears:

6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

NOTE: If nothing is visible when viewing the newly created DXF file, select Zoom
Extents to view the whole drawing.

3.7.3 Plan view to ArcView Shapefile

With this option, two ArcView Shapefiles containing the plan view data are created.
The first file contains station data and the other contains pipe data. Note that apart
from geometry, hydraulic calculation results are included in the Shapefiles.

To export the plan view to an ArcView Shapefile:
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1. Select Export from the File menu.
2. Select Plan view to ArcView Shapefile from the Export menu.
3. The following dialog box appears:

4. Select one of Nodes, Pipes from the drop-down list.
5. Select Customization... to customize the shape type and the properties that will
be included:

6. Select the appropriate shape type.

NOTE: The GIS driver recognizes the following shape types:
Nullshapes
Point/PointM/PointZ
Multipoint/MultipointM/MultipointZ
Polyline/PolylineM/PolylineZ

7. Select the properties that you want to include in the file. The quick keys (Select
all, Select None, Select Invert) can be used to quickly select all objects, deselect all
objects and invert the current selection.
8. Select Ok to proceed with the selection of the filename. Select Cancel to abort the
operation and close the dialog box.
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9. Select the path of the file.
10. Type the filename in the File name text box.
11. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: If nothing is visible when viewing the newly created ArcView Shapefile, select
Zoom Extents to view the whole drawing.

3.7.4 Plan view to GTM

With this option, a GPS Trackmaker (GTM) file containing the plan view is created. The
following data are included in the plan view:

Sections, Section names
Pipes

To export the plan view to GTM file:

1. Select Export from the File menu.
2. Select Plan view to GTM file from the Export menu.
3. The following dialog box appears:

4. Select the predefined grid and the datum of the coordinate system. The default
values are used in most cases.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
6. The file selection dialog box appears.
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7. Select the path of the file.
8. Type the filename in the File name text box.
9. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

NOTE: If nothing is visible when viewing the newly created GTM file, select Zoom
Extents to view the whole drawing.

3.7.5 Plan view to BMP picture

With this option, you can create a BMP file containing the plan view as it is currently
displayed on screen.

To create a BMP file:

1. Select Export from the File menu..
2. Select Plan view to BMP picture from the Export menu. The following form will

appear:

3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.
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3.7.6 Plan view to LandXML

The plan view is exported (background, networks and calculations) to a LandXML file.
For more information regarding programs supporting LandXML or for the LandXML
scheme, please refer to LandXML forum.

To export plan view to LandXML:

1. Select Export from the File menu..
2. Select Plan view to LandXML from the Export menu. The following form will

appear:

3. Click Browse to select an existing or a new LandXML file. The file selection dialog
box appears.

4. Select the path of the file.
5. Type the filename in the File name text box to select a new file or select an
existing file.
6. Select Save to finalize your selection.
7. If you selected an existing LandXML file, then it is loaded and analyzed so that the
program will be ready to update it. If not, then its name appears on the form and the
update check box is disabled.
8. Optionally, click on Settings to change the driver's settings.

8.1. Select the LandXML scheme that will be used to create / update the file. It is
recommended to select 1.0 for maximum compatibility or the scheme version
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supported by the destination program (the program that will be used to read the
exported file).
8.2. Select the number of decimal digits. It is recommended to select any number
from 4 to 8 digits.
8.3. Click Ok to save changes. Click Cancel to ignore changes and close the form.

9. If an existing file has been selected, the update file check box is enabled. If this
check box is selected then the target file will be updated with any changes made
within the program.
10. Press Ok to close the form and finalize the export procedure or press Cancel to
close the form and cancel the export procedure.

3.7.7 Plan view to SWMM

The plan view is exported (background and networks) to a SWMM file. This file can be
read from other programs such as EPA's SWMM and Bentley's Sewergems.

To export the plan view to a SWMM file:

1. Select Export from the File menu..
2. Select Plan view to SWMM from the Export menu. The following form will appear:

3. Click Browse to select a new SWMM file. The file selection dialog box appears.

4. Select the path of the file.
5. Type the filename in the File name text box to select a new file.
6. Select Save to finalize your selection.
7. Optionally, click on Settings to select which sections will be exported to the SWMM
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file.

7.1. Select the sections.
7.2. Click Ok to save changes. Click Cancel to ignore changes and close the form.

8. Press Ok to close the form and finalize the export procedure or press Cancel to
close the form and cancel the export procedure.

3.8 Print Setup

With this option, you can select which parts of the project will be included in the
printouts. When a new project is created, a full report is selected by default.

To modify the print setup:

1. Select Print setup from the File menu.
2. Select the sections (Title, Project information etc) that will be included in the
reports.
3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection of a list.

NOTE: The changes are saved with the project. The above preferences are used to all
printouts, either to the printer or to other formats such as Word file, Excel file etc.

3.9 Print

With this option, you can prepare a report to be printed to a local, network or virtual
printer such as Adobe PDF Writer. The parts of the project that will be included in the
report are determined from print setup.

By selecting Print, the report is not printed directly; instead, a document is prepared
and a preview of the printout is created by the Print manager. You can print the
report by clicking the Print button of the toolbar of Print manager.

To create a report:

1. Select Print from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.

NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.
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3.10 Print to

3.10.1 Print to File

With this option, you can create a simple text file containing a report of the project.
This file is recognized and can be further modified by word processors such as
Microsoft Word, OpenOffice Writer etc.

To print to a text file:

1. Select Print to from the File menu.
2. Select Print to file from the Print to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.

The parts of the project that will be included in the report are determined from print
setup.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but the report is NOT printed.

3.10.2 Print to Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.
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3.10.3 Print to Word (Formatted)

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a formatted Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word (Formatted) from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup. This operation is much slower than the regular print to word function. However,
the final output requires minimal user intervention as it comes fully formatted with
tables, alignment, font styles, etc.

NOTE: Do not use Copy (CTRL+C) on any of the programs running during this
operation. If you do so, it will most likely affect the communication between Microsoft
Word and the clipboard and as a result the final document will be corrupt.

3.10.4 Print to Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the report can be created. Note that
Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the report to a Microsoft Excel file:

1. Select Print to from the File menu.
2. Select Print to Excel from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

3.11 Exit

With this option, you can exit the program. If there are changes in the current project
that have not been saved then the program will:

either ask the user to save the changes
or save the changes
or ignore the changes

depending on what you have selected in General preferences.

To exit the program:

1. Select Exit from File menu.
2. If you are asked whether to save the changes or not, you can save changes or



File 53

© 2012 TechnoLogismik i

ignore them.
3. The program is terminated.
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4 Edit

4.1 Edit menu

With this menu, you can perform basic operations regarding data. In the Edit menu
you can select one of the following options:

Undo
Redo
Copy
Cut
Paste
Select all 
Clipboard delimiter
Clipboard decimal separator
Select objects
o Create selection

o Load selection

o Save selection

o Clear selection

Locate objects

4.2 Undo

Undo cancels the last committed change in the project.

To cancel the last committed change:

1. Select Undo from the Data menu.
2. The last committed change is canceled.

To cancel an undo command, you may use the redo function which is described
below. Redo becomes available once undo is used.

It is possible to undo more than one recent changes and to redo them, by following
the step described above. The number of actions that are kept in memory and may be
undone or redone is 20 by default. This means that the program is able to keep track
of up to 20 successive changes and undo them. This number may change for all
programs, using the option in the main menu. For more information, please consult
main menu user guide.

NOTE: Some changes cannot be undone like the new project or the save project
functions.

4.3 Redo

Redo cancels the latest undo command.

To redo the latest change that was undone:

1. Select Redo from the Data menu.
2. The latest undone change is redone.
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To undo a redo, you may use the undo command.

It is possible to redo more than one changes that were previously undone by following
the steps described above. The number of actions that are kept in memory and may
be undone or redone is 20 by default. This means that the program is able to keep
track of up to 20 successive changes that are undone and redo them. This number
may change for all programs, using the option in the main menu. For more
information, please consult main menu user guide.

4.4 Copy

With this option, you can copy the contents of the selected cells to the clipboard. 

To copy the contents of the selected cells to the clipboard:

1. Select the cells from the data table.
2. Select Copy from the Edit menu. The contents of the selected cells are copied to
the clipboard.

To copy data to be used with Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Select the cells from the data table.
4. Select Copy from the Edit menu. The contents of the selected cells are copied to
the clipboard.
5. Hit CTRL+V to paste the data when using Microsoft Excel.

4.5 Cut

With this option, you can copy the contents of the selected cells to the clipboard and
clear the current selection.

To copy the contents of the selected cells to the clipboard and clear the current
selection:

1. Select the cells from the data table.
2. Select Cut from the Edit menu. The contents of the selected cells are copied to the
clipboard and the selection is cleared.

To cut data to be used with Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Select the cells from the data table.
4. Select Cut from the Edit menu. The contents of the selected cells are copied to the
clipboard and the selection is cleared.
5. Hit CTRL+V to paste the data when using Microsoft Excel.

4.6 Paste

With this option, you can paste data from the clipboard to the data table.
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To paste data from the clipboard to the data table:

1. Select the top left cell.
2. Select Paste from the Edit menu. The data are copied from the clipboard to the
data table.

To paste data from Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Within Microsoft Excel, select all cells and hit CTRL+C to copy the data to the
clipboard.
4. Within Sewer Networks, select the top left cell that corresponds to the data.
5. Select Paste from the Edit menu. The data are copied from the clipboard to the
data table.

NOTE:
You cannot paste data into the grayed cells.
All data is transferred from consecutive columns, even if these are not visible.
Other software may require other delimiter when using clipboard.

4.7 Select all

With this option, when in plan view mode all objects are selected. When in profiles
mode, all cells of the data table are selected.

To select all:

1. Select Select all from the Edit menu.

4.8 Clipboard delimiter

With this option, you can select the delimiter that will be used that will be used when
transferring data to and from the clipboard.  

To select the delimiter:

1. Select Clipboard delimiter from the Edit menu.
2. Select one of Tab, Comma, Space.

NOTE: Although Sewer Networks can handle all three cases of delimiters, other
software may have some restrictions. For example, to exchange data with Microsoft
Excel, you should use TAB as  delimiter.

4.9 Clipboard decimal separator

With this option, you can select the decimal separator that will be used when
transferring data to and from the clipboard.  

To select the decimal separator:

1. Select Clipboard decimal separator from the Edit menu.
2. Select one of System, Period.
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NOTE: To exchange data with Microsoft Excel, you should use the System decimal
separator (by default). It is possible to modify the settings in Microsoft Excel to
accept period as decimal separator. Please refer to the manual of Microsoft Excel.

4.10 Select objects

4.10.1 Create selection

With this option, you can modify the set of selected objects. You can create a new
selection set or add objects to the current selection set. The selection is based on
various criteria. The successful completion of calculations is recommended before
using this option.

To modify the set of selected objects:

1. Perform calculations. This step is optional, but if you do not follow it, the results for
some objects may not be available and the selection may not function properly.
2. Select Select 0bjects from the Edit menu.
3. Select Create selection from the Select 0bjects menu. The following form
appears:

4. Select the scope from the drop-down list. The scope can either be the entire
project or the current selection.
5. Select the object type from the drop-down list.
6. Select the object property from the drop-down list. This list is depended on the
object type.
7. Select the operator which will be used in the comparison.
8. Enter the value of the property.
9. Optionally click on Enumerate Selection to preview how many items will be
selected if this query is applied.
10. Select either Include in new selection set to clear any existing selection and
create a new one or Exclude from new selection set to remove matching items from
the selection.
11. Enable Append to current selection set to preserve the current selection and
expand it by adding items from current query.
12. Click on Clear Selection to clear the selected items.
13. Click on Apply Selection to perform the query according to the specified
parameters.
14. Repeat steps 4 to 13 as necessary.
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15. Select Ok to close the form and accept changes or Cancel to close the form and
ignore any changed.

4.10.2 Load selection

With this option, you can load a selection set from an external file that was previously 
saved. This process will fail if the objects currently loaded do not correspond to the
selection set.

To load a selection set from an external file:

1. Select Select 0bjects from the Edit menu.
2. Select Load Selection from the Select 0bjects menu. The following form appears:

3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"Selection Files" with the extension .sel.
5. Select the file by clicking on it.
6. Select Open to open the selected file. Select Cancel to cancel the operation.

4.10.3 Save selection

With this option, you can save the current selection set to an external file. Note that
no object properties are saved whatsoever. The file can be loaded and used at a later
time, as long as the objects are not modified.

To save the current selection set to an external file:

1. Select Selection from the Objects menu.
2. Select Save Selection from the Selection menu. The following form appears:
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3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

4.10.4 Clear selection

With this option, you can deselect all items.

To deselect all items:

1. Select Select objects from the Edit menu.
2. Select Clear Selection from the Select objects menu. All objects are deselected.

4.11 Locate objects

With this option, the connectivity of a specified point, linear or surface object is
revealed.

To locate objects:

1. Select Locate objects from the Edit menu. The following form appears:

2. Select the Object type from the drop-down list.
3. Select the Name of the object.
4. The connectivity of the specified object is loaded in the list.
5. Select Ok or Cancel to close the form.
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5 View

5.1 View menu

With this menu, you can modify the appearance of the plan view and the profiles. In
the View menu you can select one of the following options:

Plan view
o Visible objects

o Background

Background pictures
o Add

o Edit

o Delete

o Show

Profile
o Options

5.2 Plan view

5.2.1 Visible objects

With this option, you can select the object type(s) that will be visible in plan view.
This option refers to the active objects of the plan view and not the background
objects.

To select the object type(s) that will be visible in plan view:

1. Select Plan view from the View menu.
2. Select Visible objects from the Plan view menu. The following form appears:

3. Select the object type(s) that you wish to be visible. The quick keys (Select all,
Select None, Select Invert) can be used to quickly select all objects, deselect all
objects and invert the current selection.
4. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.
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5.2.2 Background

With this option, you have full access to the background data from DXF files. This
includes the option to import data from a DXF file , under the File > Import menu.

To modify the background:

1. Select Plan view from the View menu.
2. Select Background from the Plan view menu. The following form appears:

3. To load data from a DXF file, select Load from DXF. This process is described in
the File > Import > Background from DXF section.
4. Select Clear to clear the existing background. A confirmation message will be
displayed.
5. Select Show background to toggle the visibility of the background.
6. Select Show text to toggle the visibility of TEXT objects of the background.
7. Select Background in color if you wish to view the background in color. 
8. If the option of step 7 is deselected, a single color is used for all background
objects. This color can be modified by selecting Select color.
8.1. The color selection dialog box appears.

8.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
8.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
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dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

9. Select the Background layers that you wish to be active (visible).  The quick keys
(Select all, Select None, Select Invert) can be used to quickly select all objects,
deselect all objects and invert the current selection.
10. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.

5.3 Background pictures

5.3.1 Add

With this option, you can add a picture to the background.

To add a picture to the background:

1. Select Background Pictures from the View menu.
2. Select Add from the Background Pictures menu. The following form will appear:

3. Select Path. The file selection dialog box will appear:

4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"Bitmap file" with the extension .bmp.
6. Select the file by clicking on it.
7. Select Open to open the selected file. Select Cancel to cancel the operation. 
8. Enter the Left X, Top Y, Width and Height of the picture in drawing units. If you
provide only the height or the width, the ratio of the source picture will be used to
calculate the missing data.
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9. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

NOTE: The following image file types are supported: bitmaps (.bmp) and JPEG (.jpg).

5.3.2 Edit

With this option, you can modify the position and dimensions of an existing
background picture.

To modify the position and dimensions of an existing background picture:

1. Select Background Pictures from the View menu.
2. Select Edit from the Background Pictures menu. The following form will appear:

3. Select the picture from the drop-down list.
4. Make the appropriate changes. If you provide only the height or the width, the ratio
of the source picture will be used to calculate the missing data.
5. Select Apply to apply the changes without closing the form. Select Ok to save the
changes and close the dialog box. Select Cancel to close the dialog box without saving
any changes.

5.3.3 Delete

With this option, you can delete one or more existing background pictures.

To delete one or more existing background pictures:

1. Select Background Pictures from the Map menu.
2. Select Delete from the Background Pictures menu. The following form will
appear:

3. Select the picture from the list.
4. Select Delete to delete the selected picture.
5. Select Delete all to delete all pictures.
6. Select Close to close the dialog box.
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5.3.4 Show

With this option, you can show or hide all pictures in the background.

To show or hide all pictures in the background:

1. Select Background pictures from the View menu.
2. Select Show from the Background pictures menu.
3. If the background pictures were visible, they become invisible and vice-versa. A
checkbox in the menu indicates if this option is enabled.

5.4 Profile

5.4.1 Options

With this option, you can modify the appearance of the profile sketch.

To modify the appearance of the profile sketch:

1. Select Profile from the View menu.
2. Select Options from the Profile menu. The following form appears:

3. Select Zoom extents after changes if you wish the sketch to zoom automatically
to the extents of the drawing whenever you make a change.
4. Select an appropriate Height stretch factor. This factor magnifies distances in the
Y direction so that small elevation differences are clear.
5. Select Draw min depth line to draw a line parallel to the ground at a specified
depth. This line is a design tool that shows the minimum depth that a conduit should
be placed (for example, to ensure a minimum backfill depth)
6. Type the depth of the min depth line in the Min depth field and select its color by
pressing the corresponding Select color button.
7. Select Draw max depth line to draw a line parallel to the ground at a specified
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depth. This line is a design tool that shows the maximum depth that a conduit should
be placed (for example, to show the maximum depth that an excavator can reach)
8. Type the depth of the max depth line in the Max depth field and select its color by
pressing the corresponding Select color button
9. Select Make default for all new projects to use these options for all new
projects.
10. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.
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6 Data

6.1 Data menu

With this menu, you can add and modify data. In the Data menu you can select one
of the following options:

Project info
Project summary
General data
o General

o Dates

o Time steps

o Dynamic wave

o Interface files

o Design

o Checks

o Excavation options

Climatology: Temperature, Evaporation, Wind speed, Snow melt, Areal depletion,
IDF curve
Hydrology: Raingages, Subcatchments, Aquifers, Snow packs, RDII Hydrographs
Quality: Pollutants, Land uses, Quality data
Curves: Management, Add, Delete, Edit, Move, Sort
Time series: Management, Add, Delete, Edit, Move, Sort
Time patterns: Management, Add, Delete, Edit, Move, Sort
Runoff areas: Management, Add, Delete, Edit
Sewer flow (population): Management, Add, Delete, Edit
Sewer flow (area): Management, Add, Delete, Edit
Conduit shapes: Management, Add, Delete, Edit, Import, Export
Manhole specifications: Management, Add, Delete, Edit, Import, Export
Trench specifications: Management, Add, Delete, Edit, Import, Export
Network consistency
Options
o General preferences

o Sketch

o Grid editing

o Customize toolbar

o Default values

o Algorithm

6.2 Project info

With this option, you can add project information that include title, firm title and
comments. If you want, this information can be included in the reports. The empty
fields are ignored.

To add or modify the project information:

1. Select Project info from the Data menu.
2. Type the project title, firm title and comments.
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3. Check Include project time and date if you want to include the time and date in
the project. In this case, type the day, month, year, hours and seconds in the
corresponding text boxes. Alternatively, press Today to insert the current values
automatically.
4. Check Include the name of the project file if you want the full path and filename
of the project to be included in the report.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

By selecting the buttons with the ellipses (...) next to the project title and firm, you
can access the corresponding databases.

Project title database

For the completion of a project, more than one programs may be needed. For
convenience, you can add the project title to the database and retrieve it from all
programs.

To use the project title database:

1. Select the button with the ellipses (...) next to the project title text box. The project
title database appears.
2. Select Add to add a new title to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected project title and close the dialog box. Select
Cancel to close the dialog box without applying any changes.
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Firm database

An engineer or firm may be involved in multiple projects. For convenience, you can
add the title to the database and retrieve it from all programs.

To use the firm database:

1. Select the button with the ellipses (...) next to the firm text box. The firm database
appears.
2. Select Add to add a new firm/author to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected firm and close the dialog box. Select Cancel
to close the dialog box without applying any changes.
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6.3 Project summary

With this option, a summary of the project is displayed. This includes the number of
objects and the most important simulation and calculation options.

To display the project summary:

1. Select Project summary from the Data menu.
2. The project summary is displayed:

3. Press Ok to close the form.

6.4 General data

6.4.1 General

With this option, you can input general data.

To input general data:

1. Select General data > General from the Data menu. The following form appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Model preferences
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Flow units: select the appropriate flow units. There are six combination available,
three of which belong to the metric system (m3/s, L/s, ML/day) and three (ft3/s, g/m,
Mg/day) to the English systems. This affects all data input/output. 

NOTE: If you change this setting, existing data will not be converted.

The units that are used in both the metric and English system are enumerated in the 
Appendix.

Infiltration model: select the appropriate infiltration model, which can be one of
Horton, Green-Ampt or SCS Curve Number. Depending on the model, different data
are required for each subcatchment.

Routing method: select the appropriate routing method, which can be one of: None,
Kinematic wave, Dynamic wave and Steady flow. For compatibility with previous
versions of the program, select steady flow.

Miscellaneous options:

Allow excess water ponding: Checking this option will allow excess water to collect
atop nodes and be re-introduced into the system as conditions permit. In order for
ponding to actually occur at a particular node, a nonzero value for its Ponded Area
attribute must be used.

Report control actions: This option exists for compatibility with EPA's SWMM. It is
always enabled in Sewer Networks.

Report input summary: This option exists for compatibility with EPA's SWMM. It is
always enabled in Sewer Networks.

Skip steady state periods: Checking this option will make the simulation use the
most recently computed conveyance system flows during a steady state period instead
of computing a new flow routing solution. A time step is considered to be in steady
state if the change in external inflow at each node is below 0.5 ft3/s and the relative
difference between total system inflow and outflow is below 5%.

Ignore rainfall / runoff, snow melt, ground water, flow routing and water
quality: Check this option to ignore the respective models and computations. If
rainfall / runoff calculations are disabled, then only user-specified direct inflow time
series and dry weather inflows will be considered.

Minimum Conduit Slope: The minimum value allowed for a conduit's slope (%). If
zero (the default) then no minimum is imposed (although the program uses a lower
limit on elevation drop of 0.001 ft (0.00035 m) when computing a conduit slope). 

6.4.2 Dates

With this option, you can input data regarding dates, simulation duration, report
frequency etc.

To input data regarding dates:

1. Select General data > Dates from the Data menu. The following form appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Dates:

Start analysis on: select the day, month, year, hour and minute of the beginning of
the simulation.

Start reporting on: select the day, month, year, hour and minute when reporting of
simulation results is to begin. This must be on or after the simulation starting date
and time.

End analysis on: Enter the date and time when the simulation is to end. This must
be after the simulation starting date and time.

Start sweeping on: Enter the day of the year (month/day) when street sweeping
operations begin. The default is January 1.

End sweeping on: Enter the day of the year (month/day) when street sweeping
operations end. The default is December 31.

Dry days:

Number of antecedent dry days: Enter the number of days with no rainfall prior to
the start of the simulation. This value is used to compute an initial buildup of pollutant
load on the surface of subcatchments.

NOTE: If you are interested in steady state analysis then:

1. The start of the reporting is set equal to the start of the analysis.
2. The end of the analysis is set equal to the start of the analysis plus 15 minutes.
3. You should not change the default values of the times steps.

6.4.3 Time steps

With this option, you can input data regarding time steps.

To input data regarding time steps:

1. Select General data > Time steps from the Data menu. The following form
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appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Time steps:

Reporting time step: Enter the time interval for reporting of computed results. You
should select an appropriate time step so that the number of results is about 100 per
project.

Dry weather runoff: Enter the time step length used for runoff computations
(consisting essentially of pollutant buildup) during periods when there is no rainfall
and no ponded water. This must be greater or equal to the wet weather time step.

Wet weather runoff: Enter the time step length used to compute runoff from
subcatchments during periods of rainfall or when ponded water still remains on the
surface..

Routing (sec): Enter the time step length in decimal seconds used for routing flows
and water quality constituents through the conveyance system. Values around 600
seconds are generally sufficient. However, note that Dynamic wave routing requires a
much smaller time step than the other methods of flow routing

6.4.4 Dynamic wave

With this option, you can input data regarding the dynamic wave solver. These
settings are ignored in case other solvers are employed.

To input data regarding the dynamic wave solver:

1. Select General data > Dynamic wave from the Data menu. The following form
appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Dynamic wave:

Inertial terms: Indicates how the inertial terms in the St. Venant momentum
equation will be handled. Select keep to maintain these terms at their full value under
all conditions. Select Dampen to reduce the terms as flow comes closer to being
critical and ignores them when flow is supercritical. Select Ignore to drop the terms
altogether from the momentum equation, producing what is essentially a Diffusion
Wave solution.

Variable step: Check the box if an internally computed variable time step should be
used at each routing time period and select an adjustment (or safety) factor to apply
to this time step. The variable time step is computed so as to satisfy the Courant
condition within each conduit and yet prevent an excessive change in water depth at
each node. A typical adjustment factor would be 75% to provide some margin of
conservatism. The computed variable time step will not be less than 0.5 seconds nor
be greater than the fixed time step specified on the Time Steps page of the dialog. If
the latter was set lower than 0.5 seconds then the variable time step option is
ignored.

Minimum surface area: This is a minimum surface area used at nodes when
computing changes in water depth. If 0 is entered, then the default value of 12.566
ft2 (1.167 m2) is used. This is the area of a 4-ft diameter manhole.

Normal flow limit

Selects the basis used to determine when supercritical flow occurs in a conduit. The
choices are (a) water surface slope only (i.e., water surface slope > conduit slope) (b)
Froude number only (i.e., Froude number > 1.0) and (c) both water surface slope and
Froude number. The last option is recommended.

Conduit lengthening:

Time step (0 for no lengthening) (sec): This is a time step, in seconds, used to
artificially lengthen conduits so that they meet the Courant stability criterion under
full-flow conditions (i.e., the travel time of a wave will not be smaller than the
specified conduit lengthening time step). As this value is decreased, fewer conduits
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will require lengthening. A value of 0 means that no conduits will be lengthened.

Circular force main equation: select one of Hazen-Williams or Darcy-Weisbach. This
equation will be used to compute friction losses during pressurized flow for conduits
that have been assigned a Circular Force Main cross-section.

6.4.5 Interface files

With this option, you can input data regarding interface files.

To input data regarding interface files:

1. Select General data > Interface files from the Data menu. The following form
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Use:

The external file references that are defined serve as source for data input. Press the
corresponding button with the ellipses "..." to define a reference to an external file.
Press the "X" button to remove the reference. Source files can be defined for the
following cases:

Rainfall
Runoff
RDII
Hotstart
Inflow

Save:

The external file references that are defined serve as data output. Press the
corresponding button with the ellipses "..." to define a reference to an external file.
Press the "X" button to remove the reference. Target files can be defined for the
following cases:

Rainfall
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Runoff
RDII
Hotstart
Outflow

General information on the interface files

SWMM can use several different kinds of interface files that contain either externally
imposed inputs (e.g., rainfall or infiltration/inflow hydrographs) or the results of
previously run analyses (e.g., runoff or routing results). These files can help speed up
simulations, simplify comparisons of different loading scenarios, and allow large study
areas to be broken up into smaller areas that can be analyzed individually. 

The rainfall and runoff interface files are binary files created internally by the
program. These can be saved and reused from one analysis to the next.

If the same rainfall data are being used with many different analyses, saving the
rainfall interface file after the first run and then reusing this file in subsequent runs
can save computation time.

The rainfall interface file should not be confused with a rainfall data file. The latter is
an external text file that provides rainfall time series data for a single rain gage. The
former is a binary file created internally that processes all of the rainfall data files used
by a project.

The runoff interface file can be used to save the runoff results generated from a
simulation run. If runoff is not affected in future runs, the user can request that the
program use this interface file to supply runoff results without having to repeat the
runoff calculations again.

Hot start files are binary files created by the program that contain hydraulic and
water quality variables for the drainage system at the end of a run. These data consist
of the water depth and concentration of each pollutant at each node of the system as
well as the flow rate and concentration of each pollutant in each link. The hot start file
saved after a run can be used to define the initial conditions for a subsequent run.

Hot start files can be used to avoid the initial numerical instabilities that sometimes
occur under Dynamic Wave routing. For this purpose they are typically generated by
imposing a constant set of base flows (for a natural channel network) or set of dry
weather sanitary flows (for a sewer network) over some startup period of time. The
resulting hot start file from this run is then used to initialize a subsequent run where
the inflows of real interest are imposed

It is also possible to both use and save a hot start file in a single run, starting off the
run with one file and saving the ending results either to the same or to another file.
The resulting file can then serve as the initial conditions for a subsequent run if need
be. This technique can be used to divide up extremely long continuous simulations
into more manageable pieces

The RDII interface file is a text file that contains a time series of rainfall-derived
infiltration/inflow flows for a specified set of drainage system nodes. This file can be
generated from a previous run when Unit Hydrographs and nodal RDII inflow data
have been defined for the project, or it can be created outside of the program using
some other source of RDII data (e.g., through measurements or output from a
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different computer program). The format of the file is the same as that of the routing
interface file discussed below, where Flow is the only variable contained in the file.

A routing interface file stores a time series of flows and pollutant concentrations that
are discharged from the outfall nodes of drainage system model. This file can serve as
the source of inflow to another drainage system model that is connected at the outfalls
of the first system. This allows very large systems to be broken into smaller sub-
systems that can be analyzed separately and linked together through the routing
interface file. 

Interface file format (RDII/routing)

RDII interface files and routing interface files have the same format. They are simple
text files. Their structure is as follows:

1. the first line contains the keyword "SWMM5" (without the quotes).
2. a line of text that describes the file (can be blank).
3. the time step used for all inflow records (integer seconds).
4. the number of variables stored in the file, where the first variable must always be
flow rate.
5. the name and units of each variable (one per line), where flow rate is the first
variable listed and is always named FLOW.
6. the number of nodes with recorded inflow data
7. the name of each node (one per line).
8. a line of text that provides column headings for the data to follow (can be blank).
9. for each node at each time step, a line with:

the name of the node
the date (year, month, and day separated by spaces)
the time of day (hours, minutes, and seconds separated by spaces)
the flow rate followed by the concentration of each quality constituent

Time periods with no values at any node can be skipped. An excerpt from an RDII /
routing interface file is shown below:

SWMM5
Example File
300
1
FLOW CFS
2
N1
N2
Node Year Mon Day Hr Min Sec Flow
N1   2002 04  01  00 20  00  0.000000
N2   2002 04  01  00 20  00  0.002549
N1   2002 04  01  00 25  00  0.000000
N2   2002 04  01  00 25  00  0.002549

6.4.6 Design

With this option, you can input data regarding design.

To input data regarding design:
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1. Select General data > Design from the Data menu. The following form appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Design:

Conduit placement automation: select one of crown elevations, invert
elevations, 80% of conduit height, axes or none. Whatever this setting may be,
the user can always define the position of a conduit manually.

Cuts in excavations measured: select one of from ground or from trench. In the
second case, trench data are required.

Inlet bottoms measured: select one from bottom slab  or from sublayer.

Kinematic viscosity (m2/s): select the kinematic viscosity of the fluid. Press the
button with the ellipses "..." to invoke the corresponding database. This value is
needed when quality checks are performed and when the friction is calculated based
on the Darcy - Weisbach method.

Density (kg/m3): select the density of the fluid. Press the button with the ellipses
"..." to invoke the corresponding database. This value is needed when quality checks
are performed and when the friction is calculated based on the Darcy - Weisbach
method.

Maximum sewer peak flow factor: this is the maximum acceptable value of peak
flow factor. According to Greek Regulations, this value is equal to 3.

6.4.7 Checks

With this option, the maximum and minimum values of various parameters can be set.
If these values are breached, the corresponding field is typed in different (but
customizable) color. The default color option is red.

To set the maximum and minimum values of various parameters:

1. Select General data > Checks from the Data menu. The following form appears:
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2. Select Check the following hydraulic properties to enable or disable all checks.
3. Make the appropriate selections as described below.
4. Select Make default for all new projects if you wish to use these settings for all
new projects.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Capacity

Check New conduits maximum capacity to enable this check. Set the value in the
corresponding field.
Check Existing conduits maximum capacity to enable this check. Set the value in
the corresponding field. This check does not necessarily refer to old conduits, but to
existing conduits as set in conduit properties.
Press the corresponding colored button to change the font color of the results that
fail these checks.

NOTE: This check is not restrictive for the network. A conduit is functional even when
its capacity is 80%. However, the desired maximum capacity may be only 50%.

Velocities

Check Maximum flow velocity to enable this check. Set the value in the
corresponding field.
Check Minimum velocity for cleaning to enable this check.
Check Minimum velocity for full cleaning to enable this check.
Press the corresponding colored button to change the font color of the results that
fail these checks.

NOTE: The minimum velocity for cleaning and for full cleaning can be determined
only when appropriate quality data are provided.

Slopes

Set the Maximum allowed slope in the corresponding field.
Check Minimum allowed slope to enable this check. Press the button with the
ellipses to select the calculation method. The following form appears:
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Select the method of calculating the minimum slope. This can be one of the following:
o Greek Regulations 696/74 for storm networks

o Greek Regulations 696/74 for sewer or combined networks

o American regulations ASCE & WPCF

o Compare to value (in this case, you must provide the threshold value in the

corresponding field)

Press Ok to accept the changes. Press Cancel to close the form without any changes.

Press the corresponding colored buttons to change the font color of the results that
fail these checks.

6.4.8 Excavation options

With this option, you can set several excavation options.

To set excavation options:

1. Select General data > Checks from the Data menu. The following form appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data

Enter the expected dislocation of public utilities in ft or m.
Enter the average transport distance of excavations in ft or m.
Enter the number of pumps used for pumping out rainfall water.
Select the pump diameter.
Enter the pump operation hours.

6.5 Climatology

6.5.1 Temperature

With this option, you can input temperature data.

To input temperature data:
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1. Select Climatology > Temperature from the Data menu. The following form
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Source

Select No data if you do not want to input temperature data. Make this selection if
you do not want to simulate snow melt.
Select From time series if you have already entered a temperature time series and
you wish to use it. Otherwise, press the corresponding button with the ellipses "..."
to define a time series.
Select External climate file if you wish to use an external file containing data.
Press the corresponding button with the ellipses "..." to define a reference to an
external file. You can optionally select the first record to be taken into account by
setting its day, month and time.

Climate files

The program can use an external climate file that contains daily air temperature,
evaporation, and wind speed data. The program recognizes the following formats:

DSI-3200/DSI-3210 file available from the National Climatic Data Center (USA).
Canadian climate files available from Environment Canada.
A user-prepared climate file where each line contains a recording station name,
the year, month, day, maximum temperature, minimum temperature, and
optionally, evaporation rate, and wind speed. If no data are available for any of
these items on a given date, then an asterisk should be entered as its value.

When a climate file has days with missing values, the program will use the value from
the most recent previous day with a recorded value. For a user-prepared climate file,
the data must be in the same units as the project being analyzed. For US units,
temperature is in degrees F, evaporation is in inches/day, and wind speed is in miles/
hour. For metric units, temperature is in degrees C, evaporation is in mm/day, and
wind speed is in km/hour:

ST001  2004  12  01  10.0  28.0  145.0  1.9
ST002  2004  12  01  11.1  27.6  155.3  2.0
ST001  2004  12  01  9.9   26.5  144.0  1.9
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ST002  2004  12  01  10.2  26.2  150.1  1.8

6.5.2 Evaporation

With this option, you can input data regarding evaporation rates. Evaporation occurs 
for standing water on subcatchment surfaces, for subsurface water in groundwater
aquifers, and for water held in storage units.

To input data regarding evaporation rates:

1. Select Climatology > Evaporation from the Data menu. The following form
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Source

Select Constant value if evaporation remains constant over time. Provide the
evaporation rate in the corresponding field.
Select From time series if you have already entered a evaporation time series and
you wish to use it. If you have not defined a time series, press the corresponding
button with the ellipses "..." to define one.
Select From climate file if you wish to use the external climate file defined in the
temperature page. The file must contain evaporation data.
Select Monthly averages if you wish to use mean annual monthly values. Press the
corresponding button with the ellipses "...". The following form appears:
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The user can specify an optional Monthly Soil Recovery Pattern. This is a time
pattern whose factors adjust the rate at which infiltration capacity is recovered during
periods with no precipitation. It applies to all subcatchments for any choice of
infiltration method. For example, if the normal infiltration recovery rate was 1% during
a specific time period and a pattern factor of 0.8 applied to this period, then the actual
recovery rate would be 0.8%. The Soil Recovery Pattern allows one to account for
seasonal soil drying rates. In principle, the variation in pattern factors should mirror
the variation in evaporation rates but might be influenced by other factors such as
seasonal groundwater levels. 

Type the values directly onto the table. Press Ok to close the form saving all changes.
Press Cancel to close the form without any changes.

6.5.3 Wind speed

With this option, you can input wind speed data. Wind speed is an optional climatic
variable that is only used for snowmelt calculations.

To input wind speed data:

1. Select Climatology > Wind speed from the Data menu. The following form
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Source

Select From climate file if you wish to use the external climate file defined in the
temperature page. The file must contain wind speed data.
Select Monthly averages if you wish to use mean annual monthly values. Press the
corresponding button with the ellipses "...". The following form appears:
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Type the values directly onto the table. Press Ok to close the form saving all changes.
Press Cancel to close the form without any changes.

6.5.4 Snow melt

With this option, you can input snow melt data. 

To input snow melt data:

1. Select Climatology > Snow melt from the Data menu. The following form
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data

Dividing temperature between snow and rain: If the temperature is below this
value then the precipitation falls as snow instead of rain.
Antecedent Temperature Index weight: This parameter reflects the degree to
which heat transfer within a snow pack during non-melt periods is affected by prior
air temperatures. Smaller values reflect a thicker surface layer of snow which results
in reduced rates of heat transfer. Values must be between 0 and 1, and the default
is 0.5.
Negative melt ratio: This is the ratio of the heat transfer coefficient of a snow pack
during non-melt conditions to the coefficient during melt conditions. It must be a
number between 0 and 1. The default value is 0.6.
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Elevation above mean sea level: Enter the average elevation above mean sea
level for the study area, in feet or meters. This value is used to provide a more
accurate estimate of atmospheric pressure. The default is 0.0, which results in a
pressure of 29.9 inches Hg. The effect of wind on snow melt rates during rainfall
periods is greater at higher pressures, which occur at lower elevations.
Latitude: Enter the latitude of the study area in degrees North. This number is used
when computing the hours of sunrise and sunset, which in turn are used to extend
min/max daily temperatures into continuous values. The default is 50 degrees North
Longitude correction (+/- minutes): This is a correction, in minutes of time,
between true solar time and the standard clock time. It depends on a location's
longitude (θ) and the standard meridian of its time zone (SM) through the
expression 4(θ-SM). This correction is used to adjust the hours of sunrise and sunset
when extending daily min/max temperatures into continuous values. The default
value is 0.

6.5.5 Areal depletion

With this option, you can input areal depletion data. These are used to specify points
on the Areal Depletion Curves for both impervious and pervious surfaces within a
project's study area. These curves define the relation between the area that remains
snow covered and snow pack depth. Each curve is defined by 10 equal increments of
relative depth ratio between 0 and 0.9. (Relative depth ratio is the ratio of an area's
current snow depth to the depth at which there is 100% areal coverage). A typical
graph is as follows:
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To input area depletion data:

1. Select Climatology > Areal depletion from the Data menu. The following form
appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data

Select the button with the ellipses to edit the fraction of area covered by snow.
The following form appears:

Enter values in the data grid provided for the fraction of each area that remains snow
covered at each specified relative depth ratio. Valid numbers must be between 0 and
1, and be increasing with increasing depth ratio.
Press the Natural Area button to fill the grid with values that are typical of natural
areas. 
Press the No Depletion button to fill the grid with all 1's, indicating that no areal
depletion occurs.
Press Ok to save the changes and close the dialog box. Press Cancel to close the
dialog box without saving any changes.

6.5.6 IDF curve

With this option, you can select the IDF curve that will be used for the calculation of
the design storm. The rain intensity can be either constant or calculated from an IDF
curve or by using linear interpolation in a data matrix that correlates the rainfall
duration and intensity. 

To select the IDF curve:

1. Select Climatology > IDF curve from the Data menu. The following form
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appears:

2. Make the appropriate changes.
3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To use an IDF curve:

1. Click the Intensity duration curve option button.
2. Enter the values of the coefficients c, b and n, in such a way that when time t is
entered in hours, the intensity will be given in mm/h.
3. Optionally, select Database... to invoke the IDF database. 

NOTE: The selection of IDF curve is not required in case the design flow rate is known
or raingages are to be used. IDF curves are used in conjunction with runoff areas.

To select a constant rainfall intensity:

1. Click the Constant rainfall intensity option button.
2. Enter the rainfall intensity in mm/h. The design flow rate is calculated based on
this value; it is not based on the initial concentration time.

To use linear interpolation in a data matrix that correlates the rainfall duration and
intensity:

1. Click the Rainfall duration - intensity correlation option button.
2. Enter a curve that describes the correlation between rainfall duration (in min) and
intensity (in mm/h). The program will use the exact values, if found, or will estimate a
value using linear interpolation. The curve can be entered manually or imported from a
RCV (TechnoLogismiki) file or a HYDRO IDF file.
3. Select Import to import a curve from a RCV (TechnoLogismiki) file or a HYDRO IDF
file.
4. Select Export to export the current curve from a RCV (TechnoLogismiki) file or a
HYDRO IDF file.
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5. Select Add, Remove and Insert to add, remove and insert a record, respectively.

6.6 Hydrology

6.6.1 Raingages

This option is described in detail in Objects > Properties > Raingages.

6.6.2 Subcatchments

This option is described in detail in Objects > Properties > Subcatchments.

6.6.3 Aquifers

Aquifers are sub-surface groundwater areas used to model the vertical movement of
water infiltrating from the subcatchments that lie above them. They also permit the
infiltration of groundwater into the drainage system, or exfiltration of surface water
from the drainage system, depending on the hydraulic gradient that exists.

The same aquifer object can be shared by several subcatchments. Aquifers are only
required in models that need to explicitly account for the exchange of groundwater
with the drainage system or to establish baseflow and recession curves in natural
channels and non-urban systems.

Aquifers are represented using two zones – an un-saturated zone and a saturated
zone. Their behavior is characterized using such parameters as soil porosity, hydraulic
conductivity, evapotranspiration depth, bottom elevation, and loss rate to deep
groundwater. In addition, the initial water table elevation and initial moisture content
of the unsaturated zone must be supplied.

Aquifers are connected to subcatchments and to drainage system nodes. 

To manage aquifers:

1. Select Hydrology > Aquifers from the Data menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new aquifer:

1. Press Add. The following form appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing aquifer:

1. Select the aquifer from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing aquifer:

1. Select the aquifer from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The aquifer is deleted from the list.

To move an existing aquifer upwards in the list:

1. Select the aquifer from the list on the left.
2. Press Move Up. 
3. The aquifer is moved one place upwards.

To move an existing aquifer downwards in the list:

1. Select the aquifer from the list on the left.
2. Press Move Down. 
3. The aquifer is moved one place downwards.

To sort the aquifer list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

Aquifer properties

Name: enter a user-assigned aquifer name. This name cannot be null or used for
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another aquifer in the project.
Porosity (volumetric fraction): enter the ration of volume of voids over the total
soil volume 
Wilting point (volumetric fraction): enter the soil moisture content at which
plants cannot survive.
Field capacity (volumetric fraction): enter the soil moisture content after all free
water has drained off.
Saturated hydraulic conductivity (in/hr or mm/hr): enter the soil's saturated
hydraulic conductivity.
Mean slope of conductivity vs soil moisture content curve (in/hr or mm/hr):
enter the average slope of conductivity versus soil moisture content curve.
Mean slope of soil tension vs soil moisture content curve (inches or mm): 
enter the average slope of soil tension versus soil moisture content curve.
Upper unsaturated zone evaporation fraction : enter the fraction of total
evaporation available for evapotranspiration in the upper unsaturated zone.
Lower evaporation depth (ft or m): enter the maximum depth into the lower
saturated zone over which evapotranspiration can occur.
Lower groundwater loss rate to deep groundwater (in/hr or mm/hr) : enter
the rate of percolation from saturated zone to deep groundwater.
Bottom aquifer elevation (ft or m): enter the elevation of the bottom of the
aquifer.
Water table elevation at the start of the simulation (ft or m): enter the
elevation of the water table in the aquifer at the start of the simulation.
Moisture content of the unsaturated aquifer upper zone (volumetric
fraction): enter the moisture content of the unsaturated upper zone of the aquifer
at the start of the simulation (it cannot exceed soil porosity).

6.6.4 Snow packs

Snow Pack objects contain parameters that characterize the buildup, removal, and
melting of snow over three types of sub-areas within a subcatchment:

The Plowable snow pack area consists of a user-defined fraction of the total
impervious area. It is meant to represent such areas as streets and parking lots
where plowing and snow removal can be done.
The Impervious snow pack area covers the remaining impervious area of a
subcatchment.
The Pervious snow pack area encompasses the entire pervious area of a
subcatchment.

Each of these three areas is characterized by the following parameters:

Minimum and maximum snow melt coefficients
minimum air temperature for snow melt to occur
snow depth above which 100% areal coverage occurs
initial snow depth
initial and maximum free water content in the pack

In addition, a set of snow removal parameters can be assigned to the Plowable area.
These parameters consist of the depth at which snow removal begins and the fractions
of snow moved onto various other areas.

A single snow pack object can be applied to any number of subcatchments. Assigning
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a snow pack to a subcatchment simply establishes the melt parameters and initial
snow conditions for that subcatchment. Internally, the program creates a "physical"
snow pack for each subcatchment, which tracks snow accumulation and melting for
that particular subcatchment based on its snow pack parameters, its amount of
pervious and impervious area, and the precipitation history it sees.

To manage snow packs:

1. Select Hydrology > Snow packs from the Data menu. The following form
appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new snow pack:

1. Press Add. The following form appears:

2. Make the appropriate selections as described below.
3. Press the button with the ellipses "..." to edit the snow pack parameters. The
following form appears:
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Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing snow pack:

1. Select the snow pack from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing snow pack:

1. Select the snow pack from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The snow pack is deleted from the list.

To move an existing snow pack upwards in the list:

1. Select the snow pack from the list on the left.
2. Press Move Up. 
3. The snow pack is moved one place upwards.

To move an existing snow pack downwards in the list:

1. Select the snow pack from the list on the left.
2. Press Move Down. 
3. The snow pack is moved one place downwards.

To sort the snow pack list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

Snow pack properties

Name: enter a user-assigned snow pack name. This name cannot be null or used for
another snow pack in the project.
Fraction of impervious area that is plowable: enter the fraction of the
impervious area that is plowable and therefore is not subject to areal depletion.
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Depth at which snow removal begins (in or mm): no removal occurs at depths
below this and the fractions specified below are applied to the snow depths in excess
of this number.
Fraction transferred out of the watershed: enter the fraction of excess snow
depth that is removed from the system (and does not become runoff).
Fraction transferred to the impervious area: enter the fraction of excess snow
depth that is added to snow accumulation on the pack's impervious area.
Fraction transferred to the pervious area: enter the fraction of excess snow
depth that is added to snow accumulation on the pack's pervious area.
Fraction converted into immediate melt: enter the fraction of excess snow depth
that becomes liquid water which runs onto any subcatchment associated with the
snow pack.
Fraction moved to another subcatchment: enter the fraction of excess snow
depth which is added to the snow accumulation on some other subcatchment. The
name of the subcatchment must also be provided.

Snow pack parameters

Min melt coefficient (in/h/deg.F or mm/h/deg.C): enter the degree-day snow
melt coefficient that occurs on December 21.
Max melt coefficient (in/h/deg.F or mm/h/deg.C): enter the degree-day snow
melt coefficient that occurs on June 21. For a short term simulation of less than a
week or so it is acceptable to use a single value for both the minimum and
maximum melt coefficients. The minimum and maximum snow melt coefficients are
used to estimate a melt coefficient that varies by day of the year. The latter is used
in the following degree-day equation to compute the melt rate for any particular
day:

Melt Rate = (Melt Coefficient) * (Air Temperature – Base Temperature).
Base temperature (deg. F or deg. C): enter the temperature at which snow
begins to melt.
Fraction free water capacity: enter the volume of a snow pack's pore space which
must fill with melted snow before liquid runoff from the pack begins, expressed as a
fraction of snow pack depth.
Initial snow depth (water equivalent in or mm): enter the depth of snow at the
start of the simulation.
Initial free water (in or mm): enter the depth of melted water held within the
pack at the start of the simulation. This number should be at or below the product of
the initial snow depth and the fraction free water capacity.
Depth at 100% cover (in or mm): enter the depth of snow beyond which the
entire area remains completely covered and is not subject to any areal depletion
effect.

6.6.5 RDII hydrographs

Unit Hydrographs (UHs) estimate rainfall-derived infiltration/inflow (RDII) into a sewer
system. A UH set contains up to three such hydrographs, one for a short-term
response, one for an intermediate-term response, and one for a long-term response. A
UH group can have up to 12 UH sets, one for each month of the year. Each UH group is
considered as a separate object by the program, and is assigned its own unique name
along with the name of the rain gage that supplies rainfall data to it.

Each unit hydrograph is defined by three parameters:
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R: the fraction of rainfall volume that enters the sewer system 
Τ: the time from the onset of rainfall to the peak of the UH (h)
Κ: the ratio of time to recession of the UH to the time to peak

A UH group can also have a set of Initial Abstraction (IA) parameters associated with
it. These determine how much rainfall is lost to interception and depression storage
before any excess rainfall is generated and transformed into RDII flow by a unit
hydrograph. The IA parameters consist of:

a maximum possible depth of IA (inches or mm).
a recovery rate (inches/day or mm/day) at which stored IA is depleted during
dry periods.
an initial depth of stored IA (inches or mm). 

Unit Hydrograph RDII
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In the above example, the time to the peak of the UH is 1 hour, the base time is Tb=6
hours and hence K=(Tb-T)/T=5. The peak flow is 50 units.

An alternative to using unit hydrographs to define RDII flow is to create an external
RDII interface file, which contains RDII time series data.

To manage UH RDIIs:

1. Select Hydrology > RDII hydrographs from the Data menu. The following form
appears:
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2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new UH RDII:

1. Press Add. The following form appears:

2. Make the appropriate selections as described below.
3. Select All months if you wish to use common values for all months. If you wish to
use separate values for each month, check the corresponding months. If there is no
data for a specified month, the common values are used.
4. Press the corresponding button with the ellipses "..." to enter data for a specified
month (or common values). The following form appears:

Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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To edit an existing UH RDII:

1. Select the UH RDII from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing UH RDII:

1. Select the UH RDII from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The UH RDII is deleted from the list.

To move an existing UH RDII upwards in the list:

1. Select the UH RDII from the list on the left.
2. Press Move Up. 
3. The UH RDII is moved one place upwards.

To move an existing UH RDII downwards in the list:

1. Select the UH RDII from the list on the left.
2. Press Move Down. 
3. The UH RDII is moved one place downwards.

To sort the UH RDII list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

UH properties

Name: enter a user-assigned UH name. This name cannot be null or used for
another UH in the project.
Raingage: select the raingage that corresponds to the specified UH from the drop-
down list.

UH parameters

R: the fraction of rainfall volume that enters the sewer system 
Τ: the time from the onset of rainfall to the peak of the UH (h)
Κ: the ratio of time to recession of the UH to the time to peak
maximum possible depth of IA (inches or mm).
recovery rate (inches/day or mm/day) at which stored IA is depleted during dry
periods.
initial depth of stored IA (inches or mm). 
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6.7 Quality

6.7.1 Pollutants

The program can simulate the generation, inflow and transport of any number of user-
defined pollutants. Required information for each pollutant includes:

pollutant name
concentration units (i.e., milligrams/liter, micrograms/liter, or counts/liter)
concentration in rainfall
concentration in groundwater
concentration in direct infiltration/inflow
first-order decay coefficient

Co-pollutants can also be defined. For example, pollutant X can have a co-pollutant Y,
meaning that the runoff concentration of X will have some fixed fraction of the runoff
concentration of Y added to it.

Pollutant buildup and washoff from subcatchment areas are determined by the land
uses assigned to those areas. Input loadings of pollutants to the drainage system can
also originate from external time series inflows as well as from dry weather inflows.

To manage aquifers:

1. Select Hydrology > Pollutants from the Data menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new pollutant:

1. Press Add. The following form appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing pollutant:

1. Select the pollutant from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing pollutant:

1. Select the pollutant from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The pollutant is deleted from the list.

To move an existing pollutant upwards in the list:

1. Select the pollutant from the list on the left.
2. Press Move Up. 
3. The pollutant is moved one place upwards.

To move an existing pollutant downwards in the list:

1. Select the pollutant from the list on the left.
2. Press Move Down. 
3. The pollutant is moved one place downwards.

To sort the pollutant list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

pollutant properties

Name: enter a user-assigned pollutant name. This name cannot be null or used for
another pollutant in the project.
Units: enter the concentration units (mg/L, ug/L, or #/L (counts/L)) in which the
pollutant concentration is expressed.
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Concentration in rain water: enter the concentration of the pollutant in rain water.
Concentration in groundwater: enter the concentration of the pollutant in ground
water.
Concentration in inflow/infiltration: enter the concentration of the pollutant in
any Infiltration/Inflow.
Decay coefficient (1/days): enter the first-order decay coefficient of the pollutant.
Buildup only during snowfall events: check this option if pollutant buildup occurs
only when snowfall occurs.
Runoff concentration depends on: enter (optionally) the name of another
pollutant whose runoff concentration contributes to the runoff concentration of the
current pollutant.
Fraction of contributing runoff: enter the fraction of the co-pollutant's runoff
concentration that contributes to the runoff concentration of the current pollutant.
An example of a co-pollutant relationship would be where the runoff concentration of
a particular heavy metal is some fixed fraction of the runoff concentration of
suspended solids. In this case suspended solids would be declared as the co-
pollutant for the heavy metal.

6.7.2 Land uses

Land Uses are categories of development activities or land surface characteristics
assigned to subcatchments. Examples of land use activities are residential,
commercial, industrial, and undeveloped. Land surface characteristics might include
rooftops, lawns, paved roads, undisturbed soils, etc. Land uses are used solely to
account for spatial variation in pollutant buildup and washoff rates within
subcatchments.

The program has many options for defining land uses and assigning them to
subcatchment areas. One approach is to assign a mix of land uses for each
subcatchment, which results in all land uses within the subcatchment having the
same pervious and impervious characteristics. Another approach is to create
subcatchments that have a single land use classification along with a distinct set of
pervious and impervious characteristics that reflects the classification.

The following processes can be defined for each land use category:

pollutant buildup
pollutant washoff
street cleaning

Pollutant buildup

Pollutant buildup that accumulates within a land use category is described (or
“normalized”) by either a mass per unit of subcatchment area or per unit of curb
length. Mass is expressed in pounds for US units and kilograms for metric units. The
amount of buildup is a function of the number of preceding dry weather days and can
be computed using one of the following functions:

Power Function: Pollutant buildup (B) accumulates proportionally to time (t) raised
to some power, until a maximum limit is achieved:
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where C1 is the maximum buildup possible (mass per unit of area or curb length), C2

is the buildup rate constant and C3 is the time exponent.

Exponential Function: Buildup follows an exponential growth curve that approaches
a maximum limit asymptotically:

where C1 is the maximum buildup possible (mass per unit of area or curb length) and

C2 is the buildup rate constant (1/days).

Saturation Function: Buildup begins at a linear rate that continuously declines with
time until a saturation value is reached:

where C
1
 is the maximum buildup possible (mass per unit of area or curb length) and

C
2
 is the half-saturation constant (days to reach half of the maximum buildup).

Pollutant Washoff

Pollutant washoff from a given land use category occurs during wet weather periods
and can be described in one of the following ways:

Exponential Washoff: The washoff load (W) in units of mass per hour is proportional
to the product of runoff raised to some power and to the amount of buildup remaining:

where C1 is the washoff coefficient, C2 is the washoff exponent, q is the runoff rate per

unit area (inches/hour or mm/hour), and B is the pollutant buildup in mass (lbs or kg)
per unit area or curb length. Washoff mass units are the same as used to express the 
pollutant's concentration (milligrams, micrograms, or counts).

Rating Curve Washoff: The rate of washoff W in mass per second is proportional to
the runoff rate raised to some power:

where C
1
 is the washoff coefficient, C

2
 is the washoff exponent, and Q is the runoff

rate in user-defined flow units.

Event Mean Concentration: This is a special case of Rating Curve Washoff where the
exponent C

2 
is 1.0 and the coefficient C

1
 represents the washoff pollutant

concentration in mass per liter (Note:the conversion between user-defined flow units
used for runoff and liters is handled internally by the program).

Note that in each case buildup is continuously depleted as washoff proceeds, and
washoff ceases when there is no more buildup available.
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Washoff loads for a given pollutant and land use category can be reduced by a fixed
percentage by specifying a BMP Removal Efficiency that reflects the effectiveness of
any BMP controls associated with the land use. It is also possible to use the Event
Mean Concentration option by itself, without having to model any pollutant buildup at
all.

Street Sweeping

Street sweeping can be used on each land use category to periodically reduce the
accumulated buildup of specific pollutants. The parameters that describe street
sweeping include:

days between sweeping
days since the last sweeping at the start of the simulation
the fraction of buildup of all pollutants that is available for removal by sweeping
the fraction of available buildup for each pollutant removed by sweeping

Note that these parameters can be different for each land use, and the last parameter
can vary also with pollutant.

To manage land uses:

1. Select Hydrology > Land uses from the Data menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new land use:

1. Press Add. The following form appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing land use:

1. Select the land use from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing land use:

1. Select the land use from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The land use is deleted from the list.

To move an existing land use upwards in the list:

1. Select the land use from the list on the left.
2. Press Move Up. 
3. The land use is moved one place upwards.

To move an existing land use downwards in the list:

1. Select the land use from the list on the left.
2. Press Move Down. 
3. The land use is moved one place downwards.

To sort the land use list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.
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Information

Name: enter a user-assigned land use name. This name cannot be null or used for
another land use in the project.
Description: enter an optional comment or description of the land use. Press the
button with the ellipses "..." to edit multi-line text.
Street sweeping interval (days): Days between street sweeping within the land
use.
Street sweeping availability: Fraction of the buildup of all pollutants that is
available for removal by sweeping.
Days since last swept (days): Number of days since last swept at the start of the
simulation.

Buildup

Pollutant: select the pollutant whose buildup properties are being edited.
Function: select the type of buildup function to use for the pollutant. The choices
are None, Power, Exponential and Saturation.
Maximum buildup (lbs or kg): The maximum buildup of the pollutant that can
occur per unit of the normalizer variable. This is the same as the C1 coefficient used

in the buildup formulas. 
Rate constant: The time constant that governs the rate of pollutant buildup. This is
the C2 coefficient in the Power and Exponential buildup formulas. For Power buildup

its units are mass / days raised to a power, while for Exponential buildup its units
are 1/days.
Power/saturation constant: The exponent C3 used in the Power buildup formula,

or the half-saturation constant C2 used in the Saturation buildup formula. For the

latter case, its units are days
Normalizer: The variable to which buildup is normalized on a per unit basis. The
choices are either land area (in acres or hectares) or curb length. Any units of
measure can be used for curb length,as long as they remain the same for all
subcatchments in the project.

Washoff

Function: select the choice of washoff function to use for the pollutant. The choices
are: None, Exponential, Rating curve and Event mean concentration.
Coefficient: enter the value of C

1
 in the exponential and rating curve formulas, or

the event-mean concentration.
Exponent: enter the exponent used in the exponential and rating curve washoff
formulas.
Street cleaning efficiency (%): The street cleaning removal efficiency (percent)
for the pollutant. It represents the fraction of the amount that is available for
removal on the land use as a whole which is actually removed.
BMP efficiency: Removal efficiency (percent) associated with any Best Management
Practice that might have been implemented. The washoff load computed at each
time step is simply reduced by this amount.
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6.7.3 Quality data

With this option, you can enter water quality data. These are optional. The water
quality data are the same throughout the network.

To enter water quality data:

1. Select Quality data from the Data menu. The following form will appear:

2. Enter the data as follows:

BOD5 production: enter the BOD5 production in kg/day. Click the button with

the ellipses (...) on the right of the text box to invoke the corresponding database
.
Check Use specific sewer flow rate if the sewer flow rate is known. This is
usually valid in mixed-type networks, in which case the flow rate is entered in the
corresponding text box.
Sewer temperature (deg. F or deg. C): enter the mean sewer temperature in
degrees Celsius.
Initial sulfur concentration (mg/L): enter the initial sulfur concentration in
mg/L. Click the button with the ellipses (...) on the right of the text box to invoke
the corresponding database.

Characteristic grain density (lb/ft3 or  kg/m3): enter the characteristic grain

density in kg/m3. This is used for the calculation of the cleaning velocity and the
full cleaning velocity.
Characteristic grain size (in or mm): enter the characteristic grain size in mm.
This is used for the calculation of the cleaning velocity and the full cleaning
velocity.

3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.8 Curves

6.8.1 Management

Curves are objects that describe the relation between two quantities. The following
curve types are available:

Storage curves
Diversion curves
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Tidal curves
Shape curves
Pump curves
Rating curves
Control curves

To manage curves:

1. Select Curves from the Data menu.
2. Select the appropriate curve type from the submenu. The following form appears:

3. Make the necessary modifications.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.8.2 Add

To add a new curve:

1. Press Add. The data form that corresponds to the specified curve type appears.
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2. Enter a user-assigned name. This name cannot be null or used for another curve in
the project.
3. For pump curves, select the pump curve type from the drop-down list.
4. Optionally, add some comments  to the curve. Press the ellipsis button to edit
multiline text.
5. Press add to add a line at the end of the data list.
6. Press remove to remove the current line of the data list
7. Press insert to insert a line above the current line of the data list.
8. Type the data in the data list.
9. If you wish to clear the data list, press clear. 
10. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To import a curve from an external file:

1. Press Import. The file selection dialog box appears:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Curve file" with the extension .dat.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file. 

NOTE: A warning message will be displayed if the curve type of the imported file
does not match the current curve type.

To export a curve to an external file:

1. Press Export. The file selection dialog box appears:
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6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

To view a curve:

1. Press View. The curve is drawn in a separate window:

6.8.3 Delete

To delete an existing curve:

1. Select the curve from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The curve is deleted from the list.
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6.8.4 Edit

To edit an existing curve:

1. Select the curve from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add curve topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.8.5 Move

To move an existing curve upwards in the list:

1. Select the curve from the list on the left.
2. Press Move Up. 
3. The curve is moved one place upwards.

To move an existing curve downwards in the list:

1. Select the curve from the list on the left.
2. Press Move Down. 
3. The curve is moved one place downwards.

6.8.6 Sort

To sort the curve list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.9 Time series

6.9.1 Management

Time Series objects are used to describe how certain object properties vary with time.
Time series can be used to describe:

temperature data
evaporation data
rainfall data
water stage at outfall nodes
external inflow hydrographs at drainage system nodes
external inflow pollutographs at drainage system nodes
control settings for pumps and flow regulators

Each time series must be given a unique name and can be assigned any number of
time-value data pairs. Time can be specified either as hours from the start of a
simulation or as an absolute date and time-of-day.

For rainfall time series, it is only necessary to enter periods with non-zero rainfall
amounts. The program interprets the rainfall value as a constant value lasting over
the recording interval specified for the rain gage that utilizes the time series. For all
other types of time series, the program uses interpolation to estimate values at times
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that fall in between the recorded values.

For times that fall outside the range of the time series, the program will use a value of
0 for rainfall and external inflow time series, and either the first or last series value for
temperature, evaporation, and water stage time series.

To manage time series:

1. Select Time series from the Data menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Time series files

Time series files are external text files that contain data for time series objects.
Examples of time series data include rainfall, evaporation, inflows to nodes of the
drainage system, and water stage at outfall boundary nodes. Normally these data are
entered and edited through the time series editor. However there is an option to
import data from an external file into the editor. Creating and editing this file can be
done outside of the program, using text editors or spreadsheet programs.

The format of a time series file consists of two lines of descriptive text followed by the
actual time series data, with one time series value per line. Typically, the first text line
identifies the time series and the second line includes a detailed description of the
time series. Time series values can either be in date / time / value format or in time /
value format, where each entry is separated by one or more spaces or tab characters.
For the date / time / value format, dates are entered as month/day/year (e.g.,
7/21/2004) and times as 24-hour military time (e.g., 8:30 pm is 20:30). After the
first date, additional dates need only be entered whenever a new day occurs. For the
time / value format, time can either be decimal hours or military time since the start
of a simulation (e.g., 2 days, 4 hours and 20 minutes can be entered as either 52.333
or 52:20). An example of a time series file is shown below:

EPASWMM Time Series Data
<optional description goes here>
12/31/2005  00:00   0.00
            06:00   3.22
            12:00   5.78
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      18:00   2.11
01/01/2006  00:00   1.08
            06:00   0.03
            12:00   0.00

6.9.2 Add

To add a new time series:

1. Press Add. The data form appears:

2. Enter a user-assigned name. This name cannot be null or used for another time
series in the project.
3. Optionally, add some comments  to the curve. Press the ellipsis button to edit
multiline text.
4. If the data are located in an external file, check the use this file instead of the
following table. Then click the ellipsis button to select the external time-series file.
5. Press add to add a line at the end of the data list.
6. Press remove to remove the current line of the data list
7. Press insert to insert a line above the current line of the data list.
8. Type the data in the data list.
9. If you wish to clear the data list, press clear. 
10. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To import a time series from an external file:

1. Press Import. The file selection dialog box appears:
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Time series file" with the extension .dat.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file. 

To export a time series to an external file:

1. Press Export. The file selection dialog box appears:

6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

To view a time series:

1. Press View. The time series is drawn in a separate window:



Sewer Networks114

© 2012 TechnoLogismik i

6.9.3 Delete

To delete an existing time series:

1. Select the time series from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The time series is deleted from the list.

6.9.4 Edit

To edit an existing time series:

1. Select the time series from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add time series topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.9.5 Move

To move an existing time series upwards in the list:

1. Select the time series from the list on the left.
2. Press Move Up. 
3. The time series is moved one place upwards.

To move an existing time series downwards in the list:

1. Select the time series from the list on the left.
2. Press Move Down. 
3. The time series is moved one place downwards.
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6.9.6 Sort

To sort the time series list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.10 Time patterns

6.10.1 Management

Time Patterns allow external Dry Weather Flow (DWF) to vary in a periodic fashion.
They consist of a set of adjustment factors applied as multipliers to a baseline DWF
flow rate or pollutant concentration. The different types of time patterns include:

monthly: one multiplier for each month of the year
daily: one multiplier for each day of the week
hourly: one multiplier for each hour from 12 AM to 11 PM
weekend: hourly multipliers for weekend days

Each Time Pattern must have a unique name and there is no limit on the number of
patterns that can be created. Each dry weather inflow (either flow or quality) can have
up to four patterns associated with it, one for each type listed above.

To manage time patterns:

1. Select Time patterns from the Data menu.  The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.10.2 Add

To add a new time pattern:

1. Press Add. The data form appears:
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2. Enter a user-assigned name. This name cannot be null or used for another time
series in the project.
3. Optionally, add some comments  to the curve. Press the ellipsis button to edit
multiline text.
4. Select the pattern type from the drop-down list.
5. Type the data in the data list. The time pattern is drawn in the picture box in real
time.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

NOTE: In order to maintain an average dry weather flow or pollutant concentration at
its specified value, the multipliers for a pattern should average to 1.0. The average
value is displayed graphically as a horizontal blue line. It is also displayed analytically
in the sketch as "AV".

6.10.3 Delete

To delete an existing time pattern:

1. Select the time pattern from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The time pattern is deleted from the list.

6.10.4 Edit

To edit an existing time pattern:

1. Select the time pattern from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add time pattern topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
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dialog box without saving any changes.

6.10.5 Move

To move an existing time pattern upwards in the list:

1. Select the time pattern from the list on the left.
2. Press Move Up. 
3. The time pattern is moved one place upwards.

To move an existing time pattern downwards in the list:

1. Select the time pattern from the list on the left.
2. Press Move Down. 
3. The time pattern is moved one place downwards.

6.10.6 Sort

To sort the time pattern list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.11 Runoff areas

6.11.1 Management

With this option, you can enter data regarding runoff areas. Each area can have
different runoff coefficient. For example, a storm network can include inflow from road
surface and an external basin.

To enter data regarding runoff areas:

1. Select Runoff areas from the Data menu.
2. Enter the data as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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6.11.2 Add

To add a new area:

1. Select Add. The following form appears:

2. Enter a unique name for the area.
3. Enter the runoff coefficient. Optionally, select the button with the ellipses (...) to
invoke the corresponding database.
4. Select Ok to add the new area to the list and close the dialog box. Select Cancel to
close the dialog box without saving any changes.

6.11.3 Delete

To delete an existing runoff area:

1. Select the runoff area from the list.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The runoff area is deleted from the list.

NOTE: If an existing area is deleted, all corresponding entries in the inflow forms will
also be deleted.

6.11.4 Edit

To edit an existing area:

1. Select the area from the list.
2. Select Edit. The data form appears.
3. Make the appropriate changes as described in the add area topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.12 Sewer flow (population)

6.12.1 Management

For sewer networks, the program can compute the inflows using the actual number of
people being serviced at each conduit. For example, a small village has a population of
800. Suppose that 50 people live in a block and only one pipe services their
apartments. The program can compute the flow rate of sewage into that pipe, as the
percentage (50/800) of the total flow rate. You can specify different water
consumptions that lead to different sewer design flow rates, by adding areas
corresponding to residents, tourists, factories or special consumers.

To enter data regarding sewer flow calculated using population data:

1. Select Sewer Flow (Population) from the Data menu.



Data 119

© 2012 TechnoLogismik i

2. Enter the data as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.12.2 Add

To add a new sewer flow (population) area:

1. Select Add. The following form appears:

2. Enter a unique name for the consumer.
3. Select the consumer type from the drop down list. Depending on your choice,
different data is required.
4. If you selected industry, then the number of hours that the factory is in operation
is required.
5. Enter the mean daily water consumption. Click the button with the ellipses (...)
on the right of the text box to invoke the corresponding database.
6. Enter the fraction of water consumption that ends in the sewer. Usually this
amount is around 80%.
7. Enter the daily peak factor which will be used to convert the mean daily sewer
flow to maximum daily sewer flow. If you have selected industry, then the peak factor
is equal to 24/(hours of operation), while for special consumers the peak factor is
always equal to unity.
8. Optionally you can enter an augmentation factor to increase the maximum daily
sewer flow.
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9. Select Ok to add the new area to the list and close the dialog box. Select Cancel to
close the dialog box without saving any changes.

6.12.3 Delete

To delete an existing sewer flow (population) data:

1. Select the data from the list.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The runoff area is deleted from the list.

NOTE: If an existing area is deleted, all corresponding entries in the inflow forms will
also be deleted.

6.12.4 Edit

To edit existing sewer flow (population) data:

1. Select the data from the list.
2. Select Edit. The data form appears.
3. Make the appropriate changes as described in the add sewer flow (population)
topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.13 Sewer flow (area)

6.13.1 Management

For sewer networks, the program can compute the inflows using the actual size of the
areas being serviced at each conduit. For example, a small village has a total area of
50 hectares. Suppose that one block has an area of 2 hectares and only one pipe
services the apartments built in this block. The program can compute the flow rate of
sewage into that pipe, as the percentage (2/50) of the total flow rate. You can specify
different water consumptions that lead to different sewer design flow rates, by adding
areas corresponding with varying characteristics.

To enter data regarding sewer flow calculated using areas:

1. Select Sewer Flow (Area) from the Data menu.
2. Enter the data as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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6.13.2 Add

With this option, you can estimate the maximum daily flow rate per each serviced
area. The total area of each entity can be broken down to subareas, which are added
to different nodes.

To add a new area entity:

1. Click on Add.
2. Enter the data as follows:

Enter the description of the area.
Enter the mean daily water consumption. Click the button with the ellipses (...)
on the right of the text box to invoke the corresponding database. 
Enter the fraction of water consumption that ends in the sewer. Usually this
amount is around 80%.
Enter the daily peak factor, which is used to convert mean daily flow rates to
maximum daily flow rates.
Optionally you can enter an augmentation factor to increase the maximum daily
sewer flow.
Enter the total population. If this is unknown, you can use the estimation tool by
selecting the corresponding ellipsis button.
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Enter the total area in units of area.

2. Select Ok to add this area to the serviced areas list and close the dialog box.
Select Cancel to close the dialog box without saving any changes. 

Estimating the total population

If the total population is now known, you can estimate the design population using
two or more census entries.

To estimate the design population:

1. Enter the data as follows:

Enter the design period in years. When added to the current simulation year it will
mark the target year for population growth calculations.
Enter two or more census entries. Check the entries that will be taken into account.
Enter the maximum possible population of the area. This value is required for
some growth models. It is based on criteria regarding the area, the location, the
usage of land etc.
Select one of Linear, Geometric, Decaying, S curve as the method of growth.
Some of the methods may not be available, subject to the number of available
census entries. Some methods are calibrated by various coefficients. Although the
program will provide the optimum values of these coefficients, you can modify them.

2. Select Ok to use the estimated value of the population and close the dialog box.
Select Cancel to close the dialog box without saving any changes. 

6.13.3 Delete

To delete an existing sewer flow (area) data:

1. Select the data from the list.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The runoff area is deleted from the list.

NOTE: If an existing area is deleted, all corresponding entries in the inflow forms will
also be deleted.
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6.13.4 Edit

To edit existing sewer flow (population) data:

1. Select the data from the list.
2. Select Edit. The data form appears.
3. Make the appropriate changes as described in the add sewer flow (area) topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.14 Conduit shapes

6.14.1 Management

With this option, you can add or modify conduit shape specifications. These are
recommended in case you to calculate quantities.

To add or modify conduit shape specifications:

1. Select Conduit shapes from the Data menu. The following form will appear:

2. Make the necessary modifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To change the order of pipe specifications:

1. Select an entry from the list.
2. Select Up to move the selected entry up by one place. This option is not available
for the first entry in the list.
3. Select Down to move the selected entry down by one place. This option is not
available for the last entry in the list.
4. Repeat the above steps as necessary.

NOTE: You can activate or deactivate a specific conduit shape specification using the
corresponding check box.

The quick keys perform the following actions:

Select all: activates all conduit shape specifications in the list.
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Select none: deactivates all conduit shape specifications in the list.
Invert: inverts the status of all conduit shape specifications.

Conduit shape specifications can be imported from a file or exported to a file, as
described later in this chapter.

The next sections describe the process of adding, modifying or deleting a conduit
shape specification.

6.14.2 Add

With this option, you can add a conduit shape specification. There are two ways of
adding a new specification. The first way is to add a new (empty) entry; the second is
to create a copy of an existing entry and modify only some of its properties.

To add a new (empty) entry:

1. Select Add. A new entry is added to the list.
2. Enter the appropriate data as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new entry by copying an existing entry:

1. Select the existing (base) entry from the list.
2. Select Copy. A copy of the existing entry is created.
3. Select Edit to modify the properties of the clone entry, as described below.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Shape Data Tab

Select the type of the shape from the drop-down list. 
Enter a unique shape name.
Optionally, you can enter some comments. Use the ellipsis button to edit multiline
text.
Select the material of the conduit from the drop-down list.
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Select whether the specified shape is available in unlimited quantity. If not, enter
the available quantity in ft or m.
Enter the dimensions of the shape. In case of circular shape, only the internal
diameter is required.
Enter the number of barrels. In case of twin conduits, this equals 2. Normally, the
number of barrels is equal to 1.
If the shape is irregular, select the corresponding transect from the drop-down list.
If the shape is custom, select the corresponding curve from the drop-down list.
Select the color that will be used to draw the conduit on the plane view. It can be
either the default color or a custom color. This color will also be used when the plane
view DXF drawing is created.

Construction Tab

Enter the wall thicknesses of the conduit.
Enter the Manning, Darcy - Weisbach, and Hazen - Williams friction coefficients. If
these are not known, press the corresponding ellipsis button to invoke the
corresponding database. The Darcy - Weisbach and Hazen - Williams friction
coefficients are used only in circular shapes under pressure and only if the
appropriate settings are made in the dynamic wave settings form.
Enter the maximum velocity in ft/s or m/s of the conduit shape. This is not a
restriction but a calculation check. If violated, the velocity is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant.
Enter the maximum capacity of the conduit shape. This is not a restriction but a
calculation check. If violated, the capacity of the conduit is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant. 
Check Calculate flexcell, Calculate asphalt sealer if these materials are used at
the joints. In this case, enter the characteristic length that will define the frequency
of the application of the aforementioned materials.
Check Calculate reinforcements if you want to calculate the weight of the
reinforcement using a mean weight per unit length value, which needs to be
specified in the corresponding field.
Check Calculate forms if you want to calculate the area of the forms using a mean
area per unit length value, which needs to be specified in the corresponding field.
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6.14.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.14.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.14.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Pipe specification file" with the extension .spc.
4. Select the file by clicking on it.
5. Select Open to import the specifications.

6.14.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:
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1. Select Export. The following form will appear:

2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.15 Manhole specifications

6.15.1 Management

With this option, you can add or modify inlet specifications. After defining inlet
specifications, you can use them by selecting inlets from the Profile menu.

To add or modify inlet specifications:

1. Select Inlet specifications from the Data menu. The following form will appear:

2. Enter the inlet specifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Inlet specifications can be imported from a file or exported to a file, as described later
in this chapter.

The next sections describe the process of adding, modifying or deleting an inlet
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specification.

6.15.2 Add

With this option, you can add an inlet specification.

To add an inlet specification:

1. Select Add. A new entry is added to the list.
2. Enter the appropriate data as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Design Tab

Enter a unique Name for the specification. 
Optionally, you can add some Comments. Use the ellipsis button to edit multiline
text.
Enter the external inlet height in ft or m.
Select tine inlet geometry. This can be one of circular or rectangular.
Enter the external dimensions of the inlet in ft or m. In case of circular inlet, only
one dimension is required.
Check inlet has neck if the inlet has a neck that extents from its maximum
height to the ground. In this case, you must provide the neck's external diameter
in ft or m.

Implementation Tab



Data 129

© 2012 TechnoLogismik i

In the Thickness frame, enter the thicknesses of the inlet in ft or m by typing
into the corresponding text boxes.
In the Materials frame, select the concrete grade for each element and check
whether you want to calculate wood form and/or asphalt in quantities.

Sublayer Tab

Optionally, you can use a layer of concrete below the inlet. In this case, check 
sublayer is made of in the previous tab and provide the thickness of the layer in
ft or m by typing in the text box.

6.15.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.15.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
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3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.15.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Inlet type file" with the extension .fre.
4. Select the file by clicking on it.
5. Select Open to import the specifications.

6.15.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:

1. Select Export. The following form will appear:
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2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.16 Trench specifications

6.16.1 Management

With this option, you can add or modify trench specifications. After defining trench
specifications, you can use them in the data table of the main form.

To add or modify trench specifications:

1. Select Trench specifications from the Data menu. The following form will appear:

2. Enter the trench specifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Trench specifications can be imported from a file or exported to a file, as described
later in this chapter.

The next sections describe the process of adding, modifying or deleting a trench
specification.

6.16.2 Add

With this option, you can add a trench specification.

To add a trench specification:

1. Select Add. The following form appears:
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2. Make the appropriate selections as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data Tab

Select a template for the trench.
Enter a unique Name for the trench specification. 
Optionally, you can add some Comments. Use the ellipsis button to edit multiline
text.
Depending on the selected trench template, enter the required dimensions and / or
material types. Unnecessary fields are disabled.

Profile Tab

Enter the trench profile. The profile is defined as a set of trapezoidal layers, from
bottom to top. For example, a vertical trench may be defined for the first 6 ft, followed
by a trapezoidal layer for stability reasons. There is no restriction in the combination of
layers. If the total specified depth is insufficient, the program extents the topmost
layer as necessary.

To add a layer, press Add. The layer data form appears:
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Enter the height, width and slopes of the layer. Select Ok to save changes and
close the dialog box. Select Cancel to close the dialog box without saving any
changes.

Press Remove to delete the currently selected layer.

Press Edit to edit the currently selected layer.

A sketch of the current trench profile is drawn in the form.

Advanced Tab

Check Use marking grid if you want to take into account the calculation of marking
grid in quantities.
Select the appropriate ground type from the drop-down list. This can be one of
plain, concrete or asphalt. In the latter two cases, enter the thickness in ft or m.
These are needed for the  calculation of the restoration and backfill volumes in the 
quantities.
Enter the extra surface width that is necessary for the construction in ft or m.
Enter the geological profile. The geological profile is defined in layers, from top to
bottom. For example, a single layer with height of 6ft, 20% rock percentage,
augmentation coefficient equal to 1.15 and need for support can be defined. If the
total height of the profile is insufficient, the program automatically extends the
bottommost layer as necessary.

To add a layer, press Add. The layer data form appears:

Enter the height, rock percentage and augmentation factor of the layer. Check
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Requires support if the specified layer requires support. Select Ok to save
changes and close the dialog box. Select Cancel to close the dialog box without
saving any changes.

Press Remove to delete the currently selected layer.

Press Edit to edit the currently selected layer.

6.16.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.16.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.16.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Trench specifications file" with the extension .tspc.
4. Select the file by clicking on it.
5. Select Open to import the specifications.
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6.16.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:

1. Select Export. The following form will appear:

2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.17 Network consistency

When importing a network from an external source such as a DXF file or entering
graphically its data, there can be a number of hard-to-locate inconsistencies. This form
facilitates the location and correction of several types of problems such as duplicate
nodes and pipes.

To use the network consistency check tool:

1. Select Network Consistency from the Tools menu.
2. Select the type of problems you wish to look for and optionally correct.
3. Click on Check to look for specific problems.
4. Highlight one problem in the list and click Objects of current problem to
highlight the location of the erroneous input on the map.
5. Optionally you may want to click on Objects of all problems to highlight the
location of all erroneous input on the map.
6. Click on Clear selection to hide all highlighted objects on the map.
7. Click Close to close the form.
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6.18 Options

6.18.1 General preferences

With this option, you can modify the general preferences of the program.

To modify the general preferences:

1. Select Options from the Data menu.
2. Select General preferences from the Options menu.
3. The general preferences dialog box appears. The preferences are grouped into four
tabs. You can select a tab by clicking on its name.

General Tab

This tab contains general preferences regarding the usage of the program.

Check Register the extension *.m504 with this application to associate the
extension .m504 with this program. This extension is used by the program when
saving a project. In this way, you will be able to run the program and load a project by
double-clicking on the project filename in Windows Explorer.

Check Automatically display calculation messages if you want the report details to
be automatically displayed when you calculate the results.
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Check Automatically create backup file if you want a backup file (with the
extension .bck) to be created every time a project is loaded. By default, this file is
created in the temporary folder of Windows.

Check Confirm delete actions if you want to be asked for confirmation each time an
object is about to be deleted. This setting affects the behaviour of all delete actions,
for example the deletion of an object.

You can also modify the temporary folder that will be used for the creation of backup
files. By default, this folder is the temporary folder of Windows.

Finally, there are three options regarding the termination of the program:

When exiting always ignore changes - All changes since the last save of the
project are ignored. 
When exiting always save changes - All changes in the current project are
automatically saved. If the filename of the project is not set, a dialog box will
appear that allows the selection of the filename, as when selecting Save project
as from the File menu.
When exiting prompt for action - If there are changes in the current project,
then a dialog box will appear. You can choose to save or ignore the changes. If
the filename of the project is not set, a dialog box will appear that allows the
selection of the filename, as when selecting Save project as from the File menu.

Languages Tab

If more than one language packs have been installed, then you can choose the
language of the program. In the above case, there are two language packs; English
(that are already selected) and Greek. If you change the language, all forms, menus,
messages, help files will reflect the chosen language.

In order for the changes to take effect, you must restart the program.

Digits Tab
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With this tab, you can modify the way the results are presented. All values used in the
program are displayed in the list on the left.

For each value, you can select the number of decimal digits using the Number of
digits drop-down list.

Check Use 0.1 instead of .1 to use a preceding zero when displaying numbers
between -1 and 1, for example -0.08 instead of -.08 and 0.98 instead of .98.

Check Use 1.0 instead of 1 to use trailing zeros (when necessary) in order to display
a number with the decimal digits selected in the Number of digits drop-down list, for
example 1.1600 instead of 1.16 (when the number of digits is set to 4).

Internet Tab

The program can automatically check for newer versions over the Internet. Check 
Automatically check for newer versions to enable this feature. The check is
automatically performed at an interval specified in the Every drop-down list. Select
Check now to manually check for newer versions.

When a newer version is found, you will be prompted to download and install the
latest version.

NOTE: TechnoLogismiki protects your privacy. During the check for newer versions,
no data is transferred from your computer to the Internet.
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Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.18.2 Sketch

With this option, you can modify the profile sketch.

To modify the profile sketch:

1. Select Options from the Data menu.
2. Select Sketch from the Options menu. The profile sketch options dialog box
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Grid

Select Grid active if you want the dynamic grid to be displayed.
Press the Font button to select the font that will be used by the grid.
Press the Font color button to select the color of the font that will be used by the
grid.
Press the Pen button to select the style and width of the grid line.
Press the Pen color button to select the color of the grid line.

OSnap

Select OSnap active if you want the snap to objects to be active.
Select one or more OSnaps to be active: End, Middle, Center, Quadrant, Node.
Press All to select all OSnaps. Press None to select none.

Snap to grid

Select Snap active if you want the snap to grid to be active.
Select the appropriate Spacing X and Spacing Y values.
Select the appropriate Base X and Base Y values.

Background
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Press the Color button to select the background color of the sketch

6.18.3 Grid editiing

With this option, you can modify the behavior of grids.

The behaviour of all editable grids is controlled by the preferences in this dialog box.

Select No cell automation if you want the active cell to remain the same when
hitting ENTER.

Select Open the cell below (edit by columns) if you want to activate the cell below
when hitting ENTER. This is particularly useful when editing tables by columns.

Select Open the next cell (edit by rows) if you want to activate the next cell on the
right when hitting ENTER. This is particularly useful when editing tables by rows.

NOTE: These preferences affect all projects, both old and new.

Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.18.4 Customize toolbar

With this option, you can customize the toolbar of the main form.

To customize the toolbar of the main form:

1. Select Options from the Data menu.
2. Select Customize toolbar from the Options menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The toolbar may contain small or large buttons.

Check Show description if you want a small description to be displayed under the
buttons.

Check Show tooltips if you want tooltips to be displayed when the mouse pointer
hovers over a button for 2-3 seconds.
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NOTE: These preferences affect all projects, both old and new.

6.18.5 Default values

With this option, you can modify the default values for new linear or point objects,
curves etc.

To modify the default values:

1. Select Options from the Data menu.
2. Select Default values from the Options menu.
3. In the ID Labels tab, select the prefixes of new object names.

4. In the Subcatchments tab, select the default values for new subcatchments.

5. In the Objects tab select the default values for other new objects.
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6. Select Make default for all new projects if you wish to use these settings for all
new projects.
7. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.18.6 Algorithm

With this option, you can select the method of estimation of the peak flow factor and
the extra flow rate.

To select the method of estimation of the peak flow factor and the extra flow rate:

1. Select Options from the Data menu.
2. Select Algorithm from the Options menu. The following form appears:

3. Select one of the following methods for calculating the peak coefficient:
Greek Regulations 696/74
EYDAP specifications
Analytical statistical method
Gifft
Harmon
Metcalf & Eddy
Babbit

4. Select one of the following methods for calculating the extra flow:
Ignore extra flow rate
EYDAP (high aquifer)
EYDAP (low aquifer)
Percentage of peak flow Qp
Percentage of mean daily flow Qd
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Metcalf & Eddy (New networks)
Metcalf & Eddy (Old networks)
EYDAP (per area, high aquifer)
EYDAP (per area, low aquifer)
Per area
Per pipe length
Per pipe length and diameter

5. Select Make default for all new projects if you wish to use these settings for all
new projects. It is stressed that these settings are saved with the project. Thus, older
projects are not affected by changes.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.



Chapter

VII
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7 Objects

7.1 Objects menu

With this option, you can add and modify objects. In the Objects menu you can select
one of the following options:

Add
o Raingage

o Subcatchment

o Junction

o Outfall

o Divider

o Storage

o Conduit

o Pump

o Orifice

o Weir

o Outlet

o Profile

o Label

Properties
o Raingage

o Subcatchment: Infiltration, Groundwater, Land use, Initial buildup

o Node Inflows

o Node Treatment

o Junction

o Outfall

o Divider

o Storage

o Link internal vertices

o Conduit

o Pump

o Orifice

o Weir

o Outlet

o Profile

o Label

Object conversion
Add vertex
Add vertex by distance
Delete vertex
Stretch vertex
Convert vertex to junction
Labels
Swap link ends
Transects: Management, Add, Delete, Edit, Move, Sort
Control rules: Management, Add, Delete, Edit, Move, Sort
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7.2 Add

7.2.1 Raingage

With this option, you can add one or more raingages.

To add a raingage:

1. Select Add from the Objects menu.
2. Select Raingage from the Add menu.
3. Click onto the drawing to define the position of the raingage.

To add more than one raingages:

1. Select Add from the Objects menu.
2. Select Raingage from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the raingage while holding down
CTRL key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.2 Subcatchment

With this option, you can add one or more subcatchments. Subcatchments defined by
one or two points are considered symbolical and you need to provide their area
explicitly.

To add a subcatchment:

1. Select Add from the Objects menu.
2. Select Subcatchment from the Add menu.
3. Click successively onto the drawing to define the vertices of the subcatchment.
4. Press ENTER to close the polyline and define the subcatchment. Press BACKSPACE
to erase the last defined vertex.

To add more than one subcatchments:
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1. Select Add  from the Objects menu.
2. Select Subcatchment from the Add menu while holding down CTRL key.
3. Click successively onto the drawing to define the vertices of the subcatchment.
4. Press ENTER while holding down CTRL key to close the polyline and define the
subcatchment. Press BACKSPACE to erase the last defined vertex.
5. Repeat steps 3 and 4 as many times as required.
6. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.3 Junction

With this option, you can add one or more junctions.

To add a junction:

1. Select Add from the Objects menu.
2. Select Junction from the Add menu.
3. Click onto the drawing to define the position of the junction.

To add more than one junctions:

1. Select Add from the Objects menu.
2. Select Junction from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the junction while holding down
CTRL key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:
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1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.4 Outfall

With this option, you can add one or more outfalls.

To add a outfall:

1. Select Add from the Objects menu.
2. Select Outfall from the Add menu.
3. Click onto the drawing to define the position of the outfall.

To add more than one outfalls:

1. Select Add from the Objects menu.
2. Select Outfall from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the outfall while holding down CTRL
key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.5 Divider

With this option, you can add one or more dividers.

To add a divider:

1. Select Add from the Objects menu.
2. Select Divider from the Add menu.
3. Click onto the drawing to define the position of the divider.

To add more than one dividers:
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1. Select Add from the Objects menu.
2. Select Divider from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the divider while holding down CTRL
key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.6 Storage

With this option, you can add one or more storages.

To add a storage:

1. Select Add from the Objects menu.
2. Select Storage from the Add menu.
3. Click onto the drawing to define the position of the storage.

To add more than one storages:

1. Select Add from the Objects menu.
2. Select Storage from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the storage while holding down
CTRL key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
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2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.7 Conduit

With this option, you can add one or more conduits. The ends of the conduit are
always point objects (Junctions, Outfalls, Dividers, Storages). Although there is no
such restriction, it is recommended that the direction of conduits matches the flow
direction.

To add a conduit:

1. Select Add from the Objects menu.
2. Select Conduit from the Add menu.
3. Click onto the point object that will be the start point of the conduit.
4. Click onto the point object that will be the end point of the conduit. The conduit is
drawn.

To add more than one conduits:

1. Select Add  from the Objects menu.
2. Select Conduit from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the conduit.
4. Click onto the point object that will be the end point of the conduit while holding
down CTRL key. The conduit is drawn.
5. Repeat steps 3 and 4 to add the next conduit.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a conduit, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created.
They can be taken into account when calculating the length of the conduit, in the
calculation of excavation volumes etc.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.
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NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.8 Pump

With this option, you can add one or more pumps. The ends of the pump are always
point objects (Junctions, Outfalls, Dividers, Storages). Although there is no such
restriction, it is recommended that the direction of pumps matches the flow direction.

To add a pump:

1. Select Add from the Objects menu.
2. Select Pump from the Add menu.
3. Click onto the point object that will be the start point of the pump.
4. Click onto the point object that will be the end point of the pump. The pump is
drawn.

To add more than one pumps:

1. Select Add  from the Objects menu.
2. Select Pump from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the pump.
4. Click onto the point object that will be the end point of the pump while holding
down CTRL key. The pump is drawn.
5. Repeat steps 3 and 4 to add the next pump.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a pump, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.



Sewer Networks152

© 2012 TechnoLogismik i

7.2.9 Orifice

With this option, you can add one or more orifices. The ends of the orifice are always
point objects (Junctions, Outfalls, Dividers, Storages). Although there is no such
restriction, it is recommended that the direction of orifices matches the flow direction.

To add a orifice:

1. Select Add from the Objects menu.
2. Select Orifice from the Add menu.
3. Click onto the point object that will be the start point of the orifice.
4. Click onto the point object that will be the end point of the orifice. The orifice is
drawn.

To add more than one orifices:

1. Select Add  from the Objects menu.
2. Select Orifice from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the orifice.
4. Click onto the point object that will be the end point of the orifice while holding
down CTRL key. The orifice is drawn.
5. Repeat steps 3 and 4 to add the next orifice.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a orifice, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.10 Weir

With this option, you can add one or more weirs. The ends of the weir are always point
objects (Junctions, Outfalls, Dividers, Storages). Although there is no such restriction,
it is recommended that the direction of weirs matches the flow direction.
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To add a weir:

1. Select Add from the Objects menu.
2. Select Weir from the Add menu.
3. Click onto the point object that will be the start point of the weir.
4. Click onto the point object that will be the end point of the weir. The weir is drawn.

To add more than one weirs:

1. Select Add  from the Objects menu.
2. Select Weir from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the weir.
4. Click onto the point object that will be the end point of the weir while holding down
CTRL key. The weir is drawn.
5. Repeat steps 3 and 4 to add the next weir.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a weir, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.11 Outlet

With this option, you can add one or more outlets. The ends of the outlet are always
point objects (Junctions, Outfalls, Dividers, Storages). Although there is no such
restriction, it is recommended that the direction of outlets matches the flow direction.

To add a outlet:

1. Select Add from the Objects menu.
2. Select Outlet from the Add menu.
3. Click onto the point object that will be the start point of the outlet.
4. Click onto the point object that will be the end point of the outlet. The outlet is
drawn.
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To add more than one outlets:

1. Select Add  from the Objects menu.
2. Select Outlet from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the outlet.
4. Click onto the point object that will be the end point of the outlet while holding
down CTRL key. The outlet is drawn.
5. Repeat steps 3 and 4 to add the next outlet.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a outlet, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.12 Profile

With this option, you can add one or more profiles. Profiles are not actual objects but
rather a series of references to alternating nodes and links. Although there is no
restriction in the definition of profiles, it is recommended that

they follow the flow direction,
they do not overlap each other.

To add a profile:

1. Select Add from the Objects menu.
2. Select Profile from the Add menu.
3. Click successively onto the drawing to select the nodes of the profile. It is not
necessary to click onto all nodes. If two successive nodes are not connected by a
single link, the program automatically seeks and selects the shortest path (in terms
of number of links) connecting these two nodes. Thus, in most cases, you can fully
define a profile by clicking on the first and last node.
4. Press ENTER to define the profile. Press BACKSPACE to erase the reference to the



Objects 155

© 2012 TechnoLogismik i

last defined point object.

To add more than one profiles:

1. Select Add from the Objects menu.
2. Select Profile from the Add menu while holding down CTRL key.
3. Click successively onto the drawing to select the nodes of the profile. It is not
necessary to click onto all nodes. If two successive nodes are not connected by a
single link, the program automatically seeks and selects the shortest path (in terms
of number of links) connecting these two nodes. Thus, in most cases, you can fully
define a profile by clicking on the first and last node.
4. Press ENTER while holding down CTRL key to define the profile. Press BACKSPACE
to erase the last defined vertex.
5. Repeat steps 3 and 4 as many times as required.
6. Hit ESC when you have finished.

7.2.13 Label

With this option, you can add one or more labels.

To add a label:

1. Select Add from the Objects menu.
2. Select Label from the Add menu.
3. Click onto the drawing to define the position of the label.

To add more than one labels:

1. Select Add from the Data menu.
2. Select Label from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the label while holding down CTRL
key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.
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7.3 Properties

7.3.1 Raingage

With this option, you can view and modify the properties of raingages. Raingage data
may be available as time series or by an external file.

To view and modify the properties of raingages:

1. Select Properties from the Objects menu.
2. Select Raingage from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the raingage. Two or more raingages may share the
same name, but this is not recommended since there will be confusion in the
results.
X coordinate: enter the X coordinate of the raingage.
Y coordinate: enter the Y coordinate of the raingage.
Description: enter the description of the raingage.
Tag: enter a tag for the raingage. This appears neither in the input data nor the
results.
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Rain format: Select the format in which the rain data are supplied. This can be
one of the following:
o Intensity: each value is an average rate over the recording interval in mm/h

or in/h.
o Volume: each value is the volume of rain divided by the area in mm or in.

o Cumulative: each value is the cumulative volume of rain divided by the area

mm or in.
Rain interval: Select the time interval between the midpoints of successive
events in decimal hours or HH:MM format.
Snow catch factor: enter the factor that corrects gage readings for snowfall.
Data source: enter the source of rainfall data; either Time Series for user-
supplied time series data or File for an external data file.
Series name: enter the name of time series with rainfall data if Data Source
selection was Time Series. Leave blank otherwise.
File name: enter the name of external file containing rainfall data.
Station ID: enter the recording gage station number.
Rain units: enter the depth units for rainfall values in the file. This can be one of
in or mm.

Rainfall files

The program accepts the following rainfall formats:

DSI-3240 and related formats (hourly observations) from the U.S. National
Weather Service (NWS) and Federal Aviation Agency stations. These are available
online from the National Climatic Data Center (NCDC) in USA.
DSI-3260 and related formats (15-minute observations) from the U.S. National
Weather Service (NWS). These are available online from the National Climatic
Data Center (NCDC) in USA.
HLY03 and HLY21 formats for hourly rainfall at Canadian stations, available
online from Environment Canada.
FIF21 format for fifteen minute rainfall at Canadian stations, available online
from Environment Canada.
Standard user-prepared format where each line of the file contains the station ID,
year, month, day, hour, minute, and non-zero precipitation reading, all separated
by one or more spaces, as follows:

ST001  2004  12  01  00  00  0.12
ST001  2004  12  01  00  20  0.08
ST001  2004  12  01  01  05  0.02
ST001  2004  12  01  18  35  0.10

Each value may be intensity, volume or cumulative in English or metric system.

7.3.2 Subcatchment

With this option, you can view and modify the properties of subcatchments. 

Subcatchments are hydrologic units of land whose topography and drainage system
elements direct surface runoff to a single discharge point. The user is responsible for
dividing a study area into an appropriate number of subcatchments, and for
identifying the outlet point of each subcatchment. Discharge outlet points can be
either nodes of the drainage system or other subcatchments.
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Subcatchments can be divided into pervious and impervious subareas. Surface runoff
can infiltrate into the upper soil zone of the pervious subarea, but not through the
impervious subarea. Impervious areas are themselves divided into two subareas - one
that contains depression storage and another that does not. Runoff flow from one
subarea in a subcatchment can be routed to the other subarea, or both subareas can
drain to the subcatchment outlet.

Infiltration of rainfall from the pervious area of a subcatchment into the unsaturated
upper soil
zone can be described using three different models:

Horton
Green - Ampt
SCS Curve Number

To model the accumulation, re-distribution, and melting of precipitation that falls as
snow on a subcatchment, it must be assigned a Snow Pack object. To model
groundwater flow between an aquiferunderneath the subcatchment and a node of the
drainage system, the subcatchment must be assigned a set of Groundwater
parameters. Pollutant buildup and washoff from subcatchments are associated with
the Land Uses assigned to the subcatchment.

To view and modify the properties of subcatchments:

1. Select Properties from the Objects menu.
2. Select Subcatchment from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the subcatchment. Two or more subcatchments may
share the same name, but this is not recommended since there will be confusion
in the results.
X coordinate: enter the X coordinate of the subcatchment centroid.
Y coordinate: enter the Y coordinate of the subcatchment centroid.
Description: enter the description of the subcatchment.
Tag: enter a tag for the subcatchment. This appears neither in the input data nor
the results.
Vertices: click the ellipsis button to define the vertices analytically.
Raingage: select the associated raingage from the drop-down list.
Outlet object: select one junction, outfall, divider, storage or subcatchment
which receives the subcatchment's runoff.
Area (ac or ha): enter the area of the subcatchment. Leave the field blank if you
want the program to calculate the area from plan view. In this case the result is
displayed within curly braces {}.
Width (ft or m): enter the characteristic width of the overland flow path for
sheet flow runoff. An initial estimate of the characteristic width is given by the
subcatchment area divided by the average maximum overland flow length. The
maximum overland flow length is the length of the flow path from the inlet to the
furthest drainage point of the subcatchment. Maximum lengths from several
different possible flow paths should be averaged. These paths should reflect slow
flow, such as over pervious surfaces, more than rapid flow over pavement, for
example. Adjustments should be made to the width parameter to produce good
fits to measured runoff hydrographs.
Slope (%): enter the average percent slope of the subcatchment.
Impervious (%): enter the percentage of land area which is impervious.
Manning for impervious area: enter Manning's n for overland flow over the
impervious portion of the subcatchment.
Manning for pervious area: enter Manning's n for overland flow over the
pervious portion of the subcatchment.
Depression depth impervious area (in or mm): enter the depth of depression
storage on the impervious portion of the subcatchment. You can find typical
values in the Appendix.
Depression depth pervious area (in or mm): enter the depth of depression
storage on the pervious portion of the subcatchment. You can find typical values
in the Appendix.
Impervious area with no depression (%): enter the percentage of the
impervious area with no depression storage.
Subarea routing: select the internal routing of runoff between pervious and
impervious areas. This can be one of:
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o Impervious: runoff from pervious area flows to impervious area

o Pervious: runoff from impervious area flows to pervious area

o Outlet: runoff from both areas flows directly to outlet.

Percent routed (%): enter the percentage of runoff routed between subareas.
Infiltration: enter data regarding infiltration.
Ground water: enter data regarding ground water.
Snow pack: select the snow pack associated with the subcatchment.
Land use: enter the percentages of the land uses that are associated with the
subcatchment.
Initial buildup: enter the initial pollutant concentrations that are associated with
the subcatchment.
Curb length (length units): enter the total curb length within the
subcatchment. This variable is used only when pollutant buildup is normalized to
curb length.

7.3.2.1 Infiltration

The Infiltration form is used to specify values for the parameters that describe the rate
at which rainfall infiltrates into the upper soil zone in a subcatchment's pervious area. 

It is invoked when editing the Infiltration property of a subcatchment. The infiltration
parameters depend on which infiltration model was selected for the project: Horton,
Green-Ampt, or Curve Number.

To edit the Infiltration property of a subcatchment (referring to the Subcatchment
property form):

1. Double click on the Infiltration property.
2. Click the ellipsis button. 
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Horton

Maximum infiltration (in/h or mm/h): enter the maximum infiltration. Some
characteristic values are:

1.Dry soils (with little or no vegetation):

Sandy soils 5 in/h or 130 mm/h
Loam soils 3 in /h or 75 mm/h
Clay soils 1 in/h ή 25 mm/h
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2.Dry soils (with dense vegetation):

Multiply the values of (1) by 2.

3.Moist soils:

Soils which have drained but not dried out (i.e., field capacity): Divide values
from (1) and (2) by 3.
Soils close to saturation: Choose value close to min. infiltration rate.
Soils which have partially dried out: Divide values from (1) and (2) by 1.5 -
2.5.

Minimum infiltration (in/h or mm/h): enter the minimum infiltration rate on the
Horton curve. This is equivalent to the soil’s saturated hydraulic conductivity. Typical
values are provided in theAppendix.

Decay constant (1/h): enter the decay constant. Typical values range between 2
and 7.

Drying time (d): Time in days for a fully saturated soil to dry completely. Typical
values range from 2 to 14 days.

Maximum volume (in or mm): enter the maximum infiltration volume possible. It
can be estimated as the difference between a soil's porosity and its wilting point times
the depth of the infiltration zone.

Green-Ampt

Suction head (in or mm): enter the average value of soil capillary suction along the
wetting front.
 
Conductivity (in/h or mm/h): enter the soil saturated hydraulic conductivity.

Initial deficit: enter the fraction of soil volume that is initially dry (i.e., difference
between soil porosity and initial moisture content). For a completely drained soil, it is
the difference between the soil's porosity and its field capacity. Typical values are
provided in the Appendix.

SCS Curve Number
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Curve number: enter the  SCS curve number which is tabulated in the publication
SCS Urban Hydrology for Small Watersheds, 2nd Ed., (TR-55), June 1986. Press the
ellipsis button to invoke  the corresponding database.

Conductivity (in/h or mm/h): enter the soil's saturated hydraulic conductivity. This
is used to estimate the minimum number of dry hours that must occur before a new
storm is considered to begin using the equation: dry hours = 4.5 / (conductivity, in/
hr)1/2.

Drying time (d): enter the number of days it takes a fully saturated soil to dry.
Typical values range between 2 and 14 days.

7.3.2.2 Groundwater

The Groundwater form is used to specify values for the parameters that describe the
groundwater of a subcatchment. It is invoked when editing the Groundwater
property of a subcatchment. It is used to link a subcatchment to both an aquifer and
to a node of the drainage system that exchanges groundwater with the aquifer. It also
specifies coefficients that determine the rate of groundwater flow between the aquifer
and the node. These coefficients (A1, A2, B1, B2, and A3) appear in the following
equation that computes groundwater flow as a function of groundwater and surface
water heads:

 

Where QGW groundwater flow (ft3/s/ac or m3/s/ha)

HGW elevation of groundwater table (ft or m)

HSW elevation of surface water at receiving node (ft or m)

E threshold groundwater elevation or node invert elevation (ft or m).

To edit the Groundwater property of a subcatchment (referring to the Subcatchment
property form):

1. Double click on the Groundwater property.
2. Click the ellipsis button. 
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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Aquifer name: select the aquifer that supplies groundwater from the drop-down list.

Receiving node: select the name of node that receives groundwater from the aquifer.

Surface elevation (ft or m): enter the elevation of ground surface for the
subcatchment that lies above the aquifer.

Groundwater flow coefficient: enter the value of coefficient A1 of the above

equation.

Groundwater flow exponent: enter the value of coefficient B1 of the above

equation.

Surface water flow coefficient: enter the value of coefficient A2 of the above

equation.

Surface water flow exponent: enter the value of coefficient B2 of the above

equation.

Surface / Groundwater interaction: enter the value of coefficient A3 of the above

equation.

Fixed surface water depth (ft or m): enter the fixed depth of surface water at the
receiving node. Set to zero if surface water depth will vary as computed by flow
routing.

Threshold groundwater elevation (ft or m): enter the aquifer water table elevation
which must be reached before any ground water flow occurs. Leave blank to use the
receiving node's invert elevation.

NOTE: The values of the flow coefficients must be in units that are consistent with
the groundwater flow units of cfs/acre for English unit system or cms/ha for metric .

NOTE: If groundwater flow is simply proportional to the difference in groundwater
and surface water heads, then :

B
1
 and B

2
 are set equal to 1

A
1 

 equals the proportionality factor

A
2  

equals A
1
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A3 equals 0

7.3.2.3 Land use

For each subcatchment, you must enter the associated percentage of each Land Use.
It is not necessary to associate all land uses with a specified subcatchment.

To edit the Land Use property of a subcatchment (referring to the Subcatchment
property form):

1. Double click on the Land Uses property.
2. Click the ellipsis button. 
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

7.3.2.4 Initial buildup

For each subcatchment, you must enter the initial buildup of each pollutant in lb/ac or
kg/ha. This specifies the amount of pollutant buildup existing over the subcatchment
at the start of the simulation. If a non-zero value is specified for the initial buildup of a
pollutant, it will override any initial buildup computed from the antecedent dry days
parameter in general data.

To edit the Initial buildup property of a subcatchment (referring to the
Subcatchment property form):

1. Double click on the Initial buildup property.
2. Click the ellipsis button. 
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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7.3.3 Node Inflows

Apart from inflows from subcatchments and groundwater, junctions accept four types
of inflows:

1. Direct. These are user-defined time series of inflows added directly into a node.
They can be used to perform flow and water quality routing in the absence of any
runoff computations (as in a study area where no subcatchments are defined). 

2. Dry weather. These are continuous inflows that typically reflect the contribution
from sanitary sewage in sewer systems or base flows in pipes and stream channels.
They are represented by an average inflow rate that can be periodically adjusted on a
monthly, daily, and hourly basis by applying time pattern multipliers to this average
value is used to specify a continuous source of dry weather flow entering a node of the
drainage system.

3. RDII. These are stormwater flows that enter sanitary or combined sewers due to
"inflow" from direct connections of down spouts, sump pumps, foundation drains, etc.
as well as "infiltration" of subsurface water through cracked pipes, leaky joints, poor
manhole connections, etc. RDII can be computed for a given rainfall record based on
set of triangular unit hydrographs (UH) that determine a short-term, intermediate-
term, and long-term inflow response for each time period of rainfall. Any number of
UH sets can be supplied for different sewershed areas and different months of the
year. RDII flows can also be specified in an external RDII interface file.

4. Areas. The corresponding values of Runoff Areas are entered. In this case, the IDF
curve and the runoff coefficient is required. For sewage, only the flow per unit area is
required. There is no restriction in the combination and number of runoff areas.

To enter inflow data:

1. Select the properties form of a node (junction, outfall, divider or storage).
2. Double click on the Inflows property.
3. Click the ellipsis button. 
4. Make the appropriate changes.
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5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Basic Inflow

Direct

Constituent: select the constituent (Flow or one of the project's specified pollutants)
whose direct inflow will be described.

Baseline: specifies the value of the constant baseline component of the constituent's
inflow. For Flow, the units are the project's flow units. For pollutants, the units are
the pollutant's concentration units if inflow is a concentration, or can be any mass flow
units if the inflow is a mass flow. If left blank then no baseline inflow is assumed.

Baseline Pattern: An optional Time Pattern whose factors adjust the baseline inflow
on either an hourly, daily, or monthly basis (depending on the type of time pattern
specified).
 
Time series: select the name of the time series that contains inflow data for the
selected constituent. If left blank then no direct inflow will occur for the selected
constituent at the node in question.

Scale factor: enter a multiplier used to adjust the values of the constituent's inflow
time series. The baseline value is not adjusted by this factor. The scale factor can have
several uses, such as allowing one to easily change the magnitude of an inflow
hydrograph while keeping its shape the same, without having to re-edit the entries in
the hydrograph's time series. Or it can allow a group of nodes sharing the same time
series to have their inflows behave in a time-synchronized fashion while letting their
individual magnitudes be different. 

Inflow type: (for pollutants) select the type of inflow data contained in the time
series as being either a concentration (mass/volume) or mass flow rate (mass/time).
This field does not appear for  Flow inflow.

Mass unit conversion: A numerical factor used to convert the units of pollutant mass
flow rate in the time series data into concentration mass units per second. For
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example, if the time series data were in pounds per day and the pollutant
concentration defined in the project was mg/L, then the conversion factor value would
be (453,590 mg/lb) / (86400 sec/day) = 5.25 (mg/sec) per (lb/day).

NOTE: If a pollutant is assigned a direct inflow in terms of concentration, then one
must also assign a direct inflow to flow, otherwise no pollutant inflow will occur. If
pollutant inflow is defined in terms of mass, then a flow inflow time series is not
required,

Dry weather

Constituent: select the constituent (Flow or one of the project's specified pollutants)
whose dry weather inflow will be described..

Average value: specifies the average (or baseline) value of the dry weather inflow of
the constituent in the relevant units (flow units for flow, concentration units for
pollutants). Leave blank if there is no dry weather flow for the selected constituent.

Time pattern: Specifies the names of the time patterns to be used to allow the dry
weather flow to vary in a periodic fashion by month of the year, by day of the week,
and by time of day (for both weekdays and weekends). One can either type in a name
or select a previously defined pattern from the drop down list of each combo box. Up
to four different types of patterns can be assigned.

Storm

Storm flow (area)

For each runoff area defined in the project, you can enter the real area which flows
directly in the node. Areas are expected in hectares or acres depending on the unit
system.

RDII

Unit hydrograph: select the name of the Unit Hydrograph group that applies to the
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node in question. The unit hydrographs in the group are used in combination with the
group's assigned rain gage to develop a time series of RDII inflows per unit area over
the period of the simulation. Leave this field blank to indicate that the node receives
no RDII inflow. 

Sewershed area (ac or ha): enter the area of the sewershed that contributes RDII to
the node in question. Note this area will typically be only a small, localized portion of
the subcatchment area that contributes surface runoff to the node.

Sewer

Sewer flow (population)

For each sewer area per person defined in the project, you can enter the number of
persons of that particular area whose sewage end in the selected node.

Sewer flow (area)

For each sewer area per unit area defined in the project, you can enter the area which
flows directly in the node. Areas are expected in hectares or acres depending on the
unit system.

7.3.4 Node Treatment

Removal of pollutants from the flow streams entering any drainage system node is
modeled by assigning a set of treatment functions to the node. A treatment function
can be any well-formed mathematical expression involving

the pollutant concentration of the mixture of all flow streams entering the node
the removals of other pollutants
any of the following process variables:
o FLOW for flow rate into node (in user-defined flow units)

o DEPTH (ft or m) for water depth above node invert.

o AREA (ft2 or m2) for node surface area

o DT (sec) for routing time step
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o HRT (h) for hydraulic residence time

The result of the treatment function can be either a concentration (denoted by the
letter C) or a fractional removal (denoted by R). For example, a first-order decay
expression for BOD exiting from a storage node might be expressed as:

C = BOD * exp (-0.05*HRT)

or the removal of some trace pollutant that is proportional to the removal of total
suspended solids (TSS) could be expressed as:

R = 0.75 * R_TSS

To enter treatment data:

1. Select the properties form of a node (junction, outfall, divider or storage).
2. Double click on the Treatment property.
3. Click the ellipsis button. 
4. Make the appropriate changes.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

7.3.5 Junction

Junctions are drainage system nodes where links join together. Physically they can
represent the confluence of natural surface channels, manholes in a sewer system, or
pipe connection fittings. External inflows can enter the system at junctions. Excess
water at a junction can become partially pressurized while connecting conduits are
surcharged and can either be lost from the system or be allowed to pond atop the
junction and subsequently drain back into the junction.

To view and modify the properties of junctions:

1. Select Properties from the Objects menu.
2. Select Junction from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the junction. Two or more junctions may share the
same name, but this is not recommended since there will be confusion in the
results.
X coordinate: enter the X coordinate of the junction.
Y coordinate: enter the Y coordinate of the junction.
Description: enter the description of the junction.
Tag: enter a tag for the junction. This appears neither in the input data nor the
results.
Inflows: click the ellipsis button to assign time series, dry weather, or RDII
inflows to the junction.
Treatment: click the ellipsis button to edit a set of treatment functions for
pollutants entering the junction.
Ground elevation (ft or m): enter the ground elevation of the junction. This
field can be auto-filled from the program, if the junction belongs to a profile in
which upstream and downstream ground elevations have been defined.
Invert elevation (ft or m): enter the invert elevation of the junction.
Initial water depth (ft or m): enter the depth of water at the junction at the
start of the simulation.
Surcharge depth (ft or m): enter the additional depth of water beyond the
maximum depth that is allowed before the unction floods. This parameter can be
used to simulate bolted manhole covers or force main connections.
Ponded area (ft2 or m2): enter the area occupied by ponded water atop the
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junction after flooding occurs. If the ponding option is turned on, a non-zero
value of this parameter will allow ponded water to be stored and subsequently
returned to the conveyance system when capacity exists.
Station: click the ellipsis button to enter the station of the junction.
Inlet type: select the inlet type for the junction from the drop-down list. The
inlet types are entered as manhole specifications.
Bottom elevation (ft or m): enter the bottom elevation of the junction.
Ditch elevation (ft or m): enter the ground elevation of the junction.
Generic elevation (ft or m): enter a generic elevation of the junction. This
elevation appears in the profile drawing only.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Depth (ft or m): the water depth in the junction.
Flooding: the flow that is lost when inflows exceed storage and conveyance
capacity, in user-defined flow units.
Head (ft or m): the absolute elevation of hydraulic head
Lateral inflow: the sum of runoff and all other inflows, in user-defined flow units
.
Total inflow: the sum of lateral inflow and upstream inflow, in user-defined flow
units.
Volume (ft3 or m3): the water volume held in storage (including ponded water).

7.3.6 Outfall

Outfalls are terminal nodes of the drainage system used to define final downstream
boundaries under Dynamic Wave flow routing. For other types of flow routing they
behave as a junction. Only a single link can be connected to an outfall node.

The boundary conditions at an outfall can be described by any one of the following
stage relationships:

the critical or normal flow depth in the connecting conduit
a fixed stage elevation
a tidal stage described in a curve of tide height versus hour of the day
a user-defined time series of stage versus time.

To view and modify the properties of outfalls:

1. Select Properties from the Objects menu.
2. Select Outfall from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the outfall. Two or more outfalls may share the same
name, but this is not recommended since there will be confusion in the results.
X coordinate: enter the X coordinate of the outfall.
Y coordinate: enter the Y coordinate of the outfall.
Description: enter the description of the outfall.
Tag: enter a tag for the outfall. This appears neither in the input data nor the
results.
Inflows: click the ellipsis button to assign time series, dry weather, or RDII
inflows to the outfall.
Treatment: click the ellipsis button to edit a set of treatment functions for
pollutants entering the outfall.
Ground elevation (ft or m): enter the ground elevation of the outfall. This field
can be auto-filled from the program, if the outfall belongs to a profile in which
upstream and downstream ground elevations have been defined.
Invert elevation (ft or m): enter the invert elevation of the outfall.
Tide gate: select Yes if tide gate is present to prevent backflow and No when no
tide gate is present.
Type: select one of the following types:
o Free: outfall stage determined by minimum of critical flow depth and normal

flow depth in the connecting conduit.
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o Normal: outfall stage based on normal flow depth in connecting conduit.

o Fixed: outfall stage set to a fixed value.

o Tidal: outfall stage given by a tidal curve of tide elevation versus time of day.

o Time series: outfall stage supplied from a time series of elevations.

Fixed stage (ft or m): enter the water elevation for a Fixed type of outfall.
Tidal outfall curve: select the tidal curve relating water elevation to hour of the
day for a Tidal outfall.
Time series outfall: select the time series containing time history of outfall
elevations for a Time series outfall.
Station: click the ellipsis button to enter the station of the outfall.
Inlet type: select the inlet type for the outfall from the drop-down list. The inlet
types are entered as manhole specifications.
Bottom elevation (ft or m): enter the bottom elevation of the outfall.
Ditch elevation (ft or m): enter the ground elevation of the outfall.
Generic elevation (ft or m): enter a generic elevation of the outfall. This
elevation appears in the profile drawing only.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Depth (ft or m): the water depth in the outfall.
Flooding: the flow that is lost when inflows exceed storage and conveyance
capacity, in user-defined flow units.
Head (ft or m): the absolute elevation of hydraulic head
Lateral inflow: the sum of runoff and all other inflows, in user-defined flow units
.
Total inflow: the sum of lateral inflow and upstream inflow, in user-defined flow
units.
Volume (ft3 or m3): the water volume held in storage (including ponded water).

7.3.7 Divider

Dividers are drainage system nodes that divert inflows to a specific conduit in a
prescribed manner. A flow divider can have no more than two conduit links on its
discharge side. Flow dividers are only active under Kinematic Wave routing and are
treated as simple junctions under Dynamic Wave routing.

There are four types of flow dividers, defined by the manner in which inflows are
diverted:

Cutoff: diverts all inflow above a defined cutoff value.
Tabular: uses a table that expresses diverted flow as a function of total inflow.
Overflow: diverts all inflow above the flow capacity of the on-diverted conduit.
Weir: uses a weir equation to compute diverted flow.

The flow diverted through a weir divider is computed by the following equation:

where QDIV diverted flow
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CW weir coefficient

HW weir height

f coefficient calculated as:

where Q
IN

inflow to the divider

Q
MIN

flow at which diversion begins

Q
MAX

flow given by:

To view and modify the properties of dividers:

1. Select Properties from the Objects menu.
2. Select Divider from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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Properties

Name: enter the name of the divider. Two or more dividers may share the same
name, but this is not recommended since there will be confusion in the results.
X coordinate: enter the X coordinate of the divider.
Y coordinate: enter the Y coordinate of the divider.
Description: enter the description of the divider.
Tag: enter a tag for the divider. This appears neither in the input data nor the
results.
Ground elevation (ft or m): enter the ground elevation of the divider. This field
can be auto-filled from the program, if the divider belongs to a profile in which
upstream and downstream ground elevations have been defined.
Invert elevation (ft or m): enter the invert elevation of the divider.
Initial water depth (ft or m): enter the depth of water at the divider at the
start of the simulation.
Surcharge depth (ft or m): enter the additional depth of water beyond the
maximum depth that is allowed before the divider floods. This parameter can be
used to simulate bolted manhole covers.
Ponded area (ft2 or m2): enter the area occupied by ponded water atop the
divider after flooding occurs. If the ponding option is turned on, a non-zero value
of this parameter will allow ponded water to be stored and subsequently returned
to the conveyance system when capacity exists.
Inflows: click the ellipsis button to assign time series, dry weather, or RDII
inflows to the divider.
Treatment: click the ellipsis button to edit a set of treatment functions for
pollutants entering the divider.
Diverted link: select the link which receives the diverted flow.
Type: select one of the following types:
o Cutoff: diverts all inflow above a defined cutoff value.

o Overflow: diverts all inflow above the flow capacity of the on-diverted conduit.

o Tabular: uses a table that expresses diverted flow as a function of total inflow.

o Weir: uses a weir equation to compute diverted flow.

Cutoff flow: enter the cutoff flow value used for a Cutoff divider, in user-
defined flow units.
Diversion curve: select the diversion curve used with a Tabular divider.
Minimum flow: enter the minimum flow at which diversion begins for a Weir
divider, in user-defined flow units.
Maximum depth (ft or m): enter the vertical height of Weir opening.
Discharge coefficient: enter the product of Weir's coefficient and its length.
Discharge coefficients are typically in the range of 2.65 to 3.10 per foot, for flows
in CFS
Station: click the ellipsis button to enter the station of the divider.
Inlet type: select the inlet type for the divider from the drop-down list. The inlet
types are entered as manhole specifications.
Bottom elevation (ft or m): enter the bottom elevation of the divider.
Ditch elevation (ft or m): enter the ground elevation of the divider.
Generic elevation (ft or m): enter a generic elevation of the divider. This
elevation appears in the profile drawing only.

Results

The results refer to the current time frame, selected from the drop-down
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list at the bottom-left corner of the main form.

Depth (ft or m): the water depth in the divider.
Flooding: the flow that is lost when inflows exceed storage and conveyance
capacity, in user-defined flow units.
Head (ft or m): the absolute elevation of hydraulic head
Lateral inflow: the sum of runoff and all other inflows, in user-defined flow units
.
Total inflow: the sum of lateral inflow and upstream inflow, in user-defined flow
units.
Volume (ft3 or m3): the water volume held in storage (including ponded water).

7.3.8 Storage

Storage Units are drainage system nodes that provide storage volume. Physically they
could represent storage facilities as small as a catch basin or as large as a lake. The
volumetric properties of a storage unit are described by a function or storage curve of
surface area versus height.

To view and modify the properties of storages:

1. Select Properties from the Objects menu.
2. Select Storage from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
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6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the storage. Two or more storages may share the same
name, but this is not recommended since there will be confusion in the results.
X coordinate: enter the X coordinate of the storage.
Y coordinate: enter the Y coordinate of the storage.
Description: enter the description of the storage.
Tag: enter a tag for the storage. This appears neither in the input data nor the
results.
Inflows: click the ellipsis button to assign time series, dry weather, or RDII
inflows to the storage.
Treatment: click the ellipsis button to edit a set of treatment functions for
pollutants entering the storage.
Ground elevation (ft or m): enter the ground elevation of the storage. This field
can be auto-filled from the program, if the outfall belongs to a profile in which
upstream and downstream ground elevations have been defined.
Invert elevation (ft or m): enter the invert elevation of the storage.
Initial water depth (ft or m): enter the depth of water at the storage at the
start of the simulation.
Ponded area (ft2 or m2): enter the surface area occupied by ponded water atop
the storage unit once the water depth exceeds the maximum depth. If the 
ponding option is turned on, a non-zero value of this parameter will allow ponded
water to be stored and subsequently returned to the conveyance system when
capacity exists.
Evaporation fraction: enter the fraction of the potential evaporation from the
storage unit’s water surface that is actually realized.
Shape curve type: select the type of curve describing the storage:

o Functional: the following relation holds: Surface = A x (Depth)B + C

o Tabular: a storage curve is used.

Shape curve coefficient: enter the value of A in the functional relationship
between surface area and storage depth.
Shape curve exponent: enter the value of B in the functional relationship
between surface area and storage depth.
Shape curve constant: enter the value of C in the functional relationship
between surface area and storage depth.
Shape curve name: select the storage curve containing the relationship between
surface area and storage depth.
Station: click the ellipsis button to enter the station of the storage.
Inlet type: select the inlet type for the storage from the drop-down list. The inlet
types are entered as manhole specifications.
Bottom elevation (ft or m): enter the bottom elevation of the storage.
Ditch elevation (ft or m): enter the ground elevation of the storage.
Generic elevation (ft or m): enter a generic elevation of the storage. This
elevation appears in the profile drawing only.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.
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Depth (ft or m): the water depth in the storage.
Flooding: the flow that is lost when inflows exceed storage and conveyance
capacity, in user-defined flow units.
Head (ft or m): the absolute elevation of hydraulic head
Lateral inflow: the sum of runoff and all other inflows, in user-defined flow units
.
Total inflow: the sum of lateral inflow and upstream inflow, in user-defined flow
units.
Volume (ft3 or m3): the water volume held in storage (including ponded water).

7.3.9 Link internal vertices

All links may include internal vertices. These are used to describe a more complex plan
view, so that calculation of quantities and profile drawings are more precise. There is
no restriction in the number of intermediate vertices.

To manage the internal vertices, you can use the corresponding buttons of the toolbar 
 or the internal vertices form:

1. Select the properties form of a link (conduit, pump, orifice, weir or outlet).
2. Double click on the Internal vertices property.
3. Click the ellipsis button. 
4. Make the appropriate changes.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To add a new internal vertex:

1. Press Add. The following form appears:

2. Make the appropriate selections as described below.
3. Enter the X-coordinate, the Y-coordinate, and the ground elevation (in ft or
m). Leaving the latter field empty activates auto-filling. If the specified link belongs to
a profile in which upstream and downstream ground elevation data exist, the program
calculates the elevation based on linear interpolation. In this case, the result appears
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within curly braces "{}".
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing internal vertex:

1. Select the vertex from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing internal vertex:

1. Select the internal vertex from the list on the left.
2. Press Remove. The snow pack is deleted from the list.

To move an existing internal vertex upwards in the list:

1. Select the internal vertex from the list on the left.
2. Press Move Up. 
3. The internal vertex is moved one place upwards.

To move an existing internal vertex downwards in the list:

1. Select the internal vertex from the list on the left.
2. Press Move Down. 
3. The internal vertex is moved one place downwards.

7.3.10 Conduit

Conduits are pipes or channels that move water from one node to another in the
conveyance system. Their cross-sectional shapes can be selected from a variety of
standard open and closed geometries as listed in the following table.

Name Parameters Name Parameters

Circular Full height Circular force main Full height,
Roughness

Filled Circular Full height, Filled depth Rectangular -
Closed

Full height,
Width

Rectangular - Open Full height, Width Trapezoidal Full height,
Base width,
Side slopes

Triangular Full height, Top width Horizontal Ellipse Full height,
Maximum
width

Vertical Ellipse Full height, Max. width Standardized Arch Type no.

Arch Full height, Max. width Parabolic Full height,
Top width

Power Full height, Top width,
Exponent

Rectangular -
Triangular

Full height,
Top width,
Triangle height
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Rectangular - Round Full height, Top width,
Bottom radius

Modified basket
handle

Full height,
Top width, Top
radius

Egg Full height Horseshoe Full height

Gothic Full height Catenary Full height

Semi-Elliptical Full height Basket handle Full height

Semi-Circular Full height Irregular Transect

Custom Shape curve Dummy

Most open channels can be represented with a rectangular, trapezoidal, or user-
defined irregular cross-section shape. For the latter, a transect object is used to define
how depth varies with distance across the cross-section. The most common shapes for
new drainage and sewer pipes are circular, elliptical, and arch pipes. They come in
standard sizes that are published by the American Iron and Steel Institute in Modern
Sewer Design and by the American Concrete Pipe Association in the Concrete Pipe
Design Manual. The Filled Circular shape allows the bottom of a circular pipe to be
filled with sediment and thus limit its flow capacity. The Custom Closed Shape allows
any closed geometrical shape that is symmetrical about the center line to be defined
by supplying a shape curve for the cross section.

The program uses the Manning equation to express the relationship between flow rate
(Q), cross sectional area (E), hydraulic radius (R), and slope (J) in all conduits:

Metric system English system

where n is Manning's friction coefficient. The slope J is interpreted as either the
conduit slope or the friction slope (i.e., head loss per unit length), depending on the
flow routing method used. For pipes with Circular Force Main cross-sections either the
Hazen-Williams or Darcy-Weisbach formula is used in place of the Manning equation
for fully pressurized flow:

Darcy - Weisbach

Hazen - Williams
Metric system English system

where, g is the acceleration of gravity, f is Darcy - Weisbach friction coefficient and C
is Hazen-Williams friction coefficient. For turbulent flow, the latter is determined from
the height of the roughness elements on the walls of the pipe (supplied as an input
parameter) and the flow’s Reynolds Number using the Colebrook-White equation.

A conduit does not have to be assigned a Force Main shape for it to pressurize. Any of
the closed cross-section shapes can potentially pressurize and thus function as force
mains that use the Manning equation to compute friction losses

To view and modify the properties of conduits:
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1. Select Properties from the Objects menu.
2. Select Conduit from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the storage. Two or more storages may share the same
name, but this is not recommended since there will be confusion in the results.
Start Node: select the start node (node, divider or storage) from the drop-down
list.
End node: select the end node (node, outfall, divider or storage) from the drop-
down list.
Internal vertices: click the ellipsis button to modify the internal vertices of the
conduit.
Description: enter the description of the conduit.
Tag: enter a tag for the conduit. This appears neither in the input data nor the
results.
Street address: optionally, enter the street name of the conduit
Existing conduit: select Yes if the conduit is existing (not necessarily old). The
difference is that existing conduits are checked with different maximum capacity.
The maximum capacities are defined in the checks. 
Shape: select the appropriate conduit shape. If none is selected, the program
uses the default shape or the shape that was explicitly defined upstream in a
profile that includes the conduit. In the latter case, the name of the conduit
shape appears within curly braces.
Maximum depth (ft or m, read only): this is the maximum depth of the
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selected conduit shape.
Length (ft or m): leave this field empty to activate auto-fill and let the program
calculate the length from the plan view. In this case, the result appears within
curly braces "{}". Alternatively, specify an explicit value that will be used. 
Roughness (read only): this is the conduit roughness, as entered in conduit
shapes.
Trench profile: select the trench profile from the drop-down list. T
Inlet elevation (ft or m): leave this field empty to activate auto-fill and let the
program calculate the correct elevation. This can be achieved if the conduit
belongs to a profile in which enough data for automatic calculation of elevations
exist. The calculation is based on user-defined design options and in this case the
result appears within curly braces "{}". Alternatively, specify an explicit value
that will be used.
Outlet elevation (ft or m): leave this field empty to activate auto-fill and let the
program calculate the correct elevation. This can be achieved if the conduit
belongs to a profile in which enough data for automatic calculation of elevations
exist. The calculation is based on user-defined design options and in this case the
result appears within curly braces "{}". Alternatively, specify an explicit value
that will be used.
Initial flow: the initial flow rate in the conduit, in user-defined flow units.
Maximum flow: enter the maximum flow allowed in the conduit under any
routing method (as of version 7.0), in user-defined flow units. Use 0 if not
applicable.
Entry loss coefficient: enter the head loss coefficient associated with energy
losses at the entrance of the conduit.
Exit loss coefficient: enter the head loss coefficient associated with energy
losses at the exit of the conduit.
Average loss coefficient: enter the coefficient associated with energy losses
along the length of the conduit.
Flap gate: select Yes if a flap gate exists that prevents backflow through the
conduit. Select No if no flap gate exists.
Culvert: select a culvert type from the drop-down list.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Slope: the slope of the conduit.
Depth (ft or m): the depth of the water in the conduit.
Froude No : the Froude no of the flow in the conduit.
Capacity: the capacity of the conduit.
Flow: the flow rate in the conduit, in user-defined flow units.
Velocity (ft/s or m/s): the flow velocity in the conduit.

7.3.11 Pump

Pumps are links used to lift water to higher elevations. A pump curve describes the
relation between a pump's flow rate and conditions at its inlet and outlet nodes. Four
different types of pump curves are supported:
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Type 1: An off-line pump with a wet
well where flow increases incrementally
with available wet well volume. 

Type 2: An in-line pump where flow
increases incrementally with inlet node
depth.

Type 3: An in-line pump where flow
varies continuously with head difference
between the inlet and outlet nodes.

Type 4: A variable speed in-line pump
where flow varies continuously with
inlet node depth.

Ideal: An "ideal" transfer pump whose
flow rate equals the inflow rate at its
inlet node. No curve is required. The
pump must be the only outflow link
from its inlet node. Used mainly for
preliminary design.

The on/off status of pumps can be controlled dynamically by specifying startup and
shutoff water depths at the inlet node or through user-defined control rules. Rules can
also be used to simulate variable speed drives that modulate pump flow.

To view and modify the properties of pumps:

1. Select Properties from the Objects menu.
2. Select Pump from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the pump. Two or more pumps may share the same
name, but this is not recommended since there will be confusion in the results.
Start node: select the start node (node, divider or storage) from the drop-down
list.
End node: select the end node (node, outfall, divider or storage) from the drop-
down list.
Internal vertices: click the ellipsis button to modify the internal vertices of the
pump.
Description: enter the description of the pump.
Tag: enter a tag for the pump. This appears neither in the input data nor the
results.
Pump curve: optionally, select an appropriate pump curve from the drop-down
list. If no curve is selected, the pump is assumed to be ideal.
Initial status: select the status of the pump (On or Off) at the beginning of the
simulation.
Startup depth (ft or m): enter the depth at inlet node when pump turns on.
Shutoff depth (ft or m): enter the depth at inlet node when pump shuts off.

Results

The results refer to the current time frame, selected from the drop-down
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list at the bottom-left corner of the main form.

Depth (ft or m): the depth of the water in the pump.
Froude No : the Froude no of the flow in the pump.
Capacity: the capacity of the pump.
Flow: the flow rate in the pump, in user-defined flow units.
Velocity (ft/s or m/s): the flow velocity in the pump.

7.3.12 Orifice

Orifices are used to model outlet and diversion structures in drainage systems, which
are typically openings in the wall of a manhole, storage facility, or control gate. They
are internally represented in the program as a link connecting two nodes. An orifice
can have either a circular or rectangular shape, be located either at the bottom or
along the side of the upstream node, and have a flap gate to prevent backflow.

Orifices can be used as storage unit outlets under all types of flow routing. If not
attached to a storage unit node, they can only be used in drainage networks that are
analyzed with Dynamic Wave flow routing.

The flow through a fully submerged orifice is computed as:

where Q flow rate
C discharge coefficient
A area of orifice opening
g acceleration or gravity
h head difference across the orifice

The height of an orifice's opening can be controlled dynamically through user-defined 
control rules. This feature can be used to model gate openings and closings.

To view and modify the properties of orifices:

1. Select Properties from the Objects menu.
2. Select Orifice from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the orifice. Two or more orifices may share the same
name, but this is not recommended since there will be confusion in the results.
Start node: select the start node (node, divider or storage) from the drop-down
list.
End node: select the end node (node, outfall, divider or storage) from the drop-
down list.
Internal vertices: click the ellipsis button to modify the internal vertices of the
orifice.
Description: enter the description of the orifice.
Tag: enter a tag for the orifice. This appears neither in the input data nor the
results.
Type: select the type of the orifice (Side or Bottom)
Shape: select the shape of the orifice (Circular or Closed Rectangular)
Height (ft or m): enter the height of orifice opening when fully open.
Corresponds to the diameter of a circular orifice or the height of a rectangular
orifice.
Width (ft or m): enter the width of rectangular orifice when fully opened.
Crest height (ft or m): enter the height of bottom of orifice above invert of inlet
node.
Discharge coefficient: enter the discharge coefficient. A typical value is 0.65.
Flap gate: select Yes if a flap gate exists that prevents backflow through the
orifice. Select No if no flap gate exists.
Time to open/close: enter the time it takes to open a close (or close an open)
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gate orifice in decimal hours. Use 0 or leave blank if timed openings/closings do
not apply. Use control rules to adjust gate position.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Depth (ft or m): the depth of the water in the orifice.
Froude No : the Froude no of the flow in the orifice.
Capacity: the capacity of the orifice.
Flow: the flow rate in the orifice, in user-defined flow units.
Velocity (ft/s or m/s): the flow velocity in the orifice.

7.3.13 Weir

Weirs, like orifices, are used to model outlet and diversion structures in a drainage
system. Weirs are typically located in a manhole, along the side of a channel, or within
a storage unit. They are internally represented in the program as a link connecting two
nodes, where the weir itself is placed at the upstream node. A flap gate can be
included to prevent backflow.

Four varieties of weirs are available, each incorporating a different formula for
computing flow across the weir as listed in the following table:

Weir type Cross section shape Flow formula

Transverse Rectangular

Side flow Rectangular

V-notch Triangular

Trapezoidal Trapezoidal

Weirs can be used as storage unit outlets under all types of flow routing. If not
attached to a storage unit, they can only be used in drainage networks that are
analyzed with Dynamic Wave flow routing.

The height of the weir crest above the inlet node invert can be controlled dynamically
through user-defined control rules. This feature can be used to model inflatable dams.

To view and modify the properties of weirs:

1. Select Properties from the Objects menu.
2. Select Weir from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the weir. Two or more weirs may share the same name,
but this is not recommended since there will be confusion in the results.
Start node: select the start node (node, divider or storage) from the drop-down
list.
End node: select the end node (node, outfall, divider or storage) from the drop-
down list.
Internal vertices: click the ellipsis button to modify the internal vertices of the
weir.
Description: enter the description of the weir.
Tag: enter a tag for the weir. This appears neither in the input data nor the
results.
Type: select the type of the weir (Transverse, Side flow, V-notch or
Trapezoidal).
Height (ft or m): enter the vertical height of weir opening.
Length (ft or m): enter the horizontal length of weir opening.
Side slope (H/V): enter the side slope (width to height) for V-notch or
Trapezoidal weir.
Crest height (ft or m): enter the height of bottom of weir opening from invert of
inlet node.
Discharge coefficient: enter the discharge coefficient for flow through the
central portion of the weir (for flow in CFS when using English units or CMS when
using Metric units). Typical values are: 3.33 (English) 1.84 (Metric) for sharp
crested transverse weirs, 2.5 - 3.3 (English) 1.38 - 1.83 (Metric) for broad
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crested rectangular weirs, 2.4 - 2.8 (English) 1.35 - 1.55 (Metric) for V-notch
triangular weirs.
Flap gate: select Yes if a flap gate exists that prevents backflow through the
orifice. Select No if no flap gate exists.
End coefficient: enter the discharge coefficient for flow through the triangular
ends of a Trapezoidal weir. See the recommended values for V-notch weirs listed
above.
Number of end contractions: enter the number of end contractions for a
Transverse or Trapezoidal weir whose length is shorter than the channel it is
placed in. Values will be either 0, 1, or 2 depending on if no ends, one end, or
both ends are beveled in from the side walls.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Depth (ft or m): the depth of the water in the weir.
Froude No : the Froude no of the flow in the weir.
Capacity: the capacity of the weir.
Flow: the flow rate in the weir, in user-defined flow units.
Velocity (ft/s or m/s): the flow velocity in the weir.

7.3.14 Outlet

Outlets are flow control devices that are typically used to control outflows from storage
units. They are used to model special head-discharge relationships that cannot be
characterized by pumps, orifices, or weirs. Outlets are internally represented in the
program as a link connecting two nodes. An outlet can also have a flap gate that
restricts flow to only one direction.

Outlets attached to storage units are active under all types of flow routing. If not
attached to a storage unit, they can only be used in drainage networks analyzed with
Dynamic Wave flow routing.

A user-defined rating curve determines an outlet's discharge flow as a function of the
head difference across it. Control rules can be used to dynamically adjust this flow
when certain conditions exist.

To view and modify the properties of outlets:

1. Select Properties from the Objects menu.
2. Select Outlet from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the outlet. Two or more outlets may share the same
name, but this is not recommended since there will be confusion in the results.
Start node: select the start node (node, divider or storage) from the drop-down
list.
End node: select the end node (node, outfall, divider or storage) from the drop-
down list.
Internal vertices: click the ellipsis button to modify the internal vertices of the
outlet.
Description: enter the description of the outlet.
Tag: enter a tag for the outlet. This appears neither in the input data nor the
results.
Height (ft or m): enter the height of outlet above inlet node invert.
Flap gate: select Yes if a flap gate exists that prevents backflow through the
outlet. Select No if no flap gate exists.
Rating curve: Method of defining flow (Q) as a function of freeboard depth or
head (y) across the outlet
o FUNCTIONAL/DEPTH - uses a power function Q = AyB where y is the

freeboard depth above the outlet's opening.
o FUNCTIONAL/HEAD - uses a power function Q = AyB where y is the head

difference across the outlet.
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o TABULAR/DEPTH - uses a tabulated curve of flow versus freeboard depth

values.
o TABULAR/HEAD - uses a tabulated curve of flow versus head difference

values. 
Coefficient: enter the coefficient A for the functional relationship between head
and flow rate with Functional curve.
Exponent: enter the coefficient B for the functional relationship between head
and flow rate with Functional curve.
Rating curve name: select the rating curve containing the relationship between
head and flow rate with Tabular curve.

Results

The results refer to the current time frame, selected from the drop-down
list at the bottom-left corner of the main form.

Depth (ft or m): the depth of the water in the outlet.
Froude No : the Froude no of the flow in the outlet.
Capacity: the capacity of the outlet.
Flow: the flow rate in the outlet, in user-defined flow units.
Velocity (ft/s or m/s): the flow velocity in the outlet.

7.3.15 Profile

Profiles are not actual objects but rather a series of references to alternating nodes
and links. Data input becomes very easy using profiles since:

data are input in tabular form,
the elevations are displayed in a visual and comprehensive way,
the creation of profile DXF drawings is easy,
a network may be defined without plan view data.

To view and modify the properties of profiles:

1. Select Properties from the Objects menu.
2. Select Profile from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the profile. Two or more profiles may share the same
name, but this is not recommended since there will be confusion in the results.
Description: enter the description of the profile.
Tag: enter a tag for the profile. This appears neither in the input data nor the
results.
Active: select whether the profile will appear in the profile drawing. This setting
can be changes using the profile drawing form.
First station: enter the first station of the profile. This option is used with the
semi-automatic data input of profile stations.
Concentration time (min): enter the concentration time. This field is needed
only when an IDF curve is used.

7.3.16 Label

Labels are optional text objects that can be used to enrich the plan view with
important data.

To view and modify the properties of labels:

1. Select Properties from the Objects menu.
2. Select Label from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the label (not the text).
X-coordinate: enter the X-coordinate of the label.
Y-coordinate: enter the Y-coordinate of the label.
Text: enter the text that will be displayed.

7.4 Object conversion

With this option, you can convert objects from one type to another.

To convert objects from one type to another:

1. Select (in plan view) the objects you wish to convert.
2. Select Object conversion from the Objects menu. The following form appears:

3. Select if you wish to convert nodes (point objects) or links (linear objects). 
4. Select the target object type from the list on the right.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Non-common properties are lost during object conversion.

NOTE: To convert a vertex back to a junction, see the convert vertex to junction
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function.

7.5 Add vertex

With this option, you can add an intermediate vertex to an existing link: conduit,
pump, orifice, weir, outlet. This procedure is described also in the section of link
internal vertices.

To add an intermediate vertex to an existing link:

1. Select Add vertex from the Objects menu.
2. Click on the link to add a vertex.

7.6 Add vertex by distance

With this option, you add a vertex on a conduit, by specifying a distance from either
end of the conduit. For example, if the conduit has a length equal to 20 m and you
need to add a vertex that be located 5 m from its end (station 0+015) then select its
ending node and enter 5 or its starting node and enter 15.

To add a vertex by distance:

1. Select Add Vertex By Distance from the Objects menu.
2. Select the conduit from the drop-down list. Its length appears on the form.

3. Enter the desired distance from either starting or ending node.
4. Select whether this distance is measured from the starting or ending node.
5. Select Ok to add a vertex on the specified conduit. Select Cancel to close the
dialog box without applying any changes.

7.7 Delete vertex

With this option, you can delete an intermediate vertex of an existing link: conduit,
pump, orifice, weir, outlet. This procedure is also described in the section of link
internal vertices.

To delete an intermediate vertex of an existing link:

1. Select Delete vertex from the Objects menu.
2. Click on the link vertex to delete it.

7.8 Stretch vertex

With this option, you can move an intermediate vertex of an existing link: conduit,
pump, orifice, weir, outlet. This procedure is also described in the section of link
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internal vertices.

To delete an intermediate vertex to an existing link:

1. Select Stretch vertex from the Objects menu.
2. Click on the link vertex you wish to move.
3. Click again to define the new vertex position.

7.9 Convert vertex to junction

To convert one or more vertices back to junctions, one must you this function instead
of the generic conversion form. 

To convert one vertex to a junction:

1. From the Objects menu, click on Convert Vertex To Junction.
2. On the map, click on the vertex you wish to convert back to a junction.
3. The vertex is converted.

To convert multiple vertices to junctions:

1. From the Objects menu, click on Convert Vertex To Junction.
2. Hold CTRL down and click on the map the vertex you wish to convert back to a
junction.
3. Repeat step 2 until all vertices are converted.

7.10 Labels

With this option, you can select which object properties will be displayed. Up to two
properties can be displayed simultaneously, one on the left label and one on the right.

To select which object properties will be displayed:

1. Select Labels from the Objects menu.
2. Select the object type from the Labels menu. The following form appears:

3. Select the property that will be displayed on the left.
4. Select the property that will be displayed on the right.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

7.11 Swap link ends

All links have a certain direction. With this option, you can swap the ends of the
selected links and invert their direction.
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To swap the ends of the selected links:

1. Select the links in the drawing.
2. Select Swap link ends from the Objects menu. The ends are swapped.

7.12 Transects

7.12.1 Management

Transects refer to the geometric data that describe how bottom elevation varies with
horizontal distance over the cross section of a natural channel or irregular-shaped
conduit.

To manage transects:

1. Select Transects from the Objects menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

7.12.2 Add

With this option, you can add a new transect.

To add a new transect:

1. Press Add. The data form appears:
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2. Enter a user-assigned name. This name cannot be null or used for another transect
in the project.
3. Optionally, add some comments  to the curve. Press the ellipsis button to edit
multiline text.
4. Enter the Manning friction coefficient for the left bank.
5. Enter the Manning friction coefficient for the right bank.
6. Enter the Manning friction coefficient for the channel.
7. Enter the station of the left bank in ft or m. If no left bank exists, enter the station
of the first point of the transect.
8. Enter the station of the right bank in ft or m. If no right bank exists, enter the
station of the last point of the transect.
9. Enter the stations multiplier which will be applied to the stations specified. Enter
1.0 if you wish to disable this feature.
10. Enter the elevation offset in ft or m which will be added to the elevations
specified.
11. Type the data in the data list. 
12. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

7.12.3 Delete

To delete an existing transect:

1. Select the transect from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The transect is deleted from the list.
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7.12.4 Edit

To edit an existing transect:

1. Select the transect from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add transect topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

7.12.5 Move

To move an existing transect upwards in the list:

1. Select the transect from the list on the left.
2. Press Move Up. 
3. The transect is moved one place upwards.

To move an existing transect downwards in the list:

1. Select the transect from the list on the left.
2. Press Move Down. 
3. The transect is moved one place downwards.

7.12.6 Sort

To sort the transect list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

7.13 Control rules

7.13.1 Management

Control Rules determine how pumps and regulators (orifices, weirs and outlets) in the
drainage system will be adjusted over the course of a simulation. 

Each control rule is a series of statements of the form:

RULE ruleID

IF condition_1
AND condition_2
OR condition_3
AND condition_4
Etc.

THEN action_1
AND action_2
Etc.

ELSE action_3
AND action_4
Etc.
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PRIORITY value

Only the RULE, IF and THEN portions of a rule are required; the ELSE and
PRIORITY portions are optional.

When mixing AND and OR clauses, the OR operator has higher precedence than AND,
i.e.,

IF A OR B AND C

is equivalent to:

IF (A OR B) AND C.

If the interpretation was meant to be

IF A OR (B AND C)

then this can be expressed using two rules as in

IF A THEN ...
IF B AND C THEN ...

The PRIORITY value is used to determine which rule applies when two or more rules
require that conflicting actions be taken on a link. A rule without a priority value
always has a lower priority than one with a value. For two rules with the same priority
value, the rule that appears first is given the higher priority.

Condition clauses

A condition clause of a control rule has the following format:

object id attribute relation value

where object object type
id object name
attribute attribute or property of the object
relation relational operator (=, <>, <, <=, =>, >)
value property value

Some examples of condition clauses are:

NODE N1 DEPTH > 10
PUMP A1 STATUS = OFF
SIMULATION CLOCKTIME = 22:45:00

The objects and attributes that can appear in a condition clause are as follows:

Object Property Value

Node Depth
Head
Inflow

numerical value
numerical value
numerical value
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Link Flow
Depth

numerical value
numerical value

Pump Status
Flow
Setting

On/Off
numerical value
modulated control

Orifice Setting fraction open or
modulated control

Weir Setting fraction open or
modulated control

Simulation Time
Date
Clocktime
(00:00:00)
Month
Day

elapsed time in decimal hours or hr:
min:sec
month/day/year
time of day in hr:min:sec
number of month (1-12), 1 being
January
number of day (1-7), 1 being
Sunday

Action clauses

An action clause of a control rule can have one of the following formats:

PUMP id STATUS = ON/OFF
PUMP/ORIFICE/WEIR/OUTLET id SETTING = value

where the meaning of SETTING depends on the object being controlled:

for pumps it is a multiplier applied to the flow computed from the pump curve.
for orifices it is the fractional amount that the orifice is fully open.
for weirs it is the fractional amount of the original freeboard that exists (i.e., weir
control is accomplished by moving the crest height up or down).
for outlets it is a multiplier applied to the flow computed from the outlet's rating
curve.

Some examples of action clauses are:

PUMP P67 STATUS = OFF
ORIFICE O212 SETTING = 0.5

Modulated controls

Modulated controls are control rules that provide for a continuous degree of control
applied to a pump or flow regulator as determined by the value of some controller
variable, such as water depth at a node, or by time. The functional relation between
the control setting and the controller variable is specified by using a control curve, a
timeseries or a PID controller (see below). Some examples of modulated control rules
are:

RULE MC1
IF NODE N2 DEPTH >= 0
THEN WEIR W25 SETTING = CURVE C25
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RULE MC2
IF SIMULATION TIME > 0
THEN PUMP P12 SETTING = TIMESERIES TS101

RULE MC3
IF LINK L33 FLOW <> 1.6
THEN ORIFICE O12 SETTING = PID 0.1 0.0 0.0 

Note how a modified form of the action clause is used to specify the name of the
control curve, time series or PID parameter set (Gain, Integral, and Derivative
coefficients) that defines the degree of control. Also, by convention the controller
variable used in a Control Curve or PID Controller will always be the object and
attribute named in the last condition clause of the rule. As an example, in rule MC1
above Curve C25 would define how the fractional setting at Weir W25 varied with the
water depth at Node N2. In rule MC3, the PID controller adjusts the opening of Orifice
O12 to maintain a flow of 1.6 in Link L33. 

PID Controller

A PID (Proportional-Integral-Derivative) Controller is a generic closed-loop control
scheme that tries to maintain a desired set-point on some process variable by
computing and applying a corrective action that adjusts the process accordingly. In
the context of a hydraulic conveyance system a PID controller might be used to adjust
the opening on a gated orifice to maintain a target flow rate in a specific conduit or to
adjust a variable speed pump to maintain a desired depth in a storage unit. The
classical PID controller has the form:

m(t) controller output
Kp proportional coefficient (gain)

Τi integral time (minutes)

Τd derivative time (minutes)

e(t) error (difference between setpoint and observed variable value)
t time

The performance of a PID controller is determined by the values assigned to the
coefficients Kp , Ti, and Td. The controller output m (t) has the same meaning as a link

setting used in a rule's Action Clause while dt is the current flow routing time step in
seconds. The error e(t) is the difference between the control variable setpoint x* and
its value at time t, x(t), normalized to the setpoint value:

Note that for direct action control, where an increase in the link setting causes an
increase in the controlled variable, the sign of Kp must be positive. For reverse action
control, where the controlled variable decreases as the link setting increases, the sign
of Kp must be negative. The user must recognize whether the control is direct or
reverse action and use the proper sign on Kp accordingly. For example, adjusting an
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orifice opening to maintain a desired downstream flow is direct action. Adjusting it to
maintain a downstream water level is reverse action while adjusting it to maintain an
upstream water level is direct action. Controlling a pump to maintain a fixed wet well
water level would be reverse action while using it to maintain a fixed downstream flow
is direct action.

To manage control rules:

1. Select Control rules from the Objects menu. The following form appears:

2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

7.13.2 Add

With this option, you can add a new rule. 

To add a new rule:

1. Press Add. The data form appears:

2. Enter a user-assigned name. This name cannot be null or used for another control
rule in the project.
3. Optionally, you can assign a priority level for the rule.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
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dialog box without saving any changes.

To enter a new logical statement to the rule:

1. Press Add to enter a new logical statement to the rule. The following form appears:

2. Select the Clause, Scope, Object, allowed Relation and Value. Value may be one
of the following:

Option 1: a boolean (YES/NO) or numeric value
Option 2: a control curve, if one or more control curves are present
Option 3: a time series, if one or more time series are present
Option 4: a PID controller. Enter values for gain, integral and derivative
coefficient respectively.

Not all options are available for a selected scope. If more than one option is
available, the user must specify which one will be used by activating the radio
button on the left of the option.

3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes

To delete an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the statement is deleted.

To modify an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Edit.
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To modify the position of an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Move Up to move the statement up by one row. Select Move Down to
move the statement down by one row.

7.13.3 Delete

To delete an existing control rule:
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1. Select the control rule from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The control rule is deleted from the list.

7.13.4 Edit

To edit an existing control rule:

1. Select the control rule from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add control rule topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

7.13.5 Move

To move an existing control rule upwards in the list:

1. Select the control rule from the list on the left.
2. Press Move Up. 
3. The control rule is moved one place upwards.

To move an existing control rule downwards in the list:

1. Select the control rule from the list on the left.
2. Press Move Down. 
3. The control rule is moved one place downwards.

7.13.6 Sort

To sort the control rule list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.
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8 Profiles

8.1 Profiles menu

With this menu, you can perform various operations regarding profiles and network
design. These are available in case at least one profile has been defined. In the
Profiles menu you can select one of the following options:

Profile options
Renaming of profiles nodes
Elevation calculations
Automated branch design
Force constant slope
Uniform inflow
Stations
Inlets
Street addresses
Vertical street addresses
Other junctions
Special devices

8.2 Profile options

With this option, you can modify the way the branches are displayed.

To modify the way the branches are displayed:

1. Select Profile options from the Profiles menu. The following form will appear:

2. Make the appropriate changes as described below. By clicking on each column, a
sketch of the setting is displayed on the right.

Reference elevation: Enter the reference elevation in m. However, it is
recommended that you leave this field empty, in which case a label "AUTO" will
appear and the reference elevation will be automatically calculated by the
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program.
Station from: enter the initial station if this is not zero. This affects only the
drawing of the profiles; it is not related with the stations of the data table.
Direction: enter one of positive, negative if you want the stations to be
increasing or decreasing, respectively.
Begin from: enter the distance from the first station in m. Usually this value will
coincide the Station from field, but it will be displayed in a different row in the
profile.
Draw: select one of D->U, U->D if you want the profile to be drawn downstream
to upstream or vice versa, respectively. This affects the profile drawing; in the
data table of the main form and the profile sketch, the branch is drawn upstream
to downstream.
Upstream end: select one of open, closed if you want the end to be drawn open
or closed, respectively, in the profile drawing.
Downstream end: select one of open, closed if you want the end to be drawn
open or closed, respectively, in the profile drawing.
Table name: enter the title of the branch. This is optional and it will be printed
above the corresponding table in the profile drawing. When editing this value, the
buttons Suggest and Clear of the Title frame become enabled. The former sets
the name equal to the title of the branch; the latter clears all table names.
Print table: select one of Yes, No if you want a table with row descriptions to be
included for the specific branch in the profile drawing. When editing this value,
the buttons Select all, Select None and Select Invert of  the Table frame
become enabled. With these, you can set Yes or No to all branches with one
click.

3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

8.3 Renaming of profiles nodes

Since nodes have various names and a profile usually consists of several nodes, this
tool can be used to rename all nodes belonging to a particular profile. The rename
procedure can create chained names of the nodes, making it easy for the engineer or
the reviewer to navigate through a profile. For example, a profile consisting of nodes
KP1, N2, N5, N7 and Z1 would be KP1-N2-N5-N7-Z1, while after renaming it could be
J1-J2-J3-J4-J5.

To rename the nodes of the selected profile:

1. Select the profile in the profile list.
2. From the Tools menu select Renaming Of Profile Nodes.
3. Select where renaming begins (first to last node, second to last node, and vice
versa)
4. Optionally enter a prefix, i.e. J.
5. Enter the first number.
6. Enter the step. For example if the first number is 2 and the step is 3, then nodes
will be renamed as J2, J5, J8, etc.
7. Press Ok to rename the nodes as described above or Cancel to close the form and
ignore all changes.
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NOTE: You can easily work through an entire network. Suppose you have two profiles,
J1 to J10 and P1 to P8. The second profile intersects the first at junction J5. Rename
the second profile use J5- as the prefix, first number 1 and step 1. It will be renamed
as J5-1 to J5-8.

8.4 Elevation calculations

With this option, you can add or subtract a value to or from a specified elevation.

To add or subtract a value to or from a specified elevation:

1. Select the branch from the list of the main form.
2. Select two or more rows in the data table (when viewing the profile) by clicking and
dragging the mouse. The first and last row signify the first and last station,
respectively, of the part that the calculations will be applied.
3. Select Elevation calculations from the Profiles menu. The following form will
appear:

4. The form displays the first and last station.
5. Select the type of elevation that will be modified from the drop-down list. The
available options are:

Ground elevation
Upstream bottom elevation
Downstream bottom elevation
Trench elevation
Custom elevation
Manhole bottom elevation

6. Enter the value to be added or subtracted by typing into the corresponding text
box.
7. If some values are calculated automatically by the program using linear
interpolation then, after this procedure, these will be recalculated, thus canceling the
effect of the above modifications. Check Convert automatically computed data to
fix the new values and prevent the program from recalculating them.
8. Select Ok to proceed with the operation and close the dialog box. Select Cancel to
close the dialog box and cancel the operation.
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8.5 Automated branch design

With this option, you can design a part of a network based on constant slope of the
bottom elevation or constant depth from the ground elevation.

To design a part of a network:

1. Select the profile from the list of the main form.
2. Select Automated branch design from the Profiles menu. The following form will
appear:

3. Select one of constant slope or constant depth.
4. If you select constant slope, enter the initial depth of the first inlet and the
constant slope by typing in the corresponding text boxes.
5. If you select constant depth, enter the depth (ft or m) by typing in the
corresponding text box.
6. In both cases, click the button with the ellipses (...) to select the section that will
be used for the pipes.
7. Select Ok to proceed with the operation and close the dialog box. Select Cancel to
close the dialog box and cancel the operation.

8.6 Force constant slope

With this option, you can apply a uniform slope to a specified part of a profile.

To apply a uniform slope to a specified part of a profile:

1. Select the profile from the list of the main form.
2. Select two or more rows in the data table (when viewing the profile) by clicking and
dragging the mouse. The first and last row signify the first and last station,
respectively, of the part that the uniform slope will be applied.
3. Select Force constant slope from the Profiles menu. The following form will
appear:

4. The form displays the first and last station.
5. Enter the uniform slope by typing in the corresponding text box.
6. Select Ok to proceed with the operation and close the dialog box. Select Cancel to
close the dialog box and cancel the operation.
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8.7 Uniform inflow

With this option, you can apply a flow rate uniformly along a part of a profile.

To apply a flow rate uniformly along a part of a profile:

1. Select the profile from the list of the main form.
2. Select two or more rows in the data table (when viewing the profile) by clicking and
dragging the mouse. The first and last row signify the first and last station,
respectively, of the part that the flow rate will be applied uniformly.
3. Select Uniform flow from the Profiles menu. The following form will appear:

4. The form displays the first and last station.
5. Enter the inflow value in user selected flow units by typing in the corresponding
text box.
6. Select Ok to proceed with the operation and close the dialog box. Select Cancel to
close the dialog box and cancel the operation.

NOTE: If the last inlet is selected then it is ignored because is does not affect the
flow rate of the branch. The inflow is distributed uniformly, taking into account the
length of the segments between the stations.

8.8 Stations

With this option, you can enter station data for the selected profile. This option is very
helpful if you want to enter the data of all stations, especially if these are uniformly
spaced (e.g. every 20m). Alternatively, the station data can be input using the data
table of the main form.

To enter station data for the selected profile:

1. Select the profile from the list.
2. Select Stations from the Data menu. The following form appears:



Profiles 211

© 2012 TechnoLogismik i

3. Enter the station data.
4. You can optionally use the following quick buttons:

Incremental: beginning with the first station, add the distance between two
stations.
Decremental: beginning with the first station, subtract the distance between two
stations.

5. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

NOTE: The first station is defined in the profile options form.

8.9 Inlets

With this option, you can set the type of the inlets. The default type is manhole;
however, the inlet may be just a computational node. You can use this option to:

Define the simple computational nodes and the inlets with manholes.
Define the type of inlet.

Prior to using this option, you must enter the inlet types that will be used in the
network. In general, these are depended on the pipe diameter. This can be
accomplished using manhole specifications found in the Data menu.

To set the type of inlets:

1. Select the profile from the list.
2. Select Inlets from the Profiles menu. The following form will appear:

3. Select Select All to set the type of all inlets to manhole.
4. Select Select None to set the type of all inlets to simple computational node.
These are displayed in different color in the data table.
5. Select Select Invert to toggle the type of inlets between the above two types.
6. Select When slope changes to set the type of all inlets where slope changes to
manhole.
7. Select When diameter changes to set the type of all inlets where size or shape of
the pipe changes to manhole.
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8. You can change the type of the inlet manually as follows:

Select one or more inlets from the list on the left. In order to select multiple
inlets, hold down CTRL while selecting.
From the Inlet types frame, select one of Without inlet, Without type, or
select a specified type of inlet.
Repeat the above procedure for all inlets.

9. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

8.10 Street addresses

With this option, you can add or modify street addresses to the profile drawing. This
data does not affect calculations.

To add or modify street addresses:

1. Select the profile from the list of the main form.
2. Select Street addresses from the Profiles menu. The following form will appear:

3. Enter the street addresses by typing directly onto the grid.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

For your convenience, the following options are available from the Edit menu:

Select all: All cells are selected.
Cut: The data of the selected cells are deleted from the grid and copied to the
clipboard.
Copy: The data of the selected cells are copied to the clipboard.
Paste: The data of the clipboard is pasted into the grid.
Clear selection: The data of the selected cells are deleted.

NOTE: If the same street address spans more than one sections, the program will
merge the street addresses into one.



Profiles 213

© 2012 TechnoLogismik i

8.11 Vertical street addresses

With this option, you can add or modify vertical street addresses to the profile
drawing. This data does not affect calculations.

To add or modify vertical street addresses:

1. Select the profile from the list of the main form.
2. Select Vertical street addresses from the Profiles menu. The following form will
appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a vertical street address:

1. Select Add. The following form will appear:

2. Enter the Street address by typing in the corresponding text box.
3. In the Coordinates frame, enter the distance from start of the vertical street
address. For your convenience, you can select Inlet. The following form appears:

Select the inlet from the drop-down list.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing vertical street address:

1. Select the vertical street address from the list.
2. Select Modify. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing vertical street address:

1. Select the vertical street address from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The vertical street address is deleted.

8.12 Other junctions

With this option, you can add pipe junctions from other networks to the profile
drawing and the profile sketch. These do not affect calculations.

To add pipe junctions to the profile drawing and the profile sketch:

1. Select the profile from the list of the main form.
2. Select Other junctions from the Profiles menu. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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To add a pipe junction:

1. Select Add. The following form will appear:

2. Select the Section type and Diameter of the pipe in m.
3. In the Coordinates frame, enter the Distance from start of the pipe junction and
the Bottom elevation in m. For your convenience, you can select Inlet. The following
form appears:

Select the inlet from the drop-down list.
Check Match invert if you wish to match the invert elevation of the specified
inlet.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. In the Placement frame, you can select the position of the pipe junction i.e.
whether the junction comes from the left or right, and you can add comments to the
pipe junction. This data is used only for the profile drawings.
5. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing junction:

1. Select the junction from the list.
2. Select Modify. The following form will appear:



Sewer Networks216

© 2012 TechnoLogismik i

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing junction:

1. Select the junction from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The junction is deleted.

8.13 Special devices

With this option, you can add special devices to the profile drawing and the profile
sketch. These do not affect calculations.

To add special devices to the profile drawing and the profile sketch:

1. Select the profile from the list of the main form.
2. Select Special devices from the Profiles menu. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a special device:
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1. Select Add. The following form will appear:

2. In the Properties frame, select one of Air release valve, Vacuum valve  and
Valve as the type of the special device. You can also provide a Description of the
special device by typing into the corresponding  text box.
3. In the Coordinates frame, enter the Distance from start of the special device and
the Elevation in m. For your convenience, you can select Inlet. The following form
appears:

Select the inlet from the drop-down list.
Check Match invert if you wish to match the invert elevation of the specified
inlet.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing special device:

1. Select the special device from the list.
2. Select Modify. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing special device:
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1. Select the special device from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The special device is deleted.
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9 Tools

9.1 Tools menu

With this menu, you can perform advanced operations regarding network's design and
integrity design. In the tools menu you can select one of the following options:

Object renaming
Placement of conduits at constant depth
Vertical displacement
Inflow distribution
Sewer area distribution
Exact total sewer area
Delete all inflows
Subcatchments from DXF
Automatic design
Contours

9.2 Object renaming

To conveniently rename objects of a certain type such as junctions, conduits, pumps,
etc, you may use the object renaming tool.

To rename objects of a certain type:

1. Select Object Renaming from the Tools menu.
2. Select the object type from the drop-down list.
3. Select the scope from the drop-down list. The scope can either be the entire
project or the current selection.
4. Enter the renaming command (see below).
5. Press Apply to rename the objects described above or Cancel to close the form and
ignore all changes.

Renaming command

The renaming command is a string that dictates how the objects will be renamed. This
command is consisted of keywords and strings. Keyword vary depending on the object
type selected and appear as buttons for your convenience.

Examples:

J&[Index]: will rename all objects as J1, J2, J3, etc.
&[StartNodeName] -> &[EndNodeName]: will rename all pipes as J1 -> J2, J2 -> J3,
etc.
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9.3 Placement of conduits at constant depth

This tools places the selected conduits at a constant (given) depth. The depth may be
entered in m or ft, depending on the unit system, and can be measured from the
invert elevation of the crown elevation. To place all conduits in a network at a constant
depth, select them all before invoking this command by pressing CTRL+A.

To place the selected conduits at a constant depth:

1. Select the conduits to be placed at a constant depth.
2. From the Tools menu, select Placement Of Conduits At Constant Depth.
3. Select whether the calculations will be made based on the invert or crown
elevations.
4. Enter the depth in ft or m.
5. Press Ok to place the selected conduits at the specified depth or Cancel to ignore
changes.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.4 Vertical displacement

Use this tool to move the selected conduits upwards or downwards. Positive offsets
move the network towards the ground level while negative values have the opposite
effect, sinking the network.

To move the whole network:

1. Select the conduits you wish to move, either in plan-view or in profile view.
2. From the Tools menu, select Vertical Displacement.
3. Enter the distance in ft or m. A positive distance will move the network towards the
ground. The distance requested is the absolute difference in the new elevation minus
the current elevation of any object.
4. Press Ok to place the selected conduits at the specified depth or Cancel to ignore
changes.
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NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.5 Inflow distribution

This tool is useful when one wants to distribute a know inflow (say 60 L/s) in all the
network's conduits, depending on their length. The program will calculate the total
conduits length and will distribute proportionally the total inflow to their upstream
nodes.

To distribute a known inflow:

1. From the Tools menu select Inflow Distribution.
2. If you wish to erase all existing inflows prior to distribute the total inflow, check the
option Erase existing inflows first. Otherwise, the portion of the total inflow at every
node will be added to the existing inflow (if any).
3. Select whether the inflow distribution will be performed based on all conduits or the
selected conduits only.
4. Enter the total inflow in flow units.
5. Press Ok to distribute the total inflow to all nodes in the network or Cancel to
ignore any changes and hide the form.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.6 Sewer area distribution

Use sewer area distribution tool to divide a user specified sewer area across the
network. This division will be proportional to the conduit lengths and the inflows (in
terms of areas) will be placed at the upstream node of each conduit. Optionally, you
can remove any existing inflows from the nodes prior to distributing a sewer area.

To distribute a known sewer area:

1. From the Tools menu select Sewer Area Distribution.
2. If you wish to erase all existing inflows prior to distribute the total area, check the
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option Erase existing inflows first. Otherwise, the portion of the total area at every
node will be added to the existing inflow area (if any).
3. Select the area category from the drop-down list.
4. Enter the total area in ha or ac depending on the unit system.
5. Press Ok to distribute the total area to all nodes in the network or Cancel to ignore
any changes and hide the form.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.7 Exact total sewer area

This tool calculates the total area of the area objects for a selected area category and
automatically transfers the result to the category's data.

To calculate the area of a specified area category:

1. Select Exact Total Sewer Area from the Tools menu.
2. Select the area category whose area will be computed.
3. Click Ok to compute the total area and transfer the result to the area category.
Click Cancel to hide the tool.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.8 Delete all inflows

Use this tool to remove all inflows from all nodes.

To delete all inflows:

1. From the Tools menu select Delete All Inflows.
2. Click on Yes to remove all inflows or No to cancel the command without removing
the inflows.
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NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.9 Subcatchments from DXF

If you do not wish to specify on screen each area separately via the program's user
interface, it is possible to import one or more areas from external dxf files. The areas
have to be closed polygons (polylines). This tool, apart from reading and plotting areas
from external dxf files, scans for the nearest junction to every area and connects
them. 

To import subcatchments from DXF:

1. Select Subcatchments From DXF from the Tools menu.
2. The following form appears, where the input file can be selected.

3. Select one or more layers containing the polygon data.
4. The quick keys (Select all, Select None, Select Invert) can be used to quickly
select all objects, deselect all objects and invert the current selection.
5. Select Ok to import the polygons, display them on the drawing and close the dialog
box. Select Cancel to close the dialog box without applying any changes.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.10 Automatic design

Use this tool to automatically select the appropriate conduit shape for each conduit,
depending on a wide variety of criteria. To use this tool, you must first specify all
conduit shapes that will be used in the automatic design and have them sorted by size
(not mandatory, but logical). The program will start from the first specification and
move to the last, solving the network and verifying that the following conditions are
met:
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a) The velocity at each conduit is between the minimum and maximum values of its
specification.
b) The percent full at each conduit is not above the maximum limit set in its
specification.
c) The network operates under gravity forces only.

Please note that once this operation finishes, the previous specifications at each
conduit will be replaced by the results of the automatic design.

To automatically select specifications for the whole network:

1. Enter the appropriate conduit shapes and check those that will be used in the
design.
2. From the Tools menu select Automatic Design.
3. Click on Run to start the procedure or Close to hide the tool without applying any
changes.

NOTES:

1. Although the result will be optimal, it will be dependent on the specifications
entered. Please ensure that all data in the specifications are correct.
2. This operation may take a lot of time, especially in large networks.
3. You can always undo this operation using the undo button or command.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.11 Contours

Use this tool to create contours for a specific property of point objects.

To create contours for a specific property of point objects:

1. From the Tools menu select Contours. The following form appears:
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2. Check Enabled to enable the contours. 
3. Select the Contour step (e.g. for the ground elevation of nodes, this is expressed
in units of length), the step for the major contours (which are printed thicker and
they are accompanied by their value) and the Contour segments, which controls the
smoothness of curves.
4. Select Point objects and the corresponding property.
5. Select the colors that correspond to the minimum and maximum values by clicking
on the corresponding Change button. If you want to use custom (user defined) high
and low values, check the corresponding field. In this case you need to provide the
colors for the values that are higher than the high value or lower than the low value.
6. Select the number of classes for the classification of objects. 
7. Select Ok to close the dialog box and save changes. Select Cancel to close the
dialog box and ignore changes.

NOTES:

1. The settings for the contour coloring are the same (and affect) those of object
coloring. To create contours though, you must select Point objects.
2. Each time you perform calculations, the contours are evaluated anew. This
operation may take a lot of time.
3. The contours are exported, in color, when you perform File > Export > Plan view to
DXF.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.
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10 Results

10.1 Results menu

With this menu, you can perform calculations and view the results. In the Results
menu you can select one of the following options:

Perform calculations
Results report
Tabulated report
o By object

o By variable

Graphical report
o Graph

o System

o Scatter

Colors
Total conduit lengths
Special devices count
Quality
Profiles

Options
Design

Quantities

10.2 Perform calculations

With this option, you can perform calculations.

To perform calculations:

1. Select Perform calculations from the Results menu.
2. The calculations are performed.

10.3 Results report

After the completion of calculations, a report is prepared that contains a list with
possible issues.

To show this report:

1. Select Perform calculations from the Results menu.
2. Select Results report from the Results menu. If an error report is available, it is
displayed.
3. Hit ESC to close the form.

NOTE: The error codes are described in detail in the Appendix. For each error code,
common troubleshooting options are provided.
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10.4 Tabular report

10.4.1 By object

With this option, the results of the calculations are displayed in tabular form an a per-
object basis.

To display the results of the calculations in tabular form an a per-object basis:

1. Make sure that the calculations have been completed successfully.
2. Select Tabular report from the Results menu.
3. Select By object from the Tabular report menu. The following form appears:

4. Select the Start date from the drop-down list.
5. Select the End date from the drop-down list.
6. Select whether you wish to view the result with Elapsed time or in the format
Date/Time.
7. Select the object category from the drop-down list.
8. Select the Name of the object. This step is omitted when System is selected in the
previous step.
9. Select one or more results from the list. The quick keys (Select all, Select None,
Select Invert) can be used to quickly select all objects, deselect all objects and invert
the current selection.
10. Press Ok to create the table. Press Cancel to close the form without creating the
table.
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10.4.2 By variable

With this option, the results of the calculations are displayed in tabular form an a per-
variable basis.

To display the results of the calculations in tabular form an a per-variable basis:

1. Make sure that the calculations have been completed successfully.
2. Select Tabular report from the Results menu.
3. Select By variable from the Tabular report menu. The following form appears:

4. Select the Start date from the drop-down list.
5. Select the End date from the drop-down list.
6. Select whether you wish to view the result with Elapsed time or in the format
Date/Time.
7. Select the object category from the drop-down list.
8. Select the Variable of the object.
9. Select one or more objects from the list. The quick keys (Select all, Select None,
Select Invert) can be used to quickly select all objects, deselect all objects and invert
the current selection.
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10. Press Ok to create the table. Press Cancel to close the form without creating the
table.

10.5 Graphical report

10.5.1 Graph

With this option, the results of the calculations are displayed in graphical form an a
per-variable basis.

To display the results of the calculations in graphical form an a per-variable basis:

1. Make sure that the calculations have been completed successfully.
2. Select Graphical report from the Results menu.
3. Select Graph from the Graphical report menu. The following form appears:

4. Select the Start date from the drop-down list.
5. Select the End date from the drop-down list.
6. Select whether you wish to view the result with Elapsed time or in the format
Date/Time.
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7. Select the object category from the drop-down list.
8. Select the Variable of the object.
9. Select one or more objects from the list. The quick keys (Select all, Select None,
Select Invert) can be used to quickly select all objects, deselect all objects and invert
the current selection.
10. Press Ok to create the graph. Press Cancel to close the form without creating the
graph.

In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

10.5.2 System

With this option, the results of the calculations regarding system variables are
displayed in graphical form.
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To display the results of the calculations regarding system variables in graphical form:

1. Make sure that the calculations have been completed successfully.
2. Select Graphical report from the Results menu.
3. Select System from the Graphical report menu. The following form appears:

4. Select the Start date from the drop-down list.
5. Select the End date from the drop-down list.
6. Select whether you wish to view the result with Elapsed time or in the format
Date/Time.
7. Select one or more variables from the list. The quick keys (Select all, Select None,
Select Invert) can be used to quickly select all objects, deselect all objects and invert
the current selection.
8. Press Ok to create the graph. Press Cancel to close the form without creating the
graph.

In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
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Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

10.5.3 Scatter

With this option, the results of the calculations regarding two variables are displayed
in a scatter graph form.

To display the results of the calculations in a scatter graph form:

1. Make sure that the calculations have been completed successfully.
2. Select Graphical report from the Results menu.
3. Select Scatter from the Graphical report menu. The following form appears:

4. Select the Start date from the drop-down list.
5. Select the End date from the drop-down list.
6. Select the Object category, Object name and Variable for both objects.
7. Press Ok to create the graph. Press Cancel to close the form without creating the
graph.
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In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

10.6 Colors

With this option, you can modify the settings for the coloring of objects depending on
their properties.

To modify the settings for the coloring of objects:

1. Select Colors from the Results menu. The following form appears:
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2. Check Enabled to enable the coloring of objects. 
3. Select whether you want to color the point or the linear objects.
4. Select the colors that correspond to the minimum and maximum values by clicking
on the corresponding Change button. If you want to use custom (user defined) high
and low values, check the corresponding field. In this case you need to provide the
colors for the values that are higher than the high value or lower than the low value.
5. Select the number of classes for the classification of objects. 
6. Select Ok to close the dialog box and save changes. Select Cancel to close the
dialog box and ignore changes.

NOTE: In some cases, such as when the calculations have not been completed or
when there is no variation of property values, the coloring will not be applied. In these
cases, the default coloring is used.

10.7 Total conduit lengths

With this option, you can calculate the conduit lengths per profile that is currently
used in the network. The report is based on conduit shapes.

To calculate the conduit lengths:

1. Select Total conduit lengths from the Results menu. The following form appears:
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2. The total conduit lengths are displayed in the list.
3. Select Ok or Cancel to close the dialog box.

From the File menu, the following options are available:

Print, Print to Word, Print to Excel

Select the appropriate option to create a report and sent it to the corresponding
recipient.

10.8 Special devices count

With this option, you can count the special devices, i.e. air release valves, vacuum
valves and valves, that are currently used in the network.

To count the special devices:

1. Select Special devices count from the Results menu. The following form appears:

2. The total number of special devices are displayed in the list.
3. Select Ok or Cancel to close the dialog box.

From the File menu, the following options are available:

Print, Print to Word, Print to Excel

Select the appropriate option to create a report and sent it to the corresponding
recipient.

10.9 Quality

With this option, you can display a form with results of quality calculations.

To display a form with results of quality calculations:

1. Select Quality from the Results menu. The following form appears:
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2. The results are displayed in the list.
3. Select Close to close the dialog box.

The results include:

1. The number and name of the conduit (note that only circular conduits are taken
into account).
2. The effective concentration EBOD of the active organic content.
3. The limit concentration S after a long distance in the conduit.
4. The value of the Pomeroy index.
5. The flow velocity V in the conduit.
6. The self-ventilating velocity Vmina, according to Bielecki & Schremmer.
7. The corrosion rate CR of concrete conduits, according to Bielecki & Schremmer.

From the File menu, the following options are available:

Print, Print to Word, Print to Excel

Select the appropriate option to create a report and sent it to the corresponding
recipient.

10.10 Profiles

10.10.1 Options

With this option, you can modify the settings of the profile drawings.

To modify the settings of the profile drawings:

1. Select Profiles from the Results menu.
2. Select Options from the Profiles menu. The following form will appear:
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2. In the Settings frame:

Check Do not display the inlet types if you do not want to display the inlet
types.
Check Do not display the inlet stations if you do not want to display the inlet
stations.
Check Draw all pipes flat (no thickness line) if you do not want to display the
pipe thickness in the profile drawing. This does not affect the sketch of the main
form where the pipe thickness is not drawn.

3. In the Hydraulic calculations frame, select one or more values that you wish to
be included in the profile drawing.
4. In the Custom line frame:

Check Draw custom line along the profiles if you want a custom line to be
drawing along the profiles. In this case, you can provide the title of the custom
line in the corresponding text box.

5. Check Default values for all new projects if you wish to make the settings
default for all new projects. This does not affect existing projects.
6. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

10.10.2 Design

With this option, you can create the profile drawing. The data are prepared and sent to
the Profile designer. A complete user manual on the capabilities of Profile designer
can be found in the corresponding help file.

To create a profile:

1. Select Draw profiles from the Results menu. The following form appears:
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2. Select one or more profiles to be included in the profile drawing. The quick keys (
Select all, Select None, Select Invert) can be used to quickly select all objects,
deselect all objects and invert the current selection. 
3. Select Ok to sent the data to the Profile designer. Select Cancel to cancel the
operation.

10.11 Quantities

With this option, a report on the network quantities is assembled and prepared for
preview.

In the current version of the program, this report includes:

Excavation tables based on trench profiles
Excavation/backfill volumes
Pipe quantities based on conduit shapes
Manhole quantities based on manhole specifications
Trench quantities based on trench specifications

To create a report on the network quantities:

1. Select Quantities from the Results menu.
2. The printer selection form appears:
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3. Depending on the printer selected, the relevant object appears:

NOTE: The formatted Microsoft Word file requires the use of the clipboard. During the
creation of the file, you should not use the clipboard.
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11 Help

11.1 Help menu

In the Help menu you can select one of the following options:

Contents
User guide
Tutorials
Tip of the day
Unit conversion
TechnoLogismiki website
Buy products
TechnoLogismiki NOMOS
TechnoLogismiki Live!
About the program

11.2 Contents

With this option, you can access the online help which contains detailed information
regarding the usage of the program.

To view the online help:

1. Click Contents from the Help menu.
2. The online help appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

11.3 User guide

With this option, you can access the user guide which contains detailed information
regarding the usage of the program.

To view the user guide:

1. Click User Guide from the Help menu.
2. The user guide appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

NOTE: Adobe Acrobat Reader or a similar program that can display pdf files is
required in order to view or print the user guide.

11.4 Tutorials

With this option, you can access the tutorials of the program. The tutorials are step-
by-step examples that allow you to decrease the learning cycle of the programs
dramatically.
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To access the tutorials:

1. Click Tutorials from the Help menu.
2. The tutorial selection dialog box appears.
2. Select the appropriate tutorial and click Start to proceed. Click Cancel to close the
dialog box.

NOTE: The number and content of the tutorials is changed frequently. Use the live
update system of TechnoLogismiki's products to download the latest tutorials.

11.5 Tip of the day

With this option, you can access the tip database of the program. The tips are short
guidelines regarding the usage of the programs which may be of great help to the
user.

To access the tips:

1. Click Tip of the day from the Help menu.
2. The tip of the day form appears.
3. Check Do not show this form again to prevent the program from showing the tip
of the day when starting. Press the Previous/Next buttons to browse all available
tips.
4. Press Esc to close the form.

NOTE: The number and content of the tips is changed frequently. Use the live update
system of TechnoLogismiki's products to download the latest tips.
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11.6 Unit conversion

With this option, you can access the unit conversion tool. You can find more
information about its usage in its help system. 

To launch the unit conversion tool:

1. Click Unit conversion from the Help menu.
2. The unit conversion tool is launched.

NOTE: If an error message appears then the unit conversion tool has not been
installed. You can install the unit conversion tool from the installation CD or the
Internet.

11.7 TechnoLogismiki website

With this option, you can load on your Internet browser the website of
TechnoLogismiki's.

11.8 Buy products

With this option, you can load on your Internet browser the main product page of
TechnoLogismiki's website.

11.9 TechnoLogismiki NOMOS

With this option, you can load on your Internet browser the NOMOS service of
Technologismiki.

11.10 TechnoLogismiki Live!

With this option, you can load on your Internet browser the Live! service of
Technologismiki.

11.11 About the program

With this option, a form containing the name, version and licence information of the
program appears.

To show this form:
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1. From the Help menu, select About the program.
2. The form appears.
3. Click anywhere on the form or hit ESC to close the form.
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12 Appendix

12.1 Unit system

Unit Metric system English system

Area
hectares

m2
acres

ft2

Length
m

mm
ft
in

Rainfall intensity mm/h in/h

Flow rate
m3/s
L/s

ML/day

ft3/s
g/m

Mg/day

Pollutant concentration mass/hectare mass/acre

Volume m3 ft3

12.2 Fluid database

For your convenience, a fully customizable fluid database is embedded in the program.
The fluid database is invoked in various cases within the program. By selecting an
appropriate fluid record and clicking Ok, the data is transferred to the corresponding
fields. Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the name of the fluid. This field is required.
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3. Enter the temperature, density, viscosity and kinematic viscosity of the fluid.
4. The specific weight is calculated automatically.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.3 Friction database

For your convenience, a fully customizable friction database is embedded in the
program. The friction database is invoked in various cases within the program. By
selecting an appropriate friction record (which is depended on the selected friction
formula) and clicking Ok, the data is transferred to the corresponding fields. Select
Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.



Sewer Networks250

© 2012 TechnoLogismik i

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the friction.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

NOTE: In case of Manning friction coefficients in natural streams, you can estimate
the values based on several characteristics of the stream. Click on the buttons with
the ellipses (...) next to the text boxes to invoke the following dialog box: 

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.
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To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.4 Manning friction coefficients

Surface / Material
Mean
Value

Aluminum 0.024

Asbestos cement 0.013

Asphalt ditch 0.016

Asphalt pavement 0.016

Asphalt smooth 0.013

Asphalted cast iron 0.012

Natural ground 0.020

Best concrete 0.010

Brick in mortar 0.015

Brick sewer 0.015

Cast iron 0.012

CMP 0.024

Concrete 0.013

PVC 0.010

Centrifugal SPUN 0.013

Concrete (steel forms) 0.011

Concrete (wood forms) 0.015

Concrete gutter (broom finish) 0.016

Concrete gutter (troweled finish) 0.012

Copper 0.011
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Fiber glass roving 0.011

Gravel riprap (D=25) 0.033

Gravel riprap (D=50) 0.041

Grouted riprap 0.030

Natural stream (clean) 0.030

Natural stream (stone) 0.050

Natural stream (weedy) 0.035

12.5 Bazin friction coefficients

Surface / Material
Max

value
Min

value
Mean
value

Rough concrete 0.5 0.4 0.46

Smooth concrete 0.08 0.04 0.06

Brick in mortar 0.018 0.014 0.016

Sewer pipes (Greek regulations
696/74)

0.25 0.25 0.25

Storm pipes (Greek regulations
696/74)

0.46 0.46 0.46

12.6 Hazen - Williams friction coefficients

Surface / Material
Mean
value

Asbestos cement 140

Asphalted cast iron 130

Best concrete 150

Centrifugal SPUN 135

Concrete (wood forms) 120

Concrete (steel forms) 140

Copper 135

Ductile iron 130

Galvanized iron 120

Glass 140

PVC 150

Riveted steel (new, rough) 80

Riveted steel (new, smooth) 110

Steel 120

Wood (new) 140
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12.7 Darcy - Weisbach friction coefficients

Surface / Material
Mean
value
(mm)

Aluminum 0.300

Asbestos cement 0.002

Asphalted cast iron 0.120

Best concrete 0.366

Brick in mortar 0.610

Sewer brick 0.610

CMP 0.305

Concrete 0.122

Centrifugal SPUN 0.366

Concrete (steel forms) 1.829

Concrete (wood forms) 0.610

Copper 0.002

Galvanized steel 1.520

Glass 0.001

PVC 0.122

HDPE 0.150

12.8 IDF database

For your convenience, a fully customizable IDF (Intensity - Duration - Frequency)
database is embedded in the program. The IDF database is invoked in various cases
within the program. By selecting an appropriate record and clicking Ok, the data is
transferred to the corresponding fields. Select Cancel to close the database without
transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database. Note that the database was built using data from various resources in the
literature; you need to be cautious when using a curve.

To add a new record:
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1. Click Add to open the new record dialog box.
2. Enter the area and optionally the description of the record.
3. Enter the return period in years. This value was used for the calculation of the IDF
curve and is for reference purposes only; it is not used in the calculations.
4. Enter the dimensionless coefficients c, b, n, in such a way that when time is
entered in hours, the intensity is given in mm/hr.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked for confirmation only if you
have selected to confirm deletions in the General preferences tab. 
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.9 Runoff coefficient database

For your convenience, a fully customizable runoff coefficient database is embedded in
the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories. Usually, the category defines the
regulations (e.g. FHWA, 2001).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the runoff coefficient.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

NOTE: You can calculate the mean runoff coefficient for complex areas with known
runoff coefficients. Click on the buttons with the ellipses (...) next to the text boxes to
invoke the following dialog box:

Click the plus sign (+) to add a new area. Type the runoff coefficient and the area in
m2. The total area and the mean runoff coefficient is displayed in the Results frame.
Click the minus sign (-) to delete the selected area. The area is deleted with no
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confirmation.

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.10 BOD5 production

For your convenience, a fully customizable BOD5 production database is embedded in
the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories.

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the BOD5 production.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:
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1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.11 Initial sulfur concentration

For your convenience, a fully customizable initial sulfur concentration database is
embedded in the program. The database is invoked in various cases within the
program. By selecting an appropriate record and clicking Ok, the data is transferred to
the corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories.

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the initial sulfur concentration
production.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
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3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.12 Water consumption

For your convenience, a fully customizable water consumption database is embedded
in the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories.

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.
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To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the water consumption.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.13 Initial time

For your convenience, a fully customizable initial time database is embedded in the
program. The database is invoked in various cases within the program. By selecting an
appropriate record and clicking Ok, the data is transferred to the corresponding fields.
Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories. Usually, the category defines the
regulations e.g. Greek regulations 696/74.

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the initial time in min.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
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2. Click Remove to remove the record. You will be asked for confirmation only if you
have selected to confirm deletions in the General preferences tab.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.14 SCS curve number database

For your convenience, a fully customizable SCS curve number database is embedded
in the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the description and optionally the details.
3. Enter the condition, imperviousness, soil type (A, B, C or D) and curve number (0-
100).

Soil type A: Soils having high infiltration rates, even when thoroughly wetted
and consisting chiefly of deep, well to excessively-drained sands or gravels. These
soils have a high rate of water transmission.
Soil type B: Soils having moderate infiltration rates when thoroughly wetted and
consisting chiefly of moderately deep to deep, moderately fine to moderately
coarse textures. These soils have a moderate rate of water transmission.
Soil type C: Soils having slow infiltration rates when thoroughly wetted and
consisting chiefly of soils with a layer that impedes downward movement of
water, or soils with moderately fine to fine texture. These soils have a slow rate of
water transmission.
Soil type D: Soils having very slow infiltration rates when thoroughly wetted and
consisting chiefly of clay soils with a high swelling potential, soils with a
permanent high water table, soils with a clay pan or clay layer at or near the
surface, and shallow soils over nearly impervious material. These soils have a very
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slow rate of water transmission.

4. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked for confirmation only if you
have selected to confirm deletions in the General preferences tab.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

12.15 Soil characteristics

Soil texture class
Κ (in/

h)

Κ
(mm/

h)

Ψ
(in)

Ψ
(mm)

φ FC WP

Sand 4.74 120.4 1.93 49.0
0.43

7
0.06

2
0.02

4

Loamy sand 1.18 30.0 2.40 61.0
0.43

7
0.10

5
0.04

7

Sandy loam 0.43 10.9 4.33 110.0
0.45

3
0.19

0
0.08

5

Loam 0.13 3.3 3.50 88.9
0.46

3
0.23

2
0.11

6

Silt loam 0.26 6.6 6.69 169.9 0.50
1

0.28
4

0.13
5
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Sandy clay loam 0.06 1.5 8.66 220.0 0.39
8

0.24
4

0.13
6

Clay loam 0.04 1.0 8.27 210.1 0.46
4

0.31
0

0.18
7

Silty clay loam 0.04 1.0 10.63 270.0 0.47
1

0.34
2

0.21
0

Sandy clay 0.02 0.5 9.45 240.0 0.43
0

0.32
1

0.22
1

Silty clay 0.02 0.5 11.42 290.1 0.47
9

0.37
1

0.25
1

Clay 0.01 0.3 12.60 320.0 0.47
5

0.37
8

0.26
5

Κ saturated hydraulic conductivity
Ψ suction head
φ porosity, fraction
FC field capacity, fraction
WP wilting point, fraction

Source: Rawls, W.J. et al (1983), Journal of Hydraulic Engineering, 109:1316.

12.16 Water Quality Characteristics of Urban Runoff

Constituent
Event Mean

Concentrations

TSS (mg/L) 180 - 548

BOD (mg/L) 12 - 19

COD (mg/L) 82 - 178

Total P (mg/L) 0.42 - 0.88

Soluble P (mg/L) 0.15 - 0.28

ΤΚΝ (mg/L) 1.90 - 4.18

NO2/NO3-N (mg/L) 0.86 - 2.2

Total Cu 43 - 118

Total Pb 182 - 443

Total Zn 202 -  633

Source: U.S. Environmental Protection Agency (1983), "Results of the Nationwide
Urban Runoff Program (NURP)", Volume I, NTIS PB 94-185552, Water Planning
Division, Washington DC, USA.

12.17 Depression storage

Surface Depression (in)
Depression

(mm)

Impervious surfaces 0.05 - 0.10 1.3 - 2.6

Lawns 0.10 - 0.20 2.6 - 5.1
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Pasture 0.20 5.1

Forest litter 0.30 7.6

Source: ASCE (1992), "Design & Construction of Urban Stormwater Management
Systems", New York, NY, USA.

12.18 Error messages

12.18.1 Error codes

The error codes that are displayed in the results report consist of a three-digit number
and a brief description. In the following, a more detailed description as well as
common  troubleshooting options are provided.

Codes 100-199
Codes 200-299
Codes 300-399
Codes 400-499

12.18.2 Codes 1XX

[101] memory allocation error.
There is not enough physical memory in the computer to analyze the study area.

[103] cannot solve KW equations for Link xxx.
The internal solver for Kinematic Wave routing failed to converge for the
specified link at some stage of the simulation. Try to change the time step or use
another solver.

[105] cannot open ODE solver.
The system could not open its Ordinary Differential Equation solver.

[107] cannot compute a valid time step.
A valid time step for runoff or flow routing calculations (i.e., a number greater
than 0) could not be computed at some stage of the simulation. Try to change
the time step or use another solver.

[108] ambiguous outlet ID name for Subcatchment xxx.
The name of the element identified as the outlet of a subcatchment belongs to
both a node and a subcatchment in the project's data base. This problem may
occur only in case you import a SWMM project, as internal procedures in the
program cover this case without user intervention.

[109] invalid parameter values for Aquifer xxx.
The properties entered for an aquifer object were either invalid numbers or were
inconsistent with one another (e.g., the soil field capacity was higher than the
porosity).

[111] invalid length for Conduit xxx.
Conduits cannot have zero or negative lengths.
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[112] Elevation drop exceeds length for Conduit xxx.
In order to maintain the numerical stability of the network, the difference in
elevation between the upstream and downstream nodes cannot exceed the
conduit's length. This corresponds to a slope of 45% (1:1). To correct this
problem you can either use a drop well, reduce the elevation difference or
increase the conduit's length.

[113] invalid roughness for Conduit xxx.
Conduits cannot have zero or negative roughness values. Correct the roughness
coefficient in conduit shape specifications corresponding to the solver invoked.

[114] invalid number of barrels for Conduit xxx.
The number of barrels in conduit shape specifications is zero or negative. Correct
the number of barrels to at least 1.

[115] adverse slope for Conduit xxx.
Under Steady or Kinematic Wave routing, all conduits must have positive slopes.
This can usually be corrected by reversing the inlet and outlet nodes of the
conduit. Adverse slopes are permitted under Dynamic Wave routing.

[116] wrong elevations for Link xxx.
The elevations entered in the properties of the specific link are incorrect. This
may occur when the inlet or outlet elevation is higher than the ground elevation.

[117] no cross section defined for Link xxx
Cross section geometry was never defined for the specified link. Select an
appropriate conduit shape for the specific link.

[119] invalid cross section for Link xxx
Either an invalid shape or invalid set of dimensions was specified for a link's
cross section in  conduit shape specifications.

[121] missing or invalid pump curve assigned to Pump xxx.
Either no pump curve or an invalid type of curve was specified for a pump.

[131] the following links form cyclic loops in the drainage system.
The Steady and Kinematic Wave flow routing methods cannot be applied to
systems where a cyclic loop exists (i.e., a directed path along a set of links that
begins and ends at the same node). Most often the cyclic nature of the loop can
be eliminated by reversing the direction of one of its links (i.e., switching the
inlet and outlet nodes of the link). The names of the links that form the loop will
be listed following this message.

[133] Node xxx has more than one outlet link.
Under Steady and Kinematic Wave flow routing, a junction node can have only a
single outlet link.

[134] Node xxx has more than one DUMMY outlet link.
Only a single conduit with a DUMMY cross section can be directed out of a node.

[135] Divider xxx does not have two outlet links.
Flow divider nodes must have two outlet links connected to them.
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[136] Divider xxx has invalid diversion link.
The link specified as being the one carrying the diverted flow from a flow divider
node was defined with a different inlet node. This problem may occur only in
case you import a SWMM project, as internal procedures in the program cover
this case without user intervention.

[137] Weir Divider xxx has invalid parameters.
The parameters of a weir-type divider node either are non-positive numbers or
are inconsistent (i.e., the value of the discharge coefficient times the weir height
raised to the 3/2 power must be greater than the minimum flow parameter).

[138] Node xxx has initial depth greater than maximum depth.
Self-explanatory.

[139] Regulator xxx is the outlet of a non-storage node.
Under Steady and Kinematic Wave flow routing, orifices, weirs, and outlets links
can only be used as outflow links from storage nodes.

[141] Outfall xxx has more than 1 inlet link or an outlet link.
An outfall node is only permitted to have one link attached to it.

[143] Regulator xxx has invalid cross-section shape.
An orifice must have either a Circular or Closed Rectangle shape, while a weir
must have either an Open Rectangle, Trapezoidal, or Triangular shape.

[145] Drainage system has no acceptable outlet nodes.
Under Dynamic Wave flow routing, there must be at least one node designated
as an outfall.

[151] a Unit Hydrograph in set xxx has invalid time base.
The time base of a unit hydrograph must be greater than 0.

[153] a Unit Hydrograph in set xxx has invalid response ratios.
The response ratios for a set of unit hydrographs (the short-, medium-, and
long-term response hydrographs) must be between 0 and 1.0 and cannot add up
to a value greater than 1.0. 

[155] invalid sewer area for RDII at Node xxx.
The sewer area contributing RDII inflow to a node cannot be a negative number.

[157] Inconsistent rainfall format for Rain Gage xxx.
When two or more rain gages reference the same time series data, this fatal
error message is generated if the Rainfall Formats (intensity, volume, or
cumulative volume) for the gages are not all the same.

[161] cyclic dependency in treatment functions at Node xxx.
An example would be where the removal of pollutant 1 is defined as a function of
the removal of pollutant 2 while the removal of pollutant 2 is defined as a
function of the removal of pollutant 1.

[171] Curve xxx has its data out of sequence.
The X-values of a curve object must be entered in increasing order.
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[173] Time Series xxx has its data out of sequence.
The time (or date/time) values of a time series must be entered in sequential
order.

[181] Invalid snow melt climatology parameters.
The ATI Weight or Negative Melt Ratio parameters are not between 0 and 1 or
the site latitude is not between -60 and +60 degrees. 

[182] Invalid parameters for Snow pack xxx.
A snow pack's minimum melt coefficient is greater than its maximum coefficient;
the fractions of free water capacity or impervious plowable area are not between
0 and 1; or the snow removal fractions sum to more than 1.0. 

[191] simulation start date comes after ending date.
Self-explanatory.

[193] report start date comes after ending date.
Self-explanatory.

[195] reporting time step is less than routing time step.
Self-explanatory. Change the report time step or the routing time step.

12.18.3 Codes 2ΧΧ

[200] one or more errors in input file.
This message appears when one or more input file parsing errors (the 200-series
errors) occur.

[201] too many characters in input line.
A line in the input file cannot exceed 1024 characters.

[203] too few items at line n of input file.
Not enough data items were supplied on a line of the input file. This problem
may occur only in case you import a SWMM project, as internal procedures in the
program cover this case without user intervention.

[205] invalid keyword at line n of input file.
An unrecognized keyword was encountered when parsing a line of the input file.
This problem may occur only in case you import a SWMM project, as internal
procedures in the program cover this case without user intervention.

[207] duplicate ID name at line n of input file.
An ID name used for an object was already assigned to an object of the same
category. This problem may occur only in case you import a SWMM project, as
internal procedures in the program cover this case without user intervention.

[209] undefined object xxx at line n of input file.
A reference was made to an object that was never defined. An example would be
if node 123 were designated as the outlet point of a subcatchment, yet no such
node was ever defined in the study area.

[211] invalid number xxx at line n of input file. 
Either a non-numeric character was encountered where a numerical value was
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expected or an invalid number (e.g., a negative value) was supplied. This
problem may occur only in case you import a SWMM project, as internal
procedures in the program cover this case without user intervention.

[213] invalid date/time xxx at line n of input file.
An invalid format for a date or time was encountered. Dates must be entered as
month/day/year and times as either decimal hours or as hour:minute:second.
This problem may occur only in case you import a SWMM project, as internal
procedures in the program cover this case without user intervention.

[217] control rule clause out of sequence at line n of input file.
Errors of this nature can occur when the format for writing control rules is not
followed correctly.

[219] data provided for unidentified transect at line n of input file.
This problem may occur only in case you import a SWMM project, as internal
procedures in the program cover this case without user intervention.

[221] transect station out of sequence at line n of input file.
The station distances specified for the transect of an irregular cross section must
be in increasing numerical order starting from the left bank.

[223] Transect xxx has too few stations.
A transect for an irregular cross section must have at least 2 stations defined for
it.

[225] Transect xxx has too many stations.
A transect cannot have more than 1500 stations defined for it. This problem may
occur only in case you import a SWMM project, as internal procedures in the
program cover this case without user intervention.

[227] Transect xxx has no Manning's N.
No Manning’s N was specified for a transect. Correct the transect specified.

[229] Transect xxx has invalid overbank locations.
The distance values specified for either the left or right overbank locations of a 
transect do not match any of the distances listed for the transect's stations.

[231] Transect xxx has no depth.
All of the stations for a transect were assigned the same elevation. Correct the
transect specified.

[233] invalid treatment function expression at line n of input file.
A treatment function supplied for a pollutant at a specific node is either not a
correctly formed mathematical expression or refers to unknown pollutants,
process variables, or math functions.

12.18.4 Codes 3ΧΧ

[301] files share same names.
The input, report, and binary output files specified on the command line cannot
have the same names.

[303] cannot open input file.
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The input file either does not exist or cannot be opened (e.g., it might be in use
by another program).

[305] cannot open report file.
The report file cannot be opened (e.g., it might reside in a directory to which the
user does not have write privileges).

[307] cannot open binary results file.
The binary output file cannot be opened (e.g., it might reside in a directory to
which the user does not have write privileges). 

[309] error writing to binary results file.
There was an error in trying to write results to the binary output file (e.g., the
disk might be full or the file size exceeds the limit imposed by the operating
system).

[311] error reading from binary results file.
There was an error in reading results saved to the binary output file when writing
results to the report file.

[313] cannot open scratch rainfall interface file.
SWMM could not open the temporary file it uses to collate data together from
external rainfall files. Make sure that the temporary folder exists and is
accessible.

[315] cannot open rainfall interface file xxx.
The program could not open the specified interface file file, possibly because it
does not exist or because the user does not have write privileges to its directory.

[317] cannot open rainfall data file xxx.
An external rainfall data file could not be opened, most likely because it does not
exist.

[319] invalid format for rainfall interface file.
The program was trying to read data from a designated rainfall interface file with
the wrong format (i.e., it may have been created for some other project or
actually be some other type of file).

[321] no data in rainfall interface file for gage xxx.
This message occurs when a project wants to use a previously saved rainfall
interface file, but cannot find any data for one of its rain gages in the interface
file.

[323] cannot open runoff interface file xxx.
A runoff interface file could not be opened, possibly because it does not exist or
because the user does not have write privileges to its directory.

[325] incompatible data found in runoff interface file.
The program was trying to read data from a designated runoff interface file with
the wrong format (i.e., it may have been created for some other project or
actually be some other type of file).

[327] attempting to read beyond end of runoff interface file.
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This error can occur when a previously saved runoff interface file is being used in
a simulation with a longer duration than the one that created the interface file.

[329] error in reading from runoff interface file.
A format error was encountered while trying to read data from a previously saved
runoff interface file.

[330] different hotstart interface files share the same name.
You have selected a common name for more than one hotstart interface file.

[331] cannot open hotstart interface file xxx.
A hotstart interface file could not be opened, possibly because it does not exist
or because the user does not have write privileges to its directory.

[333] incompatible data found in hotstart interface file.
The program was trying to read data from a designated hotstart interface file
with the wrong format (i.e., it may have been created for some other project or
actually be some other type of file).

[335] error in reading from hotstart interface file.
A format error was encountered while trying to read data from a previously saved
hotstart interface file.

[336] no climate file specified for evaporation and/or wind speed.
This error occurs when the user specifies that evaporation or wind speed data will
be read from an external climate file, but no name is supplied for the file.

[337] cannot open climate file xxx.
An external climate data file could not be opened, most likely because it does not
exist.

[338] error in reading from climate file xxx.
The program was trying to read data from an external climate data file with the
wrong format.

[339] attempt to read beyond end of climate file xxx.
The specified external climate does not include data for the period of time being
simulated.

[341] cannot open scratch RDII interface file.
The program could not open the temporary file it uses to store RDII flow data.
Make sure that the temporary folder exists and is accessible.

[343] cannot open RDII interface file xxx.
An RDII interface file  could not be opened, possibly because it does not exist or
because the user does not have write privileges to its directory.

[345] invalid format for RDII interface file.
The program was trying to read data from a designated RDII interface file with
the wrong format (i.e., it may have been created for some other project or
actually be some other type of file).

[351] cannot open routing interface file xxx.
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A routing interface file could not be opened, possibly because it does not exist or
because the user does not have write privileges to its directory.

[353] invalid format for routing interface file xxx.
The program was trying to read data from a designated routing interface file with
the wrong format (i.e., it may have been created for some other project or
actually be some other type of file).

[355] mismatched names in routing interface file xxx.
The names of pollutants found in a designated routing interface file do not match
the names used in the current project.

[357] inflows and outflows interface files have same name.
In cases where a run uses one routing interface file to provide inflows for a set of
locations and another to save outflow results, the two files cannot both have the
same name.

[361] Could not open external file used for Time Series xxx.
The program could not open the specified external file, possibly because it does
not exist or because the user does not have write privileges to its directory.

[363] Invalid data in external file used for Time Series xxx.
The external time series file has been located but it contains invalid data or data
out of order. Please correct the data contained in the external file.

12.18.5 Codes 4ΧΧ

[401] Generic solver error.
If the error persists after you have rebooted your computer, contact technical
support for further assistance.

[402] Impossible to load project as it is already loaded.
Reboot your computer to correct this problem.

[403] The project cannot be loaded or the last run was not completed.
Reboot your computer to correct this problem.

[405] The number or results exceeds the maximum value.
The number or results is excessive. Select an earlier end date or increase the
time step of the report.
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unlimited     124

unsaturated     17, 90

update     47

upper     17, 90

upstream     206, 208

urban     16, 270

usage     243

use     101, 164
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