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1 About the program

1.1 What does the program do?

This programs calculates the following:

maximum flood flow in water basins caused by rainfall.
maximum flood flow after flood routing in rivers.
maximum flood flow after flood routing in reservoirs.

For the calculation of the flood flows in water basins, the Rational method or other
empirical formulas may be used. If the Rational method is used, one of the following
formulas may be utilized to calculate the concentration time:

Giandotti
Kirpich / Kirpich (PA)
Federal Aviation Administration
Kerby / Hathaway
Carter
Eagleson
Espey / Winslow
SCS Lag
Length and velocity
TR-55U / TR-55P
Direct value
California culverts practice
Izzard
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Kinematic wave

The concentration time is used in the IDF curve to calculate the rainfall intensity. In
the case of empirical formulas, one of the following seven options may be used:

Fuller
Forti
Fanning
Iskovski 
Kuichling

The use of the above formulas is restricted by certain conditions. The program notifies
the user in case one or more formulas are out of scope and should not be used.

The following synthetic hydrographs can be used:

Snyder Synthetic Hydrograph
SCS Unit hydrograph

For the flood routing in a river the following methods may be used:

Muskingum
Muskingum-Cunge
SCS Convex 
Kinematic Wave

For the flood routing in reservoirs the Storage Indicator method is used.

1.2 Minimum requirements

The minimum requirements for the usage of the programs are the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium III 800 MHz
800x600 with 256 color palette
700 MB free disk space
CD-Rom

If your system does not meet one or more of the above requirements, it is highly
recommended that you upgrade it before installing the programs. The recommended
system configuration is the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium IV 2.0 GHz
1280x768 with 16-bit color palette
1.2 GB free disk space
CD-Rom
Internet connection
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1.3 Technical support

Support through the Internet

TechnoLogismiki offers technical support 24 hours per day, 365 days per year, through
the web site where you can get information on the latest programs and services.

Support by e-mail

Please use the dedicated e-mail addresses for better customer service:

for questions regarding sales: sales@technologismiki.com
for questions regarding the usage of programs: support@technologismiki.com
for any other question or comment: info@technologismiki.com

The normal response time is within two business days. If your inquiry cannot be
answered by e-mail, a customer service representative will contact you by telephone.

Interactive Support

Business days, 09:00 - 17:00 Eastern European Time:

Telephone [3 lines]: ++30-210-656-4147
Fax: ++30-210-654-8461
Address: 5, Imittou street, Cholargos, 15561, Athens, Greece.
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2 Theoretical background

2.1 Introduction

In this chapter, a summary description of the necessary theoretical background is
presented.

Flood flows calculation

The calculation of the maximum flood flow can be achieved using the rational method
or a variety of empirical formulas.

Rational method

The time of concentration can be estimated using one of the following methods:

Length and velocity method
Carter formula
Eagleson formula
Espey / Winslow formula
Federal Aviation Agency (FAA) formula
Giandotti formula
Kerby / Hathaway formula
Kirpich and Kirpich (PA) formula
TR55 (P or U) method
SCS Lag method
California Culverts Practice method
Izzard formula
Kinematic wave method

Empirical formulas

Forti empirical formula
Fanning empirical formula
Fuller empirical formula
Kuichling empirical formula
Iskovski empirical formula

Synthetic unit hydrograph

SCS Dimensionless Hydrograph
Snyder synthetic hydrograph

Flood routing in river

Muskingum method
Muskingum - Cunge method
SCS Convex method
Kinematic wave method

Flood routing in reservoir
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Storage Indicator method

2.2 Flood flows

2.2.1 Rational method

2.2.1.1 Rational method

According to the rational method, the maximum flood flow is  proportional  to the area
of the basin, the runoff coefficient and the intensity of the critical storm:

where:
Q, maximum flood flow (m3/s)
c, dimensionless runoff coefficient (-)
f, a rainfall correction factor that accounts for spatial non-uniformity (-)
I, rainfall intensity of critical storm (mm/h)

A, the total area of the basin (km2)

Two  important  assumptions  behind  the  rational  method  are  a)  the  duration  of  the
critical storm is equal to the basin's time of concentration and b) the return period  of
the calculated flood flow is equal to the critical storm's return period.

The runoff coefficient is defined as the amount of precipitation that flows to the basin's
outlet  to  the  total  precipitation  over  the  basin,  during  a  specified  time  period.  This
time period is usually one year.

where:
c, dimensionless runoff coefficient (-)
P, the total precipitation (mm)
h, the equivalent areal water depth (mm)

The  runoff  coefficient  depends  on  a  variety  of  parameters  such  as  the  vegetation,
geology,  land  uses,  etc.  Characteristic  values  of  this  coefficient  can  be  taken  from
tables. However, it is common that a single basin consists of several different surfaces,
each  of  them  with  a  different  runoff  coefficient.  In  these  cases,  a  weighted  runoff
coefficient is computed using all the areas of the basin:

where:
CM, the weighted dimensionless runoff coefficient of n areas

c i, the runoff coefficient of the ith area

A
i
, the ith area (common units for denominator and nominator)

The most  common  runoff  coefficient  values  are  included  in  the  program's  database.
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For more information regarding the embedded database, please refer to the appendix.

The rainfall  intensity of  the  critical  storm  is  usually  derived  from  intensity-duration-
frequency  (IDF)  curves.  The  IDF  curves  are  given  by  mathematic  equations  of  the
following form:

where:
i, the rainfall intensity (mm/h)
t, time of concentration (h)
T, return period (years)
b, n, K, IDF coefficients (with dimensions)

The  time  of  concentration  is  necessary  to  calculate  the  rainfall  intensity  using  IDF
curves. For urban areas without  large basins,  the  Greek  regulations  suggest  a  value
equal to 10 min. According to the US regulations, this time can be smaller or greater
depending on the existence of water collection inlets  and the percentage of coverage
by constructions and infrastructure such as roads, cement areas, etc.

2.2.1.2 Time of concentration

2.2.1.2.1  Length and velocity

If the speed at which the surface water moves is known, the time of concentration is
calculated by the ratio of the length the water travels to its velocity:

Where:

tc, time of concentration (h)

L, length of the main basin river (km)
V, velocity of water (m/s)

2.2.1.2.2  Carter

This equation was introduced by Carter in order to be used in Washington DC sewers,
to calculate the time of concentration is serviced surfaces with a total area of less than
18 km2 and average slopes around 2%. 

Where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
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2.2.1.2.3  Eagleson

It is applied in the special case where the surface flow occurs in natural channels with
constant geometry (constant cross section). This method is based on kinematic wave's
theory. The time of concentration depends on the hydraulic  radius of  the stream and
on the average Manning coefficient among others.

where:

t
c
, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
n, Manning's friction coefficient
R, hydraulic radius of the main river (m)

2.2.1.2.4  Espey / Winslow

This method calculates the time of concentration based on Espey's stream coefficient,
which is a function of Manning's friction factor and the percentage of impervious soil.
Apart from these factors, the length of the water's path and the average ground slope
are also taken into consideration:

where:

t
c
, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
IMP, percent of impervious soil (%)
F, the dimensionless Espey stream coefficient

2.2.1.2.5  Federal Aviation Agency

For small water basins without  formed hydrographic  network (the water flows on the
surface forming a wet  front  rather than in  streams and rivers), the following  formula
can be used:

where:

t
c
, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
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c, runoff coefficient

2.2.1.2.6  Giandotti

This formula has been derived from experiments conducted  in  large basins with total
area equal or greater than 170 km2.

where:

tc, time of concentration (h)

L, length of the main basin river (km)

A, the total area of the basin (km2)
H

M
, the mean elevation of the basin (m)

H
E
, the elevation at the basin's outlet (m)

2.2.1.2.7  Kerby / Hathaway

If Manning's friction coefficient is known for a specific water basin, then the following
equation introduced Kerby and Hathaway can be used:

where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
n, Manning's friction coefficient

2.2.1.2.8  Kirpich

This  method  comes  in  two  variations.  The  first  is  very  common  in  Greece.  The  two
variations  yield  different  results,  since  the  PA  variation  is  valid  only  for  basins  with
very small average slopes:

PA: 

where:
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tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)

2.2.1.2.9  TR55 P/U

From the US TR 55 method, two variations are given in order to calculate the time of
concentration: method Ρ can be used in paved surfaces while method U can be used in
undeveloped  surfaces.  For  paved  surfaces  the  following  equation  yields  the  time  of
concentration:

while for unpaved surfaces the following equation is used:

where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)

2.2.1.2.10  SCS Lag

This method was developed by U.S. Soil Conservation Service. The time of
concentration based on the SCS curve number (CN - Curve Number), the length of the
main river and the average basin slope:

where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
CN, the SCS curve number

The curve number (CN) depends on the soil's type, its status and its  imperviousness.
It is usually taken from tables integrated in the program.

2.2.1.2.11  California Culverts Practice

This formula was proposed by U.S. California Culverts Practice, and is similar to 
Kirpich's equation. The only difference is that the average slope J has been substituted
by the L/DH ratio. This equation was developed in 1942 for small basins for the state
of California:
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where:

tc, time of concentration (h)

L, length of the main basin river (km)
DH=Η

up
-H

E
 (m)

H
UP

, the elevation of the most upstream point of the main river (m)

H
E
, the elevation of the basin's outlet (m)

2.2.1.2.12  Izzard

Izzard equation was developed in 1946 based on laboratory experiments from the
American Bureau of Public Roads. It concerns areas covered with roads or vegetation
without a developed hydrographic network. The equation is valid only for laminar flow
where iL<3.87.

where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
i, rainfall intensity (mm/h)
cr, Izzard's deceleration coefficient (-)

This  equation is  solved  by trial-and-error, since the time of concentration appears  in
both  sides  of  the  equation.  Common  values  of  Izzard's  deceleration  coefficient  are
available through the program's database.

2.2.1.2.13  Kinematic Wave

Kinematic wave's equation was proposed by several researches during 1965-1975. It
was developed after processing experimental data using equations derived from
kinematic wave's theory for surface flow over developed areas.

where:

tc, time of concentration (h)

L, length of the main basin river (km)
J, the average basin slope (m/m)
c, runoff coefficient
i, rainfall intensity (mm/h)
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n, Manning's friction coefficient

The  aforementioned  equation  is  solved  by  trial-and-error,  since  the  time  of
concentration appears in both sides of the equation.

2.2.1.3 Correction coefficient

2.2.1.3.1  Fornari

The reduction factor for the conversion of point rainfall to areal depends, according to
Fornari, on the total area of the basin and the duration of the critical storm. It is given
by the following equation:

where:

f, the reduction coefficient (-)

A, the total area of the basin (km2)
tc, time of concentration (h)

2.2.1.3.2  TP29

Leclerc and Scahhe (1972) quantified the TP-29 results using the following best-fit
equation in order to estimate the value of the reduction coefficient:

where:

f, the reduction coefficient (-)

A, the total area of the basin (km2)
tc, time of concentration (h)

2.2.2 Empirical formulas

2.2.2.1 Forti

The maximum flood flow depends only on the basin's area according to Forti's
empirical formula:

Where:

Q, the maximum flood flow (m³/s)

A, the total area of the basin (km2)
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2.2.2.2 Fanning

Fanning's empirical method can be applied only to basins with total area greater than
50 km2. According to this method, the flood flow depends only on the total basin area:

Where:

Q, the maximum flood flow (m³/s)

A, the total area of the basin (km2)

2.2.2.3 Fuller

Fuller's empirical method calculates the maximum flood flow in a basin as a function
of its total area and the return period of the critical storm:

Where:

Q, the maximum flood flow (m3/s)

A, the total area of the basin (km2)
Τ, the return period of the critical storm (years)

2.2.2.4 Kuichling

Kuichling's empirical formula is valid only in small and average basins with a total area
up to 250 km2. According to this method, the maximum flood flow depends only on
the total basin area:

Where:

Q, the maximum flood flow (m3/s)

A, the total area of the basin (km2)

2.2.2.5 Iskovski

Iskovski's method is regarded as more complex and accurate compared to the other
empirical methods. According to Iskovski, the maximum flood flow is calculated using
the following equation:
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Where:

Q, the maximum flood flow (m³/s)

A, the total area of the basin (km2)
Η

ΑΝ
, the annual rainfall height in the basin (m)

TPG, topography coefficient (-)
ST, Iskovski's coefficient

The topography coefficient TPG is a function of the basin's topography and the ground
type. Values of this coefficient can be found in the embedded database.

Iskovski's coefficient is given from graphs as a function of the basin's area.

2.2.3 Synthetic unit hydrograph

2.2.3.1 SCS Dimensionless Hydrograph

The SCS dimensionless hydrograph is a synthetic unit hydrograph in which the
discharge is expressed by the ratio of discharge q to peak discharge qp and the time

by the ratio of time t to the time of rise of the unit hydrograph, Tp. Given the peak
discharge and lag time for the duration of excess rainfall, the unit hydrograph can be
estimated from the synthetic dimensionless hydrograph for the given basin. The
values of qp and Tp may be estimated using a simplified model of a triangular unit

hydrograph.

From a review of a large number of unit hydrographs, the Soil Conservation Service
suggests the time of recession may be approximated as 1.67Tp. As the area under the
unit hydrograph should be equal to a direct runoff of 1 cm, it can be shown that:

where A is the drainage area in km2.

Further, a study of unit hydrographs of many large and small rural watersheds
indicates that the basin lag tp~0.6Tc, where Tc is the time of concentration of the
watershed. Time of rise Tp can be expressed in terms of lag time tp and the duration
of effective rainfall tr:
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2.2.3.2 Snyder synthetic hydrograph

Snyder defined a standard unit hydrograph as one whose rainfall duration tr is related

to the basin lag tp by:

For a standard unit hydrograph he found that:

1. The basin lag is:

where tp is in hours, L is the length of the main stream in km from the outlet to the
upstream divide, L

C
 is the distance in km from the outlet to a point on the stream

nearest the centroid of the watershed area and C
t
 is a coefficient derived from gaged

watersheds in the same region.

2. The peak discharge per unit drainage area in m3/s x km2 of the standard unit
hydrograph is:

Where CP is a coefficient derived from gaged watersheds in the same region.

To compute Ct and CP for a gaged watershed, the values of L and LC are measured

from the basin map. From a derived unit hydrograph of the watershed are obtained
values of its effective duration tR in hours, its basin lag tPR in hours, and its peak

discharge per unit drainage area, qPR, in m3/s x km2. If tPR = 5.5 tR, then tR = tr, tPR =

tP, and qPR = qP and Ct and CP are computed by the aforementioned equations. 

2.3 Routing in rivers

2.3.1 Muskingum

Muskingum  method's  is  the  simplest  form  of  flood  routing.  It  is  based  on  the
continuity equation and on the recursive relation between storage and flow rate at any
stream or river. The storage capacity is considered to be the sum of a prismatic and a
wedge component:

where:

S, the (temporary) storage in the stream (m3)

Q, stream outflow (m3/s)

I, stream inflow (m3/s)
x, a dimensionless parameter
Κ, a time parameter (s)
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If the continuity equation is taken into account, the change in storage is equal  to the
difference of inflow and outflow. The second equation is the formed:

where:

DS, the change in storage (m3)

Q, stream outflow (m3/s)

I, stream inflow (m3/s)
Dt, the time step of the calculations (s)

Parameter K expresses the time needed for a flood  wave to travel  the  distance  from
the upstream control section (where the inflow takes place) to the downstream control
section (where the outflow occurs). Parameter x quantifies the peak flood  attenuation
and it varies from 0 to 0.5. When x=0.5, there is no attenuation, that is the upstream
maximum flood is equal to the downstream maximum flood. On the other hand, while
x  decreases  towards  0,  the  routing  phenomenon  will  be  stronger,  that  is,  the
attenuation of the maximum flood  wave will  be higher. The practical  problem  lies  in
the  estimation  of  the  two  parameters,  K  and  x.  A  common  workaround  is  to  work
backwards:  if  the  inflow  and  outflow  hydrographs  are  known,  using  the
aforementioned equations one can compute the exact values of the two parameters.

The numerical scheme for the application of the Muskingum method dictates that  the
previous equation must be re-written using finite differences:

But according to the first equation, the change in storage may be written as:

Combining the above two equations:

If the last equation is re-arranged so that Q
j+1

 is the only term in  its  left  side (which

happens to be the one unknown term of the equation), then the following  formula is
obtained:

For simplicity reasons, the equation above can be written as:



Flood flows26

© 2012 TechnoLogismik i

From the set of equations, one can deduct that the sum of the auxiliary coefficients C
0
,

C
1
 and C

2
 is equal to unity. The first from the set of four equations is recursive. For a

given time step, the y-coordinate of the outflow hydrograph is equal to the sum of: a)
y-coordinate of the inflow hydrograph (this time step and the previous time step) and
b)  the  outflow's  previous  value.  These  three  coordinates  are  weighted  by  using  the
auxiliary coefficients.

2.3.2 Muskingum - Cunge

Cunge  used  the  finite  differences  numerical  scheme  to  convert  the  Muskingum
equations into a wave  diffusion  equation.  In  the  Muskingum  –  Cunge  method,  both
inflow and outflow are represented by the letter Q and the only way to tell them apart
is  by  their  indicators  Qi  the  inflow  and  Qi+1  the  outflow.  The  continuity  equation  is

combined with Muskingum's storage equation:

and by inserting the new notation:

Solving the above equation for Qi+1
(t+1) the final product is derived:

Same as before, for simplicity reasons, the equation can be re-written as:

It is obvious that the sum of the three auxiliary coefficients C
0
, C

1
 and  C

2
 is  equal  to

unity. Parameter x is computed using the following equation:
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where:

x, Muskingum – Cunge dimensionless coefficient
J, the average bottom slope (m/m)

q, the runoff per width unit (m2/s)
c, celerity - flood wave velocity (m/s)
Dx, the spatial step (m)

The temporal coefficient K is given by the following equation:

To  calculate  the  flood  wave  celerity  (if  no  measurements  exist),  the  uniform  flow
equation can be applied:

where:

c, celerity - flood wave velocity (m/s)
V, the average velocity (m/s)

n, a parameter that can be derived from the equation Q=b·An

The wave celerity c, can be computed in a simpler way by applying  a friction formula
(such as Manning's) in a known cross section geometry. A necessary condition for this,
is  that  the  cross  section  geometry  that  will  be  used  will  remain  constant  along  the
river or stream.

2.3.3 SCS Convex

This method was developed by SCS (Soil Conservation Service) and is similar to 
Muskingum's method and wide spread. In every time step, the volume of the inflow
hydrograph ie equal to the volume of the outflow hydrograph. If two consecutive time
steps whose distance is Dt are considered and Q1 and Q2 the respective outflow

values, then the following is true:

The aforementioned equation could be used for flood routing if the value of Ct was

known:

The value of the unknown coefficient can be approximated as follows:

The SCS Convex method can be applied only when C
t
 coefficient varies between 0 and

1. This can be achieved by selecting a time step Dt smaller or equal to the one fifth of
the time interval required for peak flood to occur (for the inflow hydrograph).
Parameter Κ is constant and can be approximated using the same techniques that
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were introduced by Muskingum. Ct coefficient has approximately twice  the value of

parameter x described in Muskingum method. An estimate of parameter Κ can be
obtained by dividing the length of the stream segment to the wave celerity. If no
other indications or estimates exist regarding Ct coefficient, then the following

approximation can be used:

where V is a velocity for constant and usual flow rate and V+1.7 is the wave celerity in
the segment. Velocity units are in feet per second.

Compared to the other flood routing methods, in the Convex SCS method, the
calculation of the outflow Q

2
 does not depend on the simultaneous inflow I

2
. Therefore

the method can be used to estimate flood flows in time steps with unknown inflows.
This feature may be used as a draft warning system if used in combination with
electronic early warning systems, so that the flood downstream can be predicted at
least a time step before it takes place.

2.3.4 Kinematic wave

In  kinematic  wave's  routing  method,  the  kinetic  and  diffusive  terms  are  neglected.
The flow is considered steady for momentum conservation and unsteady as flow depth
can increase and decrease. The simplified momentum equation is:

According to the aforementioned equation, there is a unique relationship between flow
and depth, i.e. Q=Q(y) or Q=Q(A). This relationship can be expressed as:

In which c represents the wave celerity and is given by the following formula:

If the wave celerity c remains constant while the flood wave propagates from
upstream to downstream, then the maximum flood wave remains constant or in other
words there is no attenuation. Therefore it can be said that if c is constant, the shape
of the hydrograph does not change.

2.4 Routing in reservoirs

2.4.1 Storage Indicator

Same with the flood routing in rivers, during flood routing in reservoirs the momentum
and  continuity  equations  are  both  true.  However  in  reservoirs  there  is  a  unique
relationship between storage and outflow. Outflow is  possible through special  devices
such as weirs, which can be computed given the weir's geometry and the head. 
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Flood routing is of interest when the water level in the reservoir is equal the elevation
of its crest, or when the reservoir is completely filled with water to its capacity. This is
also the worst case scenario, since if  the reservoir is  empty, then the inflow will  just
increase the stored water and the outflow will be zero:

If  the  water  level  in  the  reservoir  exceeds  the  elevation  of  the  weir  crest,  then  the
outflow is non-zero, therefore the above equation is false. Puls was the first to express
the continuity equation using finite differences:

The  aforementioned  equation  is  recursive  and  can  be  used  to  compute  the  outflow
when the relationship  between storage  and  outflow  is  known.  Since  storage  S  is  by
default  uniquely  dependent  on  the  water  level  inside  the  reservoir  and  the  outflow
through a weir is computed as follows:

where:

Q,outflow through the weir (m3/s)
L, the weir's width (m)
H0, crest elevation (m)

H, water level elevation in the reservoir (m)
X, hydraulic head coefficient (usually equal to 3/2)

c,  flow  coefficient  (usually  equal  to  3  m1/2/s.  The  flow  units  depend  on  the
parameter X.)

Hence,  the  two  variables  (outflow  and  storage)  depend  on  the  water  level,  so  they
have a unique relationship among themselves.
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3 File

3.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New project
Open project
Save project
Save project as
Import
o Solution from file

Export
o Solution to file

Print setup
Print
Print to
o Print to file

o Print to Word

o Print to Word (Formatted)

o Print to Excel

Exit

3.2 New project

With this option, a new project is started. All data, results, graphs, titles etc. of the
previous project are erased.

To create a new project:

1. Select New Project from the File menu.
2. If a project is already loaded and changes have been made, a warning message will
appear that asks the user whether to save the changes or not.
3. The current project is erased and a new project is started.

3.3 Open project

With this option, an existing project is loaded. The project may be stored locally, in a
network or in an external media device such as a CD-Rom. If a project is already
loaded and changes have been made, a warning message will appear that asks
whether to save the changes or not. When a project is loaded, all data of the previous
project are lost.

To open an existing project:

1. Select Open project from the File menu.
2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Flood flows project" with the extension .m20.
4. Select the file by clicking on it.
5. Select Open to open the selected file. Select Cancel to cancel the operation.
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NOTE: You can find sample projects in the installation folder of the program:
C:\Program Files\TechnoLogismiki\TLW2013\Samples\FloodFlows

Supported file types

Μ20 (Flood flows project): Files created by version 2012 and 2013 of Flood flows.
Μ502 (Flood flows project): Files created by versions 2011, 2010, 2009, 2008, 2007
and 5.0 of Flood flows.
M14 (Flood flows v2.xx - v4.xx): Files created by versions 2.x, 3.x or 4.x of Flood
flows. This program had been updated to version 5.0, 2007, 2008, 2009 and 2010.
MB6 (Flood routing v2.xx - v4.xx): Files created by versions 2.x, 3.x or 4.x of Flood
routing. This program had been updated to version 5.0 but now it is merged with
Hydraulic solver 2007 or later.
BCK (Backup files): If you have selected from program options the creation of
backup copy when a file is loaded, then the file can be loaded by selecting Backup
files (*.bck) from the Files of type drop-down list.
*.* (All files): Displays all files in the current folder.

Backwards compatibility

This version implements full backwards compatibility; however, note that when a
project is saved with the latest format, it cannot be used by previous versions.

NOTE: If the message "Could not load project. File may be corrupt or saved by an
unknown or incompatible version of the program" appears, then either you are trying
to load a project that does not belong to this program or the file is used (and locked)
by another process in your computer.

3.4 Save project

With this option, you can save all data of a project into a file. The file can be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you attempt to save a project.
When the filename and path are set, all subsequent saves will be made to the same
file.

When you want to rename a file or save it in a new location, use Save project as...
from the File menu.
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To save the current project:

1. Select Save project from the File menu.
2. If the location of the file is already set, the project is saved to this file without any
messages. If the filename is not set, a dialog box will appear that allows the selection
of the filename and path.

3.5 Save project as

With this option, the current project is saved just as in the case of Save project, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.

To save a project with another name and/or to another location:

1. Select Save project as from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current project are saved.

3.6 Import

3.6.1 Solution from file

A project may contain one or more solutions. With this option, solutions in files with
the extension .sln can be imported in the current project. You can create solution files
by exporting a solution.

To import solutions from an existing file to the current project:
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1. Select Import from the File menu.
2. Select Solution from file from the Import menu.
3. Select the location of the solution file.
4. Select the file type from the Files of type drop-down list. The default option is
"Solution file" with the extension .sln.
5. Select the file by clicking on it.
6. Select Open to import the solution to the current project. The solution is appended
to the end of the list of the solutions. Select Cancel to cancel the operation.

NOTE: With this option, you can import solutions exported by the same version of the
program.

3.7 Export

3.7.1 Solution to file

A project may contain one or more solutions. With this option, a file containing a
single solution from the current project can be exported. This is the preferred option
when you want to send a solution to another user.

To export a solution to a file:

1. Select the solution containing the section data you wish to export from the list in
the main form.
2. Select Export from the File menu.
3. Select Solution to file from the Export menu.
4. Select the location of the new file.
5. Type the filename in the File name text box.
6. Select Save to create the solution file with the extension .sln. Select Cancel to
cancel the operation.
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To import a solution from a file, select Solution from file from the File > Import
menu.

NOTE: A solution file contains a single solution only. The solution currently selected in
the list of the main form will be saved in the file.

3.8 Print setup

With this option, you can select which parts of the project will be included in the
printouts. When a new project is created, a full report is selected by default.

To modify the print setup:

1. Select Print setup from the File menu.
2. Select the sections (Title, Project information etc) that will be printed for each
solution, from the list on the left.
3. Select the solutions that will be included in the report from the list on the right.
4. Check Use new page for each object if you want to use a new page for each
solution in the report.
5. Check Repeat headers for data/results if you want to repeat the headers each
time a separate data or results table is used.
6. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection of a list.
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NOTE: The changes are saved with the project. The above preferences are used to all
printouts, either to the printer or to other formats such as Word file, Excel file etc.

3.9 Print

With this option, you can prepare a report to be printed to a local, network or virtual
printer such as Adobe PDF Writer. The parts of the project that will be included in the
report are determined from print setup.

By selecting Print, the report is not printed directly; instead, a document is prepared
and a preview of the printout is created by the Print manager. You can print the
report by clicking the Print button of the toolbar of Print manager.

To create a report:

1. Select Print from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.

NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.
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3.10 Print to

3.10.1 Print to File

With this option, you can create a simple text file containing a report of the project.
This file is recognized and can be further modified by word processors such as
Microsoft Word, OpenOffice Writer etc.

To print to a text file:

1. Select Print to from the File menu.
2. Select Print to file from the Print to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.

The parts of the project that will be included in the report are determined from print
setup.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but the report is NOT printed.

3.10.2 Print to Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.
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3.10.3 Print to Word (Formatted)

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a formatted Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word (Formatted) from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup. This operation is much slower than the regular print to word function. However,
the final output requires minimal user intervention as it comes fully formatted with
tables, alignment, font styles, etc.

NOTE: Do not use Copy (CTRL+C) on any of the programs running during this
operation. If you do so, it will most likely affect the communication between Microsoft
Word and the clipboard and as a result the final document will be corrupt.

3.10.4 Print to Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the report can be created. Note that
Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the report to a Microsoft Excel file:

1. Select Print to from the File menu.
2. Select Print to Excel from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

3.11 Exit

With this option, you can exit the program. If there are changes in the current project
that have not been saved then the program will:

either ask the user to save the changes
or save the changes
or ignore the changes

depending on what you have selected in General preferences.

To exit the program:

1. Select Exit from File menu.
2. If you are asked whether to save the changes or not, you can save changes or
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ignore them.
3. The program is terminated.
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4 Data

4.1 Data menu

With this menu, you can add and modify data. In the Data menu you can select one
of the following options:

Project info
Undo
Redo
Add solution
Remove solution
Basins
o Basin properties

o IDF curve

Rivers
o River properties

o Inflow hydrograph

o Friction calculations

Reservoirs
o Reservoir properties

o Inflow hydrograph

o Storage - outflow graph

Copy data from solution
Options
o General preferences

o Cell editing

o Customize toolbar

4.2 Project info

With this option, you can add project information that include, optionally, title, author
and comments. If you want, this information can be included in the reports. The
empty fields are ignored.

To add or modify the project information:

1. Select Project info from the Data menu.
2. Type the project title, author and comments.
3. Check Include project time and date if you want to include the time and date in
the project.
3.1. Type the day, month, year, hours and minutes in the corresponding text boxes.
Alternatively, you may click on the up/down arrows to increase or decrease the
respective value in the text box.
3.2. If you click on Now then all text boxes are filled with the current values
automatically.
4. Check Include the name of the project file if you want the full path and filename
of the project to be included in the report.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.



Flood flows42

© 2012 TechnoLogismik i

By selecting the buttons with the ellipses (...) next to the project title and author, you
can access the corresponding databases.

Project title database

For the completion of a project, more than one programs may be needed. For
convenience, you can add the project title to the database and retrieve it from all
programs.

To use the project title database:

1. Select the button with the ellipses (...) next to the project title text box. The project
title database appears.
2. Select Add to add a new title to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected project title and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

Author database
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An engineer may be involved in multiple projects. For convenience, you can add the
author name to the database and retrieve it from all programs.

To use the author database:

1. Select the button with the ellipses (...) next to the author text box. The author
database appears.
2. Select Add to add a new author to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected author and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

4.3 Undo

Undo cancels the last committed change in the project.

To cancel the last committed change:

1. Select Undo from the Data menu.
2. The last committed change is canceled.

To cancel an undo command, you may use the redo function which is described
below. Redo becomes available once undo is used.

It is possible to undo more than one recent changes and to redo them, by following
the step described above. The number of actions that are kept in memory and may be
undone or redone is 20 by default. This means that the program is able to keep track
of up to 20 successive changes and undo them. This number may change for all
programs, using the option in the main menu. For more information, please consult
main menu user guide.

NOTE: Some changes cannot be undone like the new project or the save project
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functions.

4.4 Redo

Redo cancels the latest undo command.

To redo the latest change that was undone:

1. Select Redo from the Data menu.
2. The latest undone change is redone.

To undo a redo, you may use the undo command.

It is possible to redo more than one changes that were previously undone by following
the steps described above. The number of actions that are kept in memory and may
be undone or redone is 20 by default. This means that the program is able to keep
track of up to 20 successive changes that are undone and redo them. This number
may change for all programs, using the option in the main menu. For more
information, please consult main menu user guide.

4.5 Add solution

With this option, you can add a new solution.

To add a solution:

1. Select Add solution from the Data menu.
2. Select the type of the problem (see below)
3. Select Ok to create a new solution. The solutions are grouped; the first group are
the Basins, the second group are the Rivers and the last group are the Reservoirs.
The new solution is appended at the end of the corresponding group. Select Cancel to
close the dialog box without adding a solution.

4.6 Remove solution

With this option, you can delete an existing solution.

To delete an existing solution:

1. Select the solution you wish to delete from the list in the main form.
2. Select Delete solution from the Data menu.
3. You may be prompted to confirm the deletion depending on what you have selected
in General preferences. If you select No then the deletion is canceled.
4. The solution is deleted.
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4.7 Basins

4.7.1 Basin properties

With this option, you can display and modify the properties of a basin.

To define the properties of a basin:

1. Select Basin from the Data menu.
2. Select Basin properties from the Basins menu.
3. Enter the data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Not all data are required, as these depend on the calculation formula.

General data

Name: enter the name of the basin.
Comments: (optional) enter comments.



Flood flows46

© 2012 TechnoLogismik i

Solver:
o Rational method: the calculations will be performed with the Rational method.

o Fuller: the area and return period are required for the Fuller empirical formula.

o Forti: the area is required for the Forti empirical formula.

o Fanning: the area is required for the Fanning empirical formula.

o Kuichling: the area is required for the Kuichling empirical formula.

o Iskovski: the area, the mean annual accumulated rainfall and the topography

coefficient are required for the Iskovski empirical formula.
o SCS unit hydrograph: the area, the excess rainfall duration and data for the

concentration time.
o Snyder synthetic hydrograph: the area, length of main basin river and all

data in Snyder's category.
Concentration time: if the calculations are performed with the Rational method,
then the concentration time can be calculated with one of the following formulas:
o Direct value: if the concentration time is known, it can be entered directly in

the Concentration time field.
o Carter: the Carter formula (Washington DC, USA) requires the length and the

mean slope of the basin.
o Eagleson: the Eagleson formula requires the length, mean slope, hydraulic

radius and the Manning friction coefficient.
o Espey/Winslow: the Espey and Winslow formula requires the length, mean

slope, the Espey coefficient and the imperviousness of the area.
o Federal Aviation Administration: the FAA formula requires the length and

mean slope of the basin.
o Giandotti: the Giandotti formula requires the length, mean slope, mean

elevation and the elevation at the basin outlet.
o Kerby/Hathaway: the Kerby and Hathaway formula requires the length, mean

slope, and the Manning friction coefficient.
o Kirpich/Kirpich (PA): the well known Kirpich method and a variation for fields.

The length and mean slope of the basin are required.
o Length and velocity: the length and mean velocity are required. The

concentration time is given by the result of their division.
o SCS Lag: the SCS lag formula requires the length, mean slope and CN curve

number.
o TR-55U/TR-55P: the TR-55U/TR-55P formula requires the length and mean

slope of the basin.
o California Culverts Practice: the length, the maximum elevation of the main

river and the elevation at the basin outlet are required.
o Izzard: the length, the average basin slope and Izzard's' deceleration coefficient

are required.
o Kinematic wave: Manning friction coefficient, the length, the runoff coefficient

and the average basin slope are required.
Concentration time: In case you select Rational method and Direct value,
enter the direct value in this field in h.
Excess rainfall duration (h): Used in SCS unit hydrograph method, the total
excess rainfall duration in h.
Correction for areal intensity: If the rational method is used, a correction factor
can be optionally used in order to reduce the point rainfall intensity when
converted to areal. One of the following cases can be applied:
o None: the point intensity is not reduced when converted to areal.

o Fornari: the Fornari method is applied to estimate the reduction factor.
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o TP-29: the reduction factor is estimated using the TP-29 method.

o Custom: a user-supplied reduction factor is entered below.

Correction coefficient: if the custom selection is chosen in the correction for
areal intensity field, then a user supplied correction coefficient is expected in this
field. The factor must be smaller than unity.

Basin geometry

Area of the basin: enter the area of the basin in km2.
Length of the main basin river: enter the length of the main basin river in km.
If the basin does not have a clearly defined main river, then you should enter the
appropriate length depending on the formula you will be using e.g. Federal
Aviation Administration.
Average surface slope: the mean slope in m/m
Average basin elevation: the mean basin elevation in m.
Maximum elevation of basin river: The maximum elevation of the basin's main
river is entered in m.
Elevation of basin outlet: the elevation of the basin outlet in m.

Ground information

Runoff coefficient: enter the runoff coefficient of the basin. If it is not known, it
can be estimated based on the characteristics of the basin from the embedded 
database, by clicking the button with the ellipses (...).
Manning friction factor: enter the Manning friction coefficient of the basin. If it
is not known, it can be estimated based on the characteristics of the basin from
the embedded database, by clicking the button with the ellipses (...).
Hydraulic radius: enter the hydraulic radius of the main river at peak flow rate in
m. You can enter a trial value and confirm it after completing the calculations. The
hydraulic calculations can be performed by the Section Solver by
TechnoLogismiki.
Espey canalization factor: enter the Espey canalization factor for the basin. If it
is not known, it can be estimated based on the characteristics of the basin from
the embedded database, by clicking the button with the ellipses (...).
Water traveling velocity: enter the water traveling velocity in m/s.
SCS curve number (CN): enter the SCS curve number for the basin. If it is not
known, it can be estimated based on the characteristics of the basin from the
embedded database, by clicking the button with the ellipses (...).
Izzard deceleration coefficient: an estimate of Izzard's deceleration coefficient
is entered in this field. If it is not know, then it can be estimated using various
physical characteristics of the basin from the embedded database, by clicking the
button with the ellipses (...).

Empirical formulas data

Return period Τ: enter the return period in years (for the Fuller formula).
Mean annual accumulated rainfall : enter the mean annual accumulated
rainfall in m (for the Iskovski formula).
Topography coefficient: enter the topography coefficient using the embedded
database. This is required for the Iskovski formula. To use the database, click the
button with the ellipses (...).
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Snyder

Distance from outlet to centroid: enter the total distance from the catchment's
outlet to its centroid, measured along the flow path in km.
Ct Snyder parameter: enter the dimensionless value of Snyder's Ct parameter.
Cp Snyder parameter: enter the dimensionless value of Snyder's Cp parameter.
Hours of synthetic hydrograph: the duration of the hydrograph, i.e. for a six-
hour hydrograph enter 6. 

NOTE: This menu is accessible only if the selected solution is a basin-type solution.

4.7.2 IDF curve

With this option, you can enter the intensity of the rainfall. This can be calculated
directly from an IDF curve, by linear interpolation from a table containing rainfall
duration - intensity data or take a constant value.

To enter the rainfall intensity:

1. Select Basin from the Data menu.
2. Select IDF curve from the Basin menu.
3. Make the appropriate selections.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To use an IDF:

1. Select the Intensity duration curve option button.
2. Enter the dimensionless coefficients c, b and n in such a way that when t is entered
in hours, the resulting intensity is given in mm/h.
3. Optionally, you can use the embedded IDF database by clicking Database.

To use a constant rainfall intensity:
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1. Select the Constant rainfall intensity option button.
2. Enter the rainfall intensity in mm/h. This value is not depended on the
concentration time.

To use a rainfall duration - intensity correlation:

1. Select the Rainfall duration - intensity option button.
2. Enter pairs of data i.e. rainfall duration in min and rainfall intensity in mm/h. The
program will use linear interpolation to find the appropriate value. You can create the
curve manually, using the Add, Remove and Insert buttons. You can also import a
curve from a file.
3. Select Import to import data from an IDF or RCV file.
4. Select Export to export the current table data to a file.
5. Select Add to add a line to the table. Select Remove to remove the current line
from the table. Select Insert to insert a line above the current line of the table.

NOTE: This menu is accessible only if the selected solution is a basin-type solution.

4.8 Rivers

4.8.1 River properties

With this option, you can display and modify the properties of a river.

To define the properties of a river:

1. Select River from the Data menu.
2. Select River properties from the Rivers menu.
3. Enter the data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Not all data are required, as these depend on the solution method.

Common data
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Name: enter the name of the river.
Comments: (optional) enter comments.
Solver: select one of Muskingum, Muskingum-Cunge, SCS Convex, Kinematic
Wave.
Total observation time: enter the total observation time of the routing
phenomenon in s. This must greater than the base time of the inflow hydrograph.
Temporal step: enter the time step in s. In most cases it should be the same
with the time step of the inflow hydrograph.

Muskingum method

In addition, the following data are required in the case of Muskingum method:

Temporal constant K: enter the time constant K in h. This constant is related to
the time lag between the upstream and downstream peak flow rates.
Storage coefficient x: enter the dimensionless coefficient x. This coefficient
takes a value between 0 and 0.5 and is related to the attenuation of the wave. For
x=0.5 there is no attenuation whereas for x=0 the attenuation is maximum.

Muskingum-Cunge method

In addition, the following data are required in the case of Muskingum-Cunge method:

Total river length: enter the total river length in m.
Wave celerity: enter the wave celerity in m/s.
Bottom slope: enter the mean slope of the river bed in m/m.

Flow rate: enter the peak flow rate in m3/s. This is usually set equal to the peak
value of the upstream inflow hydrograph. This value is not required when the
wave celerity is known.

Lateral inflow: (optional) enter the lateral inflow in m3/s. This value is used in
the calculation of the C3 dimensionless coefficient of the Muskingum-Cunge
formula.
Friction factor: enter the friction factor. This is depended on the river
characteristics. Click the button with the ellipses (...) to access the friction
coefficient database containing the values corresponding to the selected friction
formula.
Section: enter a characteristic (constant) river section.

SCS Convex method

In addition, the following data are required in the case of SCS Convex method:

Total river length: enter the total river length in m.
Velocity: enter the flow velocity in m/s. This is not required if Ct or K is known.
SCS Ct coefficient: enter the dimensionless SCS Ct coefficient. This coefficient is
the ratio of two consecutive flow discharge values to the difference of inflow and
discharge during the same time span. If the coefficient is not known then it is
calculated based on K.
Temporal constant K: enter the time constant K in h. This constant is related to
the time lag between the upstream and downstream peak flow rates. This is not
required when SCS Ct coefficient is known.
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Kinematic Wave method

In addition, the following data are required in the case of Kinematic Wave method:

Total river length: enter the total river length in m.
Bottom slope: enter the mean bottom slope in m/m.
Friction factor: enter the friction factor. This is depended on the river
characteristics. Click the button with the ellipses (...) to access the friction
coefficient database containing the values corresponding to the selected friction
formula.
Section: enter a characteristic (constant) river section.

NOTE: This menu is accessible only if the selected solution is a river-type solution.

4.8.2 Inflow hydrograph

With this option, you can define the inflow hydrograph.

To define the inflow hydrograph:

1. Select Rivers from the Data menu.
2. Select Inflow hydrograph from the Rivers menu.
3. Enter the hydrograph data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To enter the data directly:

1. Select the appropriate time unit (e.g. s, min, day, hour) from the drop-down list.
2. Click Add to add a line at the end of the list.
3. Click Insert to insert a line above the currently selected line.
4. Click Delete to delete the currently selected line. You will be asked for confirmation
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only if you have selected to confirm deletions in the General preferences tab. If you
select No then the deletion is canceled.
5. You can view the current hydrograph in the Preview frame.

To import a hydrograph from a file:

1. Select Import from the Data frame.
2. Select the location of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Hydrograph file" with the extension .hyf.
4. Select the file by clicking on it.
5. Select Open to import the hydrograph. Select Cancel to cancel the operation.

To export a hydrograph to a file:

1. Select Export from the Data frame.
2. Select the location of the new file.
3. Type the filename in the File name text box.
4. Select Save to create the solution file with the extension .hyf. Select Cancel to
cancel the operation.

In the Functions menu, you can select one of the following options:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
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Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Word.

NOTE: This menu is accessible only if the selected solution is a river-type solution.

4.8.3 Friction calculations

With this option, you can select the formulas that will be used for the calculation of
the friction losses and calibrate the solvers.

To select the friction formulas:

1. Select the solution for which you wish to select the friction formulas from the list in
the main form..
2. Select Friction calculation from the Data menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Depending on the type of flow (under pressure or with free surface), two different
dialog boxes may appear:

A. Flow under pressure

In case the flow is under pressure, you can select up to three different friction
formulas, depending on the type of flow (turbulent, transient, laminar). If you check 
Set as defaults for all new projects then these values will be preselected for all
new projects.

First, you define the boundaries of turbulent and laminar flow. The use of Re>4000 for
turbulent flow and Re<2000 for laminar flow is recommended. For intermediate
values, the flow is considered to be transient. If you set the same friction formula for
all types of flow, this analysis has no effect.

Note that different friction formulas need different friction coefficients. The first three
choices are variations of the well-known Manning formula. The first, named Manning,
assumes constant friction coefficient. The other two calculate the friction coefficient as
a function of the fill ratio and the coefficient that corresponds to full flow. These three
formulas give the same results in flow under pressure; this is not the case for flow
with free surface, where up to 30% difference may be observed.

The Accuracy and Maximum number of trials ensure the stability of the algorithm.
The default values are 0.0005 for the accuracy and 1000 for the maximum number of
trials. It is recommended that you do not change these values.

The averaging formula may take one of the following values:

Pavlovskii
Colebatch
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Horton
Cox
Lotter

The above formulas are used when there are different friction coefficients within the
same section and an average friction coefficient is needed.

B. Flow with free surface

In case the flow is with free surface, you can select a single friction formula. If you
check Set as defaults for all new projects then this value will be preselected for all
new projects. The friction formulas available are: Manning, Bazin, Kutter, Ganguillet-
Kutter, Chezy, Hazen-Williams.

The Accuracy and Maximum number of trials ensure the stability of the algorithm.
The default values are 0.0005 for the accuracy and 1000 for the maximum number of
trials. It is recommended that you do not change these values.

NOTE: This menu is accessible only if the selected solution is a river-type solution.

4.9 Reservoirs

4.9.1 Reservoir properties

With this option, you can display and modify the properties of a reservoir.

To define the properties of a reservoir:

1. Select Reservoirs from the Data menu.
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2. Select Reservoir properties from the Reservoirs menu.
3. Enter the data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

General data

Name: enter the name of the reservoir.
Comments: (optional) enter comments.
Total observation time: enter the total observation time in s. This must be
greater than the base time of the inflow hydrograph.
Temporal step: enter the time step in s. In most cases it should be the same
with the time step of the inflow hydrograph.

Initial outflow: enter the outflow at t=0 in m3/s.

Initial storage: enter the storage at t=0 in m3.

NOTE: This menu is accessible only if the selected solution is a reservoir-type
solution.

4.9.2 Inflow hydrograph

With this option, you can define the inflow hydrograph.

To define the inflow hydrograph:

1. Select Reservoirs from the Data menu.
2. Select Inflow hydrograph from the Reservoirs menu.
3. Enter the hydrograph data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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To enter the data directly:

1. Select the appropriate time unit (e.g. s, min, day, hour) from the drop-down list.
2. Click Add to add a line at the end of the list.
3. Click Insert to insert a line above the currently selected line.
4. Click Delete to delete the currently selected line. You will be asked for confirmation
only if you have selected to confirm deletions in the General preferences tab. If you
select No then the deletion is canceled.
5. You can view the current hydrograph in the Preview frame.

To import a hydrograph from a file:

1. Select Import from the Data frame.
2. Select the location of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Hydrograph file" with the extension .hyf.
4. Select the file by clicking on it.
5. Select Open to import the hydrograph. Select Cancel to cancel the operation.
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To export a hydrograph to a file:

1. Select Export from the Data frame.
2. Select the location of the new file.
3. Type the filename in the File name text box.
4. Select Save to create the solution file with the extension .hyf. Select Cancel to
cancel the operation.

In the Functions menu, you can select one of the following options:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Word.

NOTE: This menu is accessible only if the selected solution is a reservoir-type
solution.

4.9.3 Storage - outflow graph

With this option, you can define the storage-outflow graph of the reservoir.

To define the storage-outflow graph:

1. Select Reservoirs from the Data menu.
2. Select Storage - outflow graph from the Reservoirs menu.
3. Enter the storage-outflow data as described below.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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To enter the data directly:

1. Click Add to add a line at the end of the list.
2. Click Insert to insert a line above the currently selected line.
3. Click Delete to delete the currently selected line. You will be asked for confirmation
only if you have selected to confirm deletions in the General preferences tab. If you
select No then the deletion is canceled.
4. You can view the current storage - outflow graph in the Preview frame.

To import a storage - outflow graph from a file:

1. Select Import from the Data frame.
2. Select the location of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Reservoir curve file" with the extension .rcu.
4. Select the file by clicking on it.
5. Select Open to import the graph. Select Cancel to cancel the operation.

To export a storage - outflow graph to a file:

1. Select Export from the Data frame.
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2. Select the location of the new file.
3. Type the filename in the File name text box.
4. Select Save to create the solution file with the extension .rcu. Select Cancel to
cancel the operation.

In the Functions menu, you can select one of the following options:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Word.

NOTE: This menu is accessible only if the selected solution is a reservoir-type
solution.

4.10 Copy data from solution

With this option, you can copy all data from another existing solution of the same
project. This command is particularly useful when you want to solve multiple problems
that are almost the same.

To copy all data from another existing solution:

1. Select the target solution from the list in the main form.
2. Select Copy from solution from the Data menu.
3. The name of the target solution is displayed in the caption of the dialog box.
4. Select the source solution from the drop-down list.
5. Select Copy to copy the data from the source solution to the target solution. Select
Cancel to cancel the operation.
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NOTE: The data of the target solution is erased and substituted by the data of the
source solution.

4.11 Options

4.11.1 General preferences

With this option, you can modify the general preferences of the program.

To modify the general preferences:

1. Select Options from the Data menu.
2. Select General preferences from the Options menu.
3. The general preferences dialog box appears. The preferences are grouped into four
tabs. You can select a tab by clicking on its name.

General Tab

This tab contains general preferences regarding the usage of the program.

Check Register the extension *.m20 with this application to associate the
extension .m20 with this program. This extension is used by the program when saving
a project. In this way, you will be able to run the program and load a project by
double-clicking on the project filename in Windows Explorer.

Check Automatically display calculation messages if you want the report details to
be automatically displayed when you calculate the results.

Check Automatically create backup file if you want a backup file (with the
extension .bck) to be created every time a project is loaded. By default, this file is
created in the temporary folder of Windows.

Check Confirm delete actions if you want to be asked for confirmation each time an
object is about to be deleted. This setting affects the behavior of all delete actions, for
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example the deletion of a solution

You can also modify the temporary folder that will be used for the creation of backup
files. By default, this folder is the temporary folder of Windows.

Finally, there are three options regarding the termination of the program:

When exiting always ignore changes - All changes since the last save of the
project are ignored. 
When exiting always save changes - All changes in the current project are
automatically saved. If the filename of the project is not set, a dialog box will
appear that allows the selection of the filename, as when selecting Save project
as from the File menu.
When exiting prompt for action - If there are changes in the current project,
then a dialog box will appear. You can choose to save or ignore the changes. If
the filename of the project is not set, a dialog box will appear that allows the
selection of the filename, as when selecting Save project as from the File menu.

Languages Tab

If more than one language packs have been installed, then you can choose the
language of the program. In the above case, there are two language packs; English
(that are already selected) and Greek. If you change the language, all forms, menus,
messages, help files will reflect the chosen language.

In order for the changes to take effect, you must restart the program.

Digits Tab
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With this tab, you can modify the way the results are presented. All values used in the
program are displayed in the list on the left.

For each value, you can select the number of decimal digits using the Number of
digits drop-down list.

Check Use 0.1 instead of .1 to use a preceding zero when displaying numbers
between -1 and 1, for example -0.08 instead of -.08 and 0.98 instead of .98.

Check Use 1.0 instead of 1 to use trailing zeros (when necessary) in order to display
a number with the decimal digits selected in the Number of digits drop-down list, for
example 1.1600 instead of 1.16 (when the number of digits is set to 4).

Internet Tab

The program can automatically check for newer versions over the Internet. Check 
Automatically check for newer versions to enable this feature. The check is
automatically performed at an interval specified in the Every drop-down list. Select
Check now to manually check for newer versions.

When a newer version is found, you will be prompted to download and install the
latest version.

NOTE: TechnoLogismiki protects your privacy. During the check for newer versions,
no data is transferred from your computer to the Internet.
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Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

4.11.2 Grid editing

With this option, you can modify the behavior of grids.

The behavior of all editable grids is controlled by the preferences in this dialog box.

Select No cell automation if you want the active cell to remain the same when
hitting ENTER.

Select Open the cell below (edit by columns) if you want to activate the cell below
when hitting ENTER. This is particularly useful when editing tables by columns.

Select Open the next cell (edit by rows) if you want to activate the next cell on the
right when hitting ENTER. This is particularly useful when editing tables by rows.

In some cases, the program may automatically fill some missing values (for example,
when performing linear interpolation). In this case, you can select a distinctive color in
order to recognize these values. You can choose the color by clicking on the button in
the Auto-complete settings frame.

NOTE: These preferences affect all projects, old and new.

Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

4.11.3 Customize toolbar

With this option, you can customize the toolbar of the main form.

To customize the toolbar of the main form:

1. Select Options from the Data menu.
2. Select Customize toolbar from the Options menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The toolbar may contain small or large buttons.
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Check Show description if you want a small description to be displayed under the
buttons.

Check Show tooltips if you want tooltips to be displayed when the mouse pointer
hovers over a button for 2-3 seconds.

NOTE: These preferences affect all projects, old and new.
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5 Results

5.1 Results menu

With this menu, you can perform calculations and view the results. In the Results
menu you can select one of the following options:

Perform calculations
Calculations report
Basins
o Comparative analysis

Rivers
o Results details

Reservoirs
o Results details

5.2 Perform calculations

With this option, you can manually perform calculations for all solutions.

To manually perform calculations for all solutions:

1. Select Perform calculations from the Results menu.
2. The calculations are performed. The results are displayed in the main form. If there
are errors in one or more solutions, an error report is prepared. If you have selected 
Automatically display calculation messages in general preferences then the
calculations report is automatically displayed.

5.3 Calculations report

With this option, a report containing information on calculation problems and errors is
created. If you have selected Automatically display calculation messages in
general preferences then this report is automatically displayed when you select
Perform calculations.

To display the report:

1. Select Calculations report from the Results menu.
2. The report appears.
3. Hit ESC to close the report.
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NOTE: This option is available only when one or more solutions are not completed
successfully.

5.4 Basins

5.4.1 Comparative analysis

With this option, you can calculate the flood flow with all possible methods, whether
they are applicable or not.

To perform the comparative analysis:

1. Select Basins from the Results menu.
2. Select Comparative analysis from the Basins menu.
3. Check Include invalid results if you want all results to be displayed. The number
of the solver is printed in red if the method is not applicable.
4. Select Ok to close the dialog box.
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In the Functions menu, you can select one of the following options:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Excel.

5.5 Rivers

5.5.1 Results details

With this option, you can view the result details for the selected river.

To view the results details:

1. Select Rivers from the Results menu.
2. Select Results details from the Rivers menu.
3. Hit ESC to close the dialog box.

5.6 Reservoirs

5.6.1 Results details

With this option, you can view the result details for the selected reservoir.

To view the results details:

1. Select Reservoirs from the Results menu.
2. Select Results details from the Reservoirs menu.
3. Hit ESC to close the dialog box.
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6 Help

6.1 Help menu

In the Help menu you can select one of the following options:

Contents
User guide
Tutorials
Tip of the day
Unit conversion
TechnoLogismiki website
Buy products
TechnoLogismiki NOMOS
TechnoLogismiki Live!
About the program

6.2 Contents

With this option, you can access the online help which contains detailed information
regarding the usage of the program.

To view the online help:

1. Click Contents from the Help menu.
2. The online help appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

6.3 User guide

With this option, you can access the user guide which contains detailed information
regarding the usage of the program.

To view the user guide:

1. Click User Guide from the Help menu.
2. The user guide appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

NOTE: Adobe Acrobat Reader or a similar program that can display pdf files is
required in order to view or print the user guide.

6.4 Tutorials

With this option, you can access the tutorials of the program. The tutorials are step-
by-step examples that allow you to decrease the learning cycle of the programs
dramatically.
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To access the tutorials:

1. Click Tutorials from the Help menu.
2. The tutorial selection dialog box appears.
2. Select the appropriate tutorial and click Start to proceed. Click Cancel to close the
dialog box.

NOTE: The number and content of the tutorials is changed frequently. Use the live
update system of TechnoLogismiki's products to download the latest tutorials.

6.5 Tip of the day

With this option, you can access the tip database of the program. The tips are short
guidelines regarding the usage of the programs which may be of great help to the
user.

To access the tips:

1. Click Tip of the day from the Help menu.
2. The tip of the day form appears.
3. Check Do not show this form again to prevent the program from showing the tip
of the day when starting. Press the Previous/Next buttons to browse all available
tips.
4. Press Esc to close the form.

NOTE: The number and content of the tips is changed frequently. Use the live update
system of TechnoLogismiki's products to download the latest tips.
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6.6 Unit conversion

With this option, you can access the unit conversion tool. You can find more
information about its usage in its help system. 

To launch the unit conversion tool:

1. Click Unit conversion from the Help menu.
2. The unit conversion tool is launched.

NOTE: If an error message appears then the unit conversion tool has not been
installed. You can install the unit conversion tool from the installation CD or the
Internet.

6.7 TechnoLogismiki website

With this option, you can load on your Internet browser the website of
TechnoLogismiki's.

6.8 Buy products

With this option, you can load on your Internet browser the main product page of
TechnoLogismiki's website.

6.9 TechnoLogismiki NOMOS

With this option, you can load on your Internet browser the NOMOS service of
TechnoLogismiki.

6.10 TechnoLogismiki Live!

With this option, you can load on your Internet browser the Live! service of
TechnoLogismiki.

6.11 About the program

With this option, a form containing the name, version and licence information of the
program appears.

To show this form:
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1. From the Help menu, select About the program.
2. The form appears.
3. Click anywhere on the form or hit ESC to close the form.
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7 Sections

7.1 Section input

When you double-click the cell of the property value of Section, a command button
with ellipses (...) appears. If you click it, the following dialog box appears:

In order to enter section data, follow these steps:

1. Select the type of the section from the drop-down list.
2. Fill the geometric data by typing onto the table. The number and description of
fields depends on the type of the section.
3. You can preview the current configuration in the picture of the Preview frame.
4. Select Ok to use the currently selected configuration and close the dialog box.
Select Cancel to close the dialog box without applying any changes.

NOTE: If you click the Edit button then the section editor will appear. This editor
must be used in the case of prismatic (irregular) sections. However, its use is not
compulsory when dealing with standard section types, as these can be fully defined
by the above dialog box.

The available section types are the following:

Section type Geometric data required

Circular Diameter

Open rectangular Width, Height

Rectangular Width, Height

Open trapezoid Width, Height, Left slope, Right slope

Trapezoid Width, Height, Left slope, Right slope

Open reverse trapezoid Width, Height, Left slope, Right slope

Reverse trapezoid Width, Height, Left slope, Right slope

Open isosceles trapezoid Width, Height, Side slope

Isosceles trapezoid Width, Height, Side slope

Open reverse isosceles
trapezoid

Width, Height, Side slope

Reverse isosceles trapezoid Width, Height, Side slope

Twin rectangular Width, Height (total)

Twin open rectangular Width, Height (total)

Twin circular Diameter (of each circular section)
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Oval Width

Wide oval Width

Basket handle Width

Simple mouth-shaped Width

Normal mouth-shaped Width

Simple horse-shoe Width

Normal horse-shoe Width

Donut External diameter, Internal diameter

Arch Width, Height, Arc segments

Ellipse Width, Height, Arc segments

Parabolic Width, Height, Arc segments

Irregular Use section editor

NOTE: The above section types are based on advanced script techniques. Therefore,
this list may be changed (for example, some more types may be added) with updates
that are irrelevant with the executable file of the program.

7.2 Section editor

The list of the standard types of sections is extensive; however, when the section is
irregular it cannot be described by these types. In this case, you can use the section
editor. With this editor, you can design a new section from scratch or modify a
standard section. Note that after editing, the section will always be referred to as
irregular.

The section is described by curvilinear polygons i.e. open or closed polylines with
straight or curved edges. The curved edges are circular arcs; in this way, virtually any
section can be described accurately with a minimum number of nodes.
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The user interface of the section editor is shown in the above picture. It consists of
four parts: the menu, the toolbar, the drawing and the table of coordinates.

A section may:

consist of one or more curvilinear polygons
consist of many open or closed curvilinear polygons or any combination of them
include ground information
include excavation information

There are five main menus:

File: file operations, printing, importing from other formats
Edit: data input and editing
View: configuration of the drawing and the table of coordinates
Options: other options (colors, line styles etc)
Calculations: calculation tools for checking the section.

In order to input section data:

1. Add one or more polygons.
2. For each polygon add three or more nodes.
3. For each node, enter X coordinate, Y coordinate and friction coefficient. Optionally,
you can enter the bulge, if the edge is curved. These values are explained below.
4. Check that the section is filled (with fluid) properly. If this doesn't happen, disable
or enable some nodes so that the flow is correct.
5. You can optionally enter ground data. If stabilization works are necessary then this
line represents the ground before dredging. In the case of natural sections, the section
is the same with the ground.
6. You can optionally enter excavation data. The excavation line is located below the
section and it represents the outline of the section and the level where the section will
be built. For uncovered sections, the excavation line is the same with the section. For
covered sections, the excavation line is displaced downwards by the thickness of the
cover e.g. concrete.

To input data from the table:

Polygon list: select the active polygon by using the drop-down list. If you select to
view the nodes, then the nodes of the active polygon are shown in the drawing.
N/O: the number of the node. This column is not editable.
Χ (m): the X coordinate of the node in meters.
Υ (m): the Y coordinate of the node in meters.
Bulge (m): this is used only in cases of curved edges. It represents the distance in
meters of the middle point of the segment connecting two nodes with the middle point
of the arc. This value is 0 for straight lines. The bulge refers to segments, not nodes;
therefore, the bulge of the first node refers to the segment connecting the first with
the second node. The bulge is positive if the arc connecting two nodes is on the right
side of the corresponding straight line and vice versa. You cannot enter a value for the
last node, as this has no meaning. 
Friction (-): the friction coefficient. This value refers to segments not nodes;
therefore, the friction of the first node refers to the friction of the segment connecting
the first with the second node. You cannot enter a value for the last node, as this has
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no meaning. The values of friction coefficients depend on the selected friction formula.

NOTE: The bulge and friction coefficient columns are not available when entering
ground and excavation data.

7.3 File

7.3.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New section
Open section
Save section
Save section as
Import
o Import from GRD

o Import from PCS

o Import from DXF

o Import from ArcView Shapefile

Export
o Export to GRD

o Export to PCS

o Export to DXF

o Export to ArcView Shapefile

o Export to Bitmap

Print sketch
Print section data
Print section data to
o Microsoft Excel

o Microsoft Word

o Text file

Close

7.3.2 New section

With this option, you can start a new section. All data of the current section are lost.

To start a new section:

1. Select New Section from the File menu.
2. The current section data are erased and a new section is created.

7.3.3 Open section

With this option, an existing section is loaded. The section file may be located locally,
in a network or in an external media device such as a CD-Rom. When a section is
loaded, all data of the previous section are lost.

To open an existing project:

1. Select Open Section from the File menu.
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Section file" with the extension .sec.
4. Select the file by clicking on it.
5. Select Open to open the selected file.

Supported file formats

SEC (Section file): Section files created by versions 2010, 2009, 2008, 2007 and 5
of the program.
*.* (All files): Files with any extension.

NOTE: If a message "Error while loading file" is displayed then either you are trying
to load a file that doesn't contain section data or the file is used (and locked) by
another process in your computer.

7.3.4 Save section

With this option, you can save all data of a section into a file. The file may be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you attempt to save the
section. When the filename and path are set, all subsequent saves will be made to the
same file.

When you want to rename a file or save it in a new location, use Save section as...
from the File menu.

To save the current project:

1. Select Save Section from the File menu.
2. If the filename and path are already set, the section is saved to this file without any
messages. If the filename and path are not set, a dialog box will appear that allows
the selection of the filename and path.

7.3.5 Save section as

With this option, the current section is saved just as in the case of Save section, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.
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To save a project with another name and/or to another location:

1. Select Save Section As from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the section with the selected filename and path.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current section are saved.

7.3.6 Import

7.3.6.1 Import from GRD

GRD files are created by many popular programs such as VERM, Anadelta, Odos as
well as Hydraulic programs by TechnoLogismiki. They contain geometric information
on a prismatic cross section with straight edges as well as the title of the section,
station data etc.

To import a GRD file:

1. Select Import from the File menu.
2. Select from GRD file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"GRD file" with the extension .grd.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. Depending on the contents of the file,
there are two cases.
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Case 1

The GRD file contains only one section. In this case, the current section data are
erased and substituted by the imported section.

Case 2

The GRD file contains more than one sections. In this case, a dialog box appears that
allows the selection of a single section. Select the section that you wish to import. 

Select Ok to proceed. The current section data are erased and substituted by the
selected section. Select Cancel to cancel the operation.

7.3.6.2 Import from PCS

PCS files can be created by Hydraulic programs (by TechnoLogismiki) version 2.0 or
later. It is the preferred way to exchange section data between programs and users.
Each file contains a single section, with information on the prismatic section and the
friction coefficient of each edge.

To import a section from a PCS file:

1. Select Import from the File menu.
2. Select from PCS file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"PCS file" with the extension .pcs.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The current section data are erased and
substituted by the imported. Select Cancel to cancel the operation.
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7.3.6.3 Import from DXF

DXF files are recognized by virtually all CAD programs (AutoCAD, IntelliCAD,
Microstation etc) as well as TechnoLogismiki's products.

DXF files contain information in layers. You can select one or more layers that contain
the section data.

To import a section from a DXF file:

1. Select Import from the File menu.
2. Select Import from DXF from the Import menu. The following dialog box
appears:

3. Click Browse.
4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"DXF files" with the extension .dxf.
6. Select the file by clicking on it.
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7. Select Open to open and analyze the file. The list in the Layer frame is loaded with
the layers contained in the DXF file.
8. Select one or more layers that contain section data. The quick keys (Select all,
Select None, Select Invert) can be used to quickly select all layers, deselect all
layers and invert the current selection.

9. Select Ok to proceed. Select Cancel to close the dialog box with no changes.

NOTE: The current DXF driver can import the following entities:
Polylines
LWPolylines
Circles

If there are no recognizable entities, an error message will be displayed.

7.3.6.4 Import from ArcView Shapefile

Shapefiles can be created by several programs such as ArcView GIS, MapInfo, GPS
Trackmaker etc. In reality, this "file" consists of three files with the extensions shp,
shx and dbf. The GIS driver recognizes the following shapefile types:

Nullshape
Point/PointM/PointZ
MultiPoint/MultiPointM/MultiPointZ
PolyLine/PolyLineM/PolyLineZ

Shapefiles containing Polygons (simple, M and Ζ) and Multipatch are not recognized.

To import data from a shapefile:
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1. Select Import from the File menu.
2. Select from ArcView Shapefile from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"SHP file" with the extension .shp.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The section contained in the shapefile is
imported into the editor. Select Cancel to cancel the operation.

7.3.7 Export

7.3.7.1 Export to GRD

With this option, a GRD file containing the current section data created. GRD files
contain geometric information on a prismatic cross section with straight edges as well
as the title of the section, station data etc.

To export sections to a GRD file:

1. Select Export from the File menu.
2. Select Export to GRD file from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on the friction coefficients and curved edges (if any) will not be
exported as they are not supported by the file format.
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7.3.7.2 Export to PCS

With this option, you can create a PCS file containing data on the geometry of the
current section.

To export a section to a PCS file:

1. Select Export from the File menu.
2. Select Export To PCS from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on curved edges (if any) will not be exported as they are not
supported by the file format.

7.3.7.3 Export to DXF

DXF files are recognized by virtually all CAD programs (AutoCAD, IntelliCAD,
Microstation etc) as well as TechnoLogismiki's products.

To export a section to a DXF file:

1. Select Export from the File menu.
2. Select Export to DXF from the Export menu.
3. The DXF driver configuration form appears:

4. Make the appropriate selections. Click Ok to proceed to the filename selection form.
Click Cancel to cancel the operation.
5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to create the file. Select Cancel to cancel the operation.



Sections 87

© 2012 TechnoLogismik i

7.3.7.4 Export to ArcView Shapefile

With this option, you can create a shapefile that can be used by programs such as
ArcView GIS, MapInfo, GPS Trackmaker and other. 

To export the current section to an ArcView Shapefile:

1. Select Export from the File menu.
2. Select Export To ArcView Shapefile from the Export menu.
3. Select the shape type from the drop-down list.

4. Select Ok to proceed. Select Cancel to abort the operation and close the dialog
box.
5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to create the file. Select Cancel to cancel the operation.
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NOTE: Not all shape types are compatible with all programs.

7.3.7.5 Export to Bitmap

With this option, you can export (in BMP format) the sketch of the section, as it
appears in main form of the section editor.

To export the sketch of the section:

1. Select Export from the File menu.
2. Select Export to bitmap from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

7.3.8 Print sketch

With this option, you can print the sketch of the section, as it appears in main form of
the section editor, directly to a printer.

To print the sketch of the section:

1. Select Print sketch from the File menu.
2. Select the appropriate printer device.
3. You can optionally configure the printer device by clicking the Configure button.
This will show the default printer driver configuration dialog box. Refer to the printer's
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manual for more information.
4. Select Ok to print the sketch. Select Cancel to cancel the operation.

7.3.9 Print section data

With this option, you can prepare a report containing the section data. Note that with
this option the report is not printed directly; instead, a document is prepared and a
preview of the printout is created by the Print manager. You can print the report by
clicking the Print button of the toolbar of Print manager.

To create a report with the section data:

1. Select Print section data from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.
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NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.

7.3.10 Print section data to

7.3.10.1 Microsoft Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the section data can be created. Note
that Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the section data to a Microsoft Excel file:

1. Select Print section data to from the File menu.
2. Select Microsoft Excel from the Print section data to menu.

7.3.10.2 Microsoft Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the section data can be created. Note
that Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the section data to a Microsoft Word file:

1. Select Print section data to from the File menu.
2. Select Microsoft Word from the Print section data to menu.

7.3.10.3 Text file

With this option, you can create a simple text file containing the section data. This file
is recognized and can be further modified by word processors such as Microsoft Word,
OpenOffice Writer etc.

To print to a text file:

1. Select Print section data to from the File menu.
2. Select Text file from the Print section data to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.
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NOTE: If a file with the same name and in the same location already exists, a
warning message will appear that asks whether to overwrite the file or not. If you
answer Yes, then the existing file is erased and the new file takes its place. If you
answer No, the existing file remains intact but the report is NOT printed.

7.3.11 Close

With this option, you can close the Section editor and return to section input.

To close the Section editor:

1. Select Close from the File menu.
2. Select Yes if you want to save the changes and return to section input. Select No if
you want to discard the changes and return to section input. Select Cancel if you want
to cancel the operation and return to Section editor.

7.4 Edit

7.4.1 Edit menu

With this menu, you can add and modify the section data. In the Edit menu you can
select one of the following options:

Add polygon
Remove polygon
Add vertex
Insert vertex
Remove vertex
Select all
Cut
Copy
Paste
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7.4.2 Add polygon

With this option, you can add a curvilinear polygon to the section  i.e. an open or
closed polyline with straight or curved edges. A section must contain at least one
polygon. There is no restriction in the number of nodes of the polygon.

To add a polygon:

1. Select Add polygon from the Edit menu.
2. A polygon is added to the drop-down list of the polygons.

NOTE: This option is not available when entering ground and excavation data, as they
must consist of a single polygon.

7.4.3 Remove polygon

With this option, you can remove a curvilinear polygon from the section.

To remove a polygon:

1. Select the polygon from the drop-down list.
2. Select Remove polygon from the Edit menu.
3. The polygon is deleted. You will be asked for confirmation only if you have selected
to confirm deletions in the General preferences tab. If you select No then the deletion
is canceled.

NOTE: This option is not available when entering ground and excavation data, as they
must consist of a single polygon.

7.4.4 Add vertex

With this option, you can add a vertex to the currently selected polygon. The vertex is
appended to the data matrix.

To add a vertex:

1. Select the polygon from the drop-down list.
2. Select Add vertex from the Edit menu.
3. A vertex is appended to the data matrix of the currently selected polygon.

NOTE: This option is not available when there is no polygon in the section. In this
case, add a polygon before adding a vertex.

7.4.5 Insert vertex

With this option, you can add a vertex to the selected polygon. The vertex is inserted
before the currently selected vertex of the currently selected polygon.

To insert a vertex:
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1. Select the polygon from the drop-down list.
2. Select Insert vertex from the Edit menu.
3. A vertex is inserted before the selected vertex of the currently selected polygon.

NOTE: This option is not available when there is no polygon in the section. In this
case, add a polygon before inserting a vertex.

7.4.6 Remove vertex

With this option, you can remove a vertex of the currently selected polygon.

To remove a vertex:

1. Select the polygon from the drop-down list.
2. Select the vertex from the data matrix.
3. Select Remove vertex from the Edit menu.
4. The currently selected vertex of the currently selected polygon is removed.

NOTE: Each polygon must consist of at least two nodes. These nodes cannot be
removed.

7.4.7 Select all

With this option, you can select all vertices of the currently selected polygon.

To select all vertices:

1. Select Select all from the Edit menu
2. All vertices of the currently selected polygon are selected.

7.4.8 Cut

With this option, you can cut the currently selected cells of the data matrix and
transfer them to the clipboard.

To cut:

1. Select the cells you wish to cut from the data matrix.
2. Select Cut from the Edit menu.
3. All selected cells of the data matrix are cut and transferred to the clipboard.

7.4.9 Copy

With this option, you can copy the currently selected cells of the data matrix to the
clipboard.

To copy:

1. Select the cells you wish to copy from the data matrix.
2. Select Copy from the Edit menu.
3. All selected cells of the data matrix are copied to the clipboard.
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7.4.10 Paste

With this option, you can paste data from the clipboard to the data matrix.

To paste:

1. Select the top left cell of the range where you want to paste the data.
2. Select Paste from the Edit menu.
3. The data are pasted from the clipboard to the data matrix.

NOTES:
The appropriate number of columns and rows is automatically identified by the
program.
With this option you can transfer data from other programs, such as Microsoft
Excel.

7.5 View

7.5.1 View menu

With this menu, you can modify the way you view the section. In the View menu you
can select one of the following options:

Zoom extent
Zoom window
Zoom previous
Zoom in
Zoom out
Display vertices
Display origin
Display grid
Display data matrix
Toggle excavations / section

7.5.2 Zoom extent

With this option, you can view the whole section.

To view the whole section:

1. Select Zoom extent from the View menu.
2. The viewport is adjusted automatically to include the whole section.

NOTE: This option is also available in the toolbar.

7.5.3 Zoom window

With this option, you can zoom to a specified window.

To zoom to a window:

1. Select Zoom window from the View menu.
2. Click on the drawing to define one corner of the window or hit ESC to cancel the
procedure.
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3. Click on the drawing to define the opposite corner of the window or hit ESC to
cancel the procedure.
4. The viewport is adjusted automatically to zoom to the specified window.

NOTE: This option is also available in the toolbar.

7.5.4 Zoom previous

With this option, you can revert to the previous zoom configuration.

To use the previous zoom configuration:

1. Select Zoom previous from the View menu.
2. The previous zoom configuration is applied.

NOTE: This option is also available in the toolbar.

7.5.5 Zoom in

With this option, you can zoom in to a specified point.

To zoom in to a specified point:

1. Select Zoom in from the View menu.
2. Click on the drawing to define the point to zoom in to or hit ESC to cancel the
procedure.
3. The zoom factor is doubled and the viewport is adjusted to zoom in to the specified
point.

NOTE: This option is also available in the toolbar.

7.5.6 Zoom out

With this option, you can zoom out from a specified point.

To zoom out from a specified point:

1. Select Zoom out from the View menu.
2. Click on the drawing to define the point to zoom out from or hit ESC to cancel the
procedure.
3. The zoom factor is halved and the viewport is adjusted to zoom out from the
specified point.

NOTE: This option is also available in the toolbar.

7.5.7 Pan

With this option, you can move the drawing within the viewport.

To pan the drawing:

1. Select Pan from the View menu.
2. Click and drag on the drawing to move it within the viewport or hit ESC to cancel
the procedure.
3. The drawing is moved within the viewport.
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NOTE: This option is also available in the toolbar.

7.5.8 Display vertices

With this option, you can show or hide the vertices of the currently selected polygon.

To show or hide the vertices of the currently selected polygon:

1. Select Display vertices from the View menu.
2. If the vertices are visible then they become hidden and vice versa. If the option is
active then there is a tick on the left of the menu.

7.5.9 Display origin

With this option, you can show or hide the origin i.e. the point corresponding to (0,0).

To show or hide the origin:

1. Select Display origin from the View menu.
2. If the origin is visible then it becomes hidden and vice versa. If the option is active
then there is a tick on the left of the menu.

7.5.10 Display grid

With this option, you can show or hide the grid.

To show or hide the grid:

1. Select Display grid from the View menu.
2. If the grid is visible then it becomes hidden and vice versa. If the option is active
then there is a tick on the left of the menu.

7.5.11 Display data matrix

With this option, you can show or hide the data matrix.

To show or hide the data matrix:

1. Select Display data matrix from the View menu.
2. If the data matrix is visible then it becomes hidden and vice versa. If the option is
active then there is a tick on the left of the menu.

7.5.12 Toggle excavations / section

With this option, you can set whether the data matrix will display section data or
excavation data.

To toggle between section and excavation data:

1. Select Toggle excavations / section from the View menu.
2. If the data matrix contains section data then it will be loaded with excavation data
and vice versa.

NOTE: When the data matrix contains excavation data, the drop-down list of
polygons is loaded with two polygons, namely the excavation line and the natural
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ground line.

7.6 Options

7.6.1 Options menu

With this menu, you can modify the way you view the section. In the Options menu
you can select one of the following options:

Background color
Interior color
Grid
Edge pen color
Edge pen width
Inactive vertices
Water area
Excavations

7.6.2 Background color

With this option, you can change the background color of the drawing. The default
value is white.

To change the background color:

1. Select Background color from the Options menu.
2. The color selection dialog box appears.
3. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

7.6.3 Interior color

With this option, you can change the interior color of closed polygons. The default
value is grey.
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To change the interior color of closed polygons:

1. Select Interior color from the Options menu.
2. The color selection dialog box appears.
3. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

7.6.4 Grid

With this option, you can change the color and line style of the grid. Note that in order
to view the changes the grid must be visible.

To change the color and line style of the grid:

1. Select Grid from the Options menu.
2. The grid options dialog box appears:

3. Select Color to change the color of the line.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

4. Select Line to change the line style.
4.1. The line style selection dialog box appears.
4.2. Select the line style and width. The currently selected color is marked with a tick.
On top of the Cancel button, the old and the new color are displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

5. Click Ok to save the grid options and close the dialog box or click the Cancel
button to close the dialog box without saving the changes.

7.6.5 Edge pen color

With this option, you can change the pen color of the polygon edges.

To change the pen color of the polygon edges:

1. Select Edge pen color from the Options menu.
2. The edge pen color dialog box appears:



Flood flows100

© 2012 TechnoLogismik i

3. Select One common color to use a single color for all edges. Select Gradient
color to use an intermediate color between two colors depending on the friction of the
edge.

A. One common color

4. Select Color to change the color of the pen.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

B. Gradient color

4. Two colors must be defined. The first corresponds to the minimum friction and the
second to the maximum friction value. These values are displayed next to the
corresponding picture boxes. Select the appropriate Color button to change the
corresponding color.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

5. Repeat step 4 with the second color, if necessary.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

Example of section with gradient edge color

NOTE: You can combine gradient color with varying pen width.

7.6.6 Edge pen width

With this option, you can change the pen width of the polygon edges.

To change the pen width of the polygon edges:

1. Select Edge pen width from the Options menu.
2. The edge pen width dialog box appears:

3. Select One common width to use a single width for all edges. Select
Proportional to friction to use an intermediate width between two values depending
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on the friction of the edge.

A. One common width

4. Select the appropriate width using the slider.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

B. Proportional to friction

4. Two values must be defined. The first corresponds to the minimum friction and the
second to the maximum friction. These values are displayed next to the corresponding
labels. Select the appropriate width using the corresponding slider.

5. Repeat step 4 with the second width, if necessary.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

Example of section with proportional edge width

NOTE: You can combine proportional width with varying pen color.
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7.6.7 Inactive vertices

With this option, you can change the color and pen width of the edges between
inactive vertices.

To change the color and pen width of the inactive edges:

1. Select Inactive vertices from the Options menu.
2. The inactive vertices dialog box appears:

3. Select Change to change the color of the pen.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

4. Select the appropriate pen width using the slider.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

7.6.8 Water area

With this option, you can change the interior color of water areas. You can also change
the pen color and width of the free width.

To change the interior color of water areas or the pen color and pen width of the free
width:

1. Select Water areas from the Options menu.
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2. The following dialog box appears:

3. Select Change from the Color frame to change the interior color for water areas.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

4. Select Change from the Free width frame to change the pen color for free width.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

5. Select the appropriate pen width using the slider.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The free width is not visible in pressure sections.

7.6.9 Excavations

With this option, you can change the color and line styles of objects related to
excavations.

To change the color and line styles of objects related to excavations:

1. Select Excavations from the Options menu.
2. The following dialog box appears:

3. Select Change from the Excavations frame to change the interior color for
excavations.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

4. Select Change from the Landfills frame to change the interior color for landfills.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

5. Select Change from the Ground frame to change the pen color for the ground line.
5.1. The color selection dialog box appears.
5.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
5.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

6. Select the appropriate pen width of the ground line using the slider of the Ground
frame.

7. Select Change from the Excavation frame to change the pen color for the
excavation line.
7.1. The color selection dialog box appears.
7.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
7.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

8. Select the appropriate pen width of the excavation line using the slider of the
Excavation frame.
9. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: In order for excavations or landfills to be calculated, the ground and
excavation line must intersect each other. However, the presence of excavation or
landfill areas is not compulsory.
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7.7 Calculations

7.7.1 Calculation menu

With this menu, you have access to several computational tools. In the Calculations
menu you can select one of the following options:

Origin
o Enter origin coordinates

o Enter origin graphically

o Set origin to deep point

Active nodes
Select flow depth
Full flow

7.7.2 Origin

7.7.2.1 Enter origin coordinates

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) analytically. The coordinates of all vertices are
changed to comply with the new origin of the coordinate system.

To set the coordinates of the origin analytically:

1. Select Origin from the Calculations menu.
2. Select Enter origin coordinates from the Origin menu.
3. The origin coordinates dialog box appears.
4. Type the appropriate coordinates in the text boxes.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0.

7.7.2.2 Enter origin graphically

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) graphically. The coordinates of all vertices are
changed to comply with the new origin of the coordinate system.

To set the coordinates of the origin graphically:

1. Select Origin from the Calculations menu.
2. Select Enter origin graphically from the Origin menu.
3. Click the desired point on the drawing or hit ESC to cancel the operation.
4. The coordinates of the origin are changed.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0 analytically.
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7.7.2.3 Set origin to deep point

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) equal to those of the deep point of the section. The
coordinates of all vertices are changed to comply with the new origin of the coordinate
system.

To set the coordinates of the origin equal to those of the deep point:

1. Select Origin from the Calculations menu.
2. Select Set origin to deep point from the Origin menu.
3. The coordinates of the origin are set equal to those of the deep point of the section.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0 analytically.

7.7.3 Active nodes

With this option, you can set the active nodes (vertices) of a section. By default, all
nodes are active; therefore, the flow may occur anywhere in the section.

However, if we know that the flow occurs between vertex 4 and 10 of the above
example, we must deactivate vertices 0 to 4.

To select the active nodes (vertices):

1. Select Active nodes from the Calculations menu.
2. Select the polygon in question, the lower active index (in this case, 4 instead of 0)
and the upper active index (in this case, the same node i.e. node 10 is selected).
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3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

If you select 4 as the first active vertex in the above example, the flow is confined to
the right riverbed:

NOTE: The inactive edges are drawn with different pen color and size, according to
the preferences of the program.

7.7.4 Select flow depth

With this option, you can set a trial flow depth. This may be a value between 0 and
the maximum flow depth. This option is used for demonstrating the way the section is
filled for various depths and it is not used in calculations.

To set a trial depth:

1. Select Select flow depth from the Calculations menu.
2. The flow depth selection dialog box appears.
3. Type the trial flow depth in the text box. The maximum flow depth is displayed in
the label beneath the text box.
4. Alternatively, click Maximum to use the maximum flow depth.
5. Click Ok to close the dialog box and apply the selected flow depth. Click Cancel to
close the dialog box without changing the flow depth.
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7.7.5 Full flow

With this option, you can view the way the section is filled in an animated way. After
the animation, the full flow configuration of the section is displayed.

To view the way the section is filled in an animated way and view the full flow
configuration of the section:

1. Select Full flow from the Calculations menu.
2. The flow depth is increased from 0 to its maximum value.



Chapter

VIII
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8 Databases

8.1 Fluid database

For your convenience, a fully customizable fluid database is embedded in the program.
The fluid database is invoked in various cases within the program. By selecting an
appropriate fluid record and clicking Ok, the data is transferred to the corresponding
fields. Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the name of the fluid. This field is required.
3. Enter the temperature, density, viscosity and kinematic viscosity of the fluid.
4. The specific weight is calculated automatically.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
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3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.2 Friction database

For your convenience, a fully customizable friction database is embedded in the
program. The friction database is invoked in various cases within the program. By
selecting an appropriate friction record (which is depended on the selected friction
formula) and clicking Ok, the data is transferred to the corresponding fields. Select
Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:
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1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the friction.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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NOTE: In case of Manning friction coefficients in natural streams, you can estimate
the values based on several characteristics of the stream. Click on the buttons with
the ellipses (...) next to the text boxes to invoke the following dialog box: 

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
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8.3 Manning friction coefficients

Surface / Material
Mean
Value

Aluminum 0.024

Asbestos cement 0.013

Asphalt ditch 0.016

Asphalt pavement 0.016

Asphalt smooth 0.013

Asphalted cast iron 0.012

Natural ground 0.020

Best concrete 0.010

Brick in mortar 0.015

Brick sewer 0.015

Cast iron 0.012

CMP 0.024

Concrete 0.013

PVC 0.010

Centrifugal spun 0.013

Concrete (steel forms) 0.011

Concrete (wood forms) 0.015

Concrete gutter (broom finish) 0.016

Concrete gutter (troweled finish) 0.012

Copper 0.011

Fiber glass roving 0.011

Gravel riprap (D=25) 0.033

Gravel riprap (D=50) 0.041

Grouted riprap 0.030

Natural stream (clean) 0.030

Natural stream (stone) 0.050

Natural stream (weedy) 0.035

8.4 Bazin friction coefficients

Surface / Material
Max

value
Min

value
Mean
value

Rough concrete 0.5 0.4 0.46

Smooth concrete 0.08 0.04 0.06

Brick in mortar 0.018 0.014 0.016

Sewer pipes (Greek regulations
696/74)

0.25 0.25 0.25

Storm pipes (Greek regulations
696/74)

0.46 0.46 0.46
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8.5 Hazen - Williams friction coefficients

Surface / Material
Mean
value

Asbestos cement 140

Asphalted cast iron 130

Best concrete 150

Centrifugal spun 135

Concrete (wood forms) 120

Concrete (steel forms) 140

Copper 135

Ductile iron 130

Galvanized iron 120

Glass 140

PVC 150

Riveted steel (new, rough) 80

Riveted steel (new, smooth) 110

Steel 120

Wood (new) 140

8.6 Darcy - Weisbach friction coefficients

Surface / Material
Mean
value
(mm)

Aluminum 0.300

Asbestos cement 0.002

Asphalted cast iron 0.120

Best concrete 0.366

Brick in mortar 0.610

Sewer brick 0.610

CMP 0.305

Concrete 0.122

Centrifugal spun 0.366

Concrete (steel forms) 1.829

Concrete (wood forms) 0.610

Copper 0.002

Galvanized steel 1.520

Glass 0.001

PVC 0.122

HDPE 0.150
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8.7 Topography coefficient

For your convenience, a topography coefficient database is embedded in the program. 

To select the topography coefficient:

1. Click the cell containing the desired value.
2. Click Ok to transfer the data to the corresponding fields and close the database.
Select Cancel to close the database without transferring any data.

8.8 IDF database

For your convenience, a fully customizable IDF (Intensity - Duration - Frequency)
curves database is embedded in the program. The IDF database is invoked in various
cases within the program. By selecting an appropriate record and clicking Ok, the data
is transferred to the corresponding fields. Select Cancel to close the database without
transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database. Note that the database was built using data from various resources in the
literature; you need to be cautious when using a curve.

To add a new record:

1. Click Add to open the new record dialog box.
2. Enter the area and optionally the description of the record.
3. Enter the return period in years. This value was used for the calculation of the IDF
curve and is for reference purposes only; it is not used in the calculations.
4. Enter the dimensionless coefficients c, b, n, in such a way that when time is
entered in hours, the intensity is given in mm/hr.
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5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked for confirmation only if you
have selected to confirm deletions in the General preferences tab. 
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.9 Runoff coefficient database

For your convenience, a fully customizable runoff coefficient database is embedded in
the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories. Usually, the category defines the
regulations (e.g. FHWA, 2001).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the runoff coefficient.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

NOTE: You can calculate the mean runoff coefficient for complex areas with known
runoff coefficients. Click on the buttons with the ellipses (...) next to the text boxes to
invoke the following dialog box:

Click the plus sign (+) to add a new area. Type the runoff coefficient and the area in
m2. The total area and the mean runoff coefficient is displayed in the Results frame.
Click the minus sign (-) to delete the selected area. The area is deleted with no
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confirmation.

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.10 Izzard deceleration coefficient

For your convenience, a fully customizable Izzard deceleration coefficient database is
embedded in the program. The database is invoked in various cases within the
program. By selecting an appropriate record and clicking Ok, the data is transferred to
the corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories. Usually, the category defines the
calculation formula (e.g. Manning and % impervious ground function).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the Izzard deceleration
coefficient.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.



Flood flows126

© 2012 TechnoLogismik i

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.11 Espey channel coefficient database

For your convenience, a fully customizable Espey channel coefficient database is
embedded in the program. The database is invoked in various cases within the
program. By selecting an appropriate record and clicking Ok, the data is transferred to
the corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the
calculation formula (e.g. Manning and % impervious ground function).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.
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To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the Espey channel coefficient.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.12 SCS curve number database

For your convenience, a fully customizable SCS curve number database is embedded
in the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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To add a new record:

1. Click Add to open the new record dialog box.
2. Type the description and optionally the details.
3. Enter the condition, imperviousness, soil type (A, B, C or D) and curve number (0-
100).

Soil type A: Soils having high infiltration rates, even when thoroughly wetted
and consisting chiefly of deep, well to excessively-drained sands or gravels. These
soils have a high rate of water transmission.
Soil type B: Soils having moderate infiltration rates when thoroughly wetted and
consisting chiefly of moderately deep to deep, moderately fine to moderately
coarse textures. These soils have a moderate rate of water transmission.
Soil type C: Soils having slow infiltration rates when thoroughly wetted and
consisting chiefly of soils with a layer that impedes downward movement of
water, or soils with moderately fine to fine texture. These soils have a slow rate of
water transmission.
Soil type D: Soils having very slow infiltration rates when thoroughly wetted and
consisting chiefly of clay soils with a high swelling potential, soils with a
permanent high water table, soils with a clay pan or clay layer at or near the
surface, and shallow soils over nearly impervious material. These soils have a very
slow rate of water transmission.

4. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:
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1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked for confirmation only if you
have selected to confirm deletions in the General preferences tab.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
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