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1 About the program

1.1 What does the program do?

This program allows the calculation of flow problems in:

sections with free surface
sections under pressure
orifices
weirs
grates
curbs
combination inlets
ditches
slots
pumps
reaction turbines
impulse turbines
hydropower pumps

For the calculation of the linear friction losses several formulas may be used, such as
Hazen - Williams, Manning, Kutter, Bazin etc. The friction coefficients can also be
calculated from several formulas, according to the preferences of the user.

For each type of problem a number of solvers may be invoked, based on the available
data. For example, for the flow with free surface, the unknown variable may be the
flow depth for given flow rate and slope or the unknown variable may be the flow rate
for given flow depth and slope etc.

The rating tools (rating graphs or rating tables) allow the optimum design of sections
based on custom criteria. The rating graph is created for a specific output subject to
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variation of up to two variables, whereas the rating table is created for a specific
output subject to variation of up to five variables.

1.2 Minimum requirements

The minimum requirements for the usage of the programs are the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium III 800 MHz
800x600 with 256 color palette
700 MB free disk space
CD-Rom

If your system does not meet one or more of the above requirements, it is highly
recommended that you upgrade it before installing the programs. The recommended
system configuration is the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium IV 2.0 GHz
1280x768 with 16-bit color palette
1.2 GB free disk space
CD-Rom
Internet connection

1.3 Technical support

Support through the Internet

TechnoLogismiki offers technical support 24 hours per day, 365 days per year, through
the web site where you can get information on the latest programs and services.

Support by e-mail

Please use the dedicated e-mail addresses for better customer service:

for questions regarding sales: sales@technologismiki.com
for questions regarding the usage of programs: support@technologismiki.com
for any other question or comment: info@technologismiki.com

The normal response time is within two business days. If your inquiry cannot be
answered by e-mail, a customer service representative will contact you by telephone.

Interactive Support

Business days, 09:00 - 17:00 Eastern European Time:

Telephone [3 lines]: ++30-210-656-4147
Fax: ++30-210-654-8461
Address: 5, Imittou street, Cholargos, 15561, Athens, Greece.
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2 File

2.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New project
Open project
Save project
Save project as
Import
o Solution from file

o From GRD file

o From PCS file

o From ArcView Shapefile

Export
o Solution to file

o To GRD file

o To PCS file

o To ArcView Shapefile

o Export sketch

Print setup
Print
Print to
o Print to file

o Print to Word

o Print to Word (Formatted)

o Print to Excel

Exit

2.2 New project

With this option, a new project is started. All data, results, graphs, titles etc. of the
previous project are erased.

To create a new project:

1. Select New project from the File menu.
2. If a project is already loaded and changes have been made, a warning message will
appear that asks the user whether to save the changes or not.
3. The current project is erased and a new project is started.

2.3 Open project

With this option, an existing project is loaded. The project may be stored locally, in a
network or in an external media device such as a CD-Rom. If a project is already
loaded and changes have been made, a warning message will appear that asks
whether to save the changes or not. When a project is loaded, all data of the previous
project are lost.
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To open an existing project:

1. Select Open project from the File menu.
2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Hydraulic solver project" with the extension .m01.
4. Select the file by clicking on it.
5. Select Open to open the selected file. Select Cancel to cancel the operation.

NOTE: You can find sample projects in the installation folder of the program:
C:\Program Files\TechnoLogismiki\TLW2013\Samples\HydraulicSolver

Supported file types

Μ01 (Hydraulic solver project): Files created by version 2012 and 2013 of Hydraulic
solver.
Μ501 (Hydraulic solver project): Files created by versions 2011, 2010, 2009, 2008,
2007 and 5.0 of Hydraulic solver.
M521 (Hydropower works v5.xx): Files created by Hydropower works version 5.0.
This program has been merged with Hydraulic solver 2007 or later and has been
discontinued.
MB9 (Free surface sections v4.xx): Files created by Free surface sections version
4.0. This program has been merged with Hydraulic solver 2007 or later and has been
discontinued.
Μ10 (Flow under pressure v4.xx): Files created by Flow under pressure version 4.0.
This program has been merged with Hydraulic solver 2007 or later and has been
discontinued.
MB1 (Hydraulic pump v4.xx): Files created by Hydraulic pump version 4.0. This
program had been updated to version 5.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
Μ21 (Hydropower works v4.xx): Files created by Hydropower works version 4.0.
This program had been updated to version 5.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
ΜΒ9 (Section solver v3.xx): Files created by Section solver version 3.0. This
program had been updated to version 5.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
Μ10 (Flow under pressure v3.xx): Files created by Flow under pressure version 3.0.
This program had been updated to version 4.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
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ΜΒ1 (Hydraulic pump v3.xx): Files created by Hydraulic pump version 3.0. This
program had been updated to version 4.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
Μ21 (Hydropower works v3.xx): Files created by Hydropower works version 3.0.
This program had been updated to versions 4.0 and 5.0 but now it has been merged
with Hydraulic solver 2007 or later and has been discontinued.
ΜΒ2 (Section solver v2.xx): Files created by Section solver version 2.0 or earlier.
This program had been updated to version 3.0 and 4.0 but now it has been merged
with Hydraulic solver 2007 or later and has been discontinued.
ΜΒ5 (Uniform flow v2.xx): Files created by Uniform flow version 2.0 or earlier. This
program had been discontinued since version 3.0 and now it has been merged with
Hydraulic solver 2007 or later.
Μ10 (Flow under pressure v2.xx): Files created by Flow under pressure version 2.0.
This program had been updated to version 3.0 and 4.0 but now it has been merged
with Hydraulic solver 2007 or later and has been discontinued.
ΜΒ1 (Hydraulic pump v2.xx): Files created by Hydraulic pump version 2.0. This
program had been updated to version 3.0 and 4.0 but now it has been merged with
Hydraulic solver 2007 or later and has been discontinued.
BCK (Backup files): If you have selected from program options the creation of
backup copy when a file is loaded, then the file can be loaded by selecting Backup
files (*.bck) from the Files of type drop-down list.
*.* (All files): Displays all files in the current folder.

Backwards compatibility

This version implements full backwards compatibility; therefore, the loading of a
project that has been created with older versions of the program or other programs
that have been merged with Hydraulic solver is guaranteed. Note however that when a
project is saved with the latest format, it cannot be used by previous versions.

NOTE: If the message "Could not load project. File may be corrupt or saved by an
unknown or incompatible version of the program" appears, then either you are trying
to load a project that does not belong to this program or the file is used (and locked)
by another process in your computer.

2.4 Save project

With this option, you can save all data of a project into a file. The file can be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you attempt to save a project.
When the filename and path are set, all subsequent saves will be made to the same
file.

When you want to rename a file or save it in a new location, use Save project as...
from the File menu.

To save the current project:

1. Select Save project from the File menu.
2. If the location of the file is already set, the project is saved to this file without any
messages. If the filename is not set, a dialog box will appear that allows the selection
of the filename and path.
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2.5 Save project as

With this option, the current project is saved just as in the case of Save project, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.

To save a project with another name and/or to another location:

1. Select Save project as from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current project are saved.

2.6 Import

2.6.1 Solution from file

A project may contain one or more solutions. With this option, solutions in files with
the extension .sln can be imported in the current project. You can create solution files
by exporting a solution.

To import solutions from an existing file to the current project:

1. Select Import from the File menu.
2. Select Solution from file from the Import menu.
3. Select the location of the solution file.
4. Select the file type from the Files of type drop-down list. The default option is
"SLN file" with the extension .sln.
5. Select the file by clicking on it.
6. Select Open to import the solution to the current project. The solution is appended
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to the end of the list of the solutions. Select Cancel to cancel the operation.

NOTE: With this option, you can import solutions exported by the same version of the
program.

2.6.2 From GRD file

GRD files are created by many popular programs such as VERM, Anadelta, Odos as
well as Hydraulic programs by TechnoLogismiki. They contain geometric information
on a prismatic cross section with straight edges as well as the title of the section,
station data etc.

To import a GRD file:

1. Select Import from the File menu.
2. Select from GRD file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"GRD file" with the extension .grd.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. Depending on the contents of the file,
there are two cases.

Case 1

The GRD file contains only one section. In this case, a new solution of flow with free
surface with no calculations is appended to the list of solutions of the current project.
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Case 2

The GRD file contains more than one sections. In this case, a dialog box appears that
allows the selection of one or more sections. Select the sections that you wish to
import to the project. 

The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all sections, deselect all sections and invert the current selection.

Select Ok to proceed. For each of the selected sections, a new solution of flow with
free surface with no calculations is appended to the list of solutions of the current
project. Select Cancel to close the dialog box with no changes.

NOTE: By default, the type of the new solutions is set to flow with free surface with
no calculations. You can change the type of the solution by selecting Change solution
from the Data menu.

2.6.3 From PCS file

PCS files can be created by Hydraulic programs (by TechnoLogismiki) version 2.0 or
later. It is the preferred way to exchange section data between programs and users.
Each file contains a single section, with information on the prismatic section and the
friction coefficient of each edge.

To import a section from a PCS file:

1. Select Import from the File menu.
2. Select from PCS file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"PCS file" with the extension .pcs.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. A new solution of flow with free surface
with no calculations is appended to the list of solutions of the current project. Select 
Cancel to cancel the operation.
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NOTE: By default, the type of the new solutions is set to flow with free surface with
no calculations. You can change the type of the solution by selecting Change solution
from the Data menu.

2.6.4 From ArcView Shapefile

Shapefiles can be created by several programs such as ArcView GIS, MapInfo, GPS
Trackmaker etc. In reality, this "file" consists of three files with the extensions shp,
shx and dbf. The GIS driver recognizes the following shapefile types:

Nullshape
Point/PointM/PointZ
MultiPoint/MultiPointM/MultiPointZ
PolyLine/PolyLineM/PolyLineZ

Shapefiles containing Polygons (simple, M and Ζ) and Multipatch are not recognized.

To import data from a shapefile:

1. Select Import from the File menu.
2. Select from ArcView Shapefile from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"SHP file" with the extension .shp.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. A new solution of flow with free surface
with no calculations is appended to the list of solutions of the current project. Select 
Cancel to cancel the operation.
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NOTE: By default, the type of the new solutions is set to flow with free surface with
no calculations. You can change the type of the solution by selecting Change solution
from the Data menu.

2.7 Export

2.7.1 Solution to file

A project may contain one or more solutions. With this option, a file containing a
single solution from the current project can be exported. This is the preferred option
when you want to send a solution to another user.

To export a solution to a file:

1. Select the solution containing the section data you wish to export from the list in
the main form.
2. Select Export from the File menu.
3. Select Solution to file from the Export menu.
4. Select the location of the new file.
5. Type the filename in the File name text box.
6. Select Save to create the solution file with the extension .sln. Select Cancel to
cancel the operation.

To import a solution from a file, select Solution from file from the File > Import
menu.
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NOTE: A solution file contains a single solution only. The solution currently selected in
the list of the main form will be saved in the file.

2.7.2 To GRD file

With this option, a GRD file containing the sections of one or more solutions of the
current project is created. GRD files contain geometric information on a prismatic cross
section with straight edges as well as the title of the section, station data etc.

To export sections to a GRD file:

1. Select Export from the File menu.
2. Select To GRD file from the Export menu.
3. The solutions included in the current project are analyzed. If there are no solutions
that contain section data then the process is terminated automatically. If there are
more than one solutions that contain section data, then the process is lead to step 4,
or else to step 5.
4. A dialog box appears that allows the selection of the solutions that will be included
in the GRD file. The quick keys (Select all, Select None, Select Invert) can be used
to quickly select all solutions, deselect all solutions and invert the current selection. 

5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on the friction coefficients and curved edges (if any) will not be
exported as they are not supported by the file format.
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2.7.3 To PCS file

With this option, you can create a PCS file containing data on the geometry of the
section of the selected solution.

To export a section to a PCS file:

1. Select the solution containing the section data you wish to export from the list in
the main form.
2. Select Export from the File menu.
3. Select To PCS file from the Export menu.
4. Select the path of the file.
5. Type the filename in the File name text box.
6. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on curved edges (if any) will not be exported as they are not
supported by the file format.

2.7.4 To ArcView Shapefile

With this option, you can create a shapefile that can be used by programs such as
ArcView GIS, MapInfo, GPS Trackmaker and other. 

To export a section to an ArcView Shapefile:

1. Select the solution containing the section data you wish to export from the list in
the main form.
2. Select Export from the File menu.
3. Select To ArcView Shapefile from the Export menu.
4. Select the shape type from the drop-down list.
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5. Select Ok to proceed. Select Cancel to abort the operation and close the dialog
box.
6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Not all shape types are compatible with all programs.

2.7.5 Export sketch

With this option, you can export (in BMP format) the sketch of the solution as it
appears in the main form of the program.

To export the sketch of the solution:

1. Select the solution from the list of the main form in order to display the sketch.
2. Select Export from the File menu.
3. Select Export sketch from the Export menu.
4. Select the path of the file.
5. Type the filename in the File name text box.
6. Select Save to create the file. Select Cancel to cancel the operation.
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2.8 Print setup

With this option, you can select which parts of the project will be included in the
printouts. When a new project is created, a full report is selected by default.

To modify the print setup:

1. Select Print setup from the File menu.
2. Select the sections (Title, Project information etc) that will be printed for each
solution, from the list on the left.
3. Select the solutions that will be included in the report from the list on the right.
4. Check Use new page for each object if you want to use a new page for each
solution in the report.
5. Check Repeat headers for data/results if you want to repeat the headers each
time a separate data or results table is used.
6. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection of a list.

NOTE: The changes are saved with the project. The above preferences are used to all
printouts, either to the printer or to other formats such as Word file, Excel file etc.
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2.9 Print

With this option, you can prepare a report to be printed to a local, network or virtual
printer such as Adobe PDF Writer. The parts of the project that will be included in the
report are determined from print setup.

By selecting Print, the report is not printed directly; instead, a document is prepared
and a preview of the printout is created by the Print manager. You can print the
report by clicking the Print button of the toolbar of Print manager.

To create a report:

1. Select Print from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.

NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.

2.10 Print to

2.10.1 Print to File

With this option, you can create a simple text file containing a report of the project.
This file is recognized and can be further modified by word processors such as
Microsoft Word, OpenOffice Writer etc.

To print to a text file:
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1. Select Print to from the File menu.
2. Select Print to file from the Print to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.

The parts of the project that will be included in the report are determined from print
setup.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but the report is NOT printed.

2.10.2 Print to Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

2.10.3 Print to Word (Formatted)

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a formatted Microsoft Word file:
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1. Select Print to from the File menu.
2. Select Print to Word (Formatted) from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup. This operation is much slower than the regular print to word function. However,
the final output requires minimal user intervention as it comes fully formatted with
tables, alignment, font styles, etc.

NOTE: Do not use Copy (CTRL+C) on any of the programs running during this
operation. If you do so, it will most likely affect the communication between Microsoft
Word and the clipboard and as a result the final document will be corrupt.

2.10.4 Print to Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the report can be created. Note that
Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the report to a Microsoft Excel file:

1. Select Print to from the File menu.
2. Select Print to Excel from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

2.11 Exit

With this option, you can exit the program. If there are changes in the current project
that have not been saved then the program will:

either ask the user to save the changes
or save the changes
or ignore the changes

depending on what you have selected in General preferences.

To exit the program:

1. Select Exit from File menu.
2. If you are asked whether to save the changes or not, you can save changes or
ignore them.
3. The program is terminated.
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3 Data

3.1 Data menu

With this menu, you can add and modify data. In the Data menu you can select one
of the following options:

Project info
Undo
Redo
Add solution
Change solution
Delete solution
Move up
Move down
Friction calculation
Copy from solution
Options
o General preferences

o Grid editing

o Customize toolbar

o Sketch

3.2 Project info

With this option, you can add project information that include, optionally, title, author
and comments. If you want, this information can be included in the reports. The
empty fields are ignored.

To add or modify the project information:

1. Select Project info from the Data menu.
2. Type the project title, author and comments.
3. Check Include project time and date if you want to include the time and date in
the project.
3.1. Type the day, month, year, hours and minutes in the corresponding text boxes.
Alternatively, you may click on the up/down arrows to increase or decrease the
respective value in the text box.
3.2. If you click on Now then all text boxes are filled with the current values
automatically.
4. Check Include the name of the project file if you want the full path and filename
of the project to be included in the report.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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By selecting the buttons with the ellipses (...) next to the project title and author, you
can access the corresponding databases.

Project title database

For the completion of a project, more than one programs may be needed. For
convenience, you can add the project title to the database and retrieve it from all
programs.

To use the project title database:

1. Select the button with the ellipses (...) next to the project title text box. The project
title database appears.
2. Select Add to add a new title to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected project title and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

Author database
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An engineer may be involved in multiple projects. For convenience, you can add the
author name to the database and retrieve it from all programs.

To use the author database:

1. Select the button with the ellipses (...) next to the author text box. The author
database appears.
2. Select Add to add a new author to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected author and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

3.3 Undo

Undo cancels the last committed change in the project.

To cancel the last committed change:

1. Select Undo from the Data menu.
2. The last committed change is canceled.

To cancel an undo command, you may use the redo function which is described
below. Redo becomes available once undo is used.

It is possible to undo more than one recent changes and to redo them, by following
the step described above. The number of actions that are kept in memory and may be
undone or redone is 20 by default. This means that the program is able to keep track
of up to 20 successive changes and undo them. This number may change for all
programs, using the option in the main menu. For more information, please consult
main menu user guide.

NOTE: Some changes cannot be undone like the new project or the save project
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functions.

3.4 Redo

Redo cancels the latest undo command.

To redo the latest change that was undone:

1. Select Redo from the Data menu.
2. The latest undone change is redone.

To undo a redo, you may use the undo command.

It is possible to redo more than one changes that were previously undone by following
the steps described above. The number of actions that are kept in memory and may
be undone or redone is 20 by default. This means that the program is able to keep
track of up to 20 successive changes that are undone and redo them. This number
may change for all programs, using the option in the main menu. For more
information, please consult main menu user guide.

3.5 Add solution

With this option, you can add a new solution at the end of the list.

To add a solution:

1. Select Add solution from the Data menu.
2. Type the name of the solution in the corresponding text box. The name can be any
string that has not been used in another solution of the current project.
3. Select the type of the problem (see below)
4. Select the appropriate calculation options. The available combinations are shown in
the table below.
5. Select Ok to create a new solution and append it to the end of the list. Select
Cancel to close the dialog box without any changes.

Solver Prefix Options Description

Sections with
free surface

SFS Hydraulic
calculations will
take place
Only draw the
section

Problem of flow with free surface with
calculations without flow rate or with
given flow depth.

Sections under SUP Hydraulic Problem of flow under pressure with
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pressure calculations will
take place
Only draw the
section

hydraulic calculations or without flow
rate.

Weirs WEI Rectangular
sharp-crested
Triangular
sharp-crested
Trapezoid
(cipoletti) sharp-
crested
Generic
Broad

Several types of weirs. If a weir is
not broad and cannot be described
by one of the available sharp-crested
types, it can be described by generic
type.

Orifices ORI Generic
Rectangular
Circular

Several types of orifices. If the orifice
is not circular or rectangular, it can
be described by generic type. In this
case, the area of the hole can be
entered directly.

Grates GRA On grade
In sag

The grate can be located on grade
(where the slope is non zero) or in
sag, i.e. in a deep point where storm
water stagnates.

Curbs CUR On grade
In sag

The curb can be located on grade
(where the slope is non zero) or in
sag, i.e. in a deep point where storm
water stagnates.

Combination
inlets 

CMB On grade
In sag

The combination inlet can be located
on grade (where the slope is non
zero) or in sag, i.e. in a deep point
where storm water stagnates.

Slots SLO On grade
In sag

The slot can be located on grade
(where the slope is non zero) or in
sag, i.e. in a deep point where storm
water stagnates.

Ditches DIT On grade
In sag

The ditch can be located on grade
(where the slope is non zero) or in
sag, i.e. in a deep point where storm
water stagnates.

Pumps PUM - Calculation of pump power needed to
elevate the pressure line of a fluid
through a system containing valves,
curves and confusors.

Reaction
turbines

RCT - Calculation of geometric
characteristics and properties of
Francis-type reaction turbines used
in hydropower works.

Impulse
turbines

IMT - Calculation of geometric
characteristics and properties of
impulse turbines used in hydropower
works.
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Hydropower
pumps

HPP - Calculation of geometric
characteristics and properties of
pumps used in hydropower works.

3.6 Change solution

With this option, you can change the name, type and options of a solution. Since
different solvers require different input data (for example, orifices and sections under
pressure), if the type of the solution is changed then only the common data (in this
case, the flow rate) is kept. All other data of the new type must be entered by the
user.

To change the properties of an existing solution:

1. Select the solution you wish to change from the list in the main form.
2. Select Change solution from the Data menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.7 Delete solution

With this option, you can delete an existing solution.

To delete an existing solution:

1. Select the solution you wish to delete from the list in the main form.
2. Select Delete solution from the Data menu.
3. You may be prompted to confirm the deletion depending on what you have selected
in General preferences. If you select No then the deletion is canceled.
4. The solution is deleted.

3.8 Move up

With this option, you can move an existing solution up in the list. This command,
together with Move down, are useful when you want the solutions to be presented in
the report in a specific order.
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To move a solution up in the list:

1. Select the solution you wish to move up from the list in the main form.
2. Select Move up from the Data menu.
3. The selected solution is moved up in the list by one place.

NOTE: This command has no effect if the selected solution is first on the list.

3.9 Move down

With this option, you can move an existing solution down in the list. This command,
together with Move up, are useful when you want the solutions to be presented in the
report in a specific order.

To move a solution down in the list:

1. Select the solution you wish to move down from the list in the main form.
2. Select Move down from the Data menu.
3. The selected solution is moved down in the list by one place.

NOTE: This command has no effect if the selected solution is last on the list.

3.10 Friction calculation

With this option, you can select the formulas that will be used for the calculation of
the friction losses and calibrate the solvers.

To select the friction formulas:

1. Select the solution for which you wish to select the friction formulas from the list in
the main form.
2. Select Friction calculation from the Data menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Depending on the type of flow (under pressure or with free surface), two different
dialog boxes may appear:

A. Flow under pressure

In case the flow is under pressure, you can select up to three different friction
formulas, depending on the type of flow (turbulent, transient, laminar). If you check 
Set as defaults for all new projects then these values will be preselected for all
new projects.

First, you define the boundaries of turbulent and laminar flow. The use of Re>4000 for
turbulent flow and Re<2000 for laminar flow is recommended. For intermediate
values, the flow is considered to be transient. If you set the same friction formula for
all types of flow, this analysis has no effect.

Note that different friction formulas need different friction coefficients. The first three
choices are variations of the well-known Manning formula. The first, named Manning,
assumes constant friction coefficient. The other two calculate the friction coefficient as
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a function of the fill ratio and the coefficient that corresponds to full flow. These three
formulas give the same results in flow under pressure; this is not the case for flow
with free surface, where up to 30% difference may be observed.

The Accuracy and Maximum number of trials ensure the stability of the algorithm.
The default values are 0.0005 for the accuracy and 1000 for the maximum number of
trials. It is recommended that you do not change these values.

The averaging formula may take one of the following values:

Pavlovskii
Colebatch
Horton
Cox
Lotter

The above formulas are used when there are different friction coefficients within the
same section and an average friction coefficient is needed.

B. Flow with free surface

In case the flow is with free surface, you can select a single friction formula. If you
check Set as defaults for all new projects then this value will be preselected for all
new projects. The friction formulas available are: Manning, Bazin, Kutter, Ganguillet-
Kutter, Chezy, Hazen-Williams.

The Accuracy and Maximum number of trials ensure the stability of the algorithm.
The default values are 0.0005 for the accuracy and 1000 for the maximum number of
trials. It is recommended that you do not change these values.



Hydraulic solver36

© 2012 TechnoLogismik i

3.11 Copy from solution

With this option, you can copy all data from another existing solution of the same
project. This command is particularly useful when you want to solve multiple problems
that are almost the same. For example, you may want to solve the problem of flow
under pressure of the same section with slight variations of the friction coefficient.

To copy all data from another existing solution:

1. Select the target solution from the list in the main form.
2. Select Copy from solution from the Data menu.
3. The name of the target solution is displayed in the caption of the dialog box.
4. Select the source solution from the drop-down list.
5. Select Copy to copy the data from the source solution to the target solution. Select
Cancel to cancel the operation.

NOTE: The data of the target solution are erased and substituted by the data of the
source solution.

3.12 Options

3.12.1 General preferences

With this option, you can modify the general preferences of the program.

To modify the general preferences:

1. Select Options from the Data menu.
2. Select General preferences from the Options menu.
3. The general preferences dialog box appears. The preferences are grouped into four
tabs. You can select a tab by clicking on its name.

General Tab
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This tab contains general preferences regarding the usage of the program.

Check Register the extension *.m01 with this application to associate the
extension .m01 with this program. This extension is used by the program when saving
a project. In this way, you will be able to run the program and load a project by
double-clicking on the project filename in Windows Explorer.

Check Automatically display calculation messages if you want the report details to
be automatically displayed when you calculate the results.

Check Automatically create backup file if you want a backup file (with the
extension .bck) to be created every time a project is loaded. By default, this file is
created in the temporary folder of Windows.

Check Confirm delete actions if you want to be asked for confirmation each time an
object is about to be deleted. This setting affects the behavior of all delete actions, for
example the deletion of a solution

You can also modify the temporary folder that will be used for the creation of backup
files. By default, this folder is the temporary folder of Windows.

Finally, there are three options regarding the termination of the program:

When exiting always ignore changes - All changes since the last save of the
project are ignored. 
When exiting always save changes - All changes in the current project are
automatically saved. If the filename of the project is not set, a dialog box will
appear that allows the selection of the filename, as when selecting Save project
as from the File menu.
When exiting prompt for action - If there are changes in the current project,
then a dialog box will appear. You can choose to save or ignore the changes. If
the filename of the project is not set, a dialog box will appear that allows the
selection of the filename, as when selecting Save project as from the File menu.

Languages Tab
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If more than one language packs have been installed, then you can choose the
language of the program. In the above case, there are two language packs; English
(that are already selected) and Greek. If you change the language, all forms, menus,
messages, help files will reflect the chosen language.

In order for the changes to take effect, you must restart the program.

Digits Tab

With this tab, you can modify the way the results are presented. All values used in the
program are displayed in the list on the left.

For each value, you can select the number of decimal digits using the Number of
digits drop-down list.

Check Use 0.1 instead of .1 to use a preceding zero when displaying numbers
between -1 and 1, for example -0.08 instead of -.08 and 0.98 instead of .98.

Check Use 1.0 instead of 1 to use trailing zeros (when necessary) in order to display
a number with the decimal digits selected in the Number of digits drop-down list, for
example 1.1600 instead of 1.16 (when the number of digits is set to 4).

Internet Tab
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The program can automatically check for newer versions over the Internet. Check 
Automatically check for newer versions to enable this feature. The check is
automatically performed at an interval specified in the Every drop-down list. Select
Check now to manually check for newer versions.

When a newer version is found, you will be prompted to download and install the
latest version.

NOTE: TechnoLogismiki protects your privacy. During the check for newer versions,
no data is transferred from your computer to the Internet.

Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.12.2 Grid editing

With this option, you can modify the behavior of grids.

The behavior of all editable grids is controlled by the preferences in this dialog box.

Select No cell automation if you want the active cell to remain the same when
hitting ENTER.

Select Open the cell below (edit by columns) if you want to activate the cell below
when hitting ENTER. This is particularly useful when editing tables by columns.

Select Open the next cell (edit by rows) if you want to activate the next cell on the
right when hitting ENTER. This is particularly useful when editing tables by rows.

In some cases, the program may automatically fill some missing values (for example,
when performing linear interpolation). In this case, you can select a distinctive color in
order to recognize these values. You can choose the color by clicking on the button in
the Auto-complete settings frame.
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NOTE: These preferences affect all projects, old and new.

Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.12.3 Customize toolbar

With this option, you can customize the toolbar of the main form.

To customize the toolbar of the main form:

1. Select Options from the Data menu.
2. Select Customize toolbar from the Options menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The toolbar may contain small or large buttons.

Check Show description if you want a small description to be displayed under the
buttons.

Check Show tooltips if you want tooltips to be displayed when the mouse pointer
hovers over a button for 2-3 seconds.

NOTE: These preferences affect all projects, old and new.

3.12.4 Sketch

With this option, you can show or hide the sketch in the main form.

To show or hide the sketch in the main form:

1. Select Options from the Data menu.
2. Select Sketch from the Options menu.
3. If the sketch is hidden, it is shown and vice versa.
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4 Results

4.1 Results menu

With this menu, you can perform calculations and create rating tables and curves. In
the Results menu you can select one of the following options:

Perform calculations
Calculate all
Report details
Rating table
Rating curves

4.2 Perform calculations

With this option, you can manually perform calculations for the current solution.
Normally, this is done automatically as you enter or modify data. However, you may
need to repeat the calculations manually when specific preferences have changed,
such as the friction formula.

To manually perform calculations for the current solution:

1. Select Perform calculations from the Results menu.
2. The calculations are performed and the results are displayed in the main form.

4.3 Calculate all

With this option, you can manually perform calculations for all solutions in the project.
This is equivalent to performing calculations for each solution separately.

To manually perform calculations for all solutions in the current project:

1. Select Calculate all from the Results menu.
2. The calculations are performed and the results of the current solution are displayed
in the main form.
3. If there are errors in one or more solutions, an error report is prepared. If you have
selected Automatically display calculation messages in general preferences then
the report details are automatically displayed.

4.4 Report details

With this option, a report containing information on calculation problems and errors is
created. If you have selected Automatically display calculation messages in
general preferences then this report is automatically displayed when you select
Calculate all.

To display the report:

1. Select Report details from the Results menu.
2. The report appears.
3. Hit ESC to close the report.
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4.5 Rating table

With this option, you can create rating tables with up to 5 variables. For example,
variable A may take values from A1 to A2 with step equal to AS and variable B may
take values from B1 to B2 with step equal to BS. The solver is invoked for all possible
combinations and the results are presented in tabulated form.

The results can be copied to the clipboard, saved in ASCII, Word or Excel format.

To create a rating table:

1. Select the solution you wish to use for the rating table from the list in the main
form.
2. Select Rating table from the Results menu.
3. Select the values that will be used for the creation of the rating table:
3.1. Select the design variable from the drop-down list in the Design variable frame.
If the list is disabled then the currently selected design variable is the only option.
3.2. Select up to 5 variables. To select a variable, the previous variable must have
been set.
3.3. Select the lower bound, the upper bound and the step of each variable.
4. Select Create > to create the rating table. Select Cancel to close the dialog box
without creating the rating table.

NOTE: This process may take several minutes, depending on the number, range and
step of the variables.

5. The rating table appears. The table contains all results from the repetitive process.
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In the Functions menu, you can select one of the following options:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Word.

Select Ok  to close the rating table.

NOTE: The number and type of the available variables depends on the invoked solver.

4.6 Rating curve

With this option, you can create rating curves with up to 2 variables. For example,
variable A may take values from A1 to A2 with step equal to AS and variable B may
take values from B1 to B2 with step equal to BS. The solver is invoked for all possible
combinations and the results are presented in a graph.

To create a rating curve:

1. Select the solution you wish to use for the rating table from the list in the main
form.
2. Select Rating curve from the Results menu.
3. Select the values that will be used for the creation of the rating table:
3.1. Select the design variable from the drop-down list in the Design variable frame.
If the list is disabled then the currently selected design variable is the only option.
3.2. Select up to 2 variables. To select a variable, the previous variable must have
been set.
3.3. Select the lower bound, the upper bound and the step of each variable.
4. Select Create > to create the rating curve. Select Cancel to close the dialog box
without creating the rating table.
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NOTE: This process may take several minutes, depending on the number, range and
step of the variables.

5. The rating curve appears. The graph contains all results from the repetitive process.

In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
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useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

Click the X button at the top-right corner of the form to close the rating curve.

NOTE: The number and type of the available variables depends on the invoked solver.
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5 Solvers

5.1 Sections with free surface

The variables associated with this solver are the following:

Variable Explanation

Flow rate The flow rate in m3/s.

Slope The bottom slope in (m/m).

Kinematic
viscosity

The kinematic viscosity of the fluid in m2/s. This is required in case
the selected friction formula depends on this variable. You can use
the database to select default values. To use the database, click the
button with the ellipses (...) that appears when you double-click the
cell of the property value.

Friction
coefficient

The value and unit system of the friction coefficient depends on the
selected friction formula. You can use the database to select default
values. To use the database, click the button with the ellipses (...)
that appears when you double-click the cell of the property value. 

In the Database section you can find some default values for the
friction coefficient for the following formulas: Manning, Bazin, Hazen
- Williams and Darcy - Weisbach.

Section The section. The data is entered using the advanced section editor.
To invoke the editor, click the button with the ellipses (...) that
appears when you double-click the cell of the property value. 

Flow depth The uniform flow depth in (m).

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.2 Sections under pressure

The variables associated with this solver are the following:

Variable Explanation

Flow rate The flow rate in m3/s.

Length The total length of the pipe in m.

Kinematic
viscosity

The kinematic viscosity of the fluid in m2/s. This is required in case
the selected friction formula depends on this variable. You can use
the database to select default values. To use the database, click the
button with the ellipses (...) that appears when you double-click the
cell of the property value.

Specific
weight

The specific weight of the fluid in N/m3 You can use the database to
select default values. To use the database, click the button with the
ellipses (...) that appears when you double-click the cell of the
property value.

Friction The value and unit system of the friction coefficient depends on the
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coefficient selected friction formula. You can use the database to select default
values. To use the database, click the button with the ellipses (...)
that appears when you double-click the cell of the property value. 

In the Database section you can find some default values for the
friction coefficient for the following formulas: Manning, Bazin, Hazen
- Williams and Darcy - Weisbach.

Elevation 1 The elevation of the start point of the pipe (point 1) in m.

Elevation 1 The elevation of the end point of the pipe (point 2) in m.

Pressure 1 The pressure at the start point of the pipe (point 1) in Ν/m2.

Pressure 2 The pressure at the end point of the pipe (point 2) in Ν/m2.

Section The section. The data is entered using the advanced section editor.
To invoke the editor, click the button with the ellipses (...) that
appears when you double-click the cell of the property value. 

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.3 Weirs

The variables associated with this solver are the following:

Variable Explanation

Headwater
elevation

The headwater elevation in m.

Crest elevation The crest elevation in m.

Tailwater
elevation

The downstream tailwater elevation in m. This elevation can not
be greater than the upstream elevation. In this case, the weir
will operate as an orifice.

Discharge
coefficient

A dimensionless coefficient that quantifies the effect of the
boundaries friction, the headwater elevation, the opening shape
etc on the flow rate. When no experimental data are available,
its value can be taken from reference tables.

Crest length The crest length normal to the flow direction in m.

Number of
contractions

The number of contractions that suppress the jet stream. Enter
0 to describe a non-contracted jet stream. Enter 1 or 2 to
describe a one or two-sided contraction. Contractions are
possible when the upstream channel is greater than the
rectangular weir opening.

Flow rate The flow rate in m3/s.

Angle The angle of the base corner of a triangular weir in deg.

Crest breadth The crest breadth of a broad weir in m.

Crest surface type It is used by the American circular FHWA HDS-5 to calculate
the submergence factor and adjusted discharge coefficient.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.
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5.4 Orifices

The variables associated with this solver are the following:

Variable Explanation

Headwater
elevation

The headwater elevation in m.

Centroid elevation The elevation of the centroid of the orifice in m.

Tailwater
elevation

The downstream tailwater elevation in m. The upstream
elevation must be greater than the invert elevation of the
orifice. If the downstream elevation is greater than that of the
invert elevation then the orifice behaves as submerged orifice.

Discharge
coefficient

A dimensionless coefficient that quantifies the effect of the
boundaries friction, the headwater elevation, the opening shape
etc on the flow rate. When no experimental data are available,
its value can be taken from reference tables.

Opening area The area of the opening in m2 . This is used for the calculation
of the flow velocity when the orifice is not circular or
rectangular.

Opening width The width of the opening in m. This applies to rectangular
orifices.

Opening height The height of the opening in m. This applies to rectangular
orifices.

Opening diameter The diameter of the opening in m. This applies to circular
orifices.

Flow rate The flow rate in m3/s.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.5 Grates

The variables associated with this solver are the following:

Variable Explanation

Flow rate The flow rate in m3/s.

Slope The bottom slope in (m/m).

Gutter width The gutter width in m. It may be 0 in triangular sections.

Gutter cross slope
(H:V)

The dimensionless slope of the gutter. Normally, this is greater
than the corresponding road cross slope. If the gutter is not
configured properly, this value is set equal to the road cross
slope (for example 2% in straight roads, 6~8% in curves)

Road cross slope The dimensionless road cross slope.
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(H:V)

Friction coefficient The friction coefficient according to Manning. Although it is
possible to use other friction formulas, this is not
recommended as the experimental equations used during the
calculations are based on the Manning friction formula.

In the Database section you can find some default values for
the friction coefficient for the following formulas: Manning,
Bazin, Hazen - Williams and Darcy - Weisbach.

Efficiency The dimensionless efficiency ratio of the grate. This is a
number between 0 and 1.

Length The length of the grate in m.

Grate width The width of the grate in m.

Grate type One of seven characteristic grate types. If the grate is not in
the list, select the type that is closest with respect to the
arrangement of the bars. This variable is used for the
calculation of the splash-over velocity.

Clogging The dimensionless ratio of clogging. This is a number between
0 and 1 and it is used for the calculation of existing grates that
are clogged by litter. This can be set to a non-zero value even
for new grates when the engineer expects that the
maintenance of the grates will be insufficient or non-existent.

Spread The desired spread in m. This applies when the grate is located
on sag.

Depression width The depression width in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the grate. This is not common, therefore this value is usually
0.

Depression height The depression height in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the grate. This is not common, therefore this value is usually
0.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.6 Curbs

The variables associated with this solver are the following:

Variable Explanation

Flow rate The flow rate in m3/s.

Slope The bottom slope in (m/m).

Gutter width The gutter width in m. It may be 0 in triangular sections.

Gutter cross slope
(H:V)

The dimensionless slope of the gutter. Normally, this is greater
than the corresponding road cross slope. If the gutter is not
configured properly, this value is set equal to the road cross
slope (for example 2% in straight roads, 6~8% in curves)

Road cross slope The dimensionless road cross slope.
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(H:V)

Friction coefficient The friction coefficient according to Manning. Although it is
possible to use other friction formulas, this is not
recommended as the experimental equations used during the
calculations are based on the Manning friction formula.

In the Database section you can find some default values for
the friction coefficient for the following formulas: Manning,
Bazin, Hazen - Williams and Darcy - Weisbach.

Efficiency The dimensionless efficiency ratio of the curb. This is a number
between 0 and 1.

Length The length of the curb in m.

Curb throat type The entrance of the curb may be horizontal, vertical or inclined.

Throat incline
angle

If the entrance is inclined, then this angle (in degrees) is used.
0 degrees corresponds to horizontal entrance and 90 degrees
corresponds to vertical entrance.

Spread The desired spread in m. This applies when the curb is located
on sag.

Depression width The depression width in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the curb. This is not common, therefore this value is usually 0.

Depression height The depression height in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the curb. This is not common, therefore this value is usually 0.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.7 Combination inlets

The variables associated with this solver are the same with those of grates.

5.8 Slots

The variables associated with this solver are the following:

Variable Explanation

Flow rate The flow rate in m3/s.

Slope The bottom slope in (m/m).

Gutter width The gutter width in m. It may be 0 in triangular sections.

Gutter cross slope
(H:V)

The dimensionless slope of the gutter. Normally, this is greater
than the corresponding road cross slope. If the gutter is not
configured properly, this value is set equal to the road cross
slope (for example 2% in straight roads, 6~8% in curves)

Road cross slope
(H:V)

The dimensionless road cross slope.

Friction coefficient The friction coefficient according to Manning. Although it is
possible to use other friction formulas, this is not
recommended as the experimental equations used during the



Solvers 53

© 2012 TechnoLogismik i

calculations are based on the Manning friction formula.

In the Database section you can find some default values for
the friction coefficient for the following formulas: Manning,
Bazin, Hazen - Williams and Darcy - Weisbach.

Efficiency The dimensionless efficiency ratio of the slot. This is a number
between 0 and 1.

Length The length of the slot in m.

Spread The desired spread in m. This applies when the slot is located
on sag.

Depression width The depression width in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the slot. This is not common, therefore this value is usually 0.

Depression height The depression height in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the slot. This is not common, therefore this value is usually 0.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.9 Ditches

The variables associated with this solver are the following:

Variable Explanation

Friction coefficient The friction coefficient according to Manning. Although it is
possible to use other friction formulas, this is not recommended
as the experimental equations used during the calculations are
based on the Manning friction formula.

In the Database section you can find some default values for
the friction coefficient for the following formulas: Manning,
Bazin, Hazen - Williams and Darcy - Weisbach

Slope The bottom slope in (m/m).

Left side slope (H:
V)

The dimensionless slope of the left side.

Right side slope
(H:V)

The dimensionless slope of the right side.

Bottom width The width of the bottom of the ditch. The ditch is considered to
be trapezoidal.

Flow rate The flow rate in m3/s.

Efficiency The dimensionless efficiency ratio of the grate. This is a number
between 0 and 1.

Grate width The width of the grate in m.

Grate length The length of the grate in m.

Grate type One of seven characteristic grate types. If the grate is not in
the list, select the type that is closest with respect to the
arrangement of the bars. This variable is used for the
calculation of the splash-over velocity.
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Clogging The dimensionless ratio of clogging. This is a number between
0 and 1 and it is used for the calculation of existing grates that
are clogged by litter. This can be set to a non-zero value even
for new grates when the engineer expects that the maintenance
of the grates will be insufficient or non-existent.

Depression width The depression width in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the grate. This is not common, therefore this value is usually 0.

Depression height The depression height in m. A local depression may be
implemented for the improvement of the hydraulic behavior of
the grate. This is not common, therefore this value is usually 0.

Spread The desired spread in m. This applies when the slot is located
on sag.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.10 Pump

5.10.1 Pump

The variables associated with this solver are the following:

Variable Description

Slope The flow rate through the oppression and suction pipe in m3/s.
This value can be entered only when the selected solver does
not refer to its calculation.

Kinematic
viscosity

The kinematic viscosity of the fluid in m2/s. This is required in
case the selected friction formula depends on this variable. You
can use the database to select default values. To use the
database, click the button with the ellipses (...) that appears
when you double-click the cell of the property value.

Specific weight The specific weight of the fluid in N/m3 You can use the
database to select default values. To use the database, click the
button with the ellipses (...) that appears when you double-click
the cell of the property value.

Pump
performance
factor

The dimensionless performance factor of the pump. This is a
value between 0 and 1.

Length of suction
pipe

The total length of the suction pipe in m.

Diameter of
suction pipe

The diameter of the suction pipe in m. Note that only circular
non-varying pipes are supported.

Length of
oppression pipe

The total length of the oppression pipe in m.

Diameter of
oppression pipe

The diameter of the oppression pipe in m. Note that only circular
non-varying pipes are supported.

Friction
coefficient

The value and unit system of the friction coefficient depends on
the selected friction formula. You can use the database to select
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default values. To use the database, click the button with the
ellipses (...) that appears when you double-click the cell of the
property value. 

In the Database section you can find some default values for
the friction coefficient for the following formulas: Manning, Bazin
, Hazen - Williams and Darcy - Weisbach.

Elevation
difference

The desired elevation difference in m. This value can be entered
only when the selected solver does not refer to its calculation.

Pump power The pump power in CV. This value is provided by the
manufacturer. This value can be entered only when the selected
solver does not refer to its calculation.

Configure system To configure the pump system, click the button with the ellipses
(...) that appears when you double-click the cell of the property
value.

NOTE: Not all above variables may appear simultaneously. This depends on the type
of the problem and the solution settings.

5.10.2 System configuration

With system configuration, you can enter and modify the following properties of the
pump system:

Valves
Curves
Confusors
Configure entrance
Configure exit

To modify the system configuration:

1. Select the appropriate Pump solution from the list in the main form.
2. Double-click next to Configure system property cell.
3. Click the button with the ellipses (...) that appears in the property value cell.
4. The pump system configuration dialog box appears.
5. Modify the properties of the system by clicking on the corresponding buttons of the
dialog box.
6. Select Ok to close the dialog box and save the changes.
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5.10.3 Valves

With this option, you can add, modify and delete the valves of the oppression and
suction pipe. Valves are devices that are used in closed sections under pressure in
order to modify the flow rate by introducing local energy losses. The most common
types of valves are the spherical and the drawer-shaped.

To add a new valve:

1. Click Add button.
2. Select one of Drawer-shaped or Spherical valve.
3. Select the appropriate relative valve opening (if the valve is drawer-shaped) or the
opening angle (if the valve is spherical).
4. Select the location of the valve. The valve may be in the oppression pipe or the
suction pipe.
5. Select the appropriate number of valves. This can be greater than 1 if there are
more that one valves with the same characteristics.
6. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To modify an existing valve:

1. Select the valve from the list.
2. Click the Modify button.
3. Make the appropriate changes in the valve configuration dialog box. This dialog box
is the same as in the case of a new valve.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Alternatively to steps 1 & 2, you can double-click the name of the valve on the
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list.

To delete an existing valve:

1. Select the valve from the list.
2. Click the Delete button to delete the valve from the list. You will be asked for
confirmation only if you have selected to confirm deletions in the General preferences
tab. If you select No then the deletion of the valve is canceled.

5.10.4 Curves

With this option, you can add, modify and delete curves of the oppression and suction
pipe. There are curves in almost all pipes under pressure; as a consequence, local
energy losses are introduced in the system due to the change in the direction of flow.

To add a new valve:

1. Click Add button.
2. Select one of 45 degrees, 90 degrees, 180 degrees.
3. Select the location of the curve. The curve may be in the oppression pipe or the
suction pipe.
4. Select the appropriate number of curves. This can be greater than 1 if there are
more that one curves with the same characteristics.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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To modify an existing curve:

1. Select the curve from the list.
2. Click the Modify button.
3. Make the appropriate changes in the curve configuration dialog box. This dialog box
is the same as in the case of a new curve.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Alternatively to steps 1 & 2, you can double-click the name of the curve on the
list.

To delete an existing curve:

1. Select the curve from the list.
2. Click the Delete button to delete the curve from the list. You will be asked for
confirmation only if you have selected to confirm deletions in the General preferences
tab. If you select No then the deletion of the curve is canceled.

5.10.5 Confusors

With this option, you can add, modify and delete confusors of the oppression and
suction pipe. The presence of confusors introduces local energy losses due to flow
separation.
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To add a new confusor:

1. Click Add button.
2. Select one of 30 degrees, 45 degrees, 90 degrees.
3. Select the location of the confusor. The confusor may be in the oppression pipe or
the suction pipe.
4. Select the appropriate number of confusors. This can be greater than 1 if there are
more that one confusor with the same characteristics.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To modify an existing confusor:

1. Select the confusor from the list.
2. Click the Modify button.
3. Make the appropriate changes in the confusor configuration dialog box. This dialog
box is the same as in the case of a new confusor.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Alternatively to steps 1 & 2, you can double-click the name of the confusor on
the list.
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To delete an existing confusor:

1. Select the confusor from the list.
2. Click the Delete button to delete the confusor from the list. You will be asked for
confirmation only if you have selected to confirm deletions in the General preferences
tab. If you select No then the deletion of the confusor is canceled.

5.10.6 Configure entrance

Entrance losses refer to the suction pipe. These are local losses that are introduced
due to the abrupt change in the uniform flow at the entrance of the pump. Entrance
losses are usually quantified by the formula ht=Kt*V^2/2*g. Kt is the local losses
coefficient and it is depended on the shape of the edges of the entrance.

To configure the entrance:

1. Select Configure entrance from the pump system configuration.
2. Select one of the following:

No local losses at the entrance (Kt=0).
Non-round edges (Kt=0.5).
Round edges without oblique angles (Kt=0.3).
Other case: the custom coefficient text box is enabled and you can type the
desired value.

3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

5.10.7 Configure exit

Exit losses refer to the oppression pipe. These are local losses that are introduced due
to the abrupt change in the uniform flow at the exit of the pump. Exit losses are
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depended on the local losses coefficient Kt.

To configure the exit:

1. Select Configure exit from the pump system configuration.
2. Select one of the following:

No local losses at the exit (Kt=0).
Other case: the custom coefficient text box is enabled and you can type the
desired value

3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

5.11 Reaction turbines

The variables associated with this solver are the following:

Variable Explanation

Average drop
height

The average drop height in m. This can be calculated as the
mean value of the maximum and minimum drop height.

Design flow The flow rate through the turbine in m3/s.

Number of turbines The number of turbines installed. Enter 1 for a single turbine.

Electrical current The electrical current frequency in Hz. Enter 60 Hz for USA and
50 Hz for Greece. For other countries, you can use the database
to select the correct values. To use the database, click the
button with the ellipses (...) that appears when you double-
click the cell of the property value.

Operation
elevation

The elevation of the installation in m.

Max operation
temperature

The maximum temperature of the water going through the
turbine in degrees Celsius.

Propeller opening
coefficient

The dimensionless coefficient describing the opening of the
turbine propeller.

# poles
multiplicative

Select one of 2, 4 or 8 as the maximum number for which the
number of poles is a multiplicative. For example, select 8 if the
number of poles is 16.

Turbine type Select one of Francis or Propeller - type turbine.

5.12 Impulse turbines

The variables associated with this solver are the following:
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Variable Description

Average drop
height

The average drop height in m. This can be calculated as the
mean value of the maximum and minimum drop height.

Turbine power The turbine power in MW.

Best turbine
efficiency level

The dimensionless best turbine efficiency level. This is a value
between 0 and 1.

Electrical current The electrical current frequency in Hz. Enter 60 Hz for USA and
50 Hz for Greece. For other countries, you can use the database
to select the correct values. To use the database, click the
button with the ellipses (...) that appears when you double-
click the cell of the property value.

Best pump
efficiency level

The dimensionless best pump efficiency level. This is a value
between 0 and 1.

Pump speed times
area

The speed of the pump in m/s times the area in m2.

Max operation
temperature

The maximum temperature of the water going through the
turbine in degrees Celsius.

Energy losses The total energy losses, i.e. the sum of the linear and local
losses in m.

# poles
multiplicative

Select one of 2, 4 or 8 as the maximum number for which the
number of poles is a multiplicative. For example, select 8 if the
number of poles is 16.

Tailrace elevation The elevation of the bottom of the tailrace in m.

5.13 Hydropower pump

The variables associated with this solver are the following:

Variable Description

Static elevation
difference

The static elevation difference in m.

Design flow The design flow rate through the pump in m3/s.

Water level
fluctuation
upstream

The water level fluctuation upstream in m.

Number of pumps The number of pumps. Enter 1 for a single pump.

# pumps for
optimal efficiency

The number of pumps that should be used for optimal
efficiency.

Electrical current The electrical current frequency in Hz. Enter 60 Hz for USA and
50 Hz for Greece. For other countries, you can use the database
to select the correct values. To use the database, click the
button with the ellipses (...) that appears when you double-
click the cell of the property value.

Losses in suction
pipe and grates

The sum of the linear and local losses in the suction pipe and
grates in m.

Losses in
oppression pipe

The local losses in the oppression pipe at the exit of the pump
in m.

Operation losses in The linear losses in the oppression pipe at the exit of the pump
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oppression pipe in m.

Operation
elevation

The elevation of the installation in m.

Max operation
temperature

The maximum temperature of the water going through the
pump in degrees Celsius.

Suction height The suction height before the pump in m.

Special suction
speed

The special suction speed. This values is between 153 and 155.

Motor's efficiency
coefficient

The dimensionless motor efficiency coefficient. This is a value
between 0 and 1.

Operation mode Select one the following four operation modes:

Α: Clay with mean concentration less than 100 mg/L and
organic material.

Β: Clay and silt with mean concentration less than 500 mg/L
and fine sand for small return periods.

C: Clay, silt and fine sand with mean concentration less than
2000 mg/L and coarse sand during floods.

D: Clay, silt, sand and sometimes gravel with mean
concentration less than 1000 mg/L.

# poles
multiplicative

Select one of 2, 4 or 8 as the maximum number for which the
number of poles is a multiplicative. For example, select 8 if the
number of poles is 16.
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6 Sections

6.1 Section input

When you double-click the cell of the property value of Section, a command button
with ellipses (...) appears. If you click it, the following dialog box appears:

In order to enter section data, follow these steps:

1. Select the type of the section from the drop-down list.
2. Fill the geometric data by typing onto the table. The number and description of
fields depends on the type of the section.
3. You can preview the current configuration in the picture of the Preview frame.
4. Select Ok to use the currently selected configuration and close the dialog box.
Select Cancel to close the dialog box without applying any changes.

NOTE: If you click the Edit button then the section editor will appear. This editor
must be used in the case of prismatic (irregular) sections. However, its use is not
compulsory when dealing with standard section types, as these can be fully defined
by the above dialog box.

The available section types are the following:

Section type Geometric data required

Circular Diameter

Open rectangular Width, Height

Rectangular Width, Height

Open trapezoid Width, Height, Left slope, Right slope

Trapezoid Width, Height, Left slope, Right slope

Open reverse trapezoid Width, Height, Left slope, Right slope

Reverse trapezoid Width, Height, Left slope, Right slope

Open isosceles trapezoid Width, Height, Side slope

Isosceles trapezoid Width, Height, Side slope

Open reverse isosceles
trapezoid

Width, Height, Side slope

Reverse isosceles trapezoid Width, Height, Side slope

Twin rectangular Width, Height (total)

Twin open rectangular Width, Height (total)

Twin circular Diameter (of each circular section)
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Oval Width

Wide oval Width

Basket handle Width

Simple mouth-shaped Width

Normal mouth-shaped Width

Simple horse-shoe Width

Normal horse-shoe Width

Donut External diameter, Internal diameter

Arch Width, Height, Arc segments

Ellipse Width, Height, Arc segments

Parabolic Width, Height, Arc segments

Irregular Use section editor

NOTE: The above section types are based on advanced script techniques. Therefore,
this list may be changed (for example, some more types may be added) with updates
that are irrelevant with the executable file of the program.

6.2 Section editor

The list of the standard types of sections is extensive; however, when the section is
irregular it cannot be described by these types. In this case, you can use the section
editor. With this editor, you can design a new section from scratch or modify a
standard section. Note that after editing, the section will always be referred to as
irregular.

The section is described by curvilinear polygons i.e. open or closed polylines with
straight or curved edges. The curved edges are circular arcs; in this way, virtually any
section can be described accurately with a minimum number of nodes.



Sections 67

© 2012 TechnoLogismik i

The user interface of the section editor is shown in the above picture. It consists of
four parts: the menu, the toolbar, the drawing and the table of coordinates.

A section may:

consist of one or more curvilinear polygons
consist of many open or closed curvilinear polygons or any combination of them
include ground information
include excavation information

There are five main menus:

File: file operations, printing, importing from other formats
Edit: data input and editing
View: configuration of the drawing and the table of coordinates
Options: other options (colors, line styles etc)
Calculations: calculation tools for checking the section.

In order to input section data:

1. Add one or more polygons.
2. For each polygon add three or more nodes.
3. For each node, enter X coordinate, Y coordinate and friction coefficient. Optionally,
you can enter the bulge, if the edge is curved. These values are explained below.
4. Check that the section is filled (with fluid) properly. If this doesn't happen, disable
or enable some nodes so that the flow is correct.
5. You can optionally enter ground data. If stabilization works are necessary then this
line represents the ground before dredging. In the case of natural sections, the section
is the same with the ground.
6. You can optionally enter excavation data. The excavation line is located below the
section and it represents the outline of the section and the level where the section will
be built. For uncovered sections, the excavation line is the same with the section. For
covered sections, the excavation line is displaced downwards by the thickness of the
cover e.g. concrete.

To input data from the table:

Polygon list: select the active polygon by using the drop-down list. If you select to
view the nodes, then the nodes of the active polygon are shown in the drawing.
N/O: the number of the node. This column is not editable.
Χ (m): the X coordinate of the node in meters.
Υ (m): the Y coordinate of the node in meters.
Bulge (m): this is used only in cases of curved edges. It represents the distance in
meters of the middle point of the segment connecting two nodes with the middle point
of the arc. This value is 0 for straight lines. The bulge refers to segments, not nodes;
therefore, the bulge of the first node refers to the segment connecting the first with
the second node. The bulge is positive if the arc connecting two nodes is on the right
side of the corresponding straight line and vice versa. You cannot enter a value for the
last node, as this has no meaning. 
Friction (-): the friction coefficient. This value refers to segments not nodes;
therefore, the friction of the first node refers to the friction of the segment connecting
the first with the second node. You cannot enter a value for the last node, as this has
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no meaning. The values of friction coefficients depend on the selected friction formula.

NOTE: The bulge and friction coefficient columns are not available when entering
ground and excavation data.

6.3 File

6.3.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New section
Open section
Save section
Save section as
Import
o Import from GRD

o Import from PCS

o Import from DXF

o Import from ArcView Shapefile

Export
o Export to GRD

o Export to PCS

o Export to DXF

o Export to ArcView Shapefile

o Export to Bitmap

Print sketch
Print section data
Print section data to
o Microsoft Excel

o Microsoft Word

o Text file

Close

6.3.2 New section

With this option, you can start a new section. All data of the current section are lost.

To start a new section:

1. Select New Section from the File menu.
2. The current section data are erased and a new section is created.

6.3.3 Open section

With this option, an existing section is loaded. The section file may be located locally,
in a network or in an external media device such as a CD-Rom. When a section is
loaded, all data of the previous section are lost.

To open an existing project:

1. Select Open Section from the File menu.
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Section file" with the extension .sec.
4. Select the file by clicking on it.
5. Select Open to open the selected file.

Supported file formats

SEC (Section file): Section files created by versions 2010, 2009, 2008, 2007 and 5
of the program.
*.* (All files): Files with any extension.

NOTE: If a message "Error while loading file" is displayed then either you are trying
to load a file that doesn't contain section data or the file is used (and locked) by
another process in your computer.

6.3.4 Save section

With this option, you can save all data of a section into a file. The file may be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you attempt to save the
section. When the filename and path are set, all subsequent saves will be made to the
same file.

When you want to rename a file or save it in a new location, use Save section as...
from the File menu.

To save the current project:

1. Select Save Section from the File menu.
2. If the filename and path are already set, the section is saved to this file without any
messages. If the filename and path are not set, a dialog box will appear that allows
the selection of the filename and path.

6.3.5 Save section as

With this option, the current section is saved just as in the case of Save section, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.
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To save a project with another name and/or to another location:

1. Select Save Section As from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the section with the selected filename and path.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current section are saved.

6.3.6 Import

6.3.6.1 Import from GRD

GRD files are created by many popular programs such as VERM, Anadelta, Odos as
well as Hydraulic programs by TechnoLogismiki. They contain geometric information
on a prismatic cross section with straight edges as well as the title of the section,
station data etc.

To import a GRD file:

1. Select Import from the File menu.
2. Select from GRD file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"GRD file" with the extension .grd.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. Depending on the contents of the file,
there are two cases.
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Case 1

The GRD file contains only one section. In this case, the current section data are
erased and substituted by the imported section.

Case 2

The GRD file contains more than one sections. In this case, a dialog box appears that
allows the selection of a single section. Select the section that you wish to import. 

Select Ok to proceed. The current section data are erased and substituted by the
selected section. Select Cancel to cancel the operation.

6.3.6.2 Import from PCS

PCS files can be created by Hydraulic programs (by TechnoLogismiki) version 2.0 or
later. It is the preferred way to exchange section data between programs and users.
Each file contains a single section, with information on the prismatic section and the
friction coefficient of each edge.

To import a section from a PCS file:

1. Select Import from the File menu.
2. Select from PCS file from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"PCS file" with the extension .pcs.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The current section data are erased and
substituted by the imported. Select Cancel to cancel the operation.
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6.3.6.3 Import from DXF

DXF files are recognized by virtually all CAD programs (AutoCAD, IntelliCAD,
Microstation etc) as well as TechnoLogismiki's products.

DXF files contain information in layers. You can select one or more layers that contain
the section data.

To import a section from a DXF file:

1. Select Import from the File menu.
2. Select Import from DXF from the Import menu. The following dialog box
appears:

3. Click Browse.
4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"DXF files" with the extension .dxf.
6. Select the file by clicking on it.



Sections 73

© 2012 TechnoLogismik i

7. Select Open to open and analyze the file. The list in the Layer frame is loaded with
the layers contained in the DXF file.
8. Select one or more layers that contain section data. The quick keys (Select all,
Select None, Select Invert) can be used to quickly select all layers, deselect all
layers and invert the current selection.

9. Select Ok to proceed. Select Cancel to close the dialog box with no changes.

NOTE: The current DXF driver can import the following entities:
Polylines
LWPolylines
Circles

If there are no recognizable entities, an error message will be displayed.

6.3.6.4 Import from ArcView Shapefile

Shapefiles can be created by several programs such as ArcView GIS, MapInfo, GPS
Trackmaker etc. In reality, this "file" consists of three files with the extensions shp,
shx and dbf. The GIS driver recognizes the following shapefile types:

Nullshape
Point/PointM/PointZ
MultiPoint/MultiPointM/MultiPointZ
PolyLine/PolyLineM/PolyLineZ

Shapefiles containing Polygons (simple, M and Ζ) and Multipatch are not recognized.

To import data from a shapefile:
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1. Select Import from the File menu.
2. Select from ArcView Shapefile from the Import menu.
3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"SHP file" with the extension .shp.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The section contained in the shapefile is
imported into the editor. Select Cancel to cancel the operation.

6.3.7 Export

6.3.7.1 Export to GRD

With this option, a GRD file containing the current section data created. GRD files
contain geometric information on a prismatic cross section with straight edges as well
as the title of the section, station data etc.

To export sections to a GRD file:

1. Select Export from the File menu.
2. Select Export to GRD file from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on the friction coefficients and curved edges (if any) will not be
exported as they are not supported by the file format.
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6.3.7.2 Export to PCS

With this option, you can create a PCS file containing data on the geometry of the
current section.

To export a section to a PCS file:

1. Select Export from the File menu.
2. Select Export To PCS from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: Information on curved edges (if any) will not be exported as they are not
supported by the file format.

6.3.7.3 Export to DXF

DXF files are recognized by virtually all CAD programs (AutoCAD, IntelliCAD,
Microstation etc) as well as TechnoLogismiki's products.

To export a section to a DXF file:

1. Select Export from the File menu.
2. Select Export to DXF from the Export menu.
3. The DXF driver configuration form appears:

4. Make the appropriate selections. Click Ok to proceed to the filename selection form.
Click Cancel to cancel the operation.
5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to create the file. Select Cancel to cancel the operation.
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6.3.7.4 Export to ArcView Shapefile

With this option, you can create a shapefile that can be used by programs such as
ArcView GIS, MapInfo, GPS Trackmaker and other. 

To export the current section to an ArcView Shapefile:

1. Select Export from the File menu.
2. Select Export To ArcView Shapefile from the Export menu.
3. Select the shape type from the drop-down list.

4. Select Ok to proceed. Select Cancel to abort the operation and close the dialog
box.
5. Select the path of the file.
6. Type the filename in the File name text box.
7. Select Save to create the file. Select Cancel to cancel the operation.
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NOTE: Not all shape types are compatible with all programs.

6.3.7.5 Export to Bitmap

With this option, you can export (in BMP format) the sketch of the section, as it
appears in main form of the section editor.

To export the sketch of the section:

1. Select Export from the File menu.
2. Select Export to bitmap from the Export menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file. Select Cancel to cancel the operation.

6.3.8 Print sketch

With this option, you can print the sketch of the section, as it appears in main form of
the section editor, directly to a printer.

To print the sketch of the section:

1. Select Print sketch from the File menu.
2. Select the appropriate printer device.
3. You can optionally configure the printer device by clicking the Configure button.
This will show the default printer driver configuration dialog box. Refer to the printer's
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manual for more information.
4. Select Ok to print the sketch. Select Cancel to cancel the operation.

6.3.9 Print section data

With this option, you can prepare a report containing the section data. Note that with
this option the report is not printed directly; instead, a document is prepared and a
preview of the printout is created by the Print manager. You can print the report by
clicking the Print button of the toolbar of Print manager.

To create a report with the section data:

1. Select Print section data from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.
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NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.

6.3.10 Print section data to

6.3.10.1 Microsoft Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the section data can be created. Note
that Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the section data to a Microsoft Excel file:

1. Select Print section data to from the File menu.
2. Select Microsoft Excel from the Print section data to menu.

6.3.10.2 Microsoft Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the section data can be created. Note
that Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the section data to a Microsoft Word file:

1. Select Print section data to from the File menu.
2. Select Microsoft Word from the Print section data to menu.

6.3.10.3 Text file

With this option, you can create a simple text file containing the section data. This file
is recognized and can be further modified by word processors such as Microsoft Word,
OpenOffice Writer etc.

To print to a text file:

1. Select Print section data to from the File menu.
2. Select Text file from the Print section data to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.
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NOTE: If a file with the same name and in the same location already exists, a
warning message will appear that asks whether to overwrite the file or not. If you
answer Yes, then the existing file is erased and the new file takes its place. If you
answer No, the existing file remains intact but the report is NOT printed.

6.3.11 Close

With this option, you can close the Section editor and return to section input.

To close the Section editor:

1. Select Close from the File menu.
2. Select Yes if you want to save the changes and return to section input. Select No if
you want to discard the changes and return to section input. Select Cancel if you want
to cancel the operation and return to Section editor.

6.4 Edit

6.4.1 Edit menu

With this menu, you can add and modify the section data. In the Edit menu you can
select one of the following options:

Add polygon
Remove polygon
Add vertex
Insert vertex
Remove vertex
Select all
Cut
Copy
Paste
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6.4.2 Add polygon

With this option, you can add a curvilinear polygon to the section  i.e. an open or
closed polyline with straight or curved edges. A section must contain at least one
polygon. There is no restriction in the number of nodes of the polygon.

To add a polygon:

1. Select Add polygon from the Edit menu.
2. A polygon is added to the drop-down list of the polygons.

NOTE: This option is not available when entering ground and excavation data, as they
must consist of a single polygon.

6.4.3 Remove polygon

With this option, you can remove a curvilinear polygon from the section.

To remove a polygon:

1. Select the polygon from the drop-down list.
2. Select Remove polygon from the Edit menu.
3. The polygon is deleted.  You will be asked for confirmation only if you have selected
to confirm deletions in the General preferences tab. If you select No then the deletion
is canceled.

NOTE: This option is not available when entering ground and excavation data, as they
must consist of a single polygon.

6.4.4 Add vertex

With this option, you can add a vertex to the currently selected polygon. The vertex is
appended to the data matrix.

To add a vertex:

1. Select the polygon from the drop-down list.
2. Select Add vertex from the Edit menu.
3. A vertex is appended to the data matrix of the currently selected polygon.

NOTE: This option is not available when there is no polygon in the section. In this
case, add a polygon before adding a vertex.

6.4.5 Insert vertex

With this option, you can add a vertex to the selected polygon. The vertex is inserted
before the currently selected vertex of the currently selected polygon.

To insert a vertex:
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1. Select the polygon from the drop-down list.
2. Select Insert vertex from the Edit menu.
3. A vertex is inserted before the currently selected vertex of the selected polygon.

NOTE: This option is not available when there is no polygon in the section. In this
case, add a polygon before inserting a vertex.

6.4.6 Remove vertex

With this option, you can remove a vertex of the currently selected polygon.

To remove a vertex:

1. Select the polygon from the drop-down list.
2. Select the vertex from the data matrix.
3. Select Remove vertex from the Edit menu.
4. The currently selected vertex of the currently selected polygon is removed.

NOTE: Each polygon must consist of at least two nodes. These nodes cannot be
removed.

6.4.7 Select all

With this option, you can select all vertices of the currently selected polygon.

To select all vertices:

1. Select Select all from the Edit menu
2. All vertices of the currently selected polygon are selected.

6.4.8 Cut

With this option, you can cut the currently selected cells of the data matrix and
transfer them to the clipboard.

To cut:

1. Select the cells you wish to cut from the data matrix.
2. Select Cut from the Edit menu.
3. All selected cells of the data matrix are cut and transferred to the clipboard.

6.4.9 Copy

With this option, you can copy the currently selected cells of the data matrix to the
clipboard.

To copy:

1. Select the cells you wish to copy from the data matrix.
2. Select Copy from the Edit menu.
3. All selected cells of the data matrix are copied to the clipboard.

6.4.10 Paste

With this option, you can paste data from the clipboard to the data matrix.
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To paste:

1. Select the top left cell of the range where you want to paste the data.
2. Select Paste from the Edit menu.
3. The data are pasted from the clipboard to the data matrix.

NOTES:
The appropriate number of columns and rows is automatically identified by the
program.
With this option you can transfer data from other programs, such as Microsoft
Excel.

6.5 View

6.5.1 View menu

With this menu, you can modify the way you view the section. In the View menu you
can select one of the following options:

Zoom extent
Zoom window
Zoom previous
Zoom in
Zoom out
Display vertices
Display origin
Display grid
Display data matrix
Toggle excavations / section

6.5.2 Zoom extent

With this option, you can view the whole section.

To view the whole section:

1. Select Zoom extent from the View menu.
2. The viewport is adjusted automatically to include the whole section.

NOTE: This option is also available in the toolbar.

6.5.3 Zoom window

With this option, you can zoom to a specified window.

To zoom to a window:

1. Select Zoom window from the View menu.
2. Click on the drawing to define one corner of the window or hit ESC to cancel the
procedure.
3. Click on the drawing to define the opposite corner of the window or hit ESC to
cancel the procedure.
4. The viewport is adjusted automatically to zoom to the specified window.
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NOTE: This option is also available in the toolbar.

6.5.4 Zoom previous

With this option, you can revert to the previous zoom configuration.

To use the previous zoom configuration:

1. Select Zoom previous from the View menu.
2. The previous zoom configuration is applied.

NOTE: This option is also available in the toolbar.

6.5.5 Zoom in

With this option, you can zoom in to a specified point.

To zoom in to a specified point:

1. Select Zoom in from the View menu.
2. Click on the drawing to define the point to zoom in to or hit ESC to cancel the
procedure.
3. The zoom factor is doubled and the viewport is adjusted to zoom in to the specified
point.

NOTE: This option is also available in the toolbar.

6.5.6 Zoom out

With this option, you can zoom out from a specified point.

To zoom out from a specified point:

1. Select Zoom out from the View menu.
2. Click on the drawing to define the point to zoom out from or hit ESC to cancel the
procedure.
3. The zoom factor is halved and the viewport is adjusted to zoom out from the
specified point.

NOTE: This option is also available in the toolbar.

6.5.7 Pan

With this option, you can move the drawing within the viewport.

To pan the drawing:

1. Select Pan from the View menu.
2. Click and drag on the drawing to move it within the viewport or hit ESC to cancel
the procedure.
3. The drawing is moved within the viewport.

NOTE: This option is also available in the toolbar.
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6.5.8 Display vertices

With this option, you can show or hide the vertices of the currently selected polygon.

To show or hide the vertices of the currently selected polygon:

1. Select Display vertices from the View menu.
2. If the vertices are visible then they become hidden and vice versa. If the option is
active then there is a tick on the left of the menu.

6.5.9 Display origin

With this option, you can show or hide the origin i.e. the point corresponding to (0,0).

To show or hide the origin:

1. Select Display origin from the View menu.
2. If the origin is visible then it becomes hidden and vice versa. If the option is active
then there is a tick on the left of the menu.

6.5.10 Display grid

With this option, you can show or hide the grid.

To show or hide the grid:

1. Select Display grid from the View menu.
2. If the grid is visible then it becomes hidden and vice versa. If the option is active
then there is a tick on the left of the menu.

6.5.11 Display data matrix

With this option, you can show or hide the data matrix.

To show or hide the data matrix:

1. Select Display data matrix from the View menu.
2. If the data matrix is visible then it becomes hidden and vice versa. If the option is
active then there is a tick on the left of the menu.

6.5.12 Toggle excavations / section

With this option, you can set whether the data matrix will display section data or
excavation data.

To toggle between section and excavation data:

1. Select Toggle excavations / section from the View menu.
2. If the data matrix contains section data then it will be loaded with excavation data
and vice versa.

NOTE: When the data matrix contains excavation data, the drop-down list of
polygons is loaded with two polygons, namely the excavation line and the natural
ground line.
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6.6 Options

6.6.1 Options menu

With this menu, you can modify the way you view the section. In the Options menu
you can select one of the following options:

Background color
Interior color
Grid
Edge pen color
Edge pen width
Inactive vertices
Water area
Excavations

6.6.2 Background color

With this option, you can change the background color of the drawing. The default
value is white.

To change the background color:

1. Select Background color from the Options menu.
2. The color selection dialog box appears.
3. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

6.6.3 Interior color

With this option, you can change the interior color of closed polygons. The default
value is grey.

To change the interior color of closed polygons:
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1. Select Interior color from the Options menu.
2. The color selection dialog box appears.
3. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

6.6.4 Grid

With this option, you can change the color and line style of the grid. Note that in order
to view the changes the grid must be visible.

To change the color and line style of the grid:

1. Select Grid from the Options menu.
2. The grid options dialog box appears:

3. Select Color to change the color of the line.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

4. Select Line to change the line style.
4.1. The line style selection dialog box appears.
4.2. Select the line style and width. The currently selected color is marked with a tick.
On top of the Cancel button, the old and the new color are displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

5. Click Ok to save the grid options and close the dialog box or click the Cancel
button to close the dialog box without saving the changes.

6.6.5 Edge pen color

With this option, you can change the pen color of the polygon edges.

To change the pen color of the polygon edges:

1. Select Edge pen color from the Options menu.
2. The edge pen color dialog box appears:
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3. Select One common color to use a single color for all edges. Select Gradient
color to use an intermediate color between two colors depending on the friction of the
edge.

A. One common color

4. Select Color to change the color of the pen.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

B. Gradient color

4. Two colors must be defined. The first corresponds to the minimum friction and the
second to the maximum friction value. These values are displayed next to the
corresponding picture boxes. Select the appropriate Color button to change the
corresponding color.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

5. Repeat step 4 with the second color, if necessary.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

Example of section with gradient edge color

NOTE: You can combine gradient color with varying pen width.

6.6.6 Edge pen width

With this option, you can change the pen width of the polygon edges.

To change the pen width of the polygon edges:

1. Select Edge pen width from the Options menu.
2. The edge pen width dialog box appears:

3. Select One common width to use a single width for all edges. Select
Proportional to friction to use an intermediate width between two values depending
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on the friction of the edge.

A. One common width

4. Select the appropriate width using the slider.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

B. Proportional to friction

4. Two values must be defined. The first corresponds to the minimum friction and the
second to the maximum friction. These values are displayed next to the corresponding
labels. Select the appropriate width using the corresponding slider.

5. Repeat step 4 with the second width, if necessary.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

Example of section with proportional edge width

NOTE: You can combine proportional width with varying pen color.
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6.6.7 Inactive vertices

With this option, you can change the color and pen width of the edges between
inactive vertices.

To change the color and pen width of the inactive edges:

1. Select Inactive vertices from the Options menu.
2. The inactive vertices dialog box appears:

3. Select Change to change the color of the pen.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

4. Select the appropriate pen width using the slider.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

6.6.8 Water area

With this option, you can change the interior color of water areas. You can also change
the pen color and width of the free width.

To change the interior color of water areas or the pen color and pen width of the free
width:

1. Select Water areas from the Options menu.
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2. The following dialog box appears:

3. Select Change from the Color frame to change the interior color for water areas.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

4. Select Change from the Free width frame to change the pen color for free width.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

5. Select the appropriate pen width using the slider.
6. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The free width is not visible in pressure sections.

6.6.9 Excavations

With this option, you can change the color and line styles of objects related to
excavations.

To change the color and line styles of objects related to excavations:

1. Select Excavations from the Options menu.
2. The following dialog box appears:

3. Select Change from the Excavations frame to change the interior color for
excavations.
3.1. The color selection dialog box appears.
3.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
3.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

4. Select Change from the Landfills frame to change the interior color for landfills.
4.1. The color selection dialog box appears.
4.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
4.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

5. Select Change from the Ground frame to change the pen color for the ground line.
5.1. The color selection dialog box appears.
5.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
5.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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NOTE: The color palette follows standard CAD color palettes.

6. Select the appropriate pen width of the ground line using the slider of the Ground
frame.

7. Select Change from the Excavation frame to change the pen color for the
excavation line.
7.1. The color selection dialog box appears.
7.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
7.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

8. Select the appropriate pen width of the excavation line using the slider of the
Excavation frame.
9. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: In order for excavations or landfills to be calculated, the ground and
excavation line must intersect each other. However, the presence of excavation or
landfill areas is not compulsory.
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6.7 Calculations

6.7.1 Calculation menu

With this menu, you have access to several computational tools. In the Calculations
menu you can select one of the following options:

Origin
o Enter origin coordinates

o Enter origin graphically

o Set origin to deep point

Active nodes
Select flow depth
Full flow

6.7.2 Origin

6.7.2.1 Enter origin coordinates

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) analytically. The coordinates of all vertices are
changed to comply with the new origin of the coordinate system.

To set the coordinates of the origin analytically:

1. Select Origin from the Calculations menu.
2. Select Enter origin coordinates from the Origin menu.
3. The origin coordinates dialog box appears.
4. Type the appropriate coordinates in the text boxes.
5. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0.

6.7.2.2 Enter origin graphically

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) graphically. The coordinates of all vertices are
changed to comply with the new origin of the coordinate system.

To set the coordinates of the origin graphically:

1. Select Origin from the Calculations menu.
2. Select Enter origin graphically from the Origin menu.
3. Click the desired point on the drawing or hit ESC to cancel the operation.
4. The coordinates of the origin are changed.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0 analytically.
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6.7.2.3 Set origin to deep point

With this option, you can set the coordinates of the origin, i.e. the (0,0) point, in the
WCS (World Coordinate System) equal to those of the deep point of the section. The
coordinates of all vertices are changed to comply with the new origin of the coordinate
system.

To set the coordinates of the origin equal to those of the deep point:

1. Select Origin from the Calculations menu.
2. Select Set origin to deep point from the Origin menu.
3. The coordinates of the origin are set equal to those of the deep point of the section.

NOTE: To return to the WCS, set both coordinates of the origin equal to 0 analytically.

6.7.3 Active nodes

With this option, you can set the active nodes (vertices) of a section. By default, all
nodes are active; therefore, the flow may occur anywhere in the section.

However, if we know that the flow occurs between vertex 0 and 17 of the above
example, we must deactivate vertices 17 to 22.

To select the active nodes (vertices):

1. Select Active nodes from the Calculations menu.
2. Select the polygon in question, the upper active index (in this case, 17 instead of
22) and the lower active index (in this case, the same node i.e. node 0 is selected).



Sections 99

© 2012 TechnoLogismik i

3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

If you select 17 as the last active vertex in the above example, the flow is confined to
the left riverbed:

NOTE: The inactive edges are drawn with different pen color and size, according to
the preferences of the program.

6.7.4 Select flow depth

With this option, you can set a trial flow depth. This may be a value between 0 and
the maximum flow depth. This option is used for demonstrating the way the section is
filled for various depths and it is not used in calculations.

To set a trial depth:

1. Select Select flow depth from the Calculations menu.
2. The flow depth selection dialog box appears.
3. Type the trial flow depth in the text box. The maximum flow depth is displayed in
the label beneath the text box.
4. Alternatively, click Maximum to use the maximum flow depth.
5. Click Ok to close the dialog box and apply the selected flow depth. Click Cancel to
close the dialog box without changing the flow depth.
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6.7.5 Full flow

With this option, you can view the way the section is filled in an animated way. After
the animation, the full flow configuration of the section is displayed.

To view the way the section is filled in an animated way and view the full flow
configuration of the section:

1. Select Full flow from the Calculations menu.
2. The flow depth is increased from 0 to its maximum value.
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7 Help

7.1 Help menu

In the Help menu you can select one of the following options:

Contents
User guide
Tutorials
Tip of the day
Unit conversion
TechnoLogismiki website
Buy products
TechnoLogismiki NOMOS
TechnoLogismiki Live!
About the program

7.2 Contents

With this option, you can access the online help which contains detailed information
regarding the usage of the program.

To view the online help:

1. Click Contents from the Help menu.
2. The online help appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

7.3 User guide

With this option, you can access the user guide which contains detailed information
regarding the usage of the program.

To view the user guide:

1. Click User Guide from the Help menu.
2. The user guide appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

NOTE: Adobe Acrobat Reader or a similar program that can display pdf files is
required in order to view or print the user guide.

7.4 Tutorials

With this option, you can access the tutorials of the program. The tutorials are step-
by-step examples that allow you to decrease the learning cycle of the programs
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dramatically.

To access the tutorials:

1. Click Tutorials from the Help menu.
2. The tutorial selection dialog box appears.
2. Select the appropriate tutorial and click Start to proceed. Click Cancel to close the
dialog box.

NOTE: The number and content of the tutorials is changed frequently. Use the live
update system of TechnoLogismiki's products to download the latest tutorials.

7.5 Tip of the day

With this option, you can access the tip database of the program. The tips are short
guidelines regarding the usage of the programs which may be of great help to the
user.

To access the tips:

1. Click Tip of the day from the Help menu.
2. The tip of the day form appears.
3. Check Do not show this form again to prevent the program from showing the tip
of the day when starting. Press the Previous/Next buttons to browse all available
tips.
4. Press Esc to close the form.

NOTE: The number and content of the tips is changed frequently. Use the live update
system of TechnoLogismiki's products to download the latest tips.
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7.6 Unit conversion

With this option, you can access the unit conversion tool. You can find more
information about its usage in its help system. 

To launch the unit conversion tool:

1. Click Unit conversion from the Help menu.
2. The unit conversion tool is launched.

NOTE: If an error message appears then the unit conversion tool has not been
installed. You can install the unit conversion tool from the installation CD or the
Internet.

7.7 TechnoLogismiki website

With this option, you can load on your Internet browser the website of
TechnoLogismiki's.

7.8 Buy products

With this option, you can load on your Internet browser the main product page of
TechnoLogismiki's website.

7.9 TechnoLogismiki NOMOS

With this option, you can load on your Internet browser the NOMOS service of
Technologismiki.

7.10 TechnoLogismiki Live!

With this option, you can load on your Internet browser the Live! service of
Technologismiki.

7.11 About the program

With this option, a form containing the name, version and licence information of the
program appears.

To show this form:
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1. From the Help menu, select About the program.
2. The form appears.
3. Click anywhere on the form or hit ESC to close the form.
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8 Databases

8.1 Fluid database

For your convenience, a fully customizable fluid database is embedded in the program.
The fluid database is invoked in various cases within the program. By selecting an
appropriate fluid record and clicking Ok, the data is transferred to the corresponding
fields. Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the name of the fluid. This field is required.
3. Enter the temperature, density, viscosity and kinematic viscosity of the fluid.
4. The specific weight is calculated automatically.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
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3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

8.2 Friction database

For your convenience, a fully customizable friction database is embedded in the
program. The friction database is invoked in various cases within the program. By
selecting an appropriate friction record (which is depended on the selected friction
formula) and clicking Ok, the data is transferred to the corresponding fields. Select
Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:
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1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the friction.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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NOTE: In case of Manning friction coefficients in natural streams, you can estimate
the values based on several characteristics of the stream. Click on the buttons with
the ellipses (...) next to the text boxes to invoke the following dialog box: 

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
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8.3 Manning friction coefficients

Surface / Material
Mean
Value

Aluminum 0.024

Asbestos cement 0.013

Asphalt ditch 0.016

Asphalt pavement 0.016

Asphalt smooth 0.013

Asphalted cast iron 0.012

Natural ground 0.020

Best concrete 0.010

Brick in mortar 0.015

Brick sewer 0.015

Cast iron 0.012

CMP 0.024

Concrete 0.013

PVC 0.010

Centrifugal spun 0.013

Concrete (steel forms) 0.011

Concrete (wood forms) 0.015

Concrete gutter (broom finish) 0.016

Concrete gutter (troweled finish) 0.012

Copper 0.011

Fiber glass roving 0.011

Gravel riprap (D=25) 0.033

Gravel riprap (D=50) 0.041

Grouted riprap 0.030

Natural stream (clean) 0.030

Natural stream (stone) 0.050

Natural stream (weedy) 0.035

8.4 Bazin friction coefficients

Surface / Material
Max

value
Min

value
Mean
value

Rough concrete 0.5 0.4 0.46

Smooth concrete 0.08 0.04 0.06

Brick in mortar 0.018 0.014 0.016

Sewer pipes (Greek regulations
696/74)

0.25 0.25 0.25

Storm pipes (Greek regulations
696/74)

0.46 0.46 0.46
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8.5 Hazen - Williams friction coefficients

Surface / Material
Mean
value

Asbestos cement 140

Asphalted cast iron 130

Best concrete 150

Centrifugal spun 135

Concrete (wood forms) 120

Concrete (steel forms) 140

Copper 135

Ductile iron 130

Galvanized iron 120

Glass 140

PVC 150

Riveted steel (new, rough) 80

Riveted steel (new, smooth) 110

Steel 120

Wood (new) 140

8.6 Darcy - Weisbach friction coefficients

Surface / Material
Mean
value
(mm)

Aluminum 0.300

Asbestos cement 0.002

Asphalted cast iron 0.120

Best concrete 0.366

Brick in mortar 0.610

Sewer brick 0.610

CMP 0.305

Concrete 0.122

Centrifugal spun 0.366

Concrete (steel forms) 1.829

Concrete (wood forms) 0.610

Copper 0.002

Galvanized steel 1.520

Glass 0.001

PVC 0.122

HDPE 0.150
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8.7 Local energy losses friction coefficients

Fitting K-value Fitting K-value

Pipe entrance 90° smooth
bend1

Bellmouth 0.00 ~ 0.05 r/D=4 (r radius) 0.16 ~
0.18

Rounded 0.18 r/D=2 0.19 ~
0.25

Sharp edged 0.50 r/D=1.5 0.26 ~
0.34

Projecting 0.80 ~ 1.00 r/D=1 0.35 ~
0.40

Contraction -
Sudden

Mitered bend

D2/D1 = 0.20 0.41 ~ 0.50 15° angle 0.05

0.20 < D2/D1 =

0.40

0.30 ~ 0.41 30° angle 0.10

0.40 < D2/D1 =

0.60

0.18 ~ 0.30 45° angle 0.20

0.60 < D2/D1 =

0.80

0.06 ~ 0.18 60° angle 0.35

D2/D1 = 0.80 0.00 ~ 0.06 90° angle 0.80

Contraction -
Conical

Tee2

15° angle 0.02 Line flow 0.30 ~
0.40

22.5° angle 0.04 Branch flow 0.60 ~
2.10

45° angle 0.07 45° Wye2

Expansion -
Sudden

Line flow 0.20 ~
0.35

D2/D1 = 0.20 0.92 ~ 1.00 Branch flow 0.45 ~
0.55

0.20 < D2/D1 =

0.40

0.71 ~ 0.92 Cross2

0.40 < D2/D1 =

0.60

0.41 ~ 0.71 Line flow 0.40 ~
0.60

0.60 < D2/D1 =

0.80

0.13 ~ 0.41 Branch flow 0.60 ~
0.90

D2/D1 = 0.80 0.00 ~ 0.13 Spherical valves
3

Expansion -
Conical

90° angle 0.05
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Fitting K-value Fitting K-value

15° angle 0.03 60° angle 1.20

22.5° angle 0.07 45° angle 10.00

45° angle 0.14 30° angle 50.00

NOTES:

1.These values are valid for Reynolds number around 2x105.

2. Typical values for commercial parts.
3. The angle of spherical valves is the complementary angle defined by the pipe axis
and the valve opening axis.
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