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1 About the program

1.1 What does the program do?

This program calculates the water hammer caused by slow closing of a valve
downstream. The water level of the tank is assumed constant.

For the friction calculation, one of 15 available formulas may be used. The solver is
based on the method of characteristic lines which substitutes the hyperbolic partial
differential equations with common ones.

The program can show the variation of the pressure, celerity and flow rate along the
pipe in a visual and animated way, including the maximum over-pressure and sub-
pressure. Alternatively, the results can be displayed in tabulated form.

1.2 Minimum requirements

The minimum requirements for the usage of the programs are the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium III 800 MHz
800x600 with 256 color palette
700 MB free disk space
CD-Rom

If your system does not meet one or more of the above requirements, it is highly
recommended that you upgrade it before installing the programs. The recommended
system configuration is the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium IV 2.0 GHz
1280x768 with 16-bit color palette
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1.2 GB free disk space
CD-Rom
Internet connection

1.3 Technical support

Support through the Internet

TechnoLogismiki offers technical support 24 hours per day, 365 days per year, through
the web site where you can get information on the latest programs and services.

Support by e-mail

Please use the dedicated e-mail addresses for better customer service:

for questions regarding sales: sales@technologismiki.com
for questions regarding the usage of programs: support@technologismiki.com
for any other question or comment: info@technologismiki.com

The normal response time is within two business days. If your inquiry cannot be
answered by e-mail, a customer service representative will contact you by telephone.

Interactive Support

Business days, 09:00 - 17:00 Eastern European Time:

Telephone [3 lines]: ++30-210-656-4147
Fax: ++30-210-654-8461
Address: 5, Imittou street, Cholargos, 15561, Athens, Greece.
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2 File

2.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New project
Open project
Save project
Save project as
Export
o Export sketch

Print setup
Print
Print to
o Print to file

o Print to Word

o Print to Word (Formatted)

o Print to Excel

Exit

2.2 New project

With this option, a new project is started. All data, results, graphs, titles etc. of the
previous project are erased.

To create a new project:

1. Select New project from the File menu.
2. If a project is already loaded and changes have been made, a warning message will
appear that asks the user whether to save the changes or not.
3. The current project is erased and a new project is started.

2.3 Open project

With this option, an existing project is loaded. The project may be stored locally, in a
network or in an external media device such as a CD-Rom. If a project is already
loaded and changes have been made, a warning message will appear that asks
whether to save the changes or not. When a project is loaded, all data of the previous
project are lost.

To open an existing project:

1. Select Open project from the File menu.
2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Hydraulic hammer project" with the extension .m02.
4. Select the file by clicking on it.
5. Select Open to open the selected file. Select Cancel to cancel the operation.
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NOTE: You can find sample projects in the installation folder of the program:
C:\Program Files\TechnoLogismiki\TLW2013\Samples\WaterHammer

Supported file types

Μ07 (Water hammer project): Files created by version 2012 and 2013 of Water
hammer.
Μ507 (Water hammer project): Files created by versions 2011, 2010, 2009, 2008,
2007 and 5.0 of Water hammer.
MB7 (Water hammer project v2.x, 3.x or 4.x.): Files created by versions 2.x, 3.x or
4.x of Water hammer.
BCK (Backup files): If you have selected from program options the creation of
backup copy when a file is loaded, then the file can be loaded by selecting Backup
files (*.bck) from the Files of type drop-down list.
*.* (All files): Displays all files in the current folder.

Backwards compatibility

This version implements full backwards compatibility; however, note that when a
project is saved with the latest format, it cannot be used by previous versions.

NOTE: If the message "Could not load project. File may be corrupt or saved by an
unknown or incompatible version of the program" appears, then either you are trying
to load a project that does not belong to this program or the file is used (and locked)
by another process in your computer.

2.4 Save project

With this option, you can save all data of a project into a file. The file can be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you attempt to save a project.
When the filename and path are set, all subsequent saves will be made to the same
file.

When you want to rename a file or save it in a new location, use Save project as...
from the File menu.

To save the current project:
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1. Select Save project from the File menu.
2. If the location of the file is already set, the project is saved to this file without any
messages. If the filename is not set, a dialog box will appear that allows the selection
of the filename and path.

2.5 Save project as

With this option, the current project is saved just as in the case of Save project, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.

To save a project with another name and/or to another location:

1. Select Save project as from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current project are saved.

2.6 Export

2.6.1 Export sketch

With this option, you can export (in BMP format) the sketch of the solution as it
appears in the main form of the program.

To export the sketch of the solution:

1. Select the solution from the list of the main form in order to display the sketch.
2. Select Export sketch from the File menu.
3. Select Graph from the Export sketch menu.
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4. Select the path of the file.
5. Type the filename in the File name text box.
6. Select Save to create the file. Select Cancel to cancel the operation.

2.7 Print setup

With this option, you can select which parts of the project will be included in the
printouts. When a new project is created, a full report is selected by default.

To modify the print setup:

1. Select Print setup from the File menu.
2. Select the sections (Title, Project information etc) that will be printed, from the list
on the left.
3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection of a list.

NOTE: The changes are saved with the project. The above preferences are used to all
printouts, either to the printer or to other formats such as Word file, Excel file etc.

2.8 Print

With this option, you can prepare a report to be printed to a local, network or virtual
printer such as Adobe PDF Writer. The parts of the project that will be included in the
report are determined from print setup.
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By selecting Print, the report is not printed directly; instead, a document is prepared
and a preview of the printout is created by the Print manager. You can print the
report by clicking the Print button of the toolbar of Print manager.

To create a report:

1. Select Print from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.

NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.

2.9 Print to

2.9.1 Print to File

With this option, you can create a simple text file containing a report of the project.
This file is recognized and can be further modified by word processors such as
Microsoft Word, OpenOffice Writer etc.

To print to a text file:

1. Select Print to from the File menu.
2. Select Print to file from the Print to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
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5. Select Save to create the file.

The parts of the project that will be included in the report are determined from print
setup.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but the report is NOT printed.

2.9.2 Print to Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

2.9.3 Print to Word (Formatted)

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a formatted Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word (Formatted) from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup. This operation is much slower than the regular print to word function. However,
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the final output requires minimal user intervention as it comes fully formatted with
tables, alignment, font styles, etc.

NOTE: Do not use Copy (CTRL+C) on any of the programs running during this
operation. If you do so, it will most likely affect the communication between Microsoft
Word and the clipboard and as a result the final document will be corrupt.

2.9.4 Print to Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the report can be created. Note that
Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the report to a Microsoft Excel file:

1. Select Print to from the File menu.
2. Select Print to Excel from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

2.10 Exit

With this option, you can exit the program. If there are changes in the current project
that have not been saved then the program will:

either ask the user to save the changes
or save the changes
or ignore the changes

depending on what you have selected in General preferences.

To exit the program:

1. Select Exit from File menu.
2. If you are asked whether to save the changes or not, you can save changes or
ignore them.
3. The program is terminated.
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3 Data

3.1 Data menu

With this menu, you can add and modify data. In the Data menu you can select one
of the following options:

Project info
Undo
Redo
General data
Layout
o Layout

o Pipe data

o Tank data

o Valve data

Friction calculation
Options
o General preferences

o Customize toolbar

3.2 Project info

With this option, you can add project information that include, optionally, title, author
and comments. If you want, this information can be included in the reports. The
empty fields are ignored.

To add or modify the project information:

1. Select Project info from the Data menu.
2. Type the project title, author and comments.
3. Check Include project time and date if you want to include the time and date in
the project.
3.1. Type the day, month, year, hours and minutes in the corresponding text boxes.
Alternatively, you may click on the up/down arrows to increase or decrease the
respective value in the text box.
3.2. If you click on Now then all text boxes are filled with the current values
automatically.
4. Check Include the name of the project file if you want the full path and filename
of the project to be included in the report.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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By selecting the buttons with the ellipses (...) next to the project title and author, you
can access the corresponding databases.

Project title database

For the completion of a project, more than one programs may be needed. For
convenience, you can add the project title to the database and retrieve it from all
programs.

To use the project title database:

1. Select the button with the ellipses (...) next to the project title text box. The project
title database appears.
2. Select Add to add a new title to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected project title and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

Author database
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An engineer may be involved in multiple projects. For convenience, you can add the
author name to the database and retrieve it from all programs.

To use the author database:

1. Select the button with the ellipses (...) next to the author text box. The author
database appears.
2. Select Add to add a new author to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected author and close the dialog box. Select
Cancel to close the dialog box without applying any changes.

3.3 Undo

Undo cancels the last committed change in the project.

To cancel the last committed change:

1. Select Undo from the Data menu.
2. The last committed change is canceled.

To cancel an undo command, you may use the redo function which is described
below. Redo becomes available once undo is used.

It is possible to undo more than one recent changes and to redo them, by following
the step described above. The number of actions that are kept in memory and may be
undone or redone is 20 by default. This means that the program is able to keep track
of up to 20 successive changes and undo them. This number may change for all
programs, using the option in the main menu. For more information, please consult
main menu user guide.

NOTE: Some changes cannot be undone like the new project or the save project
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functions.

3.4 Redo

Redo cancels the latest undo command.

To redo the latest change that was undone:

1. Select Redo from the Data menu.
2. The latest undone change is redone.

To undo a redo, you may use the undo command.

It is possible to redo more than one changes that were previously undone by following
the steps described above. The number of actions that are kept in memory and may
be undone or redone is 20 by default. This means that the program is able to keep
track of up to 20 successive changes that are undone and redo them. This number
may change for all programs, using the option in the main menu. For more
information, please consult main menu user guide.

3.5 General data

With this option, you can input the general data.

To input the general data:

1. Select General data from the Data menu.
2. Enter the total observation time in s. The start of the closing of the valve is
considered to take place at t=0.
3. Enter the viscosity of the fluid in kg/(m x sec). Click the button with the ellipses
(...) to use the embedded fluid database.
4. Enter the density of the fluid in kg/(m3). Click the button with the ellipses (...) to
use the embedded fluid database.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.6 Layout

3.6.1 Layout

With this option, you can view the layout of the system and input additional data.

To view the layout of the system and input additional data:

1. Select Layout from the Data menu.
2. Click Pipes to input additional data regarding the pipes.
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3. Click Tank to input additional data regarding the tank.
4. Click Valve to input additional data regarding the valve.
5. Select Ok to close the dialog box.

3.6.2 Pipe data

With this option, you can input additional data regarding the pipes.

To input additional data regarding the pipes:

1. Select Layout from the Data menu.
2. Click the Pipes button. The following form appears:

3. Optionally, you can click the Legend > button to display a sketch of the system.

4. Select the pipe from the drop-down list. It the length of the selected pipe is equal
to zero, the program assumes that the pipe does not exist.

NOTE: At least two pipes are required. If the system consists of a single pipe, use
two pipes with half the total length and the same other characteristics.

5. The required data for each pipe are the following:

Pipe length: the pipe length in m.
Pipe diameter: the internal pipe diameter in mm.
Friction factor: it depends on the selected friction formula and the material of
the pipe. Click the button with the ellipses (...) to use the friction coefficient 
database. 
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Wave celerity: the wave celerity in m/s. It is depended mostly on the
compressibility of the fluid and the modulus of elasticity of the material of the
pipe. If it is known, it can be entered directly in this text box. If it is not known,
enter zero in this field and the celerity will be calculated by other data. 
Modulus of elasticity: enter the modulus of elasticity of the material of the pipe

in N/m2. Click the button with the ellipses (...) to use the modulus of elasticity
database.
Poisson ratio: enter the Poisson ratio of the material of the pipe. Click the button
with the ellipses (...) to use the Poisson ration database.
Pipe wall thickness: the pipe wall thickness in mm. This is required only if the
wave celerity is not known and must be calculated.
The pipe has no joints: check this if the pipe has no joints. This is required only
if the wave celerity is not known and must be calculated. It is used for the
estimation of the anchorage coefficient of the pipe.
It is allowed to move along its axis: check this if the pipe is allowed to move
along its axis. This is required only if the wave celerity is not known and must be
calculated. It is used for the estimation of the anchorage coefficient of the pipe.

6.  Select Ok to apply the changes and close the dialog box. Select Cancel to close
the dialog box without applying any changes.

3.6.3 Tank data

With this option, you can input additional data regarding the tank.

To input additional data regarding the tank:

1. Select Layout from the Data menu.
2. Click the Tank button. The following form appears:

3.  Enter the (constant) water level of the tank in m.
4.  Select Ok to apply the changes and close the dialog box. Select Cancel to close
the dialog box without applying any changes.

3.6.4 Valve data

With this option, you can input additional data regarding the valve.

To input additional data regarding the valve:

1. Select Layout from the Data menu.
2. Click the Valve button. The following form appears:
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3.  Enter the shutoff exponent by typing into the text box.
4.  Enter the shutoff time by typing into the text box.
5.  Select Ok to apply the changes and close the dialog box. Select Cancel to close
the dialog box without applying any changes.

NOTE: If the shutoff exponent is equal to 1 then the closing of the valve is considered
to be linear.

3.7 Friction calculation

With this option, you can select the formulas that will be used for the calculation of
the friction losses and calibrate the solvers.

To select the friction formulas:

1. Select Friction calculation from the Data menu. The following form appears:

2. Make the appropriate changes. You can select up to three different friction formulas,
depending on the type of flow (turbulent, transient, laminar). If you check Set as
defaults for all new projects then these values will be preselected for all new
projects.

First, you define the boundaries of turbulent and laminar flow. The use of Re>4000 for
turbulent flow and Re<2000 for laminar flow is recommended. For intermediate
values, the flow is considered to be transient. If you set the same friction formula for
all types of flow, this analysis has no effect.

Note that different friction formulas need different friction coefficients. The first three
choices are variations of the well-known Manning formula. The first, named Manning,
assumes constant friction coefficient. The other two calculate the friction coefficient as
a function of the fill ratio and the coefficient that corresponds to full flow. These three
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formulas give the same results in flow under pressure; this is not the case for flow
with free surface, where up to 30% difference may be observed.

The Accuracy and Maximum number of trials ensure the stability of the algorithm.
The default values are 0.0005 for the accuracy and 1000 for the maximum number of
trials. It is recommended that you do not change these values.

The averaging formula may take one of the following values:

Pavlovskii
Colebatch
Horton
Cox
Lotter

The above formulas are used when there are different friction coefficients within the
same section and an average friction coefficient is needed.

3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.8 Options

3.8.1 General preferences

With this option, you can modify the general preferences of the program.

To modify the general preferences:

1. Select Options from the Data menu.
2. Select General preferences from the Options menu.
3. The general preferences dialog box appears. The preferences are grouped into four
tabs. You can select a tab by clicking on its name.

General Tab

This tab contains general preferences regarding the usage of the program.

Check Register the extension *.m02 with this application to associate the
extension .m02 with this program. This extension is used by the program when saving
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a project. In this way, you will be able to run the program and load a project by
double-clicking on the project filename in Windows Explorer.

Check Automatically display calculation messages if you want the report details to
be automatically displayed when you calculate the results.

Check Automatically create backup file if you want a backup file (with the
extension .bck) to be created every time a project is loaded. By default, this file is
created in the temporary folder of Windows.

Check Confirm delete actions if you want to be asked for confirmation each time an
object is about to be deleted. This setting affects the behavior of most delete actions.

You can also modify the temporary folder that will be used for the creation of backup
files. By default, this folder is the temporary folder of Windows.

Finally, there are three options regarding the termination of the program:

When exiting always ignore changes - All changes since the last save of the
project are ignored. 
When exiting always save changes - All changes in the current project are
automatically saved. If the filename of the project is not set, a dialog box will
appear that allows the selection of the filename, as when selecting Save project
as from the File menu.
When exiting prompt for action - If there are changes in the current project,
then a dialog box will appear. You can choose to save or ignore the changes. If
the filename of the project is not set, a dialog box will appear that allows the
selection of the filename, as when selecting Save project as from the File menu.

Languages Tab

If more than one language packs have been installed, then you can choose the
language of the program. In the above case, there are two language packs; English
(that are already selected) and Greek. If you change the language, all forms, menus,
messages, help files will reflect the chosen language.

In order for the changes to take effect, you must restart the program.

Digits Tab
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With this tab, you can modify the way the results are presented. All values used in the
program are displayed in the list on the left.

For each value, you can select the number of decimal digits using the Number of
digits drop-down list.

Check Use 0.1 instead of .1 to use a preceding zero when displaying numbers
between -1 and 1, for example -0.08 instead of -.08 and 0.98 instead of .98.

Check Use 1.0 instead of 1 to use trailing zeros (when necessary) in order to display
a number with the decimal digits selected in the Number of digits drop-down list, for
example 1.1600 instead of 1.16 (when the number of digits is set to 4).

Internet Tab

The program can automatically check for newer versions over the Internet. Check 
Automatically check for newer versions to enable this feature. The check is
automatically performed at an interval specified in the Every drop-down list. Select
Check now to manually check for newer versions.

When a newer version is found, you will be prompted to download and install the
latest version.

NOTE: TechnoLogismiki protects your privacy. During the check for newer versions,
no data is transferred from your computer to the Internet.
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Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.8.2 Customize toolbar

With this option, you can customize the toolbar of the main form.

To customize the toolbar of the main form:

1. Select Options from the Data menu.
2. Select Customize toolbar from the Options menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The toolbar may contain small or large buttons.

Check Show description if you want a small description to be displayed under the
buttons.

Check Show tooltips if you want tooltips to be displayed when the mouse pointer
hovers over a button for 2-3 seconds.

NOTE: These preferences affect all projects, old and new.
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4 Results

4.1 Results menu

With this menu, you can perform calculations. In the Results menu you can select
one of the following options:

Perform calculations
System
Graph
Details
Pressure at station
Velocity at station
Flow at station

4.2 Perform calculations

With this option, you can perform calculations. The results are displayed in the main
form.

To perform calculations:

1. Select Perform calculations from the Results menu.
2. The calculations are performed and the results are displayed in the main form.

4.3 System

With this option, you can display the results regarding the system after the completion
of the calculations.

To display the results regarding the system:

1. Select System from the Results menu.
2. The corresponding tab is displayed in the main form:
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4.4 Graph

With this option, you can display the graph of the results after the completion of the 
calculations.

To display the graph:

1. Select Graph from the Results menu.
2. The corresponding tab is displayed in the main form:

3. Select the pipe from the drop-down list.
4. You can change the time instant by clicking the appropriate button:

 Click this button to go to the first time instant.

 Click this button to animate from the current time instant to the beginning.

 Click this button to go to the previous time instant.

 Click this button to stop the animation.

 Click this button to go to the next time instant.

 Click this button to animate from the current time instant to the end.

 Click this button to go to the last time instant.

Check Endless loop to loop when animating. This option is effective when the
animation is either normal or reverse.

4.5 Details

With this option, you can display the details of the results after the completion of the 
calculations.

To display the details:
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1. Select Details from the Results menu.
2. The corresponding tab is displayed in the main form:

3. Select the pipe from the drop-down list.
4. You can change the time instant by clicking the appropriate button:

 Click this button to go to the first time instant.

 Click this button to go to the previous time instant.

 Click this button to stop the animation.

 Click this button to go to the next time instant.

 Click this button to go to the last time instant.

4.6 Pressure at station

With this option, you can create a pressure graph at a specific station of a pipe.

To create a pressure graph:

1. Select Pressure at station from the Results menu. The following form appears:

2. Select the pipe from the drop-down list.
3. Enter the station as the distance from the start of the pipe in m.
4. Click Graph > to create the graph:
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In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

Click the X button at the top-right corner of the form to close the graph.

4.7 Velocity at station

With this option, you can create a velocity graph at a specific station of a pipe.

To create a velocity graph:

1. Select Velocity at station from the Results menu. The following form appears:

2. Select the pipe from the drop-down list.
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3. Enter the station as the distance from the start of the pipe in m.
4. Click Graph > to create the graph:

In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

Click the X button at the top-right corner of the form to close the graph.

4.8 Flow at station

With this option, you can create a flow rate graph at a specific station of a pipe.

To create a flow rate graph:

1. Select Flow at station from the Results menu. The following form appears:
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2. Select the pipe from the drop-down list.
3. Enter the station as the distance from the start of the pipe in m.
4. Click Graph > to create the graph:

In the Settings menu, you can select one of the following options:

Customize: you can customize the appearance of the graph (colors, axes, line
styles, text etc).
Save settings: the current settings are saved in a file.
Load settings: the settings are loaded from a file.
Export to BMP: the current image is saved in BMP format.

In the Tools menu, you can select one of the following options:

Copy to clipboard: the current image is copied to the clipboard and becomes
available to many programs such as Microsoft Word.
Set total graph width: the total image width (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set total graph height: the total image height (in pixels) is set. This is
particularly useful when creating images with certain dimensions.
Set graph width: the internal graph width (in pixels) is set. This is particularly
useful when creating images with certain dimensions.
Set graph height: the internal graph height (in pixels) is set. This is particularly
useful when creating images with certain dimensions.

Click the X button at the top-right corner of the form to close the graph.
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5 Help

5.1 Help menu

In the Help menu you can select one of the following options:

Contents
User guide
Tutorials
Tip of the day
Unit conversion
TechnoLogismiki website
Buy products
TechnoLogismiki NOMOS
TechnoLogismiki Live!
About the program

5.2 Contents

With this option, you can access the online help which contains detailed information
regarding the usage of the program.

To view the online help:

1. Click Contents from the Help menu.
2. The online help appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

5.3 User guide

With this option, you can access the user guide which contains detailed information
regarding the usage of the program.

To view the user guide:

1. Click User Guide from the Help menu.
2. The user guide appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

NOTE: Adobe Acrobat Reader or a similar program that can display pdf files is
required in order to view or print the user guide.

5.4 Tutorials

With this option, you can access the tutorials of the program. The tutorials are step-
by-step examples that allow you to decrease the learning cycle of the programs
dramatically.



Water Hammer38

© 2012 TechnoLogismik i

To access the tutorials:

1. Click Tutorials from the Help menu.
2. The tutorial selection dialog box appears.
2. Select the appropriate tutorial and click Start to proceed. Click Cancel to close the
dialog box.

NOTE: The number and content of the tutorials is changed frequently. Use the live
update system of TechnoLogismiki's products to download the latest tutorials.

5.5 Tip of the day

With this option, you can access the tip database of the program. The tips are short
guidelines regarding the usage of the programs which may be of great help to the
user.

To access the tips:

1. Click Tip of the day from the Help menu.
2. The tip of the day form appears.
3. Check Do not show this form again to prevent the program from showing the tip
of the day when starting. Press the Previous/Next buttons to browse all available
tips.
4. Press Esc to close the form.

NOTE: The number and content of the tips is changed frequently. Use the live update
system of TechnoLogismiki's products to download the latest tips.
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5.6 Unit conversion

With this option, you can access the unit conversion tool. You can find more
information about its usage in its help system. 

To launch the unit conversion tool:

1. Click Unit conversion from the Help menu.
2. The unit conversion tool is launched.

NOTE: If an error message appears then the unit conversion tool has not been
installed. You can install the unit conversion tool from the installation CD or the
Internet.

5.7 TechnoLogismiki website

With this option, you can load on your Internet browser the website of
TechnoLogismiki's.

5.8 Buy products

With this option, you can load on your Internet browser the main product page of
TechnoLogismiki's website.

5.9 TechnoLogismiki NOMOS

With this option, you can load on your Internet browser the NOMOS service of
Technologismiki.

5.10 TechnoLogismiki Live!

With this option, you can load on your Internet browser the Live! service of
Technologismiki.

5.11 About the program

With this option, a form containing the name, version and licence information of the
program appears.

To show this form:
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1. From the Help menu, select About the program.
2. The form appears.
3. Click anywhere on the form or hit ESC to close the form.
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6 Databases

6.1 Fluid database

For your convenience, a fully customizable fluid database is embedded in the program.
The fluid database is invoked in various cases within the program. By selecting an
appropriate fluid record and clicking Ok, the data is transferred to the corresponding
fields. Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the name of the fluid. This field is required.
3. Enter the temperature, density, viscosity and kinematic viscosity of the fluid.
4. The specific weight is calculated automatically.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
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3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

6.2 Friction database

For your convenience, a fully customizable friction database is embedded in the
program. The friction database is invoked in various cases within the program. By
selecting an appropriate friction record (which is depended on the selected friction
formula) and clicking Ok, the data is transferred to the corresponding fields. Select
Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:
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1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the friction.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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NOTE: In case of Manning friction coefficients in natural streams, you can estimate
the values based on several characteristics of the stream. Click on the buttons with
the ellipses (...) next to the text boxes to invoke the following dialog box: 

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
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6.3 Manning friction coefficients

Surface / Material
Mean
Value

Aluminum 0.024

Asbestos cement 0.013

Asphalt ditch 0.016

Asphalt pavement 0.016

Asphalt smooth 0.013

Asphalted cast iron 0.012

Natural ground 0.020

Best concrete 0.010

Brick in mortar 0.015

Brick sewer 0.015

Cast iron 0.012

CMP 0.024

Concrete 0.013

PVC 0.010

Centrifugal spun 0.013

Concrete (steel forms) 0.011

Concrete (wood forms) 0.015

Concrete gutter (broom finish) 0.016

Concrete gutter (troweled finish) 0.012

Copper 0.011

Fiber glass roving 0.011

Gravel riprap (D=25) 0.033

Gravel riprap (D=50) 0.041

Grouted riprap 0.030

Natural stream (clean) 0.030

Natural stream (stone) 0.050

Natural stream (weedy) 0.035

6.4 Bazin friction coefficients

Surface / Material
Max

value
Min

value
Mean
value

Rough concrete 0.5 0.4 0.46

Smooth concrete 0.08 0.04 0.06

Brick in mortar 0.018 0.014 0.016

Sewer pipes (Greek regulations
696/74)

0.25 0.25 0.25

Storm pipes (Greek regulations
696/74)

0.46 0.46 0.46
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6.5 Hazen - Williams friction coefficients

Surface / Material
Mean
value

Asbestos cement 140

Asphalted cast iron 130

Best concrete 150

Centrifugal spun 135

Concrete (wood forms) 120

Concrete (steel forms) 140

Copper 135

Ductile iron 130

Galvanized iron 120

Glass 140

PVC 150

Riveted steel (new, rough) 80

Riveted steel (new, smooth) 110

Steel 120

Wood (new) 140

6.6 Darcy - Weisbach friction coefficients

Surface / Material
Mean
value
(mm)

Aluminum 0.300

Asbestos cement 0.002

Asphalted cast iron 0.120

Best concrete 0.366

Brick in mortar 0.610

Sewer brick 0.610

CMP 0.305

Concrete 0.122

Centrifugal spun 0.366

Concrete (steel forms) 1.829

Concrete (wood forms) 0.610

Copper 0.002

Galvanized steel 1.520

Glass 0.001

PVC 0.122

HDPE 0.150



Water Hammer48

© 2012 TechnoLogismik i

6.7 Poisson ratio database

For your convenience, a fully customizable Poisson ratio database is embedded in the
program. The database is invoked in various cases within the program. By selecting an
appropriate record (which is depended on the selected friction formula) and clicking 
Ok, the data is transferred to the corresponding fields. Select Cancel to close the
database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the Poisson ratio.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.
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To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

6.8 Modulus of elasticity

For your convenience, a fully customizable Modulus of elasticity database is embedded
in the program. The database is invoked in various cases within the program. By
selecting an appropriate record (which is depended on the selected friction formula)
and clicking Ok, the data is transferred to the corresponding fields. Select Cancel to
close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.
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To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the modulus of elasticity.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.
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To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
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