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1 About the program

1.1 What does the program do?

Water Networks is a computer program that performs extended period simulation of
hydraulic and water quality behavior within pressurized pipe networks. A network
consists of pipes, nodes (pipe junctions), pumps, valves and storage tanks or
reservoirs. The program tracks the flow of water in each pipe, the pressure at each
node, the height of water in each tank, and the concentration of a chemical species
throughout the network during a simulation period comprised of multiple time steps.

In addition to chemical species, water age and source tracing can also be simulated.
The program is designed to be a research tool for improving our understanding of the
movement and fate of drinking water constituents within distribution systems. It can
be used for many different kinds of applications in distribution systems analysis.

Sampling program design, hydraulic model calibration, chlorine residual analysis, and
consumer exposure assessment are some examples. The program can help assess
alternative management strategies for improving water quality throughout a system.

These can include:

altering source utilization within multiple source systems
altering pumping and tank filling/emptying schedules
use of satellite treatment, such as re-chlorination at storage tanks
targeted pipe cleaning and replacement.

The program is based on and fully compatible with EPA EPANET 2. It offers unique
design tools and extensive import/export capabilities through DXF/GTM/GIS files.
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Some of the unique features of Water Networks are:

Handles Water / Irrigation networks

Easy data input in plan view and/or profile view with embedded spreadsheets.

Fully compatible with American regulations (ASCE & WPCF) as well as Greek
Regulations

Easy data input from drawings and / or spreadsheets

Automatic data input based on logical rules

Active profile drawings with CAD capabilities

Conduit / Manhole / Trench specifications

One-click generation of professional reports

One-click generation of plan view and profile drawings

One-click generation of quantities report, including pipe lengths, excavations,
backfill etc.

1.2 Minimum requirements

The minimum requirements for the usage of the programs are the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium III 800 MHz
800x600 with 256 color palette
700 MB free disk space
CD-Rom

If your system does not meet one or more of the above requirements, it is highly
recommended that you upgrade it before installing the programs. The recommended
system configuration is the following:

Windows 2000/ XP/ 2003/ Vista/ 7 (for each case, the latest service packs,
updates & patches must be installed)
Pentium IV 2.0 GHz
1280x768 with 16-bit color palette
1.2 GB free disk space
CD-Rom
Internet connection

1.3 Technical support

Support through the Internet

TechnoLogismiki offers technical support 24 hours per day, 365 days per year, through
the web site where you can get information on the latest programs and services.
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Support by e-mail

Please use the dedicated e-mail addresses for better customer service:

for questions regarding sales: sales@technologismiki.com
for questions regarding the usage of programs: support@technologismiki.com
for any other question or comment: info@technologismiki.com

The normal response time is within two business days. If your inquiry cannot be
answered by e-mail, a customer service representative will contact you by telephone.

Interactive Support

Business days, 09:00 - 17:00 Eastern European Time:

Telephone [3 lines]: ++30-210-656-4147
Fax: ++30-210-654-8461
Address: 5, Imittou street, Cholargos, 15561, Athens, Greece.
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2 User Interface

2.1 Methodology

2.1.1 Computational Methods

The program and this manual are based on EPA's EPANET 2, which is a computer
program that performs extended period simulation of hydraulic and water quality
behavior within pressurized pipe networks. 

This section briefly describes the methodology employed by the program regarding the
following topics:

Physical components
Non-physical components
Hydraulic simulation model
Water quality simulation model

2.1.2 Physical components

Water Networks models a water distribution system as a collection of links connected
to nodes. The links represent pipes, pumps, and control valves. The nodes represent
junctions, tanks, and reservoirs. The figure below illustrates how these objects can be
connected to one another to form a network.

Physical components may include:

Junctions
Reservoirs
Tanks
Emitters
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Pipes
Pumps
Valves

2.1.2.1 Junctions

Junctions are points in the network where links join together and where water enters
or leaves the network. The basic input data required for junctions are:

elevation above some reference (usually mean sea level)
water demand (rate of withdrawal from the network)
initial water quality

The output results computed for junctions at all time periods of a simulation are:

hydraulic head (internal energy per unit weight of fluid)
pressure
water quality

Junctions can also:

have their demand vary with time
have multiple categories of demands assigned to them
have negative demands indicating that water is entering the network
be water quality sources where constituents enter the network
contain emitters (or sprinklers) which make the outflow rate depend on the
pressure.

2.1.2.2 Reservoirs

Reservoirs are nodes that represent an infinite external source or sink of water to the
network. They are used to model such things as lakes, rivers, groundwater aquifers,
and tie-ins to other systems. Reservoirs can also serve as water quality source points.

The primary input properties for a reservoir are its hydraulic head (equal to the water
surface elevation if the reservoir is not under pressure) and its initial quality for water
quality analysis.

Because a reservoir is a boundary point to a network, its head and water quality
cannot be affected by what happens within the network. Therefore it has no computed
output properties. However its head can be made to vary with time by assigning a 
time pattern to it.

2.1.2.3 Tanks

Tanks are nodes with storage capacity, where the volume of stored water can vary
with time during a simulation. The primary input properties for tanks are:

bottom elevation, where water level is zero
diameter or shape if non-cylindrical
initial, minimum and maximum water levels
initial water quality

The principal outputs computed over time are:
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hydraulic head which is the water surface elevation
water quality

Tanks are required to operate within their minimum and maximum levels. The
program stops outflow if a tank is at its minimum level and stops inflow if it is at its
maximum level. Tanks can also serve as water quality source points.

2.1.2.4 Emitters

Emitters are devices associated with junctions that model the flow through a nozzle or
orifice that discharges to the atmosphere. The flow rate through the emitter varies as
a function of the pressure available at the node:

where: q, the flow rate
p, pressure
C, discharge coefficient and
γ, pressure exponent. 

For nozzles and sprinkler heads γ equals 0.5 and the manufacturer usually provides
the value of the discharge coefficient in units of (L/s)/atm0.5 or gpm/psi0.5, stated as
the flow through the device at a 1 atm (1 psi) pressure drop.

Emitters are used to model flow through sprinkler systems and irrigation networks.
They can also be used to simulate leakage in a pipe connected to the junction (if a
discharge coefficient and pressure exponent for the leaking crack or joint can be
estimated) or compute a fire flow at the junction (the flow available at some minimum
residual pressure). In the latter case one would use a very high value of the discharge
coefficient (e.g., 100 times the maximum flow expected) and modify the junction's
elevation to include the equivalent head of the pressure target. The program treats
emitters as a property of a junction and not as a separate network component.

2.1.2.5 Pipes

Pipes are links that convey water from one point in the network to another. The
program assumes that all pipes are full at all times. Flow direction is from the end at
higher hydraulic head (internal energy per weight of water) to that at lower head. The
principal hydraulic input parameters for pipes are:

start and end nodes
diameter
length
roughness coefficient for determining headloss
status which can be either open, closed, or contains a check valve

The status parameter allows pipes to implicitly contain shutoff (gate) valves and check
(non-return) valves (which allow flow in only one direction).

The water quality inputs for pipes consist of:
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bulk reaction coefficient
wall reaction coefficient

These coefficients are explained more thoroughly in the water quality reactions
section.

Computed outputs for pipes include:

flow rate
velocity
headloss
Darcy-Weisbach friction factor
average reaction rate (over the pipe length)
average water quality (over the pipe length).

The hydraulic head lost by water flowing in a pipe due to friction with the pipe walls
can be computed using one of three different formulas:

Hazen-Williams formula
Darcy-Weisbach formula
Chezy-Manning formula

The Hazen-Williams formula is the most commonly used headloss formula in the US
while the Darcy-Weisbach formula is the most commonly used formula in Europe. The
Hazen-Williams formula cannot be used for liquids other than water and was originally
developed for turbulent flow only. The Darcy-Weisbach formula is the most
theoretically correct. It applies over all flow regimes and to all liquids. The Chezy-
Manning formula is more commonly used for open channel flow.

Each formula uses the following equation to compute headloss between the start and
end node of the pipe:

where: hL, headloss (Length)

q, flow rate (Volume/Time)
A, resistance coefficient and
B, flow exponent

Each formula uses a different pipe roughness coefficient that must be determined
empirically. Be aware that a pipe’s roughness coefficient can change considerably with
age.

With the Darcy-Weisbach formula the program uses different methods to compute the
friction factor f depending on the flow regime:

The Hagen–Poiseuille formula is used for laminar flow (Re < 2,000).
The Swamee and Jain approximation to the Colebrook-White equation is used for
fully turbulent flow (Re > 4,000).
A cubic interpolation from the Moody Diagram is used for transitional flow (2,000 <
Re < 4,000)
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Pipes can be set open or closed at preset times or when specific conditions exist, such
as when tank levels fall below or above certain set points, or when nodal pressures fall
below or above certain values. This is implemented by using simple or rule based 
controls.

Minor Losses

Minor head losses (also called local losses) are caused by the added turbulence that
occurs at bends and fittings. The importance of including such losses depends on the
layout of the network and the degree of accuracy required. They can be accounted for
by assigning the pipe a minor loss coefficient. The minor headloss becomes the
product of this coefficient and the velocity head of the pipe, i.e.,

where: K, minor loss coefficient
V, flow velocity (Length/Time) and
g, acceleration of gravity (Length/Time2)

For minor loss coefficients values for several types of fittings please see appendix.

2.1.2.6 Pumps

Pumps are links that impart energy to a fluid thereby raising its hydraulic head. The
principal input parameters for a pump are its start and end nodes and its pump curve
(the combination of heads and flows that the pump can produce). In lieu of a pump
curve, the pump could be represented as a constant energy device, one that supplies
a constant amount of energy (horsepower or kilowatts) to the fluid for all combinations
of flow and head.

The principal output parameters are flow and head gain. Flow through a pump is
unidirectional and the program will not allow a pump to operate outside the range of
its pump curve.

Variable speed pumps can also be considered by specifying that their speed setting be
changed under these same types of conditions. By definition, the original pump curve
supplied to the program has a relative speed setting of 1. If the pump speed doubles,
then the relative setting would be 2; if run at half speed, the relative setting is 0.5
and so on. Changing the pump speed shifts the position and shape of the pump curve
(see the section on pump curves below).

As with pipes, pumps can be turned on and off at preset times or when certain
conditions exist in the network. A pump’s operation can also be described by assigning
it a time pattern of relative speed settings. The program can also compute the energy
consumption and cost of a pump. Each pump can be assigned an efficiency curve and
schedule of energy prices. If these are not supplied then a set of global energy options
will be used.

Flow through a pump is unidirectional. If system conditions require more head than
the pump can produce, the program shuts the pump off. If more than the maximum
flow is required, the program extrapolates the pump curve to the required flow, even if
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this produces a negative head. In both cases a warning message will be issued.

2.1.2.7 Valves

Valves are links that limit the pressure or flow at a specific point in the network. Their
principal input parameters include:

start and end nodes
diameter
setting
status

The computed outputs for a valve are flow rate and headloss. The different types of
valves included in the program are:

Pressure Reducing Valve (PRV)
Pressure Sustaining Valve (PSV)
Pressure Breaker Valve (PBV)
Flow Control Valve (FCV)
Throttle Control Valve (TCV)
General Purpose Valve (GPV)

PRVs limit the pressure at a point in the pipe network. The program computes in
which of three different states a PRV can be in:

partially opened (i.e., active) to achieve its pressure setting on its downstream side
when the upstream pressure is above the setting
fully open if the upstream pressure is below the setting
closed if the pressure on the downstream side exceeds that on the upstream side (i.
e., reverse flow is not allowed).

PSVs maintain a set pressure at a specific point in the pipe network. The program
computes in which of three different states a PSV can be in:

partially opened (i.e., active) to maintain its pressure setting on its upstream side
when the downstream pressure is below this value
fully open if the downstream pressure is above the setting
closed if the pressure on the downstream side exceeds that on the upstream side (i.
e., reverse flow is not allowed).

PBVs force a specified pressure loss to occur across the valve. Flow through the valve
can be in either direction. PBV's are not true physical devices but can be used to
model situations where a particular pressure drop is known to exist.

FCVs limit the flow to a specified amount. The program produces a warning message
if this flow cannot be maintained without having to add additional head at the valve (i.
e., the flow cannot be maintained even with the valve fully open).

TCVs simulate a partially closed valve by adjusting the minor head loss coefficient of
the valve. A relationship between the degree to which a valve is closed and the
resulting head loss coefficient is usually available from the valve manufacturer.
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GPVs are used to represent a link where the user supplies a special flow - head loss
relationship instead of following one of the standard hydraulic formulas. They can be
used to model turbines, well draw-down or reduced-flow backflow prevention valves. 

Shutoff (gate) valves and check (non-return) valves, which completely open or close
pipes, are not considered as separate valve links but are instead included as a
property of the pipe in which they are placed.

Each type of valve has a different type of setting parameter that describes its
operating point (pressure for PRVs, PSVs, and PBVs; flow for FCVs; loss coefficient for
TCVs, and head loss curve for GPVs). Valves can have their control status overridden
by specifying they be either completely open or completely closed. A valve's status
and its setting can be changed during the simulation by using control statements.

Because of the ways in which valves are modeled the following rules apply when
adding valves to a network:

a PRV, PSV or FCV cannot be directly connected to a reservoir or tank (use a length
of pipe to separate the two)
PRVs cannot share the same downstream node or be linked in series
two PSVs cannot share the same upstream node or be linked in series
a PSV cannot be connected to the downstream node of a PRV.

2.1.3 Non-physical components

In addition to physical components, the program employs three types of informational
objects – curves, patterns, and controls - that describe the behavior and operational
aspects of a distribution system.

Non-physical components are:

Curves
Time patterns
Controls

2.1.3.1 Curves

Curves are objects that contain data pairs representing a relationship between two
quantities. Two or more objects can share the same curve. The program can utilize the
following types of curves:

Pump curves
Efficiency curves
Volume curves
Head Loss curves

2.1.3.1.1  Pump curves

A pump curve represents the relationship between the head and flow rate that a pump
can deliver at its nominal speed setting. Head is the head gain imparted to the water
by the pump and is plotted on the vertical (Y) axis of the curve in feet (meters).
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Flow rate is plotted on the horizontal (X) axis in flow units. A valid pump curve must
have decreasing head with increasing flow. The program will use a different shape of
pump curve depending on the number of points supplied (see Figure below):

Single-Point Curve
A single-point pump curve is defined by a single head-flow combination that
represents a pump's desired operating point. The program adds two more points to
the curve by assuming a shutoff head at zero flow equal to 133% of the design head
and a maximum flow at zero head equal to twice the design flow. It then treats the
curve as a three-point curve.

Three-Point Curve
A three-point pump curve is defined by three operating points: a Low Flow point (flow
and head at low or zero flow condition), a Design Flow point (flow and head at desired
operating point), and a Maximum Flow point (flow and head at maximum flow). The
program tries to fit a continuous function of the form

through the three points to define the entire pump curve. In this function:

hg, head gain
q, flow rate and
A, B, and C are constants

Multi-Point Curve
A multi-point pump curve is defined by providing either a pair of head-flow points or
four or more such points. The program creates a complete curve by connecting the
points with straight-line segments.

Variable Speed Pumps
For variable speed pumps, the pump curve shifts as the speed changes. The
relationships between flow (Q) and head (H) at speeds N1 and N2 are:



Water Networks24

© 2012 TechnoLogismik i

2.1.3.1.2  Efficiency curves

An efficiency curve determines pump efficiency (Y in percent) as a function of pump
flow rate (X in flow units). An example efficiency curve is shown in the figure below.
Efficiency should represent wire-to-water efficiency that takes into account mechanical
losses in the pump itself as well as electrical losses in the pump's motor. The curve is
used only for energy calculations. If not supplied for a specific pump then a fixed
global pump efficiency will be used.

2.1.3.1.3  Volume curves

A volume curve determines how storage tank volume (Y in cubic feet or cubic meters)
varies as a function of water level (X in feet or meters). It is used when it is necessary
to accurately represent tanks whose cross-sectional area varies with height. The lower
and upper water levels supplied for the curve must contain the lower and upper levels
between which the tank operates. An example of a tank volume curve is given below.

2.1.3.1.4  Headloss curves

A headloss curve is used to described the headloss (Y in feet or meters) through a
General Purpose Valve (GPV) as a function of flow rate (X in flow units). It provides
the capability to model devices and situations with unique headloss-flow relationships,
such as reduced flow - backflow prevention valves, turbines, and well draw-down
behavior.
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2.1.3.2 Time patterns

A Time Pattern is a collection of multipliers that can be applied to a quantity to allow it
to vary over time. Nodal demands, reservoir heads, pump schedules, and water quality
source inputs can all have time patterns associated with them. The time interval used
in all patterns is a fixed value, set with the project's Time Options. Within this interval
a quantity remains at a constant level, equal to the product of its nominal value and
the pattern's multiplier for that time period.

Although all time patterns must utilize the same time interval, each can have a
different number of periods. When the simulation clock exceeds the number of periods
in a pattern, the pattern wraps around to its first period again. As an example of how
time patterns work consider a junction node with an average demand of 10 GPM.
Assume that the time pattern interval has been set to 4 hours and a pattern with the
following multipliers has been specified for demand at this node:

Period 1 2 3 4 5 6

Multiplier 0.5 0.8 1.0 1.2 0.9 0.7

Then during the simulation the actual demand exerted at this node will be as follows:

Hours 0-4 4-8 8-12 12-16 16-20 20-24 24-28

Demand 5 8 10 12 9 7 5

2.1.3.3 Controls

Controls are statements that determine how the network is operated over time. They
specify the status of selected links as a function of time, tank water levels, and
pressures at select points within the network. There are two categories of controls that
can be used:

Simple Controls
Rule-Based Controls

2.1.3.3.1  Simple based controls

Simple controls change the status or setting of a link based on:

the water level in a tank
the pressure at a junction
the time into the simulation
the time of day.

They are statements expressed in one of the following three formats:

LINK x status IF NODE y ABOVE/BELOW z
LINK x status AT TIME t
LINK x status AT CLOCKTIME c AM/PM

where:
x, a link ID label
status = OPEN or CLOSED, a pump speed setting, or a control valve setting
y, a node ID label
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z, a pressure for a junction or a water level for a tank
t, a time since the start of the simulation in decimal hours or in hours:minutes

notation
c, a 24-hour clock time.

Some examples of simple controls are:

Control Statement Meaning

LINK 12 CLOSED IF NODE 23
ABOVE 20

Close Link 12 when the level in Tank 23 exceeds 20 ft.

LINK 12 OPEN IF NODE 130
BELOW 30

Open Link 12 if the pressure at Node 130 drops below
30 psi

LINK 12 1.5 AT TIME 16 Set the relative speed of pump 12 to 1.5 at 16 hours
into the simulation

LINK 12 CLOSED AT
CLOCKTIME 10 AM
LINK 12 OPEN AT CLOCKTIME
8 PM

Link 12 is repeatedly closed at 10 AM and opened at 8
PM throughout the simulation

 
There is no limit on the number of simple control statements that can be used.

NOTE: Level controls are stated in terms of the height of water above the tank
bottom, not the elevation (total head) of the water surface.

NOTE: Using a pair of pressure controls to open and close a link can cause the system
to become unstable if the pressure settings are too close to one another. In this case
using a pair of Rule-Based controls might provide more stability.

2.1.3.3.2  Rule based controls

Rule-Based Controls allow link status and settings to be based on a combination of
conditions that might exist in the network after an initial hydraulic state of the system
is computed. Here are several examples of Rule-Based Controls:

Example 1:

This set of rules shuts down a pump and opens a by-pass pipe when the level in a
tank exceeds a certain value and does the opposite when the level is below another
value.

RULE 1
IF TANK 1 LEVEL ABOVE 19.1
THEN PUMP 335 STATUS IS CLOSED
AND PIPE 330 STATUS IS OPEN
RULE 2
IF TANK 1 LEVEL BELOW 17.1
THEN PUMP 335 STATUS IS OPEN
AND PIPE 330 STATUS IS CLOSED

Example 2:

These rules change the tank level at which a pump turns on depending on the time of
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day.

RULE 3
IF SYSTEM CLOCKTIME >= 8 AM
AND SYSTEM CLOCKTIME < 6 PM
AND TANK 1 LEVEL BELOW 12
THEN PUMP 335 STATUS IS OPEN
RULE 4
IF SYSTEM CLOCKTIME >= 6 PM
OR SYSTEM CLOCKTIME < 8 AM
AND TANK 1 LEVEL BELOW 14
THEN PUMP 335 STATUS IS OPEN

2.1.4 Hydraulic simulation model

The program’s hydraulic simulation model computes junction heads and link flows for
a fixed set of reservoir levels, tank levels, and water demands over a succession of
points in time. From one time step to the next reservoir levels and junction demands
are updated according to their prescribed time patterns while tank levels are updated
using the current flow solution. The solution for heads and flows at a particular point in
time involves solving simultaneously the conservation of flow equation for each
junction and the headloss relationship across each link in the network. This process,
known as “hydraulically balancing” the network, requires using an iterative technique
to solve the nonlinear equations involved. The program employs the “Gradient
Algorithm” for this purpose. 

The hydraulic time step used for extended period simulation (EPS) can be set by the
user. A typical value is 1 hour. Shorter time steps than normal will occur automatically
whenever one of the following events occurs:

the next output reporting time period occurs
the next time pattern period occurs
a tank becomes empty or full
a simple control or rule-based control is activated.

2.1.5 Water quality simulation model

The water quality simulation model cosists of the following routines:

Basic transport
Mixing in storage tanks
Water quality reactions
Water age and source tracing

2.1.5.1 Basic transport

The program's water quality simulator uses a Lagrangian time-based approach to track
the fate of discrete parcels of water as they move along pipes and mix together at
junctions between fixed-length time steps. These water quality time steps are
typically much shorter than the hydraulic time step (e.g., minutes rather than hours)
to accommodate the short times of travel that can occur within pipes. 

The method tracks the concentration and size of a series of non-overlapping segments
of water that fills each link of the network. As time progresses, the size of the most
upstream segment in a link increases as water enters the link while an equal loss in
size of the most downstream segment occurs as water leaves the link. The size of the
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segments in between these remains unchanged.

For each water quality time step, the contents of each segment are subjected to
reaction, a cumulative account is kept of the total mass and flow volume entering each
node, and the positions of the segments are updated. New node concentrations are
then calculated, which include the contributions from any external sources.

Storage tank concentrations are updated depending on the type of mixing model that
is used. Finally, a new segment will be created at the end of each link that receives
inflow from a node if the new node quality differs by a user-specified tolerance from
that of the link’s last segment.

Initially each pipe in the network consists of a single segment whose quality equals
the initial quality assigned to the upstream node. Whenever there is a flow reversal in
a pipe, the pipe’s parcels are re-ordered from front to back.

2.1.5.2 Mixing in storage tanks

The program can use four different types of models to characterize mixing within
storage tanks as illustrated in the figure below:

Complete Mixing
Two-Compartment Mixing
FIFO Plug Flow
LIFO Plug Flow

Different models can be used with different tanks within a network.

The Complete Mixing model (Figure a) assumes that all water that enters a tank is
instantaneously and completely mixed with the water already in the tank. It is the
simplest form of mixing behavior to assume, requires no extra parameters to describe
it, and seems to apply quite well to a large number of facilities that operate in fill-and-
draw fashion.

The Two-Compartment Mixing model (Figure b) divides the available storage
volume in a tank into two compartments, both of which are assumed completely
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mixed. The inlet/outlet pipes of the tank are assumed to be located in the first
compartment. New water that enters the tank mixes with the water in the first
compartment. If this compartment is full, then it sends its overflow to the second
compartment where it completely mixes with the water already stored there. When
water leaves the tank, it exits from the first compartment, which if full, receives an
equivalent amount of water from the second compartment to make up the difference.
The first compartment is capable of simulating short-circuiting between inflow and
outflow while the second compartment can represent dead zones. The user must
supply a single parameter, which is the fraction of the total tank volume devoted to
the first compartment.

The FIFO Plug Flow model (Figure c) assumes that there is no mixing of water at all
during its residence time in a tank. Water parcels move through the tank in a
segregated fashion where the first parcel to enter is also the first to leave. Physically
speaking, this model is most appropriate for baffled tanks that operate with
simultaneous inflow and outflow. There are no additional parameters needed to
describe this mixing model.

The LIFO Plug Flow model (Figure d) also assumes that there is no mixing between
parcels of water that enter a tank. However in contrast to FIFO Plug Flow, the water
parcels stack up one on top of another, where water enters and leaves the tank on the
bottom. This type of model might apply to a tall, narrow standpipe with an inlet/outlet
pipe at the bottom and a low momentum inflow. It requires no additional parameters
be provided.

2.1.5.3 Water quality reactions

The program can track the growth or decay of a substance by reaction as it travels
through a distribution system. In order to do this it needs to know the rate at which
the substance reacts and how this rate might depend on substance concentration.
Reactions can occur both within the bulk flow and with material along the pipe wall.
This is illustrated in the figure below. In this example free chlorine (HOCl) is shown
reacting with natural organic matter (NOM) in the bulk phase and is also transported
through a boundary layer at the pipe wall to oxidize iron (Fe) released from pipe wall
corrosion. Bulk fluid reactions can also occur within tanks. The program allows a
modeler to treat these two reaction zones separately.

Bulk Reactions

The program models reactions occurring in the bulk flow with n-th order kinetics,
where the instantaneous rate of reaction (R in mass/volume/time) is assumed to be
concentration-dependent according to:
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Where: K
b
, a bulk reaction rate coefficient

C, reactant concentration (mass/volume) and
n, a reaction order. 

K
b
 has units of concentration raised to the (1-n) power divided by time. It is positive

for growth reactions and negative for decay reactions. The program can also consider
reactions where a limiting concentration exists on the ultimate growth or loss of the
substance. In this case the rate expression becomes:

Where: C
L
, the limiting concentration. 

Thus there are three parameters (K
b
, C

L
, and n) that are used to characterize bulk

reaction rates. Some special cases of well-known kinetic models include the following:

Model Parameters Examples

First-Order Decay CL = 0, Kb < 0, n = 1 Chlorine

First-Order Saturation
Growth

CL > 0, Kb > 0, n = 1 Trihalomethanes

Zero-Order Kinetics CL = 0, Kb <> 0, n = 0 Water Age

No Reaction CL = 0, Kb = 0 Fluoride Tracer

    
The Kb for first-order reactions can be estimated by placing a sample of water in a

series of non-reacting glass bottles and analyzing the contents of each bottle at
different points in time. If the reaction is first-order, then plotting the natural log (Ct/

Co) against time should result in a straight line, where Ct is concentration at time t
and Co is concentration at time zero. Kb would then be estimated as the slope of this

line.

Bulk reaction coefficients usually increase with increasing temperature. Running
multiple bottle tests at different temperatures will provide more accurate assessment
of how the rate coefficient varies with temperature.

Wall Reactions

The rate of water quality reactions occurring at or near the pipe wall can be considered
to be dependent on the concentration in the bulk flow by using an expression of the
form:

where: Kw, a wall reaction rate coefficient and 
A/V, the surface area per unit volume within a pipe (equal to 4 divided by the
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pipe diameter). 

The latter term converts the mass reacting per unit of wall area to a per unit volume
basis. The program limits the choice of wall reaction order to either 0 or 1, so that the
units of Kw are either mass/area/time or length/time, respectively. As with Kb, Kw
must be supplied to the program by the modeler. First-order Kw values can range
anywhere from 0 to as much as 5 ft/day.

Kw should be adjusted to account for any mass transfer limitations in moving
reactants and products between the bulk flow and the wall. The program does this
automatically, basing the adjustment on the molecular diffusivity of the substance
being modeled and on the flow's Reynolds number. Setting the molecular diffusivity to
zero will cause mass transfer effects to be ignored.

The wall reaction coefficient can depend on temperature and can also be correlated to
pipe age and material. It is well known that as metal pipes age their roughness tends
to increase due to encrustation and tuburculation of corrosion products on the pipe
walls. This increase in roughness produces a lower Hazen-Williams C-factor or a higher
Darcy-Weisbach roughness coefficient, resulting in greater frictional head loss in flow
through the pipe.

There is some evidence to suggest that the same processes that increase a pipe's
roughness with age also tend to increase the reactivity of its wall with some chemical
species, particularly chlorine and other disinfectants. The program can make each
pipe's Kw be a function of the coefficient used to describe its roughness. A different
function applies depending on the formula used to compute headloss through the
pipe:

Headloss Formula Wall Reaction Formula

Hazen-Williams

Darcy-Weisbach

Chezy-Manning

 
where: C, Hazen-Williams C-factor

e, Darcy-Weisbach roughness
d, pipe diameter
n, Manning roughness coefficient and
F, wall reaction - pipe roughness coefficient 

The coefficient F must be developed from site-specific field measurements and will
have a different meaning depending on which head loss equation is used. The
advantage of using this approach is that it requires only a single parameter, F, to allow
wall reaction coefficients to vary throughout the network in a physically meaningful
way.

2.1.5.4 Water age and source tracing

In addition to chemical transport, the program can also model the changes in the age
of water throughout a distribution system. Water age is the time spent by a parcel of
water in the network. New water entering the network from reservoirs or source nodes
enters with age of zero. Water age provides a simple, non-specific measure of the
overall quality of delivered drinking water. Internally, the program treats age as a
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reactive constituent whose growth follows zero-order kinetics with a rate constant
equal to 1 (i.e., each second the water becomes a second older).

The program can also perform source tracing. Source tracing tracks over time what
percent of water reaching any node in the network had its origin at a particular node.
The source node can be any node in the network, including tanks or reservoirs.
Internally, the program treats this node as a constant source of a non-reacting
constituent that enters the network with a concentration of 100. Source tracing is a
useful tool for analyzing distribution systems drawing water from two or more different
raw water supplies. It can show to what degree water from a given source blends with
that from other sources, and how the spatial pattern of this blending changes over
time.

2.2 Main Window (Plan View tab)

To select the Plan View mode, click on the corresponding tab on the top left corner of
the main form. The main window consists of the following:

1. Menu: provides access to all program commands.
2. Toolbar: provides shortcut buttons to most common commands.
3. Categories: when plan view is selected, the categories tree view provides access to
all project properties in a concise and comprehensive way.
4. Object List: enumerates all objects contained in the specified category. This list is
equipped with a dedicated toolbar, containing the following:

Add: adds an object in the specified category.
Delete: deletes the selected object(s).
Edit: edits the selected object(s).
Move Up: moves the selected object one slot upwards.
Move Down: moves the selected object one slot downwards.
Sort: sorts all objects in the list alphabetically.

Not all options may be available at some instances.
5. Time Frame: when the calculations have been completed successfully, the time
frame controls the time instant for which the results are displayed.
6. Plan View: the main plan view drawing. To select an object, click on it. Selected
objects are drawn with a red line. Double-click on an object to display its properties.
7. Plan View Toolbar: a dedicated toolbar, containing shortcut buttons to most
common commands regarding the plan view.
8. Status Bar: displays important messages regarding the state of the program.
9. Coordinates: displays the current coordinates of the plan view or the profile.
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(Screenshot is from Sewer Networks program)

2.3 Main Window (Profiles tab)

To select the Profiles mode, click on the corresponding tab on the top left corner of the
main form. Apart from the controls already explained in the previous topic, the main
window consists of the following:

1. Profile List: a list containing all profiles.
2. Profile: the profile drawing.
3. Spreadsheet: when in profile mode, the spreadsheet provides access to the
properties of all objects consisting the specified profile.
4. Node/List tab: when in profile mode, select the appropriate tab to load the
spreadsheet with the corresponding data.
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(Screenshot is from Sewer Networks program)
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3 File

3.1 File menu

With this menu, you can perform file operations and print reports. In the File menu
you can select one of the following options:

New project
Open project
Save project
Save project as
Import
o Plan view

From DXF file
From ArcView Shapefile
From GTM

o Network from ArcView Shapefile

o Background from DXF

o Satellite image

o Network Data File

EPANET
TechnoLogismiki Cross v2.x
Encosoft Cross

o Network from MAP file

o Network Scenario file

o Data from LandXML

Export
o Network to EPANET

o MAP file

o Network Scenario file

o Plan view to BMP picture

o Plan view to DXF

o Plan view to ArcView Shapefile

o Plan view to LandXML

Print Setup
Print
Print to
o Print to File

o Print to Word

o Print to Word (Formatted)

o Print to Excel

Exit

3.2 New project

With this option, a new project is started. All data, results, graphs, titles etc. of the
previous project are erased.

To create a new project:
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1. Select New project from the File menu.
2. If a project is already loaded and changes have been made, a warning message will
appear that asks the user whether to save the changes or not.
3. The current project is erased and a new project is started.

3.3 Open project

With this option, an existing project is loaded. The project may be located locally, in a
network or in an external media device such as a CD-Rom. If a project is already
loaded and changes have been made, a warning message will appear that asks
whether to save the changes or not. When a project is loaded, all data of the previous
project are lost.

To open an existing project:

1. Select Open project from the File menu.
2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Water Network project" with the extension .m511.
4. Select the file by clicking on it.
5. Select Open to open the selected file. Select Cancel to cancel the operation.

NOTE: You can find sample projects in the installation folder of the program:
C:\Program Files\TechnoLogismiki\TLW2013\Samples\WaterNetworks

Supported file types

M11 (Water network project): Files created by versions 2012 and 2013 of Water
Networks.
Μ511 (Water network project): Files created by versions 2011, 2010, 2009 and
2008, 2007, 5.0 and 4.0 of Water Networks.
BCK (Backup files): If you have selected from program options the creation of
backup copy when a file is loaded, then the file can be loaded by selecting Backup
files (*.bck) from the Files of type drop-down list.
*.* (All files): Displays all files in the current folder.

Backwards compatibility

This version implements full backwards compatibility; however, note that when a
project is saved with the latest format, it cannot be used by previous versions.
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NOTE: If a message "Could not load project. File may be corrupt or saved by an
unknown or incompatible version of the program" then either you are  trying to load a
project that does not belong to this program or the file is used (and locked) by
another process in your computer.

3.4 Save project

With this option, you can save all data of a project into a file. The file may be saved
locally, in a network location or in an external media device such as a disk.

The filename and path will be asked only the first time you are saving a project. When
the filename and path are set, all subsequent saves will be made to the same file.

When you want to rename a file or save it in a new location, use Save project as...
from the File menu.

To save the current project:

1. Select Save project from the File menu.
2. If the location of the file is already set, the project is saved to this file without any
messages. If the filename is not set, a dialog box will appear that allows the selection
of the filename and path.

3.5 Save project as

With this option, the current project is saved just as in the case of Save project, but
with the difference that the name and/or location of the file can be changed. In this
way, you can create backup files or move a project to another media device.

To save a project with another name and/or to another location:

1. Select Save project as from the File menu.
2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
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then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but NO changes of the current project are saved.

3.6 Import

3.6.1 Plan view

With this option, you can import plan view data from an external file.

To import plan view data from an external file:

1. Select Import from the File menu.
2. Select Import plan view from the Import menu. The following form appears:

3. From the File menu, select one of the following:
Import from DXF to import plan view data from a DXF file.
Import from ArcView Shapefile to import plan view data from an Arcview
Shapefile.
Import from GTM to import plan view data from a GTM GPS Trackmaker file.

4. Import the data following the specific instructions.
5. Click Ok to save the changes and close the form. Click Cancel to close the form
without saving any changes.

To reverse the flow of the selected pipe:

1. Right-click on the selected branch. 
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2. Select Reverse Flow from the drop-down menu. The flow is reversed.

In order to manipulate the view of the drawing, use the toolbar. The button (from left
to right) are as follows:

1. Zoom In: click anywhere on the drawing to zoom in.
2. Zoom Out: click anywhere on the drawing to zoom out.
3. Extends: view the whole drawing.
4. Window: zoom to a specified window.
5. Distance: calculate the distance between two points.
6. Coordinates: click anywhere on the drawing to show the coordinates.
7. Options: customize the appearance of the drawing.

3.6.1.1 From DXF file

To import plan view data from a DXF file:

1. Select Import From DXF file from the File menu. The following form appears:

2. Click File > to select the DXF file. The file selection dialog box appears:

3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"DXF file" with the extension .dxf.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The list in the Layers frame of step 1 is
loaded with the layers contained in the DXF file:
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7. Select one or more layers containing the data. The data should be defined in
polylines or a series of lines connected to each other. The connection must be exact,
therefore you may need to use Snap or OSnap when using CAD software. The program
will create stations at the nodes of the polylines and at the end points of the lines.
Optionally, the coordinates of the stations can be used to calculate the distances
between stations. The quick keys (Select all, Select None, Select Invert) can be
used to quickly select all objects, deselect all objects and invert the current selection.
8. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: The following tips may be useful:

Use lines and/or polylines in any combination. The nodes and start/end points of
these objects define stations. You can use a different layer for each branch,
although this is not necessary. You can use a single layer for the whole network.
The names of the stations are filled automatically in descending order (upstream
to downstream). The coordinates and distances between stations are also filled
automatically.
The DXF driver recognizes the following entities:

Lines
LWPolylines
Polylines
3D Polylines

3.6.1.2 From ArcView Shapefile

With this option, you can import plan view data from an ArcView Shapefile. All
previous data are erased.

NOTE: The ArcView Shapefile driver recognizes the following entities:
Nullshapes
Point/PointM/PointZ
Multipoint/MultipointM/MultipointZ
Polyline/PolylineM/PolylineZ

To import plan view data from an ArcView Shapefile:

1. Select Import from Arcview Shapefile from the File menu. The file selection
dialog box appears:
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"ArcView shapefile" with the extension .shp.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file. The current project data are erased.
Select Cancel to cancel the operation.

3.6.1.3 From GTM

To import plan view data from a GTM file:

1. Select Import from GTM file from the File menu. The following form appears:

2. Click File > to select the GTM file. The file selection dialog box appears:
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3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"GTM file" with the extension .gtm.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file. The list in the Selection frame of step 1
is loaded with the layers contained in the GTM file:

7. Select one or more routes or tracklog containing the data. Optionally, the
coordinates of the stations can be used to calculate the distances between stations.
The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection.
8. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

3.6.2 Network from ArcView Shapefile

With this option, you can import node, pipe, tank, reservoir, pump and valve data
from an ArcView Shapefile.

To import data from an ArcView Shapefile:

1. Select Network from Arcview Shapefile from the File menu. The following form
appears:

2. Select the type of objects that you wish to import. The quick keys (Select all,
Select None, Select Invert) can be used to quickly select all objects, deselect all
objects and invert the current selection.
3. Select Ok to proceed. Select Cancel to cancel the operation and close the dialog
box.
4. The supported shapefiles are the following:

Object Type Supported Shapefiles

Nodes point/pointM/pointZ
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Pipes polyline/polylineM/polylineZ

Tanks point/pointM/pointZ

Reservoirs point/pointM/pointZ

Pumps polyline/polylineM/polylineZ

Valves polyline/polylineM/polylineZ

6. The file selection dialog box appears:

7. Select the path of the file.
8. Select the file type from the Files of type drop-down list. The default option is
"DXF file" with the extension .dxf.
9. Select the file by clicking on it.
10. Select Open to open and analyze the file. Steps 6 to 10 are repeated for each
selected object of step 1.

3.6.3 Background from DXF

With this option, you can import background data from DXF files. The background is
not active, but it is most helpful when designing a network. For performance reasons,
only the most common entities of DXF files are imported, such as lines, points,
polylines, arcs, circles, text etc.

To import background data from DXF:

1. Select Import from the File menu.
2. Select Background from DXF from the Import menu. The following form appears:
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3. Click Browse to select the DXF file. The file selection dialog box appears.

4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"DXF file" with the extension .dxf.
6. Select the file by clicking on it.
7. Select Open to open and analyze the file. The list is loaded with the layers
contained in the DXF file.

8. Select one or more layers containing the data. The quick keys (Select all, Select
None, Select Invert) can be used to quickly select all objects, deselect all objects
and invert the current selection.
9. Select Ok to import the data and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: To modify the background drawing, from the menu select View > Plan View
> Background

NOTE: Since version 2010, it is possible to snap to background objects. For large or
complex backgrounds, users may notice performance issues. It is recommended to 
disable snap capabilities once adding elements to the plane view is finished, in order
to significantly accelerate the program.

3.6.4 Satellite image

With this option you can insert a satellite image as a background image in plan view.
The image is modified accordingly (translation, rotation, skewness) so that it is 
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projected in the specified coordinate system.

To insert a satellite image as a background image in plan view:

1. Select Insert > Satellite image from the File menu. The following form appears:

2. Navigate to the area of the project. You can pan the image by holding down the left
mouse button. Using the roller you can change the resolution. Alternatively, enter the
longitude and latitude in decimal degrees and press Jump to:
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3. When you locate the area, select the appropriate resolution (the resolution varies,
depending on the quality of the satellite image), and press Import. The current
viewport is imported as a background image:

4. Without closing the window, pan the viewport and press Import again. A new image
is imported, which may overlap with the previous one. When you cover the whole area
of interest, press Close:
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In the satellite image form, the following options are available:

Style. Some options may not be available, or they may not have an effect,
depending on the quality of the satellite image.
o Roads

o Shaded

o Aerial

o Hybrid

Options
o Show navigation tool.

o Show locator tool.

o Units

Metric
English

Jump. These are quick selections for jumping to:
o To Athens

o To Greece

o To Europe

o To USA

o To World

NOTE: The images are saved as TIFF files in the same path as the project. You can
delete them selectively using the View > Background images > Delete menu.
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3.6.5 Network Data File

3.6.5.1 EPANET

With this option, you can import network data from .inp files. These files can be
created by many popular programs such as Water Networks by TechnoLogismiki,
EPANET by EPA, WaterCAD by Heastad Methods etc.

To import network data from .inp files:

1. Select Import from the File menu.
2. Select Network Data File from the Import menu.
3. Select EPANET from the Network Data File menu. The following form appears:

4. Click Browse to select the file. The file selection dialog box appears:

5. Select the path of the file.
6. Select the file type from the Files of type drop-down list. The default option is
"Water network file" with the extension .inp.
7. Select the file by clicking on it.
8. Select Open to open and analyze the file.
9. Check The file can change core program settings if you wish to override
program settings with data contained in the file.
10. By default, all data are imported. If you wish to import specific objects, select
Data.... The following form appears:
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Select the objects that you wish to import.
Select Ok to save the changes and close the dialog box. Select Cancel to close
the dialog box without saving any changes.

11. Select Ok to proceed with the import. Select Cancel to cancel the operation and
close the dialog box.
12. By selecting Ok,  existing data are erased and the network is imported. Moreover,
a list containing comments, errors etc is loaded:

13. Select Ok to close the dialog box.

3.6.5.2 TechnoLogismiki Cross v2.x

With this option, you can import data from .m11 files created by Cross v2.x by
TechnoLogismiki.

To import data from .m11 files created by Cross v2.x:

1. Select Import from the File menu.
2. Select Network Data File from the Import menu.
3. Select TechnoLogismiki Cross v2.x. from the Network Data File menu. The
following form appears: 
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4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"TechnoLogismiki Cross file" with the extension .m11.
6. Select the file by clicking on it.
7. Select Open to import data from the file.

NOTE: After importing the data, you should always check the connectivity; due to the
incompatibility of the data, some assumptions may be made during import.

3.6.5.3 Encosoft Cross

With this option, you can import data from .crs files that are created by Cross by
Encosoft. All previous data are erased. No topographical data are included in this file;
therefore you should manually enter the coordinates of the nodes.

To import data from .crs files:

1. Select Import from the File menu.
2. Select Network Data File from the Import menu.
3. Select Encosoft Cross from the Network Data File menu. The following form
appears:

4. Click Browse to select the file. The file selection dialog box appears:
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5. Select the path of the file.
6. Select the file type from the Files of type drop-down list. The default option is
"Encosoft Cross" with the extension .crs.
7. Select the file by clicking on it.
8. Select Open to open and analyze the file.
9. Enter the kinematic viscosity of the fluid in m2/s. Alternatively, select the button
with the ellipses (...) to invoke the corresponding database.
10. Enter the project title by typing into the corresponding text box. Alternatively,
you can enter the project title in project info.
11. Select Ok to proceed with the import. Select Cancel to cancel the operation and
close the dialog box.

NOTE: Two other files, with the extensions .ko and .lo must exist in the same path for
the import to be concluded successfully.

NOTE: After importing the data, you should always check the connectivity; due to the
incompatibility of the data, some assumptions may be made during import.

3.6.6 Network from MAP file

With this option, you can import network data from .map files. These files can be
created by many popular programs such as Water Networks by TechnoLogismiki,
EPANET by EPA, WaterCAD by Heastad Methods etc. These files contain the following
information:

Coordinates
Labels
Intermediate nodes
Background

The above information is included in .inp files as well. The difference is that, in this
case, only topological information is included.

To import network data from .map files:

1. Select Import from the File menu.
2. Select Network from MAP file from the Import menu. The following form
appears:
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3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"Map file" with the extension .map.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file.

3.6.7 Network Scenario file

With this option, you can import scenario data from .scn files. These files can be
created by many popular programs such as Water Networks by TechnoLogismiki,
EPANET by EPA, WaterCAD by Heastad Methods etc. These files contain the following
information:

Demands
Diameters
Friction coefficients
Initial qualities
Reaction coefficients
Rules

The above information is included in .inp files as well. With these files, you can easily
create scenarios that correspond to normal operation, fires in various places etc.

To import scenario data from .scn files:

1. Select Import from the File menu.
2. Select Scenario file from the Import menu. The following form appears:
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3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"Scenario file" with the extension .scn.
5. Select the file by clicking on it.
6. Select Open to open and analyze the file.

3.6.8 Data from LandXML

LandXML is an open source format specifically developed and tuned for exchanging
design data used in the design / build process for land development and
transportation projects. LandXML has evolved from previous efforts and is the
cooperative work of representatives from all aspects of the engineering industry. For
more information regarding programs supporting LandXML or for the LandXML scheme,
please refer to LandXML forum.

To import LandXML data:

1. Select Import from the File menu.
2. Select Data from LandXML from the Import menu. The following form appears:

3. Click Browse to select the LandXML file. The file selection dialog box appears.
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4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"LandXML file" with the extension .xml.
6. Select the file by clicking on it.
7. Select Open to open and analyze the file. If the file contains error, they are
displayed on screen otherwise another form appears containing a treeview list of all
entities that can be imported.

8. Select one or more entities that will be used as background or contain network
information.
10. Press Ok to import the background (if available) or the pipe networks (if available)
or Cancel to cancel the import process.

NOTE: In this version the following LandXML entities are supported:
LandXML
Units*
CoordinateSystem*
Project*
Application*
Alignments
CgPoints
Amendment*
GradeModel
Monuments
Parcels
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PlanFeatures
PipeNetworks
Roadways
Surfaces
Survey
FeatureDictionary*

* No visual representation.

NOTE: In this version the following LandXML schemes are supported:
v1.2 beta Build32 03.12.2007
v1.1
v1.0
v0.88

The program has been certified regarding its LandXML import and export functionality
from LandXML forum. The certified versions are 1.0 and 1.1 and version 1.2 is pending
until the scheme is finalized.

3.7 Export

3.7.1 Network to EPANET

With this option, you can create a .inp file containing network data. This file can be
used by other programs such as EPANET by EPA or WaterCAD by Heastad Methods.
Some data, such as hydrants and air release valves, are not supported by the file
format and they are not exported.

To create a .inp file containing network data:

1. Select Export from the File menu.
2. Select Network to Network Data File from the Export menu. The following form

will appear:

3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.
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3.7.2 MAP file

With this option, you can create a .map file containing topological data. This file can
be used by other programs such as EPANET by EPA or WaterCAD by Heastad Methods.
Some data, such as hydrants and air release valves, are not supported by the file
format and they are not exported.

To create a .map file containing topological data:

1. Select Export from the File menu.
2. Select Network to MAP File from the Export menu. The following form will

appear:

3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

3.7.3 Network Scenario File

With this option, you can create a .scn file containing scenarios. This file can be used
by the Water Networks or by other programs such as EPANET by EPA or WaterCAD by
Heastad Methods. You can select one or more categories that contain the data you
wish to export.

To create a .scn file containing scenarios:

1. Select Export from the File menu.
2. Select Scenario from the Export menu. The following form appears:

3. Select one or more objects that you wish to export. The quick keys (Select all,
Select None, Invert Selection) can be used to quickly select all objects, deselect all
objects and invert the current selection. At least one object must be selected. Objects
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that do not vary can be omitted.
4. Select Ok to proceed with the export. Select Cancel to cancel the operation and
close the dialog box.
5. The following form will appear:

6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

3.7.4 Plan view to BMP picture

With this option, you can create a BMP file containing the plan view as it is currently
displayed on screen.

To create a BMP file:

1. Select Export from the File menu..
2. Select Plan view to BMP picture from the Export menu. The following form will

appear:

3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.
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3.7.5 Plan view to DXF

With this option, a DXF file containing the plan view is created. The following data are
included in the file:

Station, station names 
Node data, pipe data
Hydraulic calculations

To export the plan view to DXF file:

1. Select Export from the File menu.
2. Select Plan view to DXF file from the Export menu. The following dialog box
appears:

3. Select the appropriate settings:

Intended drawing scale: Select the intended drawing scale. The rest of the
settings are measured in mm (millimeters) in the printed drawings. Based on the
intended drawing scale, the sizes of all drawing elements are automatically
derived.
Select the object you wish to configure from the list on the left. Depending on
the object, the following options may become available:

Basic symbol size (mm): Enter the basic symbol size in mm (millimeters) in
the printed drawing. For example, the basic symbol size for a junction refers 
to the diameter of the circle that represents it.
Top label font: select the font for the top label. All drawing elements are
grouped into layers and font styles, so that they can be easily modified using
CAD software.
Top label font height (mm): Enter the top label font height in mm
(millimeters) in the printed drawings. If the font height is selected to be 2mm
and the scale is 1:1000, then the text height that will be used is equal to
2mm * 1000 = 2m. When printed, the desired font height will be obtained. 
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Top label offset (mm) : Enter the top label offset from the center of the
object, in mm in the printed drawing.
Top label : Enter the text that will appear in the top label of the selected
object. The text may contain codes. The codes have the prefix "&" and contain
 a special keyword within brackets. For example, if the top label is selected to
be "&[NAME]", then the name of the object will be displayed. Any
combination of text and/or codes is allowed. For example, if the model
contains junctions named "J1", J2", etc and the manhole type is "T1", then the
label "&[NAME] - &[MANHOLE_TYPE]" will create labels "J1 - T1", "J2 - T1" etc
in the DXF drawing.
Insert code in top label: Depending on the selected object, select the code
from the list and click on the " + " button to enter it in the top label. The
insertion point is the current cursor point in the previous field entitled "Top
label".
Similar options may refer to the bottom label.
Layer color: Select the layer color of the selected object.
Layer color filled: Select the layer color for the filled elements of the selected
object.

The available codes, depending on the type of the object, are (the names are self-
explanatory):

"&[NAME]" 
"&[STATION]"
"&[DESCRIPTION]"
"&[TAG]"
"&[GROUND_ELEVATION]"
"&[AXIS_ELEVATION]"
"&[LENGTH]"
"&[SHAPE]"
"&[FLOW]"
"&[VELOCITY]"
"&[STATUS]"
"&[LOSS]"
"&[DEMAND]"
"&[PRESSURE_ELEVATION]"
"&[PRESSURE]"
"&[REAL_DEMAND]"

4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
5. The file selection dialog box appears:
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6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

NOTE: If nothing is visible when viewing the newly created DXF file, select Zoom
Extents to view the whole drawing.

3.7.6 Plan view to ArcView Shapefile

With this option, two ArcView Shapefiles containing the plan view data are created.
The first file contains station data and the other contains pipe data. Note that apart
from geometry, hydraulic calculation results are included in the Shapefiles.

To export the plan view to an ArcView Shapefile:

1. Select Export from the File menu.
2. Select Plan view to ArcView Shapefile from the Export menu.
3. The following dialog box appears:

4. Select one of Nodes, Pipes from the drop-down list.
5. Select Customization... to customize the shape type and the properties that will
be included:
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6. Select the appropriate shape type.

NOTE: The GIS driver recognizes the following shape types:
Nullshapes
Point/PointM/PointZ
Multipoint/MultipointM/MultipointZ
Polyline/PolylineM/PolylineZ

7. Select the properties that you want to include in the file. The quick keys (Select
all, Select None, Select Invert) can be used to quickly select all objects, deselect all
objects and invert the current selection.
8. Select Ok to proceed with the selection of the filename. Select Cancel to abort the
operation and close the dialog box.

9. Select the path of the file.
10. Type the filename in the File name text box.
11. Select Save to create the file. Select Cancel to cancel the operation.

NOTE: If nothing is visible when viewing the newly created ArcView Shapefile, select
Zoom Extents to view the whole drawing.

3.7.7 Plan view to LandXML

The plan view is exported (background, networks and calculations) to a LandXML file.
For more information regarding programs supporting LandXML or for the LandXML
scheme, please refer to LandXML forum.

To export plan view to LandXML:
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1. Select Export from the File menu..
2. Select Plan view to LandXML from the Export menu. The following form will

appear:

3. Click Browse to select an existing or a new LandXML file. The file selection dialog
box appears.

4. Select the path of the file.
5. Type the filename in the File name text box to select a new file or select an
existing file.
6. Select Save to finalize your selection.
7. If you selected an existing LandXML file, then it is loaded and analyzed so that the
program will be ready to update it. If not, then its name appears on the form and the
update check box is disabled.
8. Optionally, click on Settings to change the driver's settings.

8.1. Select the LandXML scheme that will be used to create / update the file. It is
recommended to select 1.0 for maximum compatibility or the scheme version
supported by the destination program (the program that will be used to read the
exported file).
8.2. Select the number of decimal digits. It is recommended to select any number
from 4 to 8 digits.
8.3. Click Ok to save changes. Click Cancel to ignore changes and close the form.
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9. If an existing file has been selected, the update file check box is enabled. If this
check box is selected then the target file will be updated with any changes made
within the program.
10. Press Ok to close the form and finalize the export procedure or press Cancel to
close the form and cancel the export procedure.

3.8 Print Setup

With this option, you can select which parts of the project will be included in the
printouts. When a new project is created, a full report is selected by default.

To modify the print setup:

1. Select Print setup from the File menu.
2. Select the sections (Title, Project information etc) that will be included in the
reports.
3. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The quick keys (Select all, Select None, Select Invert) can be used to quickly select
all objects, deselect all objects and invert the current selection of a list.

NOTE: The changes are saved with the project. The above preferences are used to all
printouts, either to the printer or to other formats such as Word file, Excel file etc.

3.9 Print

With this option, you can prepare a report to be printed to a local, network or virtual
printer such as Adobe PDF Writer. The parts of the project that will be included in the
report are determined from print setup.

By selecting Print, the report is not printed directly; instead, a document is prepared
and a preview of the printout is created by the Print manager. You can print the
report by clicking the Print button of the toolbar of Print manager.
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To create a report:

1. Select Print from the File menu.
2. A report is prepared and sent to Print manager. A preview of the document
appears.
3. You can print the report by clicking the Print button of the toolbar.

NOTE: A complete user manual on the capabilities of Print manager can be found in
the corresponding help file.

3.10 Print to

3.10.1 Print to File

With this option, you can create a simple text file containing a report of the project.
This file is recognized and can be further modified by word processors such as
Microsoft Word, OpenOffice Writer etc.

To print to a text file:

1. Select Print to from the File menu.
2. Select Print to file from the Print to menu.
3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to create the file.
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The parts of the project that will be included in the report are determined from print
setup.

NOTE: If a file with the same name and in the same path already exists, a warning
message will appear that asks whether to overwrite the file or not. If you answer Yes,
then the existing file is erased and the new file takes its place. If you answer No, the
existing file remains intact but the report is NOT printed.

3.10.2 Print to Word

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

3.10.3 Print to Word (Formatted)

If Microsoft Word (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Word file containing the report can be created. Note that
Microsoft Word is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Word.

To print the report to a formatted Microsoft Word file:

1. Select Print to from the File menu.
2. Select Print to Word (Formatted) from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup. This operation is much slower than the regular print to word function. However,
the final output requires minimal user intervention as it comes fully formatted with
tables, alignment, font styles, etc.
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NOTE: Do not use Copy (CTRL+C) on any of the programs running during this
operation. If you do so, it will most likely affect the communication between Microsoft
Word and the clipboard and as a result the final document will be corrupt.

3.10.4 Print to Excel

If Microsoft Excel (version 97, 2000, XP, 2003 or later) has been installed in the
system, then a Microsoft Excel file containing the report can be created. Note that
Microsoft Excel is a separate program and it is not included in TechnoLogismiki's
products. Moreover, no technical support is offered regarding the usage of Microsoft
Excel.

To print the report to a Microsoft Excel file:

1. Select Print to from the File menu.
2. Select Print to Excel from the Print to menu.

The parts of the project that will be included in the report are determined from print
setup.

3.11 Exit

With this option, you can exit the program. If there are changes in the current project
that have not been saved then the program will:

either ask the user to save the changes
or save the changes
or ignore the changes

depending on what you have selected in General preferences.

To exit the program:

1. Select Exit from File menu.
2. If you are asked whether to save the changes or not, you can save changes or
ignore them.
3. The program is terminated.
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4 Edit

4.1 Edit menu

With this menu, you can perform basic operations regarding data. In the Edit menu
you can select one of the following options:

Undo
Redo
Copy
Cut
Paste
Select all 
Clipboard delimiter
Clipboard decimal separator
Select objects
o Create selection

o Load selection

o Save selection

o Clear selection

Locate objects

4.2 Undo

Undo cancels the last committed change in the project.

To cancel the last committed change:

1. Select Undo from the Data menu.
2. The last committed change is canceled.

To cancel an undo command, you may use the redo function which is described
below. Redo becomes available once undo is used.

It is possible to undo more than one recent changes and to redo them, by following
the step described above. The number of actions that are kept in memory and may be
undone or redone is 20 by default. This means that the program is able to keep track
of up to 20 successive changes and undo them. This number may change for all
programs, using the option in the main menu. For more information, please consult
main menu user guide.

NOTE: Some changes cannot be undone like the new project or the save project
functions.

4.3 Redo

Redo cancels the latest undo command.

To redo the latest change that was undone:

1. Select Redo from the Data menu.
2. The latest undone change is redone.
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To undo a redo, you may use the undo command.

It is possible to redo more than one changes that were previously undone by following
the steps described above. The number of actions that are kept in memory and may
be undone or redone is 20 by default. This means that the program is able to keep
track of up to 20 successive changes that are undone and redo them. This number
may change for all programs, using the option in the main menu. For more
information, please consult main menu user guide.

4.4 Copy

With this option, you can copy the contents of the selected cells to the clipboard. 

To copy the contents of the selected cells to the clipboard:

1. Select the cells from the data table.
2. Select Copy from the Edit menu. The contents of the selected cells are copied to
the clipboard.

To copy data to be used with Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Select the cells from the data table.
4. Select Copy from the Edit menu. The contents of the selected cells are copied to
the clipboard.
5. Hit CTRL+V to paste the data when using Microsoft Excel.

4.5 Cut

With this option, you can copy the contents of the selected cells to the clipboard and
clear the current selection.

To copy the contents of the selected cells to the clipboard and clear the current
selection:

1. Select the cells from the data table.
2. Select Cut from the Edit menu. The contents of the selected cells are copied to the
clipboard and the selection is cleared.

To cut data to be used with Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Select the cells from the data table.
4. Select Cut from the Edit menu. The contents of the selected cells are copied to the
clipboard and the selection is cleared.
5. Hit CTRL+V to paste the data when using Microsoft Excel.

4.6 Paste

With this option, you can paste data from the clipboard to the data table.
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To paste data from the clipboard to the data table:

1. Select the top left cell.
2. Select Paste from the Edit menu. The data are copied from the clipboard to the
data table.

To paste data from Microsoft Excel:

1. Select TAB as the delimiter.
2. Select System as the decimal separator.
3. Within Microsoft Excel, select all cells and hit CTRL+C to copy the data to the
clipboard.
4. Within Sewer Networks, select the top left cell that corresponds to the data.
5. Select Paste from the Edit menu. The data are copied from the clipboard to the
data table.

NOTE:
You cannot paste data into the grayed cells.
All data is transferred from consecutive columns, even if these are not visible.
Other software may require other delimiter when using clipboard.

4.7 Select all

With this option, when in plan view mode all objects are selected. When in profiles
mode, all cells of the data table are selected.

To select all:

1. Select Select all from the Edit menu.

4.8 Clipboard delimiter

With this option, you can select the delimiter that will be used that will be used when
transferring data to and from the clipboard.  

To select the delimiter:

1. Select Clipboard delimiter from the Edit menu.
2. Select one of Tab, Comma, Space.

NOTE: Although Sewer Networks can handle all three cases of delimiters, other
software may have some restrictions. For example, to exchange data with Microsoft
Excel, you should use TAB as  delimiter.

4.9 Clipboard decimal separator

With this option, you can select the decimal separator that will be used when
transferring data to and from the clipboard.  

To select the decimal separator:

1. Select Clipboard decimal separator from the Edit menu.
2. Select one of System, Period.
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NOTE: To exchange data with Microsoft Excel, you should use the System decimal
separator (by default). It is possible to modify the settings in Microsoft Excel to
accept period as decimal separator. Please refer to the manual of Microsoft Excel.

4.10 Select objects

4.10.1 Create selection

With this option, you can modify the set of selected objects. You can create a new
selection set or add objects to the current selection set. The selection is based on
various criteria. The successful completion of calculations is recommended before
using this option.

To modify the set of selected objects:

1. Perform calculations. This step is optional, but if you do not follow it, the results for
some objects may not be available and the selection may not function properly.
2. Select Select 0bjects from the Edit menu.
3. Select Create selection from the Select 0bjects menu. The following form
appears:

4. Select the scope from the drop-down list. The scope can either be the entire
project or the current selection.
5. Select the object type from the drop-down list.
6. Select the object property from the drop-down list. This list is depended on the
object type.
7. Select the operator which will be used in the comparison.
8. Enter the value of the property.
9. Optionally click on Enumerate Selection to preview how many items will be
selected if this query is applied.
10. Select either Include in new selection set to clear any existing selection and
create a new one or Exclude from new selection set to remove matching items from
the selection.
11. Enable Append to current selection set to preserve the current selection and
expand it by adding items from current query.
12. Click on Clear Selection to clear the selected items.
13. Click on Apply Selection to perform the query according to the specified
parameters.
14. Repeat steps 4 to 13 as necessary.
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15. Select Ok to close the form and accept changes or Cancel to close the form and
ignore any changed.

4.10.2 Load selection

With this option, you can load a selection set from an external file that was previously 
saved. This process will fail if the objects currently loaded do not correspond to the
selection set.

To load a selection set from an external file:

1. Select Select 0bjects from the Edit menu.
2. Select Load Selection from the Select 0bjects menu. The following form appears:

3. Select the path of the file.
4. Select the file type from the Files of type drop-down list. The default option is
"Selection Files" with the extension .sel.
5. Select the file by clicking on it.
6. Select Open to open the selected file. Select Cancel to cancel the operation.

4.10.3 Save selection

With this option, you can save the current selection set to an external file. Note that
no object properties are saved whatsoever. The file can be loaded and used at a later
time, as long as the objects are not modified.

To save the current selection set to an external file:

1. Select Selection from the Objects menu.
2. Select Save Selection from the Selection menu. The following form appears:
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3. Select the path of the file.
4. Type the filename in the File name text box.
5. Select Save to save the project with the selected filename and path. Select Cancel
to cancel the operation.

4.10.4 Clear selection

With this option, you can deselect all items.

To deselect all items:

1. Select Select objects from the Edit menu.
2. Select Clear Selection from the Select objects menu. All objects are deselected.

4.11 Locate objects

With this option, the connectivity of a specified point, linear or surface object is
revealed.

To locate objects:

1. Select Locate objects from the Edit menu. The following form appears:

2. Select the Object type from the drop-down list.
3. Select the Name of the object.
4. The connectivity of the specified object is loaded in the list.
5. Select Ok or Cancel to close the form.
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5 View

5.1 View menu

With this menu, you can modify the appearance of the plan view and the profiles. In
the View menu you can select one of the following options:

Plan view
o Visible objects

o Background

Background pictures
o Add

o Edit

o Delete

o Show

Profile
o Options

5.2 Plan view

5.2.1 Visible objects

With this option, you can select the object type(s) that will be visible in plan view.
This option refers to the active objects of the plan view and not the background
objects.

To select the object type(s) that will be visible in plan view:

1. Select Plan view from the View menu.
2. Select Visible objects from the Plan view menu. The following form appears:

3. Select the object type(s) that you wish to be visible. The quick keys (Select all,
Select None, Select Invert) can be used to quickly select all objects, deselect all
objects and invert the current selection.
4. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.
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5.2.2 Background

With this option, you have full access to the background data from DXF files. This
includes the option to import data from a DXF file , under the File > Import menu.

To modify the background:

1. Select Plan view from the View menu.
2. Select Background from the Plan view menu. The following form appears:

3. To load data from a DXF file, select Load from DXF. This process is described in
the File > Import > Background from DXF section.
4. Select Clear to clear the existing background. A confirmation message will be
displayed.
5. Select Show background to toggle the visibility of the background.
6. Select Show text to toggle the visibility of TEXT objects of the background.
7. Select Background in color if you wish to view the background in color. 
8. If the option of step 7 is deselected, a single color is used for all background
objects. This color can be modified by selecting Select color.
8.1. The color selection dialog box appears.

8.2. Select the color from the 256 available colors. The currently selected color is
marked with a tick. On top of the Cancel button, the old and the new color are
displayed.
8.3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
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dialog box without saving the changes.

NOTE: The color palette follows standard CAD color palettes.

9. Select the Background layers that you wish to be active (visible).  The quick keys
(Select all, Select None, Select Invert) can be used to quickly select all objects,
deselect all objects and invert the current selection.
10. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.

5.3 Background pictures

5.3.1 Add

With this option, you can add a picture to the background.

To add a picture to the background:

1. Select Background Pictures from the View menu.
2. Select Add from the Background Pictures menu. The following form will appear:

3. Select Path. The file selection dialog box will appear:

4. Select the path of the file.
5. Select the file type from the Files of type drop-down list. The default option is
"Bitmap file" with the extension .bmp.
6. Select the file by clicking on it.
7. Select Open to open the selected file. Select Cancel to cancel the operation. 
8. Enter the Left X, Top Y, Width and Height of the picture in drawing units. If you
provide only the height or the width, the ratio of the source picture will be used to
calculate the missing data.
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9. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

NOTE: The following image file types are supported: bitmaps (.bmp) and JPEG (.jpg).

5.3.2 Edit

With this option, you can modify the position and dimensions of an existing
background picture.

To modify the position and dimensions of an existing background picture:

1. Select Background Pictures from the View menu.
2. Select Edit from the Background Pictures menu. The following form will appear:

3. Select the picture from the drop-down list.
4. Make the appropriate changes. If you provide only the height or the width, the ratio
of the source picture will be used to calculate the missing data.
5. Select Apply to apply the changes without closing the form. Select Ok to save the
changes and close the dialog box. Select Cancel to close the dialog box without saving
any changes.

5.3.3 Delete

With this option, you can delete one or more existing background pictures.

To delete one or more existing background pictures:

1. Select Background Pictures from the Map menu.
2. Select Delete from the Background Pictures menu. The following form will
appear:

3. Select the picture from the list.
4. Select Delete to delete the selected picture.
5. Select Delete all to delete all pictures.
6. Select Close to close the dialog box.
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5.3.4 Show

With this option, you can show or hide all pictures in the background.

To show or hide all pictures in the background:

1. Select Background pictures from the View menu.
2. Select Show from the Background pictures menu.
3. If the background pictures were visible, they become invisible and vice-versa. A
checkbox in the menu indicates if this option is enabled.

5.4 Profile

5.4.1 Options

With this option, you can modify the appearance of the profile sketch.

To modify the appearance of the profile sketch:

1. Select Profile from the View menu.
2. Select Options from the Profile menu. The following form appears:

3. Select Zoom extents after changes if you wish the sketch to zoom automatically
to the extents of the drawing whenever you make a change.
4. Select an appropriate Height stretch factor. This factor magnifies distances in the
Y direction so that small elevation differences are clear.
5. Select Draw min depth line to draw a line parallel to the ground at a specified
depth. This line is a design tool that shows the minimum depth that a conduit should
be placed (for example, to ensure a minimum backfill depth)
6. Type the depth of the min depth line in the Min depth field and select its color by
pressing the corresponding Select color button.
7. Select Draw max depth line to draw a line parallel to the ground at a specified
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depth. This line is a design tool that shows the maximum depth that a conduit should
be placed (for example, to show the maximum depth that an excavator can reach)
8. Type the depth of the max depth line in the Max depth field and select its color by
pressing the corresponding Select color button
9. Select Make default for all new projects to use these options for all new
projects.
10. Select Ok to accept changes and close the form. Select Cancel to close the form
without any changes.
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6 Data

6.1 Data menu

With this menu, you can add and modify data. In the Data menu you can select one
of the following options:

Project info
Project summary
General data
o General

o Hydraulics

o Times

o Energy

o Reactions

o Quality

o Checks

o Excavation options

Curves
o Management

o Add

o Delete

o Edit

o Move

o Sort

Design period
Consumptions
o General

o Population estimation

Design consumptions
Area categories
Patterns
o Management

o Add

o Delete

o Edit

o Move

o Sort

Rules
o Management

o Add

o Delete

o Edit

o Move

o Sort

Rules
o Management

o Add

o Delete



Water Networks84

© 2012 TechnoLogismik i

o Edit

o Move

o Sort

Conduit shapes
o Management

o Add

o Delete

o Edit

o Import

o Export

Manhole specifications
o Management

o Add

o Delete

o Edit

o Import

o Export

Trench specifications
o Management

o Add

o Delete

o Edit

o Import

o Export

Network consistency
Options
o General preferences

o Sketch

o Grid editing

o Customize toolbar

o Default values

o Algorithm

6.2 Project info

With this option, you can add project information that include title, firm title and
comments. If you want, this information can be included in the reports. The empty
fields are ignored.

To add or modify the project information:

1. Select Project info from the Data menu.
2. Type the project title, firm title and comments.
3. Check Include project time and date if you want to include the time and date in
the project. In this case, type the day, month, year, hours and seconds in the
corresponding text boxes. Alternatively, press Today to insert the current values
automatically.
4. Check Include the name of the project file if you want the full path and filename
of the project to be included in the report.
5. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.



Data 85

© 2012 TechnoLogismik i

By selecting the buttons with the ellipses (...) next to the project title and firm, you
can access the corresponding databases.

Project title database

For the completion of a project, more than one programs may be needed. For
convenience, you can add the project title to the database and retrieve it from all
programs.

To use the project title database:

1. Select the button with the ellipses (...) next to the project title text box. The project
title database appears.
2. Select Add to add a new title to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected project title and close the dialog box. Select
Cancel to close the dialog box without applying any changes.
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Firm database

An engineer or firm may be involved in multiple projects. For convenience, you can
add the title to the database and retrieve it from all programs.

To use the firm database:

1. Select the button with the ellipses (...) next to the firm text box. The firm database
appears.
2. Select Add to add a new firm/author to the database.
3. Select Remove to remove the selected entry from the database. You will be asked
for confirmation only if you have selected to confirm deletions in the General
preferences tab.
4. Select Edit to modify the selected entry.
5. Select Ok to use the currently selected firm and close the dialog box. Select Cancel
to close the dialog box without applying any changes.

6.3 Project summary

With this option, a summary of the project is displayed. This includes the number of
objects and the most important simulation and calculation options.

To display the project summary:

1. Select Project summary from the Data menu.
2. The project summary is displayed:
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3. Press Ok to close the form.

6.4 General data

6.4.1 General

With this option, you can enter friction data.

To enter friction data:

1. Select General Data from the Data menu.
2. Select the Friction tab:

3. Enter the kinematic viscosity in m2/s or ft2/s. Alternatively, click the button with
the ellipses (...) to invoke the corresponding database. This field is required in case of
water quality analyses using the Darcy - Weisbach friction formula.
4. Enter the fluid density in kg/m3 or lb/ft3. Alternatively, click the button with the
ellipses (...) to invoke the corresponding database. This field is required in case of
water quality analyses using the Darcy - Weisbach friction formula.
5. Select the friction formula. This can be one of Manning, Hazen-Williams or Darcy-
Weisbach. The selected formula is shown in a window.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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6.4.2 Hydraulics

With this option, you can enter additional hydraulic data. These are required in case of
irrigation networks.

To enter additional hydraulic data:

1. Select General Data from the Data menu.
2. Select the Hydraulics tab:

3. Select the flow units. Depending on this setting, all values may revent to Metric or
SI system. Values are not converted automatically from one unit system to another, it
is the responsibility of the engineer to ensure correct values for all parameters and
program variables.
4. Enter the pipe axis depth in m or ft. This will be subtracted from all ground
elevations automatically upon creation of a new pipe.
5. Enter the pressure exponent x. For nozzles and sprinklers, the default value is
0.5.
6. Check Use constant emitter coefficient if the emitter coefficient is constant. In
this case, enter its value in the corresponding text box. This value will override the
values that may be entered in nodes. The manufacturer provides this value, in (L/s)/
atm0.5 or gpm/psi0.5, and it corresponds to the flow rate with pressure loss of 1 Atm (1
psi).
7. Enter the demand multiplier by typing into the corresponding text box. The
default value is 1.0. All demands are multiplied by this number; for example, if the
multiplier is equal to 2.0, all demands will be doubled.
8. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.4.3 Times

With this option, you can enter time data. These are required in case of extended
period analyses.

To enter time data:

1. Select General Data from the Data menu.
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2. Select the Times tab:

3. Enter the appropriate data, as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To change the Start date:

1. Select the corresponding button with the ellipses (...). The following form appears:

2. Select the appropriate year, month, and day from the corresponding drop-down
lists.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To change a time:

1. Select the corresponding button with the ellipses (...). The following form appears:

2. Enter the appropriate number of hours, minutes and seconds.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The available fields are the following:
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Start time: it is used for compatibility reasons when linking to other models. It is
ignored by the solver.
Total simulation duration: if it is zero (00:00:00) then single period analysis is
used. If it is non-zero, extended period analyses are performed.
Hydraulic solver step: it is the time step that will be used in extended period
analyses. The default value is 1 hour. It is ignored in case of single period
analysis.
Quality solver step: it is the time step that will be used in quality analyses.
Usually it is much smaller than the hydraulic solver step. It is ignored in case of
single period analysis or when no water quality analyses  are performed.
Start time frame (for reports): in case of a simulation of great duration, you
may wish to export results not from the beginning but from a later time instant.
Report time step: you can use a large time step to limit the number of result
sets. For a simulation of 120 hours and a hydraulic solver step of 1 hour, there
will be 120 sets of results. If the report time step is 24 hours, the result sets are
limited to 6.
Start time frame (for patterns): it refers to the starting time of patters.
Pattern time step: it refers to the time step of patters. For example, if it is 2
hours then 12 values are sufficient for a day.

6.4.4 Energy

With this option, you can enter energy data regarding pumps. These are used when
performing operational cost and energy analyses.

To enter energy data:

1. Select General Data from the Data menu.
2. Select the Energy tab:
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3. Enter the pump efficiency in %. This value will be used in case the efficiency of a
specific pump is not defined and a  pump efficiency curve is not used. 
4. Enter the energy price in appropriate currency (€, $, etc) per kWh. If the
operational cost will not be calculated, you can safely ignore this field.
5. Select the price pattern from the drop-down list. After defining a suitable pattern,
you can use varying energy cost, as in the case of operation during the night as
compared to operation in peak hours.
6. Optionally, enter the additional demand charge in appropriate currency (€, $, etc)
per kWh.
7. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.4.5 Reactions

With this option, you can enter reaction data. These are used when performing water
quality analyses.

To enter reaction data:

1. Select General Data from the Data menu.
2. Select the Reactions tab:

3. Enter the bulk reaction order. This is the exponent of the concentration when
calculating the reaction rate. For first-order reaction enter 1.0, for second-order



Water Networks92

© 2012 TechnoLogismik i

reaction enter 2.0 etc. In order to use kinetics according to Michaelis-Menton, enter
any negative value.
4. Select the wall reaction order from the drop-down list. Zero-order reaction means
constant reaction rate.
5. Enter the global bulk coefficient. This value will be used when no value is
specified in pipe properties. A positive value means increase whereas a negative value
means decrease (decay). Enter zero to ignore the phenomenon.
6. Enter the global wall coefficient. This value will be used when no value is
specified in pipe properties. A positive value means increase whereas a negative value
means decrease (decay). Enter zero to ignore the phenomenon. The unit system is m/

day for first-order reaction and mass/m2/day for zero-order reaction.
7. Enter the limiting concentration. This is the maximum (for increase) or minimum
(for decrease) concentration. The reaction is analogous to the difference between the
current concentration and the limiting concentration.
8. Enter the wall coefficient correlation. This is a coefficient that correlates the pipe
asperity with the reaction rate.
9. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.4.6 Quality

With this option, you can enter water quality data. These are used when performing
water quality analyses.

To enter water quality data:

1. Select General Data from the Data menu.
2. Select the Quality tab:

3. Select the quality type check from the drop-down list. This can be one of the
following: 

none: no quality check will be performed.
chemical: the concentration of a chemical will be calculated.
trace: the percentage of water flow that origins from a specific node will be
calculated.
age: the time that water remains in the network will be calculated.

4. In case the quality check is of type chemical, enter the name of the chemical in
the corresponding text box. 
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5. In case the quality check is of type chemical, select the unit system for the

concentration. This can be one of mg/L or ug/L=10-6g/L. Note that when the quality
check is of type trace or age, the unit system is percentage and hours, respectively.
6. In case the quality check is of type trace, select the trace node from the drop-
down list.
7. Enter the molecular diffusion in m2/day. This value is used in the diffusion
equation.
8. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.4.7 Checks

With this option, the maximum and minimum values of various parameters can be set.
If these values are breached, the corresponding field is typed in different (but
customizable) color. The default color option is red.

To set the maximum and minimum values of various parameters:

1. Select General data > Checks from the Data menu. The following form appears:

2. Select Check the following hydraulic properties to enable or disable all checks.
3. Make the appropriate selections as described below.
4. Select Make default for all new projects if you wish to use these settings for all
new projects.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Velocities

Check Maximum velocity to enable this check.
Check Minimum velocity to enable this check.
Press the corresponding colored button to change the font color of the results that
fail these checks.

Pressure

Check Maximum pressure to enable this check.
Check Minimum pressure to enable this check. 
Press the corresponding colored button to change the font color of the results that
fail these checks.

Press Ok to accept the changes. Press Cancel to close the form without any changes.
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6.4.8 Excavation options

With this option, you can set several excavation options.

To set excavation options:

1. Select General data > Checks from the Data menu. The following form appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data

Enter the expected dislocation of public utilities in ft or m.
Enter the average transport distance of excavations in ft or m.
Enter the number of pumps used for pumping out rainfall water.
Select the pump diameter.
Enter the pump operation hours.

6.5 Curves

6.5.1 Management

Curves are objects that describe the relation between two quantities. The following
curve types are available:

Pump curves
Pump efficiency curves
Volume - height  curves
Flow rate - headloss curves

To manage curves:

1. Select Curves from the Data menu.
2. Select the appropriate curve type from the submenu. The following form appears:
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3. Make the necessary modifications.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.5.2 Add

To add a new curve:

1. Press Add. The data form that corresponds to the specified curve type appears.

2. Enter a user-assigned name. This name cannot be null or used for another curve in
the project.
3. Optionally, add some comments  to the curve. Press the ellipsis button to edit
multiline text.
4. Press add to add a line at the end of the data list.
5. Press remove to remove the current line of the data list
6. Press insert to insert a line above the current line of the data list.
7. Type the data in the data list.
8. If you wish to clear the data list, press clear. 
9. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.
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To import a curve from an external file:

1. Press Import. The file selection dialog box appears:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Curve file" with the extension .dat.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file. 

NOTE: A warning message will be displayed if the curve type of the imported file
does not match the current curve type.

To export a curve to an external file:

1. Press Export. The file selection dialog box appears:

6. Select the path of the file.
7. Type the filename in the File name text box.
8. Select Save to save the file with the selected filename and path. Select Cancel to
cancel the operation.

To view a curve:

1. Press View. The curve is drawn in a separate window:
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6.5.3 Delete

To delete an existing curve:

1. Select the curve from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The curve is deleted from the list.

6.5.4 Edit

To edit an existing curve:

1. Select the curve from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add curve topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.5.5 Move

To move an existing curve upwards in the list:

1. Select the curve from the list on the left.
2. Press Move Up. 
3. The curve is moved one place upwards.

To move an existing curve downwards in the list:

1. Select the curve from the list on the left.
2. Press Move Down. 
3. The curve is moved one place downwards.
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6.5.6 Sort

To sort the curve list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.6 Design Period

With this option, you can enter the design period of the project. This is used for the
calculation of the design population. If this is not of interest, you can safely ignore the
design period.

To enter the design period of the project:

1. Select Design Period from the Data menu. The following form appears:

2. Enter the design period in years, by typing into the corresponding text box.
3. The horizon is calculated based on the start date and the design period.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.7 Consumptions

6.7.1 General

With this option, you can define and modify the various consumers. If the water
demands are already known, you need not enter consumer data.

To define and modify the various water consumers:

1. Select Consumptions from the Data menu. The following form appears:



Data 99

© 2012 TechnoLogismik i

2. Make the appropriate changes, as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To enter a new consumer:

1. Select Add. The following form appears:

2. Enter the name of the consumer by typing into the corresponding text box.
3. Select the type of the consumer from the drop-down list. This can be one of:

Local people
Long-term tourists
Tourists
Factories
Green areas
Special consumers
Agricultural use
Fire hydrant
Losses

4. If the selected consumer type requires population then:
If the population is known, it is entered in the corresponding text box.
If the population is not known, check The design population is not known and
select Estimate... to estimate it.

5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: For proper estimation of the population, the design period is required.

To modify an existing consumer:

1. Select the consumer from the list.
2. Select Change. The consumer data form appears:

3. Make the appropriate changes, as described above.
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4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To delete an existing consumer:

1. Select the consumer from the list.
2. Select Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The consumer is deleted.

6.7.2 Population Estimation

With this option, you can estimate the design population based on census records. At
least two records are required. If the maximum population is known, it is entered in
the corresponding text box:

Select the calculation method. This can be one of the following:

Linear increase: the evolution of the population follows the linear model.
Geometric increase: the evolution of the population increases geometrically. The
coefficient is estimated but it can be modified by the user.
Decaying increase: the evolution of the population follows the decaying increase
model. The maximum population is required. The coefficient is estimated but it
can be modified by the user.
S curve: the evolution of the population follows the S curve model. The maximum
population is required. The coefficients are estimated but can be modified by the
user.

You can select the active census records by checking the appropriate check boxes.

Select Ok to close the dialog box and transfer the estimated population to the
corresponding fields. Select Cancel to close the dialog box without transferring any
data.

6.8 Design Consumptions

With this option, you can enter design consumptions for the consumers. A description
is displayed according to the selected column of the grid.

To enter design consumptions for the consumers:

1. Select Design consumptions from the Data menu.
2. Enter the appropriate data based on the consumer type. For example, in case of
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tourists, the mean consumption should be entered in L/tourist/day and the maximum
daily and maximum instantaneous factors are required.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: The above consumption data are used in the demand categories property of
the nodes.

6.9 Area categories

Area categories represent areas with different but constant instantaneous demands, in
terms of flow units to area unit. Both flow and area units vary, depending on what the
user has chosen as his flow units in the Hydraulics tab located in the general data
section. While the consumptions are virtual objects, which cannot be represented
visually, the areas are objects which can be drawn on the plane view and their areas
can either be computed automatically from the coordinates of their vertices or
specified by the user.

To manage the area categories:

1. Select Area Categories from the Data menu.
2. Make the appropriate changes, as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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To add a new area category:

1. Select Add. The following form appears:

2. Enter the description of the area by typing into the corresponding text box.
3. Enter the mean daily consumption. If the average daily consumption is not known,
you may estimate its value using the embedded database of daily consumption values
by clicking on the ellipses button (...).
4. Enter the coefficient L1. Usually, its value varies from 1.1 to 1.5. For Athens, the

water aythorities suggest a value between 1.15 and 1.20.
5. Enter the instantaneous peak coefficient L2. This value is used to convert the

maximum daily peak to maximum instantaneous.
6. You can optionally enter an augmentation factor which will be used to increase the
computed demand.
7. Enter the total population. If the population is unknown, you may estimate it by
cliock on the ellipses button (...) which will open the population estimation wizard.
8. Enter the total area in hectares (metric) or acres (english units).
9. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: For proper estimation of the population, the design period is required.

To modify an existing area:

1. Select the area from the list.
2. Select Change. The area data form appears:
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3. Make the appropriate changes, as described above.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To delete an existing area:

1. Select the area from the list.
2. Select Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The area is deleted.

6.10 Patterns

6.10.1 Management

With this option, you can add, edit and delete variation patterns. If all components of
the network are constant in time, you do not need to define variation patterns.

To add, edit and delete variation patterns:

1. Select Patterns from the Data menu. The following form appears:

2. Select Add to add a new pattern.
3. Select Remove to delete the currently selected pattern.
4. Select Edit to modify the currently selected pattern.
5. Select Move up to move the currently selected pattern by one place.
6. Select Move down to move the currently selected pattern by one place.
7. Select Sort A->Z to sort the patterns alphabetically.
8. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.10.2 Add

With this option, you can add a new variation pattern. A pattern is a series of pairs of
values that describe the variation of a factor. The first column refers to the time step
and the second column refers to the corresponding multiplying coefficient. The time
step is defined in the Times tab of the General Data. For example, if a factor has a
nominal value of 100 then during a time step that has a multiplying coefficient of 1.2,
the factor will take the value of 120.

To add a new variation pattern:
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1. Select Add from the patterns form. The following form appears:

2. Enter a unique name and an optional description for the pattern.
3. Select the sketch type of the pattern. This can be one of bar or line, and it does not
affect calculations. The pattern variation and the mean value are displayed in graphical
form on the right.
4. Make the appropriate changes in the pattern data, as described next.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To add a new entry at the end of the list:

1. Select Add. The following form appears:

2. Enter the value of the coefficient.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To delete an existing entry:

1. Select the entry from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the entry is deleted.

To modify an existing entry:

1. Select the entry from the list.
2. Select Edit. The following form appears:
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3. Enter the new value of the coefficient.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To insert a new entry:

1. Select the entry above which you wish to insert a new one.
2. Select Insert. The following form appears:

3. Enter the value of the coefficient.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.10.3 Delete

With this option, you can delete an existing variation pattern.

To delete an existing variation pattern:

1. Select the pattern from the list in the patterns form.
2. Select Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the pattern is deleted.

6.10.4 Modify

With this option, you can modify an existing variation pattern.

To modify an existing variation pattern:

1. Select the pattern from the list in the patterns form.
2. Select Change. The following form appears:
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3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.10.5 Move

To move an existing curve upwards in the list:

1. Select the curve from the list on the left.
2. Press Move Up. 
3. The curve is moved one place upwards.

To move an existing curve downwards in the list:

1. Select the curve from the list on the left.
2. Press Move Down. 
3. The curve is moved one place downwards.

6.10.6 Sort

To sort the pattern list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.11 Rules

6.11.1 Management

Rules determine how pipes, pumps and valves in the drainage system will be adjusted
over the course of a simulation. 

Each rule is a series of statements of the form:

RULE ruleID

IF condition_1
AND condition_2
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OR condition_3
AND condition_4
Etc.

THEN action_1
AND action_2
Etc.

ELSE action_3
AND action_4
Etc.

PRIORITY value

Only the RULE, IF and THEN portions of a rule are required; the ELSE and
PRIORITY portions are optional.

When mixing AND and OR clauses, the OR operator has higher precedence than AND,
i.e.,

IF A OR B AND C

is equivalent to:

IF (A OR B) AND C.

If the interpretation was meant to be

IF A OR (B AND C)

then this can be expressed using two rules as in

IF A THEN ...
IF B AND C THEN ...

The PRIORITY value is used to determine which rule applies when two or more rules
require that conflicting actions be taken on a link. A rule without a priority value
always has a lower priority than one with a value. For two rules with the same priority
value, the rule that appears first is given the higher priority.

Condition clauses

A condition clause of a rule has the following format:

object id attribute relation value

where object object type
id object name
attribute attribute or property of the object
relation relational operator (=, <>, <, <=, =>, >)
value property value

Some examples of condition clauses are:
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NODE N1 DEPTH > 10
PUMP A1 STATUS = OFF
SYSTEM CLOCKTIME = 22:45:00

The objects and attributes that can appear in a condition clause are as follows:

Object Property Value

Node Depth
Head
Pressure

numerical value
numerical value
numerical value

Tank Level
Filltime
Draintime

numerical value
numerical value
numerical value

Link Status
Flow
Setting

Open/Closed/Active
numerical value
pump speed or valve setting

System Demand
Time
Clocktime
(00:00:00)

total system demand
hours from start of simulation
time of day in hr:min:sec

Action clauses

An action clause of a rule can have one of the following formats:

PUMP id STATUS = ON/OFF
PUMP id SETTING = value

where the meaning of SETTING depends on the object being controlled:

for pumps it is a multiplier applied to the flow computed from the pump curve or
a status condition.
for pipes it is the status condition.
for valves it is a status condition or a setting value.

Some examples of action clauses are:

PUMP P67 STATUS = OFF
VALVE V212 SETTING = 0.5

To manage rules:

1. Select Rules from the Data menu. The following form appears:
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2. Make the necessary modifications.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.11.2 Add

With this option, you can add a new rule. 

To add a new rule:

1. Press Add. The data form appears:

2. Enter a user-assigned name. This name cannot be null or used for another rule in
the project.
3. Optionally, you can assign a priority level for the rule.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To enter a new logical statement to the rule:

1. Press Add to enter a new logical statement to the rule. The following form appears:
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2. Select the Clause, Scope, Object, allowed Relation and Value. Value may be one
of the following:

Option 1: a boolean (YES/NO)
Option 2: OPEN/CLOSED/ACTIVE if a status setting is required
Option 3: a numeric value

Not all options are available for a selected scope. If more than one option is
available, the user must specify which one will be used by activating the radio
button on the left of the option.

3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes

To delete an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the statement is deleted.

To modify an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Edit.
3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

To modify the position of an existing logical statement of a rule:

1. Select the statement from the list.
2. Select Move Up to move the statement up by one row. Select Move Down to
move the statement down by one row.

6.11.3 Delete

To delete an existing rule:

1. Select the rule from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The rule is deleted from the list.

6.11.4 Edit

To edit an existing rule:

1. Select the rule from the list on the left.



Data 111

© 2012 TechnoLogismik i

2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add rule topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.11.5 Move

To move an existing rule upwards in the list:

1. Select the rule from the list on the left.
2. Press Move Up. 
3. The rule is moved one place upwards.

To move an existing rule downwards in the list:

1. Select the rule from the list on the left.
2. Press Move Down. 
3. The rule is moved one place downwards.

6.11.6 Sort

To sort the rule list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.12 Controls

6.12.1 Management

With this option, you can define control rules that affect the behaviour of linear objects
(pipes, pumps, valves) based on the status of a point object (node, tank, reservoir) or
the time instant of the simulation.

To define control rules:

1. Select Controls from the Data menu.
2. Make the appropriate changes, as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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6.12.2 Add

With this option, you can add a new rule. 

To add a new rule:

1. Press Add. The data form appears:

2. Enter the name of the control.
3. Select the link type and depending on the type, the link name.
4. For the combinarion of link type and name, the status drop down list loads allowed
options. Select one option from the list of available options.
5. Select the new status of the control object. Pipes can become Open or Closed.
Pumps can become Open or Closed or obtain a new Speed property. Valves can
become Open or Closed or obtain a new Setting property. For the Speed or Setting
property, check the check box below the status and enter the new property value in
the corresponding text box.
6. Select the control check that will trigger the modification. The check can be a
pressure relation at a specific point object (node, tank, reservoir) or a specific time
instant. Select the check type by clicking on the corresponding option button of the
Control check frame. 
7. In case of a pressure relation at a specific point object, select the type and name
of the object, the inequality sign and the pressure value.
8. In case of a specific time instant, select the time by selecting Modify. The following
form appears:

Select the method of calculating the time instant. This can be in decimal hours or
hours and minutes from simulation start, or a real time instant.
Select Ok to save the changes and close the dialog box. Select Cancel to close
the dialog box without applying any changes.
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9. Select Ok to add the new control rule in the list or Cancel to discard any changes.

6.12.3 Delete

To delete an existing control rule:

1. Select the control rule from the list.
2. Select Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the control rule is deleted.

6.12.4 Edit

To modify an existing control rule:

1. Select the control rule from the list.
2. Make the appropriate changes.
3. Select Change to store the updated values.

6.12.5 Move

To move an existing control rule upwards in the list:

1. Select the control rule from the list on the left.
2. Press Move Up. 
3. The control rule is moved one place upwards.

To move an existing control rule downwards in the list:

1. Select the control rule from the list on the left.
2. Press Move Down. 
3. The control rule is moved one place downwards.

6.12.6 Sort

To sort the control list:

1. Press Sort A->Z.
2. The list is sorted alphabetically.

6.13 Calibration Data

6.13.1 General

With this option, you can enter calibration data from experiments to be compared with
the results obtained from the model.

To enter calibration data:

1. Select Calibration Data from the Data menu.
2. Select one of Demand, Pressure Height, Pressure, Quality, Flow Rate, Velocity
from the Calibration Data menu. The corresponding data form appears:
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3. Select Add to add a new entry.
4. Select Remove to delete the currently selected entry.
5. Select Modify to modify the currently selected entry .
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Alternatively, to add calibration data from an external file:

1. Select Import. The file selection dialog box appears:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Calibration files" with the extension .dat.
4. Select the file by clicking on it.
5. Select Open to open and analyze the file.

To export the current calibration data to an external file:

1. Select Export. The following dialog box appears:
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2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to save the file. Select Cancel to cancel the operation.

6.13.2 Add

With this option, you can add a new calibration data entry. 

To add a new calibration data entry:

1. Select Add from the calibration data form. The following form appears:

2. Enter the position of the object. In case of velocity or flow rate, the linear objects
are available in the drop-down list. In all other cases, the point objects are available in
the drop-down list.
3. Enter the decimal time corresponding to the measurement, in hours. Alternatively,
select the button with the ellipses (...) to invoke the following form:

Select Ok to convert the hours, minutes and seconds to decimal hours and close
the dialog box. Select Cancel to close the dialog box without applying any changes.

4. Enter the value of the measurement.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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6.13.3 Delete

With this option, you can delete an existing calibration data entry.

To delete an existing calibration data entry:

1. Select the calibration data entry from the list in the calibration data form.
2. Select Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. If you select Yes, the calibration data entry is deleted.

6.13.4 Modify

With this option, you can modify an existing calibration data entry.

To modify an existing calibration data entry:

1. Select the calibration data entry from the list in the calibration data form.
2. Select Change. The following form appears:

3. Make the appropriate changes.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.14 Conduit shapes

6.14.1 Management

With this option, you can add or modify conduit shape specifications. These are
recommended in case you to calculate quantities.

To add or modify conduit shape specifications:

1. Select Conduit shapes from the Data menu. The following form will appear:
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2. Make the necessary modifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To change the order of pipe specifications:

1. Select an entry from the list.
2. Select Up to move the selected entry up by one place. This option is not available
for the first entry in the list.
3. Select Down to move the selected entry down by one place. This option is not
available for the last entry in the list.
4. Repeat the above steps as necessary.

NOTE: You can activate or deactivate a specific conduit shape specification using the
corresponding check box.

The quick keys perform the following actions:

Select all: activates all conduit shape specifications in the list.
Select none: deactivates all conduit shape specifications in the list.
Invert: inverts the status of all conduit shape specifications.

Conduit shape specifications can be imported from a file or exported to a file, as
described later in this chapter.

The next sections describe the process of adding, modifying or deleting a conduit
shape specification.

6.14.2 Add

With this option, you can add a conduit shape specification. There are two ways of
adding a new specification. The first way is to add a new (empty) entry; the second is
to create a copy of an existing entry and modify only some of its properties.

To add a new (empty) entry:

1. Select Add. A new entry is added to the list.
2. Enter the appropriate data as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a new entry by copying an existing entry:

1. Select the existing (base) entry from the list.
2. Select Copy. A copy of the existing entry is created.
3. Select Edit to modify the properties of the clone entry, as described below.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Shape Data Tab
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Select the type of the shape from the drop-down list. 
Enter a unique shape name.
Optionally, you can enter some comments. Use the ellipsis button to edit multiline
text.
Select the material of the conduit from the drop-down list.
Select whether the specified shape is available in unlimited quantity. If not, enter
the available quantity in ft or m.
Enter the inner diameter of the shape.
Enter the wall thickness of the shape.
Enter the number of barrels. In case of twin conduits, this equals 2. Normally, the
number of barrels is equal to 1.
Select the color that will be used to draw the conduit on the plane view. It can be
either the default color or a custom color. This color will also be used when the plane
view DXF drawing is created.

Hydraulics Tab

Enter the Manning, Darcy - Weisbach, and Hazen - Williams friction coefficients. If
these are not known, press the corresponding ellipsis button to invoke the
corresponding database. 
Enter the minimum velocity in ft/s or m/s of the conduit shape. This is not a
restriction but a calculation check. If violated, the velocity is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant.
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Enter the maximum velocity of the conduit shape. This is not a restriction but a
calculation check. If violated, the capacity of the conduit is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant. 
Enter the minimum pressure in atm or psi for the junctions. This is not a
restriction but a calculation check. If violated, the pressure head is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant.
Enter the maximum pressure in atm or psi for the junctions. This is not a
restriction but a calculation check. If violated, the pressure head is printed in red.
Additional checks can be defined. However, the checks in the specifications are
dominant.
Select the pipe class from the drop down list. This is used in the water hammer
calculations.
Select the maximum pressure increase for the water hammer calculcations. If the
class of the pipe is 10 atm and 20% is entered, then a maximum of 120 m pressure
head will be allowed.

6.14.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.14.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.14.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Pipe specification file" with the extension .spc.
4. Select the file by clicking on it.
5. Select Open to import the specifications.

6.14.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:

1. Select Export. The following form will appear:

2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.15 Manhole specifications

6.15.1 Management

With this option, you can add or modify inlet specifications.
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To add or modify inlet specifications:

1. Select Inlet specifications from the Data menu. The following form will appear:

2. Enter the inlet specifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Inlet specifications can be imported from a file or exported to a file, as described later
in this chapter.

The next sections describe the process of adding, modifying or deleting an inlet
specification.

6.15.2 Add

With this option, you can add an inlet specification.

To add an inlet specification:

1. Select Add. A new entry is added to the list.
2. Enter the appropriate data as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Design Tab
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Enter a unique Name for the specification. 
Optionally, you can add some Comments. Use the ellipsis button to edit multiline
text.
Enter the external inlet height in ft or m.
Select tine inlet geometry. This can be one of circular or rectangular.
Enter the external dimensions of the inlet in ft or m. In case of circular inlet, only
one dimension is required.
Check inlet has neck if the inlet has a neck that extents from its maximum
height to the ground. In this case, you must provide the neck's external diameter
in ft or m.

Implementation Tab

In the Thickness frame, enter the thicknesses of the inlet in ft or m by typing
into the corresponding text boxes.
In the Materials frame, select the concrete grade for each element and check
whether you want to calculate wood form and/or asphalt in quantities.

Sublayer Tab

Optionally, you can use a layer of concrete below the inlet. In this case, check 
sublayer is made of in the previous tab and provide the thickness of the layer in
ft or m by typing in the text box.
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6.15.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.15.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.15.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:

2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Inlet type file" with the extension .fre.
4. Select the file by clicking on it.
5. Select Open to import the specifications.

6.15.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:

1. Select Export. The following form will appear:
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2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.16 Trench specifications

6.16.1 Management

With this option, you can add or modify trench specifications. After defining trench
specifications, you can use them in the data table of the main form.

To add or modify trench specifications:

1. Select Trench specifications from the Data menu. The following form will appear:

2. Enter the trench specifications.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Trench specifications can be imported from a file or exported to a file, as described
later in this chapter.

The next sections describe the process of adding, modifying or deleting a trench
specification.



Data 125

© 2012 TechnoLogismik i

6.16.2 Add

With this option, you can add a trench specification.

To add a trench specification:

1. Select Add. The following form appears:

2. Make the appropriate selections as described below.
3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Data Tab

Select a template for the trench.
Enter a unique Name for the trench specification. 
Optionally, you can add some Comments. Use the ellipsis button to edit multiline
text.
Depending on the selected trench template, enter the required dimensions and / or
material types. Unnecessary fields are disabled.

Profile Tab
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Enter the trench profile. The profile is defined as a set of trapezoidal layers, from
bottom to top. For example, a vertical trench may be defined for the first 6 ft, followed
by a trapezoidal layer for stability reasons. There is no restriction in the combination of
layers. If the total specified depth is insufficient, the program extents the topmost
layer as necessary.

To add a layer, press Add. The layer data form appears:

Enter the height, width and slopes of the layer. Select Ok to save changes and
close the dialog box. Select Cancel to close the dialog box without saving any
changes.

Press Remove to delete the currently selected layer.

Press Edit to edit the currently selected layer.

A sketch of the current trench profile is drawn in the form.

Advanced Tab

Check Use marking grid if you want to take into account the calculation of marking
grid in quantities.
Select the appropriate ground type from the drop-down list. This can be one of
plain, concrete or asphalt. In the latter two cases, enter the thickness in ft or m.
These are needed for the  calculation of the restoration and backfill volumes in the 
quantities.
Enter the extra surface width that is necessary for the construction in ft or m.
Enter the geological profile. The geological profile is defined in layers, from top to
bottom. For example, a single layer with height of 6ft, 20% rock percentage,
augmentation coefficient equal to 1.15 and need for support can be defined. If the
total height of the profile is insufficient, the program automatically extends the
bottommost layer as necessary.

To add a layer, press Add. The layer data form appears:



Data 127

© 2012 TechnoLogismik i

Enter the height, rock percentage and augmentation factor of the layer. Check
Requires support if the specified layer requires support. Select Ok to save
changes and close the dialog box. Select Cancel to close the dialog box without
saving any changes.

Press Remove to delete the currently selected layer.

Press Edit to edit the currently selected layer.

6.16.3 Delete

To delete an existing specification:

1. Select the specification from the list on the left.
2. Press Remove. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The specification is deleted from the list.

6.16.4 Edit

To edit an existing specification:

1. Select the specification from the list on the left.
2. Press Edit. The data form appears.
3. Make the appropriate selections as described in the add specification topic.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

6.16.5 Import

With this option, you can import specifications from an external file. Existing
specifications are erased.

To import specifications from an external file:

1. Select Import. The file selection dialog box will appear:
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2. Select the path of the file.
3. Select the file type from the Files of type drop-down list. The default option is
"Trench specifications file" with the extension .tspc.
4. Select the file by clicking on it.
5. Select Open to import the specifications.

6.16.6 Export

With this option, you can export specifications to an external file. These can be 
imported at a later time.

To export pipe specifications to an external file:

1. Select Export. The following form will appear:

2. Select the path of the file.
3. Type the filename in the File name text box.
4. Select Save to export pipe specifications with the selected filename and path.
Select Cancel to cancel the operation.

6.17 Network consistency

When importing a network from an external source such as a DXF file or entering
graphically its data, there can be a number of hard-to-locate inconsistencies. This form
facilitates the location and correction of several types of problems such as duplicate
nodes and pipes.

To use the network consistency check tool:

1. Select Network Consistency from the Tools menu.
2. Select the type of problems you wish to look for and optionally correct.
3. Click on Check to look for specific problems.
4. Highlight one problem in the list and click Objects of current problem to
highlight the location of the erroneous input on the map.
5. Optionally you may want to click on Objects of all problems to highlight the
location of all erroneous input on the map.
6. Click on Clear selection to hide all highlighted objects on the map.
7. Click Close to close the form.
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6.18 Options

6.18.1 General preferences

With this option, you can modify the general preferences of the program.

To modify the general preferences:

1. Select Options from the Data menu.
2. Select General preferences from the Options menu.
3. The general preferences dialog box appears. The preferences are grouped into four
tabs. You can select a tab by clicking on its name.

General Tab

This tab contains general preferences regarding the usage of the program.

Check Register the extension *.m511 with this application to associate the
extension .m511 with this program. This extension is used by the program when
saving a project. In this way, you will be able to run the program and load a project by
double-clicking on the project filename in Windows Explorer.

Check Automatically display calculation messages if you want the report details to
be automatically displayed when you calculate the results.
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Check Automatically create backup file if you want a backup file (with the
extension .bck) to be created every time a project is loaded. By default, this file is
created in the temporary folder of Windows.

Check Confirm delete actions if you want to be asked for confirmation each time an
object is about to be deleted. This setting affects the behaviour of all delete actions,
for example the deletion of an object.

You can also modify the temporary folder that will be used for the creation of backup
files. By default, this folder is the temporary folder of Windows.

Finally, there are three options regarding the termination of the program:

When exiting always ignore changes - All changes since the last save of the
project are ignored. 
When exiting always save changes - All changes in the current project are
automatically saved. If the filename of the project is not set, a dialog box will
appear that allows the selection of the filename, as when selecting Save project
as from the File menu.
When exiting prompt for action - If there are changes in the current project,
then a dialog box will appear. You can choose to save or ignore the changes. If
the filename of the project is not set, a dialog box will appear that allows the
selection of the filename, as when selecting Save project as from the File menu.

Languages Tab

If more than one language packs have been installed, then you can choose the
language of the program. In the above case, there are two language packs; English
(that are already selected) and Greek. If you change the language, all forms, menus,
messages, help files will reflect the chosen language.

In order for the changes to take effect, you must restart the program.

Digits Tab
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With this tab, you can modify the way the results are presented. All values used in the
program are displayed in the list on the left.

For each value, you can select the number of decimal digits using the Number of
digits drop-down list.

Check Use 0.1 instead of .1 to use a preceding zero when displaying numbers
between -1 and 1, for example -0.08 instead of -.08 and 0.98 instead of .98.

Check Use 1.0 instead of 1 to use trailing zeros (when necessary) in order to display
a number with the decimal digits selected in the Number of digits drop-down list, for
example 1.1600 instead of 1.16 (when the number of digits is set to 4).

Internet Tab

The program can automatically check for newer versions over the Internet. Check 
Automatically check for newer versions to enable this feature. The check is
automatically performed at an interval specified in the Every drop-down list. Select
Check now to manually check for newer versions.

When a newer version is found, you will be prompted to download and install the
latest version.

NOTE: TechnoLogismiki protects your privacy. During the check for newer versions,
no data is transferred from your computer to the Internet.
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Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.18.2 Sketch

With this option, you can modify the profile sketch.

To modify the profile sketch:

1. Select Options from the Data menu.
2. Select Sketch from the Options menu. The profile sketch options dialog box
appears:

2. Make the appropriate selections as described below.
3. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

Grid

Select Grid active if you want the dynamic grid to be displayed.
Press the Font button to select the font that will be used by the grid.
Press the Font color button to select the color of the font that will be used by the
grid.
Press the Pen button to select the style and width of the grid line.
Press the Pen color button to select the color of the grid line.

OSnap

Select Osnap active if you want the snap to objects to be active.
Select one or more Osnaps to be active: End, Middle, Center, Quadrant, Node.
Press All to select all osnaps. Press None to select none.

Snap to grid

Select Snap active if you want the snap to grid to be active.
Select the appropriate Spacing X and Spacing Y values.
Select the appropriate Base X and Base Y values.

Background
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Press the Color button to select the background color of the sketch

6.18.3 Grid editiing

With this option, you can modify the behavior of grids.

The behaviour of all editable grids is controlled by the preferences in this dialog box.

Select No cell automation if you want the active cell to remain the same when
hitting ENTER.

Select Open the cell below (edit by columns) if you want to activate the cell below
when hitting ENTER. This is particularly useful when editing tables by columns.

Select Open the next cell (edit by rows) if you want to activate the next cell on the
right when hitting ENTER. This is particularly useful when editing tables by rows.

NOTE: These preferences affect all projects, both old and new.

Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

6.18.4 Customize toolbar

With this option, you can customize the toolbar of the main form.

To customize the toolbar of the main form:

1. Select Options from the Data menu.
2. Select Customize toolbar from the Options menu.
3. Make the appropriate changes.
4. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

The toolbar may contain small or large buttons.

Check Show description if you want a small description to be displayed under the
buttons.

Check Show tooltips if you want tooltips to be displayed when the mouse pointer
hovers over a button for 2-3 seconds.
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NOTE: These preferences affect all projects, both old and new.

6.18.5 Default values

With this option, you can modify the default values for new linear or point objects,
curves etc.

To modify the default values:

1. Select Options from the Data menu.
2. Select Default values from the Options menu.
3. In the Labels tab, select the prefixes of new object names.

4. In the Properties tab select the default values for other new objects.

5. Select Make default for all new projects if you wish to use these settings for all
new projects.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
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dialog box without saving any changes.

6.18.6 Algorithm

With this option, you can modify the settings of the solver. Note, however, that the
use of the default values is highly recommended.

To modify the settings of the solver:

1. Select Options from the Data menu.
2. Select Algorithm from the Options menu. The following form appears:

3. Enter the maximum number of trials. This ensures that the solver will not be
trapped in endless loops. The use of 50 or more trials is sufficient for most cases.
4. Enter the solver accuracy. An accuracy of 0.001 is sufficient for most cases.
5. If the algorithm does not converge, then the process can be stop, continue for an
additional number of trials, or the problem may be ignored.
6. Enter the quality solver accuracy. An accuracy of 0.01 is sufficient for most cases.
7. The option Trials allowed before status checks sets the number of solution trials
that pass during hydraulic balancing before the status of pumps, check valves, flow
control valves and pipes connected to tanks are once again updated. The default value
is 2, meaning that status checks are made every other trial. A value equal to the
maximum number of trials would mean that status checks are made only after a
system has converged. (Whenever a status change occurs the trials must continue
since the current solution may not be balanced.) The frequency of status checks on
pressure reducing and pressure sustaining valves (PRVs and PSVs) is determined by
the damping option (see #9).
8. The discontinue status checks after # trials is the number of solution trials after
which periodic status checks on pumps, check valves flow control valves and pipes
connected to tanks are discontinued. Instead, a status check is made only after
convergence is achieved. The default value is 10, meaning that after 10 trials, instead
of checking status every given number of trials, status is checked only at convergence.
9. The accuracy value for solution damping is the the accuracy value at which
solution damping and status checks on PRVs and PSVs should begin. Damping limits
all flow changes to 60% of what they would otherwise be as future trials unfold. The
default is 0 which indicates that no damping should be used and that status checks on
control valves are made at every iteration. Damping might be needed on networks
that have trouble converging, in which case a limit of 0.01 is suggested.
10. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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7 Objects

7.1 Objects menu

With this option, you can add and modify objects. In the Objects menu you can select
one of the following options:

Add
o Junction

o Tank

o Reservoir

o Pipe

o Pump

o Valve

o Area

o Profile

o Label

Properties
o Node

o Tank

o Reservoir

o Link internal vertices

o Pipe

o Pump

o Valve

o Area

o Profile

o Label

Object conversion
Add vertex
Add vertex by distance
Delete vertex
Stretch vertex
Convert vertex to junction
Labels
Swap link ends

7.2 Add

7.2.1 Node

With this option, you can add one or more junctions.

To add a junction:

1. Select Add from the Objects menu.
2. Select Node from the Add menu.
3. Click onto the drawing to define the position of the junction.

To add more than one junctions:
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1. Select Add from the Objects menu.
2. Select Node from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the junction while holding down
CTRL key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.2 Tank

With this option, you can add one or more tanks.

To add a tank:

1. Select Add from the Objects menu.
2. Select Tank from the Add menu.
3. Click onto the drawing to define the position of the tank.

To add more than one tanks:

1. Select Add from the Objects menu.
2. Select Tank from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the tank while holding down CTRL
key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
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2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.3 Reservoir

With this option, you can add one or more reservoirs.

To add a reservoir:

1. Select Add from the Objects menu.
2. Select Storage from the Add menu.
3. Click onto the drawing to define the position of the reservoir.

To add more than one reservoirs:

1. Select Add from the Objects menu.
2. Select Storage from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the storage while holding down
CTRL key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.4 Pipe

With this option, you can add one or more pipes. The ends of the pipe are always point
objects (Junctions, Tanks, Reservoirs). Although there is no such restriction, it is
recommended that the direction of pipes matches the flow direction.

To add a pipe:

1. Select Add from the Objects menu.
2. Select Pipe from the Add menu.
3. Click onto the point object that will be the start point of the pipe.
4. Click onto the point object that will be the end point of the pipe. The pipe is drawn.
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To add more than one pipes:

1. Select Add  from the Objects menu.
2. Select Pipe from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the pipe.
4. Click onto the point object that will be the end point of the pipe while holding down
CTRL key. The pipe is drawn.
5. Repeat steps 3 and 4 to add the next pipe.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a pipe, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created.
They can be taken into account when calculating the length of the pipe, in the
calculation of excavation volumes etc.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.5 Pump

With this option, you can add one or more pumps. The ends of the pump are always
point objects (Junctions, Tanks, Reservoirs). Although there is no such restriction, it is
recommended that the direction of pumps matches the flow direction.

To add a pump:

1. Select Add from the Objects menu.
2. Select Pump from the Add menu.
3. Click onto the point object that will be the start point of the pump.
4. Click onto the point object that will be the end point of the pump. The pump is
drawn.

To add more than one pumps:

1. Select Add  from the Objects menu.



Objects 141

© 2012 TechnoLogismik i

2. Select Pump from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the pump.
4. Click onto the point object that will be the end point of the pump while holding
down CTRL key. The pump is drawn.
5. Repeat steps 3 and 4 to add the next pump.
6. Hit ESC when you have finished.

NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a pump, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.6 Valve

With this option, you can add one or more valves. The ends of the valve are always
point objects (Junctions, Outfalls, Dividers, Storages). Although there is no such
restriction, it is recommended that the direction of valves matches the flow direction.

To add a valve:

1. Select Add from the Objects menu.
2. Select Valve from the Add menu.
3. Click onto the point object that will be the start point of the valve.
4. Click onto the point object that will be the end point of the valve. The valve is
drawn.

To add more than one valves:

1. Select Add  from the Objects menu.
2. Select Valve from the Add menu while holding down CTRL key.
3. Click onto the point object that will be the start point of the valve.
4. Click onto the point object that will be the end point of the valve while holding
down CTRL key. The valve is drawn.
5. Repeat steps 3 and 4 to add the next valve.
6. Hit ESC when you have finished.
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NOTE: At least two point objects are required.

If you wish to define intermediate vertices for a valve, define their successive
coordinates either graphically or analytically prior to clicking on the end point object.
These intermediate vertices define piecewise linear objects and can be fully
manipulated (including addition, deletion, displacement) after the object is created. 

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.2.7 Area

With this option you can add a new area, which will be used to calculate the demands
of the consumers.

To add a new area:

1. Select Add from the Objects menu.
2. Select Area from the Add menu.
3. With multiple clicks on the plane view you can define the vertices of the area's
polygon.
4. Hit ENTER to create the area (the open polygon will be designed as closed
automatically) or ESC to cancel your changes and stop the procedure without adding a
new area.

When the program expects a vertex (point), you can provide the coordinates
analytically by hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
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options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

NOTE: You can use the areas from DXF tool to import closed polylines from an
existing dxf file.

7.2.8 Profile

With this option, you can add one or more profiles. Profiles are not actual objects but
rather a series of references to alternating nodes and links. Although there is no
restriction in the definition of profiles, it is recommended that

they follow the flow direction,
they do not overlap each other.

To add a profile:

1. Select Add from the Objects menu.
2. Select Profile from the Add menu.
3. Click successively onto the drawing to select the nodes of the profile. It is not
necessary to click onto all nodes. If two successive nodes are not connected by a
single link, the program automatically seeks and selects the shortest path (in terms
of number of links) connecting these two nodes. Thus, in most cases, you can fully
define a profile by clicking on the first and last node.
4. Press ENTER to define the profile. Press BACKSPACE to erase the reference to the
last defined point object.

To add more than one profiles:

1. Select Add from the Objects menu.
2. Select Profile from the Add menu while holding down CTRL key.
3. Click successively onto the drawing to select the nodes of the profile. It is not
necessary to click onto all nodes. If two successive nodes are not connected by a
single link, the program automatically seeks and selects the shortest path (in terms
of number of links) connecting these two nodes. Thus, in most cases, you can fully
define a profile by clicking on the first and last node.
4. Press ENTER while holding down CTRL key to define the profile. Press BACKSPACE
to erase the last defined vertex.
5. Repeat steps 3 and 4 as many times as required.
6. Hit ESC when you have finished.

7.2.9 Label

With this option, you can add one or more labels.

To add a label:

1. Select Add from the Objects menu.
2. Select Label from the Add menu.
3. Click onto the drawing to define the position of the label.

To add more than one labels:
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1. Select Add from the Data menu.
2. Select Label from the Add menu while holding down CTRL key.
3. Click onto the drawing to define the position of the label while holding down CTRL
key.
4. Repeat step 3 as many times as required.
5. Hit ESC when you have finished.

When the program expects a point, you can provide the coordinates analytically by
hitting CTRL+2. The following form appears:

1. Enter the coordinates by typing into the corresponding text box.
2. Select Ok to apply the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes. The program resumes the previous action.

NOTE: When selecting points graphically, you can use Snap and / or OSnap. These
options can be configured using the menu Data > Options > Sketch or by hitting
CTRL + 1.

7.3 Properties

7.3.1 Node

With this option, you can view and modify the properties of node objects. You can also
view some results regarding nodes; these are read-only fields.

To view and modify the properties of node objects:

1. Select Properties from the Objects menu.
2. Select Node from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the node, for example N1. Two or more nodes may
share the same name, but this is not recommended since there will be confusion
in the results.
X coordinate: enter the X coordinate of the node.
Y coordinate: enter the Y coordinate of the node.
Description: enter the description of the node, for example, "central node, no
hydrant, no emitter".
Tag: enter a tag for the node. This appears neither in the input data nor the
results.
Ground elevation (ft or m): enter the ground elevation in ft or m.
Axis elevation (ft or m): enter the axis elevation in ft or m.
Ditch elevation (ft or m): enter the ground elevation of the node.
Generic elevation (ft or m): enter a generic elevation of the node. This
elevation appears in the profile drawing only.
Minimum pressure (ft or m): enter the minimum pressure at the node. This is
used during optimization.
Hydrant: if set to YES then a hydrant sign is drawn. This property does not affect
calculations. On the contrary, in case of fire scenarios, the demand must include
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the additional flow rate.
Hydrants: select the number of hydrants for this node. This property is used to
evaluate correctly the flow based on Clement's formula in case of irrigation
systems.
Pressure release valve: if set to YES then a pressure release valve sign is
drawn. This property does not affect calculations except for the water hammer
analysis.
Special device: may be set to NONE, vacuum valve or air release valve
depending whether the location of the node coincides with a special device or not.
Station: click the ellipsis button to enter the station of the node.
Inlet type: select the inlet type for the junction from the drop-down list. The
inlet types are entered as manhole specifications.
Demand (selected flow units): enter the demand (outflow) from the node in
the selected flow units. If this is not known but consumption data are known, the
use of demand categories is recommended.
Demand curve: it is a curve that shows the fluctuation of demand with respect
to time. If the demand is constant, set this property to (no curve). This property
is used in extended period analyses.
Demand categories: if consumer data are known, you can enter the consumer
population instead of total demand. You can also combine outflow from direct
demand and from demand categories.
Emitter coefficient: for irrigation networks, you can enter emitter coefficients
that describe the variation of flow with respect to pressure height at the node. You
must have entered additional hydraulic data.
Initial quality: enter the initial value of the qualitative index at the specific
node. Additional quality data are required. The value and unit system of this
property vary, depending on the selected quality check.
Quality source: the quality source can be a constant concentration, additional
mass in water inflow (for example, chlorinating), additional concentration in the
water inflow or constant outflow concentration. The mass or concentration at the
node is required. Also, a curve that shows the variation of mass or concentration
with respect to time is required. This property is used in extended period
analyses.

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Real demand (flow units): this is the same as the demand in water networks,
but it is different in irrigation networks because the actual outflow from the node
is depended on the pressure height. Again, these values will differ only in case
emitter coefficients are used.
Pressure elevation (ft or m): it is equal to the sum of the bottom elevation and
the pressure height. If the bottom elevation is set to zero, it is equal to the
pressure height.
Pressure height (ft or m): the pressure height at the node in ft or m.
Quality: the final quality at the node.
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7.3.2 Tank

With this option, you can view and modify the properties of tank objects. You can also
view some results regarding tanks; these are read-only fields.

To view and modify the properties of tank objects:

1. Select Properties from the Objects menu.
2. Select Tank from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the tank, for example T1. Two or more tanks may share
the same name, but this is not recommended since there will be confusion in the
results.
X coordinate: enter the X coordinate of the tank.
Y coordinate: enter the Y coordinate of the tank.
Description: enter the description of the tank.
Tag: enter a tag for the tank. This appears neither in the input data nor the
results.
Ground elevation (ft or m): enter the ground elevation of the tank base in ft or
m.
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Axis elevation (ft or m): enter the axis elevation in ft or m.
Ditch elevation (ft or m): enter the ground elevation of the node.
Generic elevation (ft or m): enter a generic elevation of the node. This
elevation appears in the profile drawing only.
Initial level (ft or m): enter the initial level of water in the tank at the
beginning of the simulation. This is calculated with the ground elevation as
reference elevation.
Station: click the ellipsis button to enter the station of the node.
Minimum level (ft or m): enter the minimum level of water in the tank in ft or
m. If there is more demand for water, then the tank is considered empty and it is
disconnected from the network.
Maximum level (ft or m): enter the maximum level of water in the tank in ft or
m. If more water is available, it is ignored due to spillover.
Tank diameter (ft or m): if the tank is circular, enter the tank diameter in ft or
m. You can also use this property for other prismatic tanks, if you calculate and
enter the equivalent diameter.
Minimum volume (ft3 or m3). alternatively to minimum level, you can enter the

minimum volume in ft3 or m3. For non-circular tanks, it is easier to enter the
minimum volume instead of the minimum level. If you use the minimum volume,
you can safely ignore the minimum level.
Volume curve: select the volume - height curve that describes the variation of
volume with water level. In this way, any tank, whether circular or not, can be
used.
Mixing model: select one of fully mixed, 2 compartments, FIFO (first in, first
out) or LIFO (Last in, first out). The  mixing model is used for the calculation of
the lingering time of chemicals in the tank. It is used only in quality analyses.
Mixing fraction: if the 2 compartments mixing model is used, this field is the
fraction of the whole tank volume that consists the input-output system of the
tank.
Reaction coefficient: it refers to the increase or decrease of the concentration of
a chemical, in 1/day. Positive value means increase and vice versa. If a global
reaction coefficient is defined in the reactions form, this value may be left empty.
If this field is non-zero, it overrides the global reaction coefficient for the specific
tank.
Initial quality: enter the initial value of the qualitative index at the specific tank.
Additional quality data are required. The value and unit system of this property
vary, depending on the selected quality check.
Quality source: the quality source can be a constant concentration, additional
mass in water inflow (for example, chlorinating), additional concentration in the
water inflow or constant outflow concentration. The mass or concentration at the
tank is required. Also, a curve that shows the variation of mass or concentration
with respect to time is required. This property is used in extended period
analyses.

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Net inflow (flow units): it refers to the net inflow of water, in the selected flow
units. This is positive if water flows into the tank and vice-versa.
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Pressure elevation (ft or m): it is equal to the sum of the bottom elevation and
the pressure height. If the bottom elevation is set to zero, it is equal to the
pressure height.
Pressure height (ft or m): the pressure height at the node in ft or m.
Quality: the final quality at the tank.

7.3.3 Reservoir

With this option, you can view and modify the properties of reservoir objects. You can
also view some results regarding reservoirs; these are read-only fields.

To view and modify the properties of reservoir objects:

1. Select Properties from the Objects menu.
2. Select Reservoir from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the reservoir, for example P1. Two or more reservoirs
may share the same name, but this is not recommended since there will be
confusion in the results.
X coordinate: enter the X coordinate of the reservoir.
Y coordinate: enter the Y coordinate of the reservoir.
Description: enter the description of the reservoir.
Tag: enter a tag for the reservoir. This appears neither in the input data nor the
results.
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Ground elevation (ft or m): enter the ground elevation of the reservoir in ft or
m.
Axis elevation (ft or m): enter the axis elevation in ft or m.
Ditch elevation (ft or m): enter the ground elevation of the node.
Generic elevation (ft or m): enter a generic elevation of the node. This
elevation appears in the profile drawing only.
Station: click the ellipsis button to enter the station of the node.
Volume curve: select the flow rate - headloss curve that describes the variation
of the level of the reservoir with time. This can be used in case the reservoir is
part of a network with varying pressure.
Level (ft or m): enter the absolute elevation of the free surface of the reservoir.
This is assumed to be constant, except in the case a volume curve is used.
Initial quality: enter the initial value of the qualitative index at the specific
reservoir. Additional quality data are required. The value and unit system of this
property vary, depending on the selected quality check.
Quality source: the quality source can be a constant concentration, additional
mass in water inflow (for example, chlorinating), additional concentration in the
water inflow or constant outflow concentration. The mass or concentration at the
reservoir is required. Also, a curve that shows the variation of mass or
concentration with respect to time is required. This property is used in extended
period analyses.

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Net inflow (flow units): it refers to the net inflow of water, in the selected flow
units. This is positive if water flows into the reservoir and vice-versa.
Pressure elevation (ft or m): it is equal to the level of the reservoir, unless a
volume curve is used.
Pressure height (ft or m): this is always zero, as the reservoir has a free
surface.
Quality: the final quality at the reservoir.

7.3.4 Link internal vertices

All links may include internal vertices. These are used to describe a more complex plan
view, so that calculation of quantities and profile drawings are more precise. There is
no restriction in the number of intermediate vertices.

To manage the internal vertices, you can use the corresponding buttons of the toolbar 
 or the internal vertices form:

1. Select the properties form of a link (pipe, pump or valve).
2. Double click on the Internal vertices property.
3. Click the ellipsis button. 
4. Make the appropriate changes.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.
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To add a new internal vertex:

1. Press Add. The following form appears:

2. Make the appropriate selections as described below.
3. Enter the X-coordinate, the Y-coordinate, the ground elevation (in ft or m),
the axis elevation (in ft or m) and optionally select the type of the internal vertex.
Leaving either elevation field empty activates auto-filling. If the specified link belongs
to a profile in which upstream and downstream ground elevation data exist, the
program calculates the elevation based on linear interpolation. In this case, the result
appears within curly braces "{}".
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To edit an existing internal vertex:

1. Select the vertex from the list on the left.
2. Press Add. The data form appears.
3. Make the appropriate selections as described below.
4. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing internal vertex:

1. Select the internal vertex from the list on the left.
2. Press Remove. The snow pack is deleted from the list.

To move an existing internal vertex upwards in the list:

1. Select the internal vertex from the list on the left.
2. Press Move Up. 
3. The internal vertex is moved one place upwards.

To move an existing internal vertex downwards in the list:
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1. Select the internal vertex from the list on the left.
2. Press Move Down. 
3. The internal vertex is moved one place downwards.

7.3.5 Pipe

With this option, you can view and modify the properties of pipe objects. You can also
view some results regarding pipes; these are read-only fields.

To view and modify the properties of pipe objects:

1. Select Properties from the Objects menu.
2. Select Pipe from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the pipe, for example P1. Two or more pipes may share
the same name, but this is not recommended since there will be confusion in the
results.
Start node: select the start point object.
End node: enter the end point object.
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Internal vertices: click the ellipsis button to modify the internal vertices of the
conduit.
Description: enter the description of the pipe.
Tag: enter a tag for the pipe. This appears neither in the input data nor the
results.
Street address: optionally, enter the street name of the link.
Valve: specify if the upstream end of the link is a check valve or not. This is used
by the water hammer solver and appears on the plan view.
Length (ft or m): leave this field empty to activate auto-fill and let the program
calculate the length from the plan view. In this case, the result appears within
curly braces "{}". Alternatively, specify an explicit value that will be used. 
Shape: select the appropriate conduit shape. If none is selected, the program
uses the default shape or the shape that was explicitly defined upstream in a
profile that includes the conduit. In the latter case, the name of the conduit
shape appears within curly braces.
Pipe specification fixed: set this to yes if you want the selected shape not to be
altered during optimization.
Trench profile: select the trench profile from the drop-down list.
Friction coefficient: enter the friction coefficient of the pipe. The unit system is
depended on the selected friction formula. In any case, a custom form appears
that helps you enter the correct friction coefficient either directly or by invoking
the corresponding database.
Losses coefficient: optionally, enter the local losses coefficient. For example,
this can be used in the case of pipe curvature.
Reaction coefficient: it refers to the increase or decrease of the concentration of
a chemical, in 1/day. Positive value means increase and vice versa. If a global
reaction coefficient is defined in the reactions form, this value may be left empty.
If this field is non-zero, it overrides the global reaction coefficient for the specific
pipe.
Wall coefficient: it refers to the increase or decrease of the concentration of a
chemical, in 1/day. Positive value means increase and vice versa. If a global wall
coefficient is defined in the reactions form, this value may be left empty. If this
field is non-zero, it overrides the global wall coefficient for the specific pipe. This
value is used for the reactions that take place on the pipe walls.
Initial status: a pipe may be closed (non-existent), open (normal) or check
valve. The check valve will enable the pipe when flow occurs from the start node
to the end node, and vice versa.

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Length (ft or m): this is the length that will be used in the calculations. It
coincides with the fixed length in case the latter is non-zero. In all other cases,
the length is calculated from node coordinates, taking into account intermediate
pipe vertices and elevations.
Velocity (ft/s or m/s): the flow velocity in ft/s or m/s.
Flow rate (flow units): the mean flow rate in the selected flow units.
Quality: the final quality in the pipe.

Reaction rate (M/L/day or M/ft3/day): the reaction rate both internally and
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on the pipe walls.
Losses (ft/1000ft or m/km): the friction losses in ft/1000ft or m/km, taking
into account local losses.
Friction: the final friction coefficient. In case of the Darcy-Weisbach formula, this
field is equal to f.
Final status: the final status of the pipe (open or closed). This field is meaningful
when the initial status of the pipe is set to check valve. In all other cases, this
field coincides with the initial status.

7.3.6 Pump

With this option, you can view and modify the properties of pump objects. You can
also view some results regarding pumps; these are read-only fields.

To view and modify the properties of pump objects:

1. Select Properties from the Objects menu.
2. Select Pump from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the pump, for example P1. Two or more pumps may
share the same name, but this is not recommended since there will be confusion
in the results.
Start node: select the start point object.
End node: enter the end point object.
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Internal vertices: click the ellipsis button to modify the internal vertices of the
pump.
Description: enter the description of the pump.
Tag: enter a tag for the pump. This appears neither in the input data nor the
results.
Length (ft or m): leave this field empty to activate auto-fill and let the program
calculate the length from the plan view. In this case, the result appears within
curly braces "{}". Alternatively, specify an explicit value that will be used. 
Pump curve: select a pump curve that describes the relation of the flow rate and
the pressure height.
Power (kW): for constant power pumps, enter the power in kW. This value is
independent of the flow rate. This field is ignored if a pump curve is selected.
Speed : the speed coefficient of the pump. This value shows the relation of the
pump speed with respect to normal operation. For example, a speed coefficient of
1.5 shows that a pump has 50% more rpm with respect to normal operation.
Speed curve: select a speed curve that describes the operation of the pump with
respect to time. If at some time instants the coefficients are zero, the pump does
not operate.
Efficiency curve: select an efficiency curve that describes the relation between
the efficiency of the pump and the flow rate. If you use a global efficiency factor,
you do not need to select a curve.
Energy cost: enter the mean or nominal cost of energy in currency units per
kWh. This is used only in case of operational cost analyses. If you use a global
energy cost then you do not need to enter this value.
Price curve: select a price curve that shows the variation of energy cost with
respect to time. This is used only in case of operational cost analyses, when
energy cost varies, as in the case of pump operation during the night as
compared to operation in peak hours.
Initial status: a pump may be closed (non-existent) or open (normal).

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Flow rate (flow units): the mean flow rate in the selected flow units.
Quality: the final quality in the pump.
Losses (ft/1000ft or m/km): the friction losses in ft/1000ft or m/km.
Final status: the final status of the pump (open or closed). This depends on the
operational parameters (flow rate, pressure height) and its specifications.

7.3.7 Valve

With this option, you can view and modify the properties of valve objects. You can also
view some results regarding valves; these are read-only fields.

To view and modify the properties of valve objects:

1. Select Properties from the Objects menu.
2. Select Valve from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the valve, for example V1. Two or more valves may
share the same name, but this is not recommended since there will be confusion
in the results.
Start node: select the start point object.
End node: enter the end point object.
Internal vertices: click the ellipsis button to modify the internal vertices of the
valve.
Description: enter the description of the valve.
Tag: enter a tag for the valve. This appears neither in the input data nor the
results.
Length (ft or m): leave this field empty to activate auto-fill and let the program
calculate the length from the plan view. In this case, the result appears within
curly braces "{}". Alternatively, specify an explicit value that will be used. 
Diameter (mm or in): enter the diameter of the valve in mm or in. This field is
required.
Valve type: Select the type of the valve. This can be one of the following:
o PRV: Pressure reducing valve, setting value represents pressure height in m.

o PSV: Pressure sustaining valve, setting value represents pressure height in m.

o PBV: Pressure breaker valve, setting value represents pressure height in m. This

is pressure height difference because of the valve.
o FCV: Flow control valve, setting value represents flow rate in L/s. This is the

maximum flow rate that can pass through the valve.
o TCV: Throttle control valve, setting value represents friction coefficient. This

valve simulates a partly open valve by modifying the local losses coefficient.
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Usually, the relation between the local losses coefficient and the opening of the
valve is provided by the manufacturer.

o GPV: General purpose valve. This valve uses a flow rate - headloss curve that

describes the relation between the flow rate and the headloss. The setting field
is ignored and the operation curve is taken into account.

Setting: enter a value for pressure, flow rate, friction coefficient depending on
the valve type (see above).
Operation curve: for GPV valves only, select a flow rate - headloss curve that
describes the relation between the flow rate and the headloss.
Losses coefficient: enter the losses coefficient. This is zero if the valve is fully
open. Other values depend on the flow rate and are provided by the
manufacturer.
Initial status: a valve may be closed (non-existent), open (normal) or it may
have no initial status, in which case its behavior is governed by the
aforementioned properties.

Results

Some basic results regarding the selected objects are also displayed in the object
properties form. These fields are read-only and refer to the time instant that is
displayed in the bottom right corner of the main form. These are:

Velocity (ft/s or m/s): the flow velocity in ft/s or m/s.
Flow rate (L/s): the mean flow rate in L/s.
Quality: the final quality in the valve.
Losses (m/km or ft/1000ft): the friction losses in m/km or ft/1000ft, taking
into account local losses.
Final status: the final status of the valve (open or closed). 

7.3.8 Area

With this option, you can view and modify the properties of area objects.

To view and modify the properties of area objects:

1. Select Properties from the Objects menu.
2. Select Area from the Properties menu. The following form appears:



Water Networks158

© 2012 TechnoLogismik i

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the map are
preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the area, for example A1. Two or more areas may share
the same name, but this is not recommended since there will be confusion in the
results.
X-Coordindate: the X-Coordinate of the polygon's centroid.
Y-Coordindate: the Y-Coordinate of the polygon's centroid.
Description: enter the description of the valve.
Tag: enter a tag for the area. This appears neither in the input data nor the
results.
Vertices: click the ellipsis button to modify the internal vertices of the area.
Area category: select the area category that will be used to compute the water
demands from the particular area.
Related node: the node that will be used to supply the computed water depand
of the particular area.
Area: if you wish to override the automatically computed area, you can type-in
the desired area in this text field in hectares or acres.

7.3.9 Profile

Profiles are not actual objects but rather a series of references to alternating nodes
and links. Data input becomes very easy using profiles since:

data are input in tabular form,
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the elevations are displayed in a visual and comprehensive way,
the creation of profile DXF drawings is easy,
a network may be defined without plan view data.

To view and modify the properties of profiles:

1. Select Properties from the Objects menu.
2. Select Profile from the Properties menu. The following form appears:

3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the profile. Two or more profiles may share the same
name, but this is not recommended since there will be confusion in the results.
Description: enter the description of the profile.
Tag: enter a tag for the profile. This appears neither in the input data nor the
results.
Active: select whether the profile will appear in the profile drawing. This setting
can be changes using the profile drawing form.
First station: enter the first station of the profile. This option is used with the
semi-automatic data input of profile stations.
Concentration time (min): this property is NOT used.

7.3.10 Label

Labels are optional text objects that can be used to enrich the plan view with
important data.

To view and modify the properties of labels:

1. Select Properties from the Objects menu.
2. Select Label from the Properties menu. The following form appears:
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3. Select one or more objects from the list on the left. To select more than one
objects, hold down CTRL while selecting. The objects that are selected in the plan
view are preselected in the list.
4. If more than one objects are selected in the list, only the common properties are
displayed.
5. Make the appropriate changes, as described below. The new property values are
assigned to all selected objects in the list.
6. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

Properties

Name: enter the name of the label (not the text).
X-coordinate: enter the X-coordinate of the label.
Y-coordinate: enter the Y-coordinate of the label.
Text: enter the text that will be displayed.

7.4 Labels

With this option, you can select which object properties will be displayed. Up to two
properties can be displayed simultaneously, one on the left label and one on the right.

To select which object properties will be displayed:

1. Select Labels from the Objects menu.
2. Select the object type from the Labels menu. The following form appears:

3. Select the property that will be displayed on the left.
4. Select the property that will be displayed on the right.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

7.5 Object conversion

With this option, you can convert objects from one type to another.

To convert objects from one type to another:
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1. Select (in plan view) the objects you wish to convert.
2. Select Object conversion from the Objects menu. The following form appears:

3. Select if you wish to convert nodes (point objects) or links (linear objects). 
4. Select the target object type from the list on the right.
5. Select Ok to save the changes and close the dialog box. Select Cancel to close the
dialog box without applying any changes.

NOTE: Non-common properties are lost during object conversion.

NOTE: To convert a vertex back to a junction, see the convert vertex to junction
function.

7.6 Add vertex

With this option, you can add an intermediate vertex to an existing link: pipe, pump,
valve. This procedure is described also in the section of link internal vertices.

To add an intermediate vertex to an existing link:

1. Select Add vertex from the Objects menu.
2. Click on the link to add a vertex.

7.7 Add vertex by distance

With this option, you add a vertex on a conduit, by specifying a distance from either
end of the conduit. For example, if the conduit has a length equal to 20 m and you
need to add a vertex that be located 5 m from its end (station 0+015) then select its
ending node and enter 5 or its starting node and enter 15.

To add a vertex by distance:

1. Select Add Vertex By Distance from the Objects menu.
2. Select the conduit from the drop-down list. Its length appears on the form.
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3. Enter the desired distance from either starting or ending node.
4. Select whether this distance is measured from the starting or ending node.
5. Select Ok to add a vertex on the specified conduit. Select Cancel to close the
dialog box without applying any changes.

7.8 Delete vertex

With this option, you can delete an intermediate vertex of an existing link: pipe, pump
, valve. This procedure is also described in the section of link internal vertices.

To delete an intermediate vertex of an existing link:

1. Select Delete vertex from the Objects menu.
2. Click on the link vertex to delete it.

7.9 Stretch vertex

With this option, you can move an intermediate vertex of an existing link: pipe, pump,
valve. This procedure is also described in the section of link internal vertices.

To delete an intermediate vertex to an existing link:

1. Select Stretch vertex from the Objects menu.
2. Click on the link vertex you wish to move.
3. Click again to define the new vertex position.

7.10 Convert vertex to junction

To convert one or more vertices back to junctions, one must you this function instead
of the generic conversion form. 

To convert one vertex to a junction:

1. From the Objects menu, click on Convert Vertex To Junction.
2. On the map, click on the vertex you wish to convert back to a junction.
3. The vertex is converted.

To convert multiple vertices to junctions:

1. From the Objects menu, click on Convert Vertex To Junction.
2. Hold CTRL down and click on the map the vertex you wish to convert back to a
junction.
3. Repeat step 2 until all vertices are converted.

7.11 Swap link ends

All links have a certain direction. With this option, you can swap the ends of the
selected links and invert their direction.

To swap the ends of the selected links:

1. Select the links in the drawing.
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2. Select Swap link ends from the Objects menu. The ends are swapped.
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8 Profiles

8.1 Profiles menu

With this menu, you can perform various operations regarding profiles and network
design. These are available in case at least one profile has been defined. In the
Profiles menu you can select one of the following options:

Profile options
Elevation calculations
Stations
Street addresses
Vertical street addresses
Other junctions
Special devices

8.2 Profile options

With this option, you can modify the way the branches are displayed.

To modify the way the branches are displayed:

1. Select Profile options from the Profiles menu. The following form will appear:

2. Make the appropriate changes as described below. By clicking on each column, a
sketch of the setting is displayed on the right.

Reference elevation: Enter the reference elevation in m. However, it is
recommended that you leave this field empty, in which case a label "AUTO" will
appear and the reference elevation will be automatically calculated by the
program.
Station from: enter the initial station if this is not zero. This affects only the
drawing of the profiles; it is not related with the stations of the data table.
Direction: enter one of positive, negative if you want the stations to be
increasing or decreasing, respectively.
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Begin from: enter the distance from the first station in m. Usually this value will
coincide the Station from field, but it will be displayed in a different row in the
profile.
Draw: select one of D->U, U->D if you want the profile to be drawn downstream
to upstream or vice versa, respectively. This affects the profile drawing; in the
data table of the main form and the profile sketch, the branch is drawn upstream
to downstream.
Upstream end: select one of open, closed if you want the end to be drawn open
or closed, respectively, in the profile drawing.
Downstream end: select one of open, closed if you want the end to be drawn
open or closed, respectively, in the profile drawing.
Table name: enter the title of the branch. This is optional and it will be printed
above the corresponding table in the profile drawing. When editing this value, the
buttons Suggest and Clear of the Title frame become enabled. The former sets
the name equal to the title of the branch; the latter clears all table names.
Print table: select one of Yes, No if you want a table with row descriptions to be
included for the specific branch in the profile drawing. When editing this value,
the buttons Select all, Select None and Select Invert of  the Table frame
become enabled. With these, you can set Yes or No to all branches with one
click.

3. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

8.3 Elevation calculations

With this option, you can add or subtract a value to or from a specified elevation.

To add or subtract a value to or from a specified elevation:

1. Select the branch from the list of the main form.
2. Select two or more rows in the data table (when viewing the profile) by clicking and
dragging the mouse. The first and last row signify the first and last station,
respectively, of the part that the calculations will be applied.
3. Select Elevation calculations from the Profiles menu. The following form will
appear:

4. The form displays the first and last station.
5. Select the type of elevation that will be modified from the drop-down list. The
available options are:

Ground elevation
Upstream bottom elevation
Downstream bottom elevation
Trench elevation
Custom elevation
Manhole bottom elevation
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6. Enter the value to be added or subtracted by typing into the corresponding text
box.
7. If some values are calculated automatically by the program using linear
interpolation then, after this procedure, these will be recalculated, thus canceling the
effect of the above modifications. Check Convert automatically computed data to
fix the new values and prevent the program from recalculating them.
8. Select Ok to proceed with the operation and close the dialog box. Select Cancel to
close the dialog box and cancel the operation.

8.4 Stations

With this option, you can enter station data for the selected profile. This option is very
helpful if you want to enter the data of all stations, especially if these are uniformly
spaced (e.g. every 20m). Alternatively, the station data can be input using the data
table of the main form.

To enter station data for the selected profile:

1. Select the profile from the list.
2. Select Stations from the Data menu. The following form appears:

3. Enter the station data.
4. You can optionally use the following quick buttons:

Incremental: beginning with the first station, add the distance between two
stations.
Decremental: beginning with the first station, subtract the distance between two
stations.

5. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

NOTE: The first station is defined in the profile options form.

8.5 Street addresses

With this option, you can add or modify street addresses to the profile drawing. This
data does not affect calculations.

To add or modify street addresses:
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1. Select the profile from the list of the main form.
2. Select Street addresses from the Profiles menu. The following form will appear:

3. Enter the street addresses by typing directly onto the grid.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

For your convenience, the following options are available from the Edit menu:

Select all: All cells are selected.
Cut: The data of the selected cells are deleted from the grid and copied to the
clipboard.
Copy: The data of the selected cells are copied to the clipboard.
Paste: The data of the clipboard is pasted into the grid.
Clear selection: The data of the selected cells are deleted.

NOTE: If the same street address spans more than one sections, the program will
merge the street addresses into one.

8.6 Vertical street addresses

With this option, you can add or modify vertical street addresses to the profile
drawing. This data does not affect calculations.

To add or modify vertical street addresses:

1. Select the profile from the list of the main form.
2. Select Vertical street addresses from the Profiles menu. The following form will
appear:
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3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a vertical street address:

1. Select Add. The following form will appear:

2. Enter the Street address by typing in the corresponding text box.
3. In the Coordinates frame, enter the distance from start of the vertical street
address. For your convenience, you can select Inlet. The following form appears:

Select the inlet from the drop-down list.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing vertical street address:

1. Select the vertical street address from the list.
2. Select Modify. The following form will appear:
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3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing vertical street address:

1. Select the vertical street address from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The vertical street address is deleted.

8.7 Other junctions

With this option, you can add pipe junctions from other networks to the profile
drawing and the profile sketch. These do not affect calculations.

To add pipe junctions to the profile drawing and the profile sketch:

1. Select the profile from the list of the main form.
2. Select Other junctions from the Profiles menu. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a pipe junction:

1. Select Add. The following form will appear:
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2. Select the Section type and Diameter of the pipe in m.
3. In the Coordinates frame, enter the Distance from start of the pipe junction and
the Bottom elevation in m. For your convenience, you can select Inlet. The following
form appears:

Select the inlet from the drop-down list.
Check Match invert if you wish to match the invert elevation of the specified
inlet.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. In the Placement frame, you can select the position of the pipe junction i.e.
whether the junction comes from the left or right, and you can add comments to the
pipe junction. This data is used only for the profile drawings.
5. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing junction:

1. Select the junction from the list.
2. Select Modify. The following form will appear:
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3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing junction:

1. Select the junction from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The junction is deleted.

8.8 Special devices

With this option, you can add special devices to the profile drawing and the profile
sketch. These do not affect calculations.

To add special devices to the profile drawing and the profile sketch:

1. Select the profile from the list of the main form.
2. Select Special devices from the Profiles menu. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To add a special device:
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1. Select Add. The following form will appear:

2. In the Properties frame, select one of Air release valve, Vacuum valve  and
Valve as the type of the special device. You can also provide a Description of the
special device by typing into the corresponding  text box.
3. In the Coordinates frame, enter the Distance from start of the special device and
the Elevation in m. For your convenience, you can select Inlet. The following form
appears:

Select the inlet from the drop-down list.
Check Match invert if you wish to match the invert elevation of the specified
inlet.

Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To modify an existing special device:

1. Select the special device from the list.
2. Select Modify. The following form will appear:

3. Make the appropriate changes.
4. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

To delete an existing special device:
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1. Select the special device from the list.
2. Select Delete. You will be asked for confirmation only if you have selected to
confirm deletions in the General preferences tab.
3. The special device is deleted.
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9 Tools

9.1 Tools menu

With this menu, you can perform advanced operations regarding network's design and
integrity design. In the tools menu you can select one of the following options:

Automatic insertion of special devices
Object renaming
Demand distribution
Exact total water area
Water areas from DXF
Axis elevation initialization
Axis elevation calculations
Contours
Water hammer

9.2 Automatic insertion of special devices

This dialog box allows the user to automatically add air valves and vacuum valves in a
network.

To automatically insert special devices:

1. From the Tools menu select Automatic Insertion Of Special Devices.
2. If there are special devices present, you may wish to erase them first. Click on
Erase all special devices to remove all existing special devices from the network.
3. To automatically add the required air valves, click the Insert air valves button.
4. To automatically add the required vacuum valves, click the Insert vacuum valves
button.
5. To automatically add the required air and vacuum valves, click the Perform all
above operations button.
6. Press Close when done.

NOTE: There are special network configurations where more than necessary special
devices are added or when some necessary special devices are missing. It is the
engineer's responsibility to ensure correct network design. This tool is provided as a
convenient shortcut only.

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.
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9.3 Object renaming

To conveniently rename objects of a certain type such as junctions, conduits, pumps,
etc, you may use the object renaming tool.

To rename objects of a certain type:

1. Select Object Renaming from the Tools menu.
2. Select the object type from the drop-down list.
3. Select the scope from the drop-down list. The scope can either be the entire
project or the current selection.
4. Enter the renaming command (see below).
5. Press Apply to rename the objects described above or Cancel to close the form and
ignore all changes.

Renaming command

The renaming command is a string that dictates how the objects will be renamed. This
command is consisted of keywords and strings. Keyword vary depending on the object
type selected and appear as buttons for your convenience.

Examples:

J&[Index]: will rename all objects as J1, J2, J3, etc.
&[StartNodeName] -> &[EndNodeName]: will rename all pipes as J1 -> J2, J2 -> J3,
etc.

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.4 Demand distribution

This tool can be used to distribute a demand over the entire network, depending on
the conduits' lengths. The demand is equally divided on each node's upstream and
downstream ends. 

To distribute a specified demand over the entire network:

1. Select Demand Distribution from the Tools menu.
2. Enter the total demand in flow units which will be distributed depending on the
length of each conduit.
3. Press Ok to calculate and add the demand at each node depending on each conduit
length or press Cancel to hide the tool.
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NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.5 Exact total water area

This tool calculates the total area of the area objects for a selected area category and
automatically transfers the result to the category's data.

To calculate the area of a specified area category:

1. Select Exact Total Water Area from the Tools menu.
2. Select the area category whose area will be computed.
3. Click Ok to compute the total area and transfer the result to the area category.
Click Cancel to hide the tool.

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.6 Water areas from DXF

If you do not wish to specify on screen each area separately via the program's user
interface, it is possible to import one or more areas from external dxf files. The areas
have to be closed polygons (polylines). This tool, apart from reading and plotting areas
from external dxf files, scans for the nearest junction to every area and connects
them. 

To import water areas from DXF:

1. Select Water Areas From DXF from the Tools menu.
2. The following form appears, where the input file can be selected.
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3. Select one or more layers containing the polygon data.
4. The quick keys (Select all, Select None, Select Invert) can be used to quickly
select all objects, deselect all objects and invert the current selection.
5. Select Ok to import the polygons, display them on the drawing and close the dialog
box. Select Cancel to close the dialog box without applying any changes.

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.7 Axis elevation initialization

Use this tool to remove all axis elevation information and set them to their default
values. This will apply to all nodes and intermediate vertices regardless any selection
present.

To initialize all axis elevations:

1. From the Tools menu select Axis Elevation Initialization.
2. Click Yes to the following prompt:

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.8 Axis elevation calculations

Depending on the pipe specification, you may relocate all pipes at once. To do so, the
axis elevation calculations tool is provided.

To use this tool:

1. From the Tools menu click on Axis Elevation Calculations.
2. Select the pipe specification from the drop down menu.
3. Enter the desired ground to axis depth in m or ft.
4. If you wish this relocation to by applied only in cases where the depth is greater
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than the amount entered above, enabled the Update only when the depth is
greater option.
5. Press Apply to relocate all pipes or Close to hide the tool.

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.

9.9 Contours

Use this tool to create contours for a specific property of point objects.

To create contours for a specific property of point objects:

1. From the Tools menu select Contours. The following form appears:

2. Check Enabled to enable the contours. 
3. Select the Contour step (e.g. for the ground elevation of nodes, this is expressed
in units of length), the step for the major contours (which are printed thicker and
they are accompanied by their value) and the Contour segments, which controls the
smoothness of curves.
4. Select Point objects and the corresponding property.
5. Select the colors that correspond to the minimum and maximum values by clicking
on the corresponding Change button. If you want to use custom (user defined) high
and low values, check the corresponding field. In this case you need to provide the
colors for the values that are higher than the high value or lower than the low value.
6. Select the number of classes for the classification of objects. 
7. Select Ok to close the dialog box and save changes. Select Cancel to close the
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dialog box and ignore changes.

NOTES:

1. The settings for the contour coloring are the same (and affect) those of object
coloring. To create contours though, you must select Point objects.
2. Each time you perform calculations, the contours are evaluated anew. This
operation may take a lot of time.
3. The contours are exported, in color, when you perform File > Export > Plan view to
DXF.

NOTE: This tool is available as a separate product. It is enabled once the "Sewer
Networks Toolpack" product is purchased.

9.10 Water hammer

This tool checks for problems that may appear in the network's operation due to the
water hammer phenomenon. Water hammer appears in a non-looped network when a
demand stops or a valve closes. To prevent the pipes from breaking, pressure release
valves are used.

The solver can account for water hammer effects only outside loops. Pumps,
reservoirs, tanks and pressure release valves are considered fail safe devices. Water
hammer in pumps must be separately examined since the program considers them to
be "safe by design".

To solve for water hammer problems:

1. Solve the network.
2. From the Tools menu click on Water Hammer.
3. Enter the irrigation outlet closing time. This could be the time required for a
water supply demand to stop or an irrigation sprinkler to stop. The time cannot be
zero as no closing can be considered instantaneous. A common approximation is to
use a 3 seconds closing interval.
4. Enter the irrigation outlet flow rate in flow units. This is the flow rate of a single
sprinkler or a single water demand.
5. Enter the additional length in m or ft. The additional length represents the length
of the pipe that connects the sprinkler or the water consumer with the distribution
pipe. This variable varies, however a typical value is 10 meters.
6. Enter the irrigation outlet diameter in m or ft, which is the diameter of the pipe
mentioned above.
7. Enter the irrigation outlet maximum strength in m or ft. This is the maximum
instantaneous strength of the aforementioned pipe. If the pipe is 12.5 atm, then a
value 12.5*10+20%*12.5*10=150 should be used. 20% is the additional strength of
the pipe for instantenous over-pressure, above its nominal strength. This percentage
is arbitrary and could be set equal to 0 for maximum safety.
8. Enter the valve closing time in seconds. This closing time refers to valves that are
used to shutoff the flow completely in a pipe.
9. Enter the wave velocity in m/s or ft/s. The wave velocity is the speed that the
wave generated by the change in the boundary conditions (i.e. valve closing) travels
in the pipe. A value of 400 m/s for PVC is recommended.
10. Click on Run to start the Water Hammer solver or Close to hide the form.
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If the water hammer solver detects a problem then a message like the following will
pop-up:

To correct this problem, the geometry of the network could be altered, i.e. increase the
diameter or a pressure release valve could be added upstream of the node where the
problem appears. A new run is required until no error messages are generated.

In any case a complete analysis report is generated and can be exported directly to
Microsoft Word or the Printer (print preview).

NOTE: This tool is available as a separate product. It is enabled once the "Water
Networks Toolpack" product is purchased.
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10 Irrigation

10.1 Irrigation menu

With this menu, the user obtains access to advanced tools for the design and
optimization of irrigation networks, or in general, of branched networks (without loops)
under pressure. In the Irrigation menu, the following options are available:

Optimization options
Optimization
Characteristic curve options
Characteristic curve
Flow based on Clement's First Formula
Clear Clement's Flow
Check optimization constraints

10.2 Optimization options

This dialog box allows the user to set the optimization options for irrigation networks.

To set the optimization options for irrigation networks:

1. From the Irrigation menu, select Optimization options. The following form
appears:

2. Select one or more pipe specifications which will be used for optimization. The
material and class filter may assist you by limiting the available choices. 
3. Check Increased diameter upstream if you want the program to ensure that the
upstream pipes will have increasing (or the same) diameter.
4. Check Check for pipe availability if you want the program to take into account
the availability of the pipes, as defined in conduit shapes.
5. Optionally, you can impose in increase in head loss in the flow through pipes, by
setting an appropriate percentage in the relevant field.
6. Press Ok to close the form and save the changes. Press Cancel to close the form
without saving any changes.

NOTE: 

For the optimization to be successful and efficient, some requirement must be met.
The following should be noted:
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The optimization algorithm is applied to branched networks without loops with
exactly one reservoir.
After the optimization, you can convert the reservoir to a tank and finalize the
project.
You should select as many pipe specifications as possible, which should cover all
flow demands in your network.
The conduit shapes must be fully defined, i.e. they must include the cost, the
diameter, maximum velocity, minimum velocity, friction coefficient etc.
The optimization algorithm is based on SIMPLEX.
If the results indicate that two conduit shapes must be used for a single pipe, the
largest shape is selected for the whole pipe.
For the aforementioned reason, some minor violations of availability constraints may
be observed, in the case the conduit shape availability is not unlimited.
If you want to fix a specific conduit to a certain shape, produce its properties form
by double clicking on the conduit, and set Fixed pipe specification to Yes.
The optimization constraints that are taken into account are: minimum flow
velocity, maximum flow velocity, minimum head at the junctions, pipe availability
(optional), increasing diameter upstream (optional). The minimum head at the
junctions is evaluated as ground elevation plus the minimum pressure. These
properties are available in the junction properties form.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".

10.3 Optimization

This dialog box allows the user to optimize an irrigation network.

To optimize an irrigation network:

1. From the menu Irrigation, select Optimization. The following form appears:

2. Select the total head of the reservoir. This setting is saved into the reservoir's
properties.
3. To optimize the network, press Run. The shape of the pipes are modified in the
main project. An informative message appears, regarding the total cost of the network
.
4. Press Close to close the form.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".
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10.4 Characteristic curve options

With this dialog box, the user can set the options regarding the evaluation of the
network cost.

To set the options regarding the evaluation of the network cost:

1. From the Irrigation menu, select Characteristic curve options. The following form
appears:

2. Select Take into account the following to enable the following options: 

Life span of work (year): Enter the expected life span of the project. Usual
values are in the range of 50 years.
Structural cost of pumping station: Enter the structural cost of the pumping
station in € or any other consistently used currency.
Coefficient sigma of pumps: Enter the sigma coefficient of the pump cost.
Usual values are 1.10 - 1.15.
Suction water level: Enter the suction level of the water.
Pump coefficient n1: Enter the pump efficiency coefficient n1. Usual value is
0.9.
Cost coefficient A (dm=A*N^b): Enter the A coefficient which produces the
cost per HP of the pumping station.
Cost coefficient A (dm=A*N^b): Enter the b coefficient which produces the
cost per HP of the pumping station. For b=0, the cost per  HP is independent of
the size of pumps (i.e. the total cost is a linear function of the number of HP).
Irrigation area (acres): Enter the irrigation area in acres.
Area fraction that is irrigated: Enter the fraction of the above area that is
irrigated. The fraction is assumed constant for the whole life span of the project.
Water volume (ft³/acre): Enter the required water volume for irrigation per
acre.
Pump coefficient n2: Enter the mean efficiency of the pump station, which is
depended among others on its configuration.
Energy cost de (euro/KWh): Enter the energy cost in euros (or any other
currency that is consistently used) per KWh.
Network maintenance cost (% initial cost): Enter the network maintenance
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cost, as a percentage of the initial cost. Usually this is taken equal to 1%.
Pump maintenance cost (% initial cost): Enter the pump maintenance cost,
as a percentage of the initial cost. Usually this is taken equal to 2%.
Renew pumps every (years): Enter the life span of the pumping station. Usual
values are in the range of 17 years.
Mean interest rate (%): Enter the mean interest rate for the evaluation of
present value of the investment. 

3. Press Ok to close the form and save the changes. Press Cancel to close the form
without saving any changes.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".

10.5 Characteristic curve

With this option, the user can evaluate the characteristic curve of the network. If 
additional financial data are given, then the evaluation of the present value of the
investment is also possible.

To evaluate the characteristic curve of the network:

1. From the Irrigation menu, select Characteristic curve. The following form
appears:

2. Press Run to evaluate the characteristic curve of the network. The buttons in the
Results frame are enabled:

Characteristic: Produces the characteristic curve of the network without taking
into account additional financial data i.e. based on the pipe costs only.
Updated: Produces the characteristic curve of the network taking into account
additional financial data i.e. based on the present value  of the cost of the whole
investment.
Report (printer): Prepares and produces a calculation report in the print
manager.
Report (Word): Prepares and produces a calculation report in Microsoft Word.
Microsoft Word version 2003 or newer is required, with all available patches
installed.

3. Press Close to close the form.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".
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10.6 Flow based on Clement's First Formula

The program is able to evaluate and apply corrective demands in the junction
demands, so that flow in the pipes is set based on Clement's first formula.

For the flow based on Clement's first formula:

1. Form the Irrigation menu, select Flow based on Clement's first formula. The
following form appears:

2. Enter the following data:

Mean elementary probability p: Enter the mean elementary probability of each
hydrant to be open. During the analysis, each demand in the network is assumed
to be a hydrant.
Quality coefficient Pq: Enter the cumulative probability Pq that is related to the
quality of the network (usually >=95%).
Number of continuously open downstream demands: Enter the number of
downstream hydrants that will be assumed to be continuously open.
Min flow with Clement: set the minimum flow that can be used when
evaluating the flow based on Clement's formula.

4. Press Run to evaluate and apply the flow based on Clement's first formula. Press
Close to close the form.

NOTE: The flow based on Clement's first formula can be erased with the menu Clear
Clement's Flow that is described in the following paragraph. In this way, the program
is restored to its normal mode of analysis.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".

10.7 Clear Clement's Flow

With this options, the flows based on Clement's first formula are erased. The program
is restored to its normal mode of analysis.

To clear Clement's flow:

1. From the Irrigation menu, select Clear Clement's flow.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".
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10.8 Check optimization constraints

With this option, the user can check whether the optimization constraints are fulfilled.
The constraints that are checked are: minimum velocity, maximum velocity in the
pipes, minimum pressure at the junctions. The minimum head at the junctions is
evaluated as ground elevation plus the minimum pressure. These properties are
available in the junction properties form. The associated cost for the current state is
also evaluated and displayed. This cost refers to the pipes only.

To check whether the optimization constraints are fulfilled:

1. From the Irrigation menu, select Check optimization constraints.
2. A relevant informative message appears.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Irrigation optimization".
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11 Optimization

11.1 Optimization menu

With this menu, the user obtains access to advanced tools for the design and
optimization of water networks. In the Optimization menu, the following options are
available:

Optimization options
GA options
Cost function
Optimization
Check optimization constraints

11.2 Optimization options

This dialog box allows the user to set the optimization options for networks.

To set the optimization options for networks:

1. From the Optimization menu, select Optimization options. The following form
appears:

2. Select one or more pipe specifications which will be used for optimization. The
material and class filter may assist you by limiting the available choices. 
3. Check Check for pipe availability if you want the program to take into account
the availability of the pipes, as defined in conduit shapes.
4. Press Ok to close the form and save the changes. Press Cancel to close the form
without saving any changes.

NOTE: 

For the optimization to be successful and efficient, some requirement must be met.
The following should be noted:

You should select as many pipe specifications as possible, which should cover all
flow demands in your network.
The conduit shapes must be fully defined, i.e. they must include the cost, the
diameter, maximum velocity, minimum velocity, friction coefficient etc.
The minimum and maximum allowed pressure must be defined for all junctions.
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The optimization algorithm is based on Genetic Algorithms (GAs). A local optimizer
is invoked at the end of the GA analysis.
If you want to fix a specific conduit to a certain shape, produce its properties form
by double clicking on the conduit, and set Fixed pipe specification to Yes.
The optimization constraints that are taken into account are: minimum flow
velocity, maximum flow velocity, minimum/maximum pressure at the junctions,
pipe availability (optional). The minimum head at the junctions is evaluated as 
ground elevation plus the minimum/maximum pressure. These properties are
available in the junction properties form.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Network optimization".

11.3 GA options

With this option, the user can set the Genetic Algorithm (GA) options.

To set the Genetic Algorithm (GA) options:

1. From the Optimization menu, select GA options:

2. Make the desired changes.
3. Press Ok to close the form and save the changes. Press Cancel to close the form
without saving any changes.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Network optimization".

11.4 Cost function

With this option, the user can set options for the cost function.

To set the options for the cost function:

1. From the Optimization menu, select Cost function:
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2. Make the desired changes.
3. Press Ok to close the form and save the changes. Press Cancel to close the form
without saving any changes.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Network optimization".

11.5 Optimization

With this option, you can optimize a water network.

To optimize a water network:

1. From the Optimization menu, select Optimization. The following form appears:

2. Select Yes to proceed with optimization:

3. By letting the GA to finish, or by pressing Abort once, the local optimizer is
invoked. Press the Abort button again, or let the local optimizer to finish, to conclude
the optimization:
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4. Press Ok to view the calculation log. Press any other button to close the form. The
network has been updated with the best solution found by the optimization process.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Network optimization".

11.6 Check optimization constraints

With this option, the user can check whether the optimization constraints are fulfilled.
The constraints that are checked are: minimum velocity, maximum velocity in the
pipes, minimum pressure, maximum pressure at the junctions. The minimum/
maximum head at the junctions is evaluated as ground elevation plus the
minimum/maximum pressure. These properties are available in the junction
properties form. The associated cost for the current state is also evaluated and
displayed. This cost refers to the pipes only.

To check whether the optimization constraints are fulfilled:

1. From the Optimization menu, select Check optimization constraints.
2. A relevant informative message appears.

NOTE: This menu is available as a separate product. It is activated when you
purchase the program "Network optimization".
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12 Results

12.1 Results menu

With this menu, you can perform calculations and view the results. In the Results
menu you can select one of the following options:

Perform calculations
Results report
Animation
Grid
Filters
Colors
Calibrate Point Objects
o Demand

o Pressure Height

o Pressure

o Quality

Calibrate Linear Objects
o Flow Rate

o Velocity

Energy consumption
Reaction report
Total conduit lengths
Special devices count
Profiles

Options
Design

Quantities

12.2 Perform calculations

With this option, you can perform calculations.

To perform calculations:

1. Select Perform calculations from the Results menu.
2. The calculations are performed.

12.3 Results report

After the completion of calculations, a report is prepared that contains a list with
possible issues.

To show this report:

1. Select Perform calculations from the Results menu.
2. Select Results report from the Results menu. If an error report is available, it is
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displayed.
3. Hit ESC to close the form.

NOTE: The error codes are described in detail in the Appendix. For each error code,
common troubleshooting options are provided.

12.4 Animation

If extended period analysis has been performed, then with this option you can view
the results in animated form.

To view the results in animated form:

1. Select Animation from the Results menu. The following form appears:

2. Select  to move to the first time instant.

3. Select  to view the results in reverse.
4. Select  to stop animation.
5. Select  to start animation.
6. Select  to move to the last time instant.

7. Check Endless loop if you wish to view the animation with endless loop.

12.5 Grid

With this option, the results of the calculations are displayed in tabular form an a per-
object and time-instance basis.

To display the results of the calculations in tabular form an a per-object basis:

1. Make sure that the calculations have been completed successfully.
2. Select Grid from the Results menu.
3. The following form appears:
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4. Select the Object Type from the drop-down list.
5. Select the Time Instance from the drop-down list.
6. Hit ESC to close the form.

12.6 Filters

With this option, the results meeting certain criteria are displayed in tabular form.

To display the filtered results of the calculations in tabular form:

1. Make sure that the calculations have been completed successfully.
2. Select Filters from the Results menu.
3. The following form appears:
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4. Enter the filtering criteria.
5. When done, click Update Grid to view the filtered results.
6. You may repear steps 4 and 5 indefinitely.
7. Hit ESC to hide the form.

12.7 Colors

With this option, you can modify the settings for the coloring of objects depending on
their properties.

To modify the settings for the coloring of objects:

1. Select Colors from the Results menu. The following form appears:

2. Check Enabled to enable the coloring of objects. 
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3. Select whether you want to color the point or the linear objects.
4. Select the colors that correspond to the minimum and maximum values by clicking
on the corresponding Change button. If you want to use custom (user defined) high
and low values, check the corresponding field. In this case you need to provide the
colors for the values that are higher than the high value or lower than the low value.
5. Select the number of classes for the classification of objects. 
6. Select Ok to close the dialog box and save changes. Select Cancel to close the
dialog box and ignore changes.

NOTE: In some cases, such as when the calculations have not been completed or
when there is no variation of property values, the coloring will not be applied. In these
cases, the default coloring is used.

12.8 Calibrate Point Objects

12.8.1 Demand

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate point objects with respect to demand:

1. Select Calibrate Point Objects from the Results menu.
2. Select Demand from the Calibrate Point Objects menu. The calibration results
are displayed.

NOTE: This option is disabled if no observed calibration data are available.

NOTE: An example of calibration is given in the paragraph regarding quality.

12.8.2 Pressure Height

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate point objects with respect to pressure height:

1. Select Calibrate Point Objects from the Results menu.
2. Select Pressure Height from the Calibrate Point Objects menu. The calibration
results are displayed.

NOTE: This option is disabled if no observed calibration data are available.

NOTE: An example of calibration is given in the paragraph regarding quality.

12.8.3 Pressure

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate point objects with respect to pressure:
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1. Select Calibrate Point Objects from the Results menu.
2. Select Pressure from the Calibrate Point Objects menu. The calibration results
are displayed.

NOTE: This option is disabled if no observed calibration data are available.

NOTE: An example of calibration is given in the paragraph regarding quality.

12.8.4 Quality

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate point objects with respect to quality:

1. Select Calibrate Point Objects from the Results menu.
2. Select Quality from the Calibrate Point Objects menu. The following form
appears:

3. Select the point objects that will be taken into account in the calibration. The quick
keys (Select all, Select None, Invert Selection) can be used to quickly select all
objects, deselect all objects and invert the current selection.
4. Select Ok to proceed with calibration. Select Cancel to cancel the operation and
close the dialog box.
5. Select the Statistics tab to view the results of the statistical analysis.
6. Select the Correlation tab to view the autocorrelation graph.
7. Select the Mean Comparison to view the results of the comparison of mean
values.
8. Select Ok or Cancel to close the form.

For your convenience, the following options are available from the Functions menu:

Copy: the selected cells are copied to the clipboard.
Select all: all cells are selected.
Copy format: select one of tab, comma, space delimited. The use of tab
delimited is recommended for compatibility with Microsoft Excel.
Print: a document with the selected cells is created and sent to the Print
Manager.
Export to File: the contents of the selected cells are send to an ASCII text file.
Export to Word: the contents of the selected cells are send to Microsoft Word.
Export to Excel: the contents of the selected cells are send to Microsoft Word.

NOTE: This option is disabled if no observed calibration data are available.
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12.9 Calibrate Linear Objects

12.9.1 Flow Rate

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate linear objects with respect to flow rate:

1. Select Calibrate Linear Objects from the Results menu.
2. Select Flow Rate from the Calibrate Linear Objects menu. The calibration results
are displayed.

NOTE: This option is disabled if no observed calibration data are available.

NOTE: An example of calibration is given in the paragraph regarding quality.

12.9.2 Velocity

With this option, you can compare observed calibration data with results obtained
from the model. Statistical data and an autocorrelation graph are displayed, along with
the observed and calculated data.

To calibrate linear objects with respect to velocity:

1. Select Calibrate Linear Objects from the Results menu.
2. Select Velocity from the Calibrate Linear Objects menu. The calibration results
are displayed.

NOTE: This option is disabled if no observed calibration data are available.

NOTE: An example of calibration is given in the paragraph regarding quality.

12.10 Energy Consumption

If one or more pumps are included in the network, with this option you can view a
report regarding energy consumption and operational costs. Note that all data
regarding energy consumption and operational costs must have been provided.

To view a report regarding energy consumption and operational costs:

1. Select Energy Consumption from the Results menu.
2. Select the Results tab to show an overview of the results:
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3. Select the Graphs tab to view the results in a visual way:

Select the value from the list on the left. The graph is updated automatically.
Optionally, you can modify the graph by selecting Customization....

4. Select Ok to close the form.

12.11 Reaction Report

If all quality data are provided, with this option you can view a report regarding the
mean reaction (in kg/h) on the pipe walls, in the pipe interior and in tanks. The results
are displayed in both analytical and graphical form.

To view a report regarding the mean reaction:

1. Select Reaction Report from the Results menu.
2. Optionally, you can modify the graph by selecting Customization...
3. Select Ok or Cancel to close the form.
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12.12 Total conduit lengths

With this option, you can calculate the conduit lengths per profile that is currently
used in the network. The report is based on conduit shapes.

To calculate the conduit lengths:

1. Select Total conduit lengths from the Results menu. The following form appears:

2. The total conduit lengths per specification are displayed in the list.
3. Select Close to close the dialog box.

From the File menu, the following options are available:

Print, Print to Word, Print to Excel

Select the appropriate option to create a report and sent it to the corresponding
recipient.

12.13 Special devices count

With this option, you can count the special devices, i.e. air release valves, vacuum
valves and valves, that are currently used in the network.

To count the special devices:

1. Select Special devices count from the Results menu. The following form appears:
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2. The total number of special devices are displayed in the list.
3. Select Close to close the dialog box.

From the File menu, the following options are available:

Print, Print to Word, Print to Excel

Select the appropriate option to create a report and sent it to the corresponding
recipient.

12.14 Profiles

12.14.1 Options

With this option, you can modify the settings of the profile drawings.

To modify the settings of the profile drawings:

1. Select Profiles from the Results menu.
2. Select Options from the Profiles menu. The following form will appear:

2. In the Settings frame:

Check Do not display the inlet types if you do not want to display the inlet
types.
Check Do not display the inlet stations if you do not want to display the inlet
stations.
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Check Draw all pipes flat (no thickness line) if you do not want to display the
pipe thickness in the profile drawing. This does not affect the sketch of the main
form where the pipe thickness is not drawn.

3. In the Hydraulic calculations frame, select one or more values that you wish to
be included in the profile drawing.
4. In the Custom line frame:

Check Draw custom line along the profiles if you want a custom line to be
drawing along the profiles. In this case, you can provide the title of the custom
line in the corresponding text box.

5. Check Default values for all new projects if you wish to make the settings
default for all new projects. This does not affect existing projects.
6. Select Ok to save changes and close the dialog box. Select Cancel to close the
dialog box without saving any changes.

12.14.2 Design

With this option, you can create the profile drawing. The data are prepared and sent to
the Profile designer. A complete user manual on the capabilities of Profile designer
can be found in the corresponding help file.

To create a profile:

1. Select Draw profiles from the Results menu. The following form appears:

2. Select one or more profiles to be included in the profile drawing. The quick keys (
Select all, Select None, Select Invert) can be used to quickly select all objects,
deselect all objects and invert the current selection. 
3. Select Ok to sent the data to the Profile designer. Select Cancel to cancel the
operation.
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12.15 Quantities

With this option, a report on the network quantities is assembled and prepared for
preview.

In the current version of the program, this report includes:

Excavation tables based on trench profiles
Excavation/backfill volumes
Pipe quantities based on conduit shapes
Manhole quantities based on manhole specifications
Trench quantities based on trench specifications

To create a report on the network quantities:

1. Select Quantities from the Results menu.
2. The printer selection form appears:

3. Depending on the printer selected, the relevant object appears:
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NOTE: The formatted Microsoft Word file requires the use of the clipboard. During the
creation of the file, you should not use the clipboard.
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13 Help

13.1 Help menu

In the Help menu you can select one of the following options:

Contents
User guide
Tutorials
Tip of the day
Unit conversion
TechnoLogismiki website
Buy products
TechnoLogismiki NOMOS
TechnoLogismiki Live!
About the program

13.2 Contents

With this option, you can access the online help which contains detailed information
regarding the usage of the program.

To view the online help:

1. Click Contents from the Help menu.
2. The online help appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

13.3 User guide

With this option, you can access the user guide which contains detailed information
regarding the usage of the program.

To view the user guide:

1. Click User Guide from the Help menu.
2. The user guide appears.

NOTE: If an error message appears then the online help has not been installed. You
can install the online help from the installation CD or the Internet.

NOTE: Adobe Acrobat Reader or a similar program that can display pdf files is
required in order to view or print the user guide.

13.4 Tutorials

With this option, you can access the tutorials of the program. The tutorials are step-
by-step examples that allow you to decrease the learning cycle of the programs
dramatically.
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To access the tutorials:

1. Click Tutorials from the Help menu.
2. The tutorial selection dialog box appears.
2. Select the appropriate tutorial and click Start to proceed. Click Cancel to close the
dialog box.

NOTE: The number and content of the tutorials is changed frequently. Use the live
update system of TechnoLogismiki's products to download the latest tutorials.

13.5 Tip of the day

With this option, you can access the tip database of the program. The tips are short
guidelines regarding the usage of the programs which may be of great help to the
user.

To access the tips:

1. Click Tip of the day from the Help menu.
2. The tip of the day form appears.
3. Check Do not show this form again to prevent the program from showing the tip
of the day when starting. Press the Previous/Next buttons to browse all available
tips.
4. Press Esc to close the form.

NOTE: The number and content of the tips is changed frequently. Use the live update
system of TechnoLogismiki's products to download the latest tips.
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13.6 Unit conversion

With this option, you can access the unit conversion tool. You can find more
information about its usage in its help system. 

To launch the unit conversion tool:

1. Click Unit conversion from the Help menu.
2. The unit conversion tool is launched.

NOTE: If an error message appears then the unit conversion tool has not been
installed. You can install the unit conversion tool from the installation CD or the
Internet.

13.7 TechnoLogismiki website

With this option, you can load on your Internet browser the website of
TechnoLogismiki's.

13.8 Buy products

With this option, you can load on your Internet browser the main product page of
TechnoLogismiki's website.

13.9 TechnoLogismiki NOMOS

With this option, you can load on your Internet browser the NOMOS service of
Technologismiki.

13.10 TechnoLogismiki Live!

With this option, you can load on your Internet browser the Live! service of
Technologismiki.

13.11 About the program

With this option, a form containing the name, version and licence information of the
program appears.

To show this form:
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1. From the Help menu, select About the program.
2. The form appears.
3. Click anywhere on the form or hit ESC to close the form.



Chapter

XIV



Appendix 215

© 2012 TechnoLogismik i

14 Appendix

14.1 Unit system

Unit Metric system English system

Area
hectares

m2
acres

ft2

Length
m

mm
ft
in

Rainfall intensity mm/h in/h

Flow rate
m3/s
L/s

ML/day

ft3/s
g/m

Mg/day

Pollutant concentration mass/hectare mass/acre

Volume m3 ft3

14.2 Fluid database

For your convenience, a fully customizable fluid database is embedded in the program.
The fluid database is invoked in various cases within the program. By selecting an
appropriate fluid record and clicking Ok, the data is transferred to the corresponding
fields. Select Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

To add a new record:

1. Click Add to open the new record dialog box.
2. Type the name of the fluid. This field is required.
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3. Enter the temperature, density, viscosity and kinematic viscosity of the fluid.
4. The specific weight is calculated automatically.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

14.3 Friction database

For your convenience, a fully customizable friction database is embedded in the
program. The friction database is invoked in various cases within the program. By
selecting an appropriate friction record (which is depended on the selected friction
formula) and clicking Ok, the data is transferred to the corresponding fields. Select
Cancel to close the database without transferring any data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.
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The database consists of several categories. Usually, the category defines the material
of the surface (e.g. Metal surfaces).

To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:
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4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the friction.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

NOTE: In case of Manning friction coefficients in natural streams, you can estimate
the values based on several characteristics of the stream. Click on the buttons with
the ellipses (...) next to the text boxes to invoke the following dialog box: 

Make the appropriate selections. Click Ok to close the dialog box and transfer the data
to the corresponding text box. Click Cancel to close the dialog box without
transferring any data.
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To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

14.4 Manning friction coefficients

Surface / Material
Mean
Value

Aluminum 0.024

Asbestos cement 0.013

Asphalt ditch 0.016

Asphalt pavement 0.016

Asphalt smooth 0.013

Asphalted cast iron 0.012

Natural ground 0.020

Best concrete 0.010

Brick in mortar 0.015

Brick sewer 0.015

Cast iron 0.012

CMP 0.024

Concrete 0.013

PVC 0.010

Centrifugal SPUN 0.013

Concrete (steel forms) 0.011

Concrete (wood forms) 0.015

Concrete gutter (broom finish) 0.016

Concrete gutter (troweled finish) 0.012

Copper 0.011
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Fiber glass roving 0.011

Gravel riprap (D=25) 0.033

Gravel riprap (D=50) 0.041

Grouted riprap 0.030

Natural stream (clean) 0.030

Natural stream (stone) 0.050

Natural stream (weedy) 0.035

14.5 Bazin friction coefficients

Surface / Material
Max

value
Min

value
Mean
value

Rough concrete 0.5 0.4 0.46

Smooth concrete 0.08 0.04 0.06

Brick in mortar 0.018 0.014 0.016

Sewer pipes (Greek regulations
696/74)

0.25 0.25 0.25

Storm pipes (Greek regulations
696/74)

0.46 0.46 0.46

14.6 Hazen - Williams friction coefficients

Surface / Material
Mean
value

Asbestos cement 140

Asphalted cast iron 130

Best concrete 150

Centrifugal SPUN 135

Concrete (wood forms) 120

Concrete (steel forms) 140

Copper 135

Ductile iron 130

Galvanized iron 120

Glass 140

PVC 150

Riveted steel (new, rough) 80

Riveted steel (new, smooth) 110

Steel 120

Wood (new) 140
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14.7 Darcy - Weisbach friction coefficients

Surface / Material
Mean
value
(mm)

Aluminum 0.300

Asbestos cement 0.002

Asphalted cast iron 0.120

Best concrete 0.366

Brick in mortar 0.610

Sewer brick 0.610

CMP 0.305

Concrete 0.122

Centrifugal SPUN 0.366

Concrete (steel forms) 1.829

Concrete (wood forms) 0.610

Copper 0.002

Galvanized steel 1.520

Glass 0.001

PVC 0.122

HDPE 0.150

14.8 Water consumption

For your convenience, a fully customizable water consumption database is embedded
in the program. The database is invoked in various cases within the program. By
selecting an appropriate record and clicking Ok, the data is transferred to the
corresponding fields. Select Cancel to close the database without transferring any
data.

You will be asked to confirm any changes you have made to the database when
exiting. The changes will be instantly available to other programs using the same
database.

The database consists of several categories.
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To add a new category:

1. Select Add category from the Data menu.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Select Ok to add the category at the end of the list. Select Cancel to cancel the
procedure.

To modify the name of an existing category:

1. Click Modify to open the modify category dialog box.
2. Type the name of the category in the text box. The name of the category must be
unique.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing category:

1. Select the category you wish to remove from the drop-down list.
2. Click Remove to remove the category. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.
4. If the category contains records, then the following dialog box appears:

4.1. Select the first option to move the records of the category to the default (first
category).
4.2. Select the second option to delete the records.
4.3. Select the third option to cancel the deletion.
5. Click Ok to proceed.

NOTE: The database must contain at least one category.

To add a new record:

1. Click Add to open the new record dialog box.
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2. Select the category of the new record from the drop-down list.
3. Type the description of the record. This field is required.
4. Enter the minimum, maximum and mean value of the water consumption.
5. Click Ok to close the dialog box and add a new record at the end of the list. Click
Cancel to close the dialog box without making any changes.

To modify an existing record:

1. Click Modify to open the modify record dialog box.
2. Make the appropriate changes.
3. Click Ok to save the changes and close the dialog box. Click Cancel to close the
dialog box without saving the changes.

To remove an existing record:

1. Select the record you wish to remove.
2. Click Remove to remove the record. You will be asked to confirm the deletion.
3. Select Yes to proceed with the deletion. Select No to cancel the deletion.

14.9 Local energy losses friction coefficients

Fitting K-value Fitting K-value

Pipe entrance 90° smooth

bend1

Bellmouth 0.00 ~ 0.05 r/D=4 (r radius) 0.16 ~
0.18

Rounded 0.18 r/D=2 0.19 ~
0.25

Sharp edged 0.50 r/D=1.5 0.26 ~
0.34

Projecting 0.80 ~ 1.00 r/D=1 0.35 ~
0.40
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Fitting K-value Fitting K-value

Contraction -
Sudden

Mitered bend

D2/D1 = 0.20 0.41 ~ 0.50 15° angle 0.05

0.20 < D2/D1 =

0.40

0.30 ~ 0.41 30° angle 0.10

0.40 < D2/D1 =

0.60

0.18 ~ 0.30 45° angle 0.20

0.60 < D2/D1 =

0.80

0.06 ~ 0.18 60° angle 0.35

D2/D1 = 0.80 0.00 ~ 0.06 90° angle 0.80

Contraction -
Conical

Tee 2

15° angle 0.02 Line flow 0.30 ~
0.40

22.5° angle 0.04 Branch flow 0.60 ~
2.10

45° angle 0.07 45° Wye 2

Expansion -
Sudden

Line flow 0.20 ~
0.35

D2/D1 = 0.20 0.92 ~ 1.00 Branch flow 0.45 ~
0.55

0.20 < D2/D1 =

0.40

0.71 ~ 0.92 Cross 2

0.40 < D2/D1 =

0.60

0.41 ~ 0.71 Line flow 0.40 ~
0.60

0.60 < D2/D1 =

0.80

0.13 ~ 0.41 Branch flow 0.60 ~
0.90

D2/D1 = 0.80 0.00 ~ 0.13 Spherical valves
3

Expansion -
Conical

90° angle 0.05

15° angle 0.03 60° angle 1.20

22.5° angle 0.07 45° angle 10.00

45° angle 0.14 30° angle 50.00

NOTES:

1.These values are valid for Reynolds number around 2x10
5
.

2. Typical values for commercial parts.
3. The angle of spherical valves is the complementary angle defined by the pipe axis
and the valve opening axis.
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14.10 Error messages

14.10.1 Error codes

The error codes that are displayed in the results report consist of a three-digit number
and a brief description. In the following, a more detailed description as well as
common  troubleshooting options are provided.

Codes 100-199
Codes 200-299
Codes 300-399

14.10.2 Codes 1XX

[101] insufficient memory.
There is not enough physical memory in the computer to analyze the study area.

[102] no network data to process.
There is no network present.

[103] Hydraylics solver not initialized.
The internal hydraulics solver has stopped because of insufficient input. Please
make sure that you have entered all necessary information and retry.

[104] No hydraulic results available.
The time steps are such that no results are reported. You must correct the time
steps and retry to solve the network.

[105] water quality solver not initialized.
The internal water quality solver has stopped because of insufficient input. Please
make sure that you have entered all necessary information and retry.

[106] no results to report on.
The time steps are such that no hydraulic or quality results are reported. You
must correct the time steps and retry to solve the network.

[110] cannot solve water quality transport equations.
The network quality stopped before successful termination. This could be caused
be erroneous data or time steps that lead to an unstable system.

14.10.3 Codes 2ΧΧ

[200] one or more errors in input file.
This message appears when one or more input file parsing errors (the 200-series
errors) occur.

[202] illegal numeric value in function call.
A variable has an illegal numeric value. Please correct the problem and retry.

[203] undefined node in function call.
A reference was made to a node that was never defined. An example would be if
node 123 is used in a rule yet no such node was ever defined in the study area.
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[204] undefined link in function call.
A reference was made to a link that was never defined. An example would be if
link 123 is used in a rule yet no such link was ever defined in the study area.

[205] undefined time pattern in function call.
A reference was made to a time pattern that was never defined. An example
would be if time pattern 123 is used in a rule yet no such time pattern was ever
defined in the study area.

[207] attempt made to control a check valve. 
Check valves cannot be controlled by a rule or a control. Please remove or correct
the control or rule that is trying to set the status of a check valve.

[223] not enough nodes in network.
There are not enough nodes (junctions, tanks and reservoirs) in the network.
Please add the missing nodes.

[224] no tanks or reservoirs in network.
For every network at least one tank or reservoir is required.

[240] undefined source in function call.
A quality source has been used which has not been defined first.

[250] function argument has invalid format.
The format of the function is not accepted by the solver. Please correct your
input and retry.

[251] illegal parameter code in function call.
An illegal value has been used and must be corrected.

14.10.4 Codes 3ΧΧ

[301] files share same names.
The input, report, and binary output files specified on the command line cannot
have the same names.

[302] cannot open input file.
The input file either does not exist or cannot be opened (e.g., it might be in use
by another program).

[303] cannot open report file.
The report file cannot be opened (e.g., it might reside in a directory to which the
user does not have write privileges).

[304] cannot open binary results file.
The binary output file cannot be opened (e.g., it might reside in a directory to
which the user does not have write privileges). 

[305] cannot open hydraulics file.
There was an error in trying to open the hydraulics file. This is caused because of
lack of privileges. Log-in as administrator and try again.

[306] invalid hydraulics file.
There was an error accessing the hydraulics file. Disable any anti-virus software
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and retry.

[307] cannot read hydraulics file.
There was an error accessing the hydraulics file. Disable any anti-virus software
and retry.

[308] cannot save results to file.
There was an error in trying to save the results to a file. This is caused because
of lack of privileges or the disk is full. Log-in as administrator or free some hard
disk space and try again.

[309] cannot write report to file.
There was an error in trying to save the results to a file. This is caused because
of lack of privileges or the disk is full. Log-in as administrator or free some hard
disk space and try again.
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